Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 4 of 4
  1. #1
    Status
    Offline
    soerchan's Avatar
    Baru Gabung
    Join Date
    Aug 2014
    Location
    Sumatera Barat
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Question Bagi bandwidth dengan adil, pakai forward atau prerouting/postrouting?

    Salam agan2 skalian

    Nubie mau nanya nih, sesuai judul.

    Saya mencoba menerapkan management bandwidth di rb750 menggunakan
    queue-three.

    Skema
    ether1-wan= 192.168.1.2/24
    ether2-lan= 10.0.0.1/24

    Pada opsi PERTAMA saya menandakan paket dengan chain=forward

    MANGLE ===>>
    Code:
    add action=mark-packet chain=forward new-packet-mark=client1_up \
        src-address=10.0.0.2
    add action=mark-packet chain=forward dst-address=10.0.0.2 new-packet-mark=\
        client1_down
    add action=mark-packet chain=forward new-packet-mark=\
        client2_up src-address=10.0.0.3
    add action=mark-packet chain=forward dst-address=10.0.0.3 new-packet-mark=\
        client2_down
    add action=mark-packet chain=forward new-packet-mark=client3_up \
        src-address=10.0.0.4
    add action=mark-packet chain=forward dst-address=10.0.0.4 new-packet-mark=\
        client3_down
    add action=mark-packet chain=forward new-packet-mark=\
        client_undefined_up src-address=10.0.0.4-10.0.0.254
    add action=mark-packet chain=forward dst-address=10.0.0.4-10.0.0.254 \
        new-packet-mark=client_undefined_down
    QUEUE-TREE
    Code:
    /queue tree
    add comment="BW DOWNSTREAM" max-limit=512k name=DOWN parent=ether2-lan queue=\
        pcq-download-default
    add limit-at=64k max-limit=512k name=client1-down packet-mark=client1_down \
        parent=DOWN queue=default
    add limit-at=64k max-limit=512k name=client2-down packet-mark=client2_down \
        parent=DOWN queue=default
    add limit-at=64k max-limit=512k name=client3-down packet-mark=client3_down parent=\
        DOWN queue=default
    add limit-at=16k max-limit=128k name=client-undefined-down packet-mark=\
        client_undefined_down parent=DOWN queue=default
    add comment="BW UPSTREAM" max-limit=256k name=UP parent=ether1-wan queue=\
        pcq-upload-default
    add limit-at=32k max-limit=256k name=client1-up packet-mark=client1_up parent=UP \
        queue=default
    add limit-at=32k max-limit=256k name=client2-up packet-mark=client2_up \
        parent=UP queue=default
    add limit-at=32k max-limit=256k name=client3-up packet-mark=client3_up parent=UP \
        queue=default
    add limit-at=8k max-limit=64k name=client-undefined-up packet-mark=client_undefined_up \
        parent=UP queue=default
    Dan pada opsi ke DUA saya menandakan paket dengan chain=prerouting dan chain=postrouting

    MANGLE ===>>
    Code:
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=MARK-CONNECTION \
        new-connection-mark=all_bw_up src-address=10.0.0.0/24
    add action=mark-connection chain=postrouting dst-address=10.0.0.0/24 \
        new-connection-mark=all_bw_down
    add action=mark-packet chain=prerouting comment=MARK-PACKET connection-mark=\
        all_bw_up new-packet-mark=all_pk_up src-address=10.0.0.0/24
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address=10.0.0.0/24 new-packet-mark=all_pk_down
    add action=mark-packet chain=prerouting comment="CLIENT 01" connection-mark=\
        all_bw_up new-packet-mark=client_01_up passthrough=no src-address-list=\
        client_01
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address-list=client_01 new-packet-mark=client_01_down passthrough=no
    add action=mark-packet chain=prerouting comment="CLIENT 02" connection-mark=\
        all_bw_up new-packet-mark=client_02_up passthrough=no src-address-list=\
        client_02
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address-list=client_02 new-packet-mark=client_02_down passthrough=no
    add action=mark-packet chain=prerouting comment="CLIENT 03" connection-mark=\
        all_bw_up new-packet-mark=client_03_up passthrough=no src-address-list=\
        client_03
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address-list=client_03 new-packet-mark=client_03_down passthrough=no
    add action=mark-packet chain=prerouting comment="CLIENT n0" connection-mark=\
        all_bw_up new-packet-mark=client_n0_up passthrough=no src-address-list=\
        client_n0
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address-list=client_n0 new-packet-mark=client_n0_down passthrough=no
    QUEUE-TREE ===>>
    Code:
    /queue tree
    add comment="||===>>" max-limit=512k name=BW-DOWN packet-mark=all_pk_down \
        parent=ether2-lan queue=pcq-download-default
    add limit-at=64k max-limit=512k name=client-01-down packet-mark=\
        client_01_down parent=BW-DOWN priority=3 queue=default
    add limit-at=64k max-limit=512k name=client-02-down packet-mark=\
        client_02_down parent=BW-DOWN priority=3 queue=default
    add limit-at=64k max-limit=512k name=client-03-down packet-mark=\
        client_03_down parent=BW-DOWN priority=3 queue=default
    add limit-at=16k max-limit=128k name=client-n0-down packet-mark=client_n0_down \
        parent=BW-DOWN queue=default
    add comment="||===>>" max-limit=256k name=BW-UP packet-mark=all_pk_up parent=\
        ether1-wan queue=pcq-upload-default
    add limit-at=32k max-limit=256k name=client-01-up packet-mark=client_01_up \
        parent=BW-UP priority=3 queue=default
    add limit-at=32k max-limit=256k name=client-02-up packet-mark=client_02_up \
        parent=BW-UP priority=3 queue=default
    add limit-at=32k max-limit=256k name=client-03-up packet-mark=client_03_up \
        parent=BW-UP priority=3 queue=default
    add limit-at=8k max-limit=64k name=client-n0-up packet-mark=client_n0_up \
        parent=BW-UP queue=default
    Adapun menurut pengamatan saya dari kedua opsi tersebut saat testing beberapa hari: Click here to enlarge
    Opsi PERTAMA:
    - Sepertinya pembagian bandwidth lebih adil (satu pake IDM, lainnya browsing dan streaming)
    - Bandwidth lan tidak ikut terlimit (proses RB ke client tetap lancar meski load full).

    Opsi KEDUA
    - Sepertinya pembagian bandwidth kurang adil (jika satu pake IDM, yang lain bisa di katakan hanya terpenuhi limit-at)
    - Bandwidth antar client tidak terlimit, namun bandwidth dari client ke RB ikut terlimit.

    Yang mau saya tanyakan, apakah penerapan kedua opsi tersebut sudah benar demikian? mohon saran dan koreksinya.

    Terimakasih.

  2. The Following User Says Thank You to soerchan For This Useful Post:


  3. #2
    Status
    Offline
    soerchan's Avatar
    Baru Gabung
    Join Date
    Aug 2014
    Location
    Sumatera Barat
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    gaaann... Click here to enlarge

  4. #3
    Status
    Offline
    tkgit's Avatar
    Member
    Join Date
    Mar 2014
    Location
    nomaden
    Posts
    175
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    baca konsep HTB lagi, kalau susah pake tree, pake simple aja

    saya sekarang pake simple, lebih enak

  5. #4
    Status
    Offline
    brutuz_1's Avatar
    VIP Member
    Join Date
    Feb 2010
    Posts
    792
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by soerchan Click here to enlarge
    Salam agan2 skalian

    Nubie mau nanya nih, sesuai judul.

    Saya mencoba menerapkan management bandwidth di rb750 menggunakan
    queue-three.

    Skema
    ether1-wan= 192.168.1.2/24
    ether2-lan= 10.0.0.1/24

    Pada opsi PERTAMA saya menandakan paket dengan chain=forward

    MANGLE ===>>
    Code:
    add action=mark-packet chain=forward new-packet-mark=client1_up \
        src-address=10.0.0.2
    add action=mark-packet chain=forward dst-address=10.0.0.2 new-packet-mark=\
        client1_down
    add action=mark-packet chain=forward new-packet-mark=\
        client2_up src-address=10.0.0.3
    add action=mark-packet chain=forward dst-address=10.0.0.3 new-packet-mark=\
        client2_down
    add action=mark-packet chain=forward new-packet-mark=client3_up \
        src-address=10.0.0.4
    add action=mark-packet chain=forward dst-address=10.0.0.4 new-packet-mark=\
        client3_down
    add action=mark-packet chain=forward new-packet-mark=\
        client_undefined_up src-address=10.0.0.4-10.0.0.254
    add action=mark-packet chain=forward dst-address=10.0.0.4-10.0.0.254 \
        new-packet-mark=client_undefined_down
    QUEUE-TREE
    Code:
    /queue tree
    add comment="BW DOWNSTREAM" max-limit=512k name=DOWN parent=ether2-lan queue=\
        pcq-download-default
    add limit-at=64k max-limit=512k name=client1-down packet-mark=client1_down \
        parent=DOWN queue=default
    add limit-at=64k max-limit=512k name=client2-down packet-mark=client2_down \
        parent=DOWN queue=default
    add limit-at=64k max-limit=512k name=client3-down packet-mark=client3_down parent=\
        DOWN queue=default
    add limit-at=16k max-limit=128k name=client-undefined-down packet-mark=\
        client_undefined_down parent=DOWN queue=default
    add comment="BW UPSTREAM" max-limit=256k name=UP parent=ether1-wan queue=\
        pcq-upload-default
    add limit-at=32k max-limit=256k name=client1-up packet-mark=client1_up parent=UP \
        queue=default
    add limit-at=32k max-limit=256k name=client2-up packet-mark=client2_up \
        parent=UP queue=default
    add limit-at=32k max-limit=256k name=client3-up packet-mark=client3_up parent=UP \
        queue=default
    add limit-at=8k max-limit=64k name=client-undefined-up packet-mark=client_undefined_up \
        parent=UP queue=default
    Dan pada opsi ke DUA saya menandakan paket dengan chain=prerouting dan chain=postrouting

    MANGLE ===>>
    Code:
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=MARK-CONNECTION \
        new-connection-mark=all_bw_up src-address=10.0.0.0/24
    add action=mark-connection chain=postrouting dst-address=10.0.0.0/24 \
        new-connection-mark=all_bw_down
    add action=mark-packet chain=prerouting comment=MARK-PACKET connection-mark=\
        all_bw_up new-packet-mark=all_pk_up src-address=10.0.0.0/24
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address=10.0.0.0/24 new-packet-mark=all_pk_down
    add action=mark-packet chain=prerouting comment="CLIENT 01" connection-mark=\
        all_bw_up new-packet-mark=client_01_up passthrough=no src-address-list=\
        client_01
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address-list=client_01 new-packet-mark=client_01_down passthrough=no
    add action=mark-packet chain=prerouting comment="CLIENT 02" connection-mark=\
        all_bw_up new-packet-mark=client_02_up passthrough=no src-address-list=\
        client_02
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address-list=client_02 new-packet-mark=client_02_down passthrough=no
    add action=mark-packet chain=prerouting comment="CLIENT 03" connection-mark=\
        all_bw_up new-packet-mark=client_03_up passthrough=no src-address-list=\
        client_03
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address-list=client_03 new-packet-mark=client_03_down passthrough=no
    add action=mark-packet chain=prerouting comment="CLIENT n0" connection-mark=\
        all_bw_up new-packet-mark=client_n0_up passthrough=no src-address-list=\
        client_n0
    add action=mark-packet chain=postrouting connection-mark=all_bw_down \
        dst-address-list=client_n0 new-packet-mark=client_n0_down passthrough=no
    QUEUE-TREE ===>>
    Code:
    /queue tree
    add comment="||===>>" max-limit=512k name=BW-DOWN packet-mark=all_pk_down \
        parent=ether2-lan queue=pcq-download-default
    add limit-at=64k max-limit=512k name=client-01-down packet-mark=\
        client_01_down parent=BW-DOWN priority=3 queue=default
    add limit-at=64k max-limit=512k name=client-02-down packet-mark=\
        client_02_down parent=BW-DOWN priority=3 queue=default
    add limit-at=64k max-limit=512k name=client-03-down packet-mark=\
        client_03_down parent=BW-DOWN priority=3 queue=default
    add limit-at=16k max-limit=128k name=client-n0-down packet-mark=client_n0_down \
        parent=BW-DOWN queue=default
    add comment="||===>>" max-limit=256k name=BW-UP packet-mark=all_pk_up parent=\
        ether1-wan queue=pcq-upload-default
    add limit-at=32k max-limit=256k name=client-01-up packet-mark=client_01_up \
        parent=BW-UP priority=3 queue=default
    add limit-at=32k max-limit=256k name=client-02-up packet-mark=client_02_up \
        parent=BW-UP priority=3 queue=default
    add limit-at=32k max-limit=256k name=client-03-up packet-mark=client_03_up \
        parent=BW-UP priority=3 queue=default
    add limit-at=8k max-limit=64k name=client-n0-up packet-mark=client_n0_up \
        parent=BW-UP queue=default
    Adapun menurut pengamatan saya dari kedua opsi tersebut saat testing beberapa hari: Click here to enlarge
    Opsi PERTAMA:
    - Sepertinya pembagian bandwidth lebih adil (satu pake IDM, lainnya browsing dan streaming)
    - Bandwidth lan tidak ikut terlimit (proses RB ke client tetap lancar meski load full).

    Opsi KEDUA
    - Sepertinya pembagian bandwidth kurang adil (jika satu pake IDM, yang lain bisa di katakan hanya terpenuhi limit-at)
    - Bandwidth antar client tidak terlimit, namun bandwidth dari client ke RB ikut terlimit.

    Yang mau saya tanyakan, apakah penerapan kedua opsi tersebut sudah benar demikian? mohon saran dan koreksinya.

    Terimakasih.
    mungkin saya share sedikit pendapat tentang packet flow mikrotik terutama untuk kasus TS

    save dulu image nya dan pelototin yah gan...
    halah...kidding gan...Click here to enlarge

    kasus pertama, agan pake forward,
    untuk proses upload, agan posisikan dulu bahwa dalam gambar, input interface adalah interface client (lan), out interface=wan
    dalam gambar keliatan bahwa forward terjadi setelah prerouting, dan terpisah dari input (trafik ke arah mikrotik/RB)
    harus nya udah menjawab pertanyaan kenapa BW lan menuju RB tidak ikut terlimit
    begitu juga untuk proses download, agan posisikan dalam gambar bahwa input interface adalah interface dari internet (wan) dan out-interface=lan
    dan jelas lagi chain forward terpisah dari output (trafik dari RB ke client), soo... trafik dari RB ke client gk bakalan ketangkap pake chain ini

    kasus kedua pake prerouting dan postrouting
    lagi, untuk upload, posisikan bahwa dalam gambar, input interface adalah interface client (lan), out interface=wan
    keliatan prerouting terjadi sebelum input dan forward, artinya, ketika agan buat mangle "chain=prerouting action=mark-conn ..." maka sebenarnya agan menandai semua koneksi dari client baik itu koneksi ke arah RB (input) atau pun ke arah internet (forward) sehingga, karna mangle untuk packet mark nya menggunakan "mark-connection" tersebut, sudah pasti packet yg ketangkap adalah paket ke arah RB dan juga ke arah internet
    untuk proses download,
    lagi gan...agan posisikan dalam gambar bahwa input interface adalah interface dari internet (wan) dan out-interface=lan
    digambar keliatan, postrouting terjadi setelah forward (trafik dari internet) dan setlah output (trafik dari mikrotik/RB)
    dan harus nya udah jelas, kenapa semua trafik baik dari arah internet dan dari mikrotik/RB bisa ketangkap semua kalo memakai chain postrouting...Click here to enlarge

    CMIww ah..Click here to enlarge
    Last edited by brutuz_1; 19-08-2014 at 11:47.

  6. The Following User Says Thank You to brutuz_1 For This Useful Post:


 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Antara Prerouting, postrouting dan forward;
    By choi in forum General Networking
    Replies: 9
    Last Post: 23-06-2015, 23:05
  2. Mengenai prerouting, forward, postrouting dan chain
    By d33cktr4zy in forum Beginner Basics
    Replies: 42
    Last Post: 25-04-2014, 17:49
  3. [ASK]Kapan harus pakai prerouting, forward, postrouting
    By ga_konek in forum General Networking
    Replies: 6
    Last Post: 29-08-2013, 14:05
  4. [HELP] Bedanya prerouting dan postrouting ROuter.
    By tomisintara in forum Beginner Basics
    Replies: 9
    Last Post: 14-05-2011, 19:26
  5. Forward, Input, Output, Postrouting, Prerouting
    By unavailabled in forum Beginner Basics
    Replies: 4
    Last Post: 10-10-2009, 21:18

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •