Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 12 of 12
  1. #1
    Status
    Offline
    bayoubayu's Avatar
    Baru Gabung
    Join Date
    Jun 2009
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Load Balancing Fail Over Hotspot

    Dear all,

    Saya punya diagram network sebagai berikut :


    Wireless ISP 1 (192.168.1.1/30)---|
    |||||||||||||||||||||||||||||||||| Mikrotik ====> HOTSPOT (10.10.10.1/24) ==> jaringan hotspot
    Wireless ISP 2 (172.17.4.1/30 )---|


    Konfigurasi nya adalah :

    Interface
    10.10.10.1/24 10.10.10.0 10.10.10.255 ether2-hotspot
    192.168.1.1/30 192.168.1.0 192.168.1.2 ether3-isp1
    172.17.4.1/30 172.17.4.0 172.17.4.2 ether1-isp2

    catatan hotspot berjalan dengan baik jika tidak ada isp2

    / ip address
    add address=10.10.10.1/24 network=10.10.11.0 broadcast=10.10.11.255 interface=ether2-hotspot
    add address=192.168.1.1/30 network=192.168.1.0 broadcast=192.168.1.2 interface=ether3-isp1
    add address=172.17.4.1/30 network=172.17.4.0 broadcast=172.17.4.2 interface=ether1-isp2


    / ip firewall mangle
    add chain=prerouting dst-address=192.168.1.1/30 action=accept in-interface=ether2-hotspot
    add chain=prerouting dst-address=172.17.4.1/30 action=accept in-interface=ether2-hotspot
    add chain=prerouting in-interface=ether3-isp1 connection-mark=no-mark action=mark-connection new-connection-mark=isp1_conn
    add chain=prerouting in-interface=ether1-isp2 connection-mark=no-mark action=mark-connection new-connection-mark=isp2_conn
    add chain=prerouting in-interface=ether2-hotspot connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=isp1_conn
    add chain=prerouting in-interface=ether2-hotspot connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=isp2_conn
    add chain=prerouting connection-mark=isp1_conn in-interface=ether2-hotspot action=mark-routing new-routing-mark=to_isp1
    add chain=prerouting connection-mark=isp2_conn in-interface=ether2-hotspot action=mark-routing new-routing-mark=to_isp2
    add chain=output connection-mark=isp1_conn action=mark-routing new-routing-mark=to_isp1
    add chain=output connection-mark=isp2_conn action=mark-routing new-routing-mark=to_isp2


    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_isp1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=172.17.14.1 routing-mark=to_isp2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=172.17.14.1 distance=2 check-gateway=ping


    / ip firewall nat
    add chain=srcnat out-interface=ether3-isp1 action=masquerade
    add chain=srcnat out-interface=ether1-isp2 action=masquerade

    Hasilnya :
    - Fail Over berjalan ketika isp1 dimatikan
    - Load balancing terlihat walau tidak seimbang
    - User bisa melakukan koneksi ke radio

    Pertanyaannya adalah :
    Bagaimana caranya agar user ketika dapat wirelessnya langsung bisa kebuka web hotspotnya, sebab ketika konf ini dijalankan yang terjadi user enggak bisa ke web hotspotnya (ketika mau browsing untuk menanyakan username dan password).

    Mohon pencerahan nya.....

    Thanks to all and forummikrotik.

  2. #2
    Status
    Offline
    karaeng's Avatar
    VIP Member
    Join Date
    Jun 2010
    Posts
    958
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by bayoubayu Click here to enlarge
    Dear all,

    Saya punya diagram network sebagai berikut :


    Wireless ISP 1 (192.168.1.1/30)---|
    |||||||||||||||||||||||||||||||||| Mikrotik ====> HOTSPOT (10.10.10.1/24) ==> jaringan hotspot
    Wireless ISP 2 (172.17.4.1/30 )---|


    Konfigurasi nya adalah :

    Interface
    10.10.10.1/24 10.10.10.0 10.10.10.255 ether2-hotspot
    192.168.1.1/30 192.168.1.0 192.168.1.2 ether3-isp1
    172.17.4.1/30 172.17.4.0 172.17.4.2 ether1-isp2

    catatan hotspot berjalan dengan baik jika tidak ada isp2

    / ip address
    add address=10.10.10.1/24 network=10.10.11.0 broadcast=10.10.11.255 interface=ether2-hotspot
    add address=192.168.1.1/30 network=192.168.1.0 broadcast=192.168.1.2 interface=ether3-isp1
    add address=172.17.4.1/30 network=172.17.4.0 broadcast=172.17.4.2 interface=ether1-isp2


    / ip firewall mangle
    add chain=prerouting dst-address=192.168.1.1/30 action=accept in-interface=ether2-hotspot
    add chain=prerouting dst-address=172.17.4.1/30 action=accept in-interface=ether2-hotspot
    add chain=prerouting in-interface=ether3-isp1 connection-mark=no-mark action=mark-connection new-connection-mark=isp1_conn
    add chain=prerouting in-interface=ether1-isp2 connection-mark=no-mark action=mark-connection new-connection-mark=isp2_conn
    add chain=prerouting in-interface=ether2-hotspot connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=isp1_conn
    add chain=prerouting in-interface=ether2-hotspot connection-mark=no-mark dst-address-type=!local per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=isp2_conn
    add chain=prerouting connection-mark=isp1_conn in-interface=ether2-hotspot action=mark-routing new-routing-mark=to_isp1
    add chain=prerouting connection-mark=isp2_conn in-interface=ether2-hotspot action=mark-routing new-routing-mark=to_isp2
    add chain=output connection-mark=isp1_conn action=mark-routing new-routing-mark=to_isp1
    add chain=output connection-mark=isp2_conn action=mark-routing new-routing-mark=to_isp2


    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_isp1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=172.17.14.1 routing-mark=to_isp2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=172.17.14.1 distance=2 check-gateway=ping


    / ip firewall nat
    add chain=srcnat out-interface=ether3-isp1 action=masquerade
    add chain=srcnat out-interface=ether1-isp2 action=masquerade

    Hasilnya :
    - Fail Over berjalan ketika isp1 dimatikan
    - Load balancing terlihat walau tidak seimbang
    - User bisa melakukan koneksi ke radio

    Pertanyaannya adalah :
    Bagaimana caranya agar user ketika dapat wirelessnya langsung bisa kebuka web hotspotnya, sebab ketika konf ini dijalankan yang terjadi user enggak bisa ke web hotspotnya (ketika mau browsing untuk menanyakan username dan password).

    Mohon pencerahan nya.....

    Thanks to all and forummikrotik.
    DNSnya benar nga?

  3. #3
    Status
    Offline
    bayoubayu's Avatar
    Baru Gabung
    Join Date
    Jun 2009
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by karaeng Click here to enlarge
    DNSnya benar nga?
    Sudah bener ane rasa gan....

    /ip dns> static print
    Flags: D - dynamic, X - disabled, R - regexp
    # NAME ADDRESS TTL
    0 D medioku 10.10.11.1 --> sama dengan ip hotspot untuk ke lokal

    /ip dns> pri
    servers: 180.131.145.145
    allow-remote-requests: yes
    max-udp-packet-size: 512
    cache-size: 2048KiB
    cache-max-ttl: 1w
    cache-used: 911KiB

    /ip dhcp-server network> print
    # ADDRESS GATEWAY DNS-SERVER WINS-SERVER DOMAIN
    0 ;;; hotspot network
    10.10.11.0/24 10.10.11.1 10.10.11.1

  4. #4
    Status
    Offline
    wijil46's Avatar
    Member
    Join Date
    Oct 2011
    Location
    Yogyakarta, Indonesia
    Posts
    159
    Reviews
    Read 0 Reviews
    Downloads
    12
    Uploads
    1
    Feedback Score
    0
    Click here to enlarge Originally Posted by bayoubayu Click here to enlarge
    Sudah bener ane rasa gan....

    /ip dns> static print
    Flags: D - dynamic, X - disabled, R - regexp
    # NAME ADDRESS TTL
    0 D medioku 10.10.11.1 --> sama dengan ip hotspot untuk ke lokal

    /ip dns> pri
    servers: 180.131.145.145
    allow-remote-requests: yes
    max-udp-packet-size: 512
    cache-size: 2048KiB
    cache-max-ttl: 1w
    cache-used: 911KiB

    /ip dhcp-server network> print
    # ADDRESS GATEWAY DNS-SERVER WINS-SERVER DOMAIN
    0 ;;; hotspot network
    10.10.11.0/24 10.10.11.1 10.10.11.1
    coba print setting hotspotnya

  5. #5
    Status
    Offline
    bayoubayu's Avatar
    Baru Gabung
    Join Date
    Jun 2009
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by wijil46 Click here to enlarge
    coba print setting hotspotnya
    /ip hotspot profile> pri
    Flags: * - default
    0 * name="default" hotspot-address=0.0.0.0 dns-name="" html-directory=hotspot
    rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0
    login-by=cookie,http-chap,trial http-cookie-lifetime=3d
    split-user-domain=no trial-uptime=10m/1d trial-user-profile=trial
    use-radius=no

    1 name="hsprof1" hotspot-address=10.10.11.1 dns-name="medioku"
    html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0
    smtp-server=0.0.0.0 login-by=cookie,http-chap,trial
    http-cookie-lifetime=3d split-user-domain=no trial-uptime=10m/1d
    trial-user-profile=trial use-radius=no

  6. #6
    Status
    Offline
    wijil46's Avatar
    Member
    Join Date
    Oct 2011
    Location
    Yogyakarta, Indonesia
    Posts
    159
    Reviews
    Read 0 Reviews
    Downloads
    12
    Uploads
    1
    Feedback Score
    0
    Click here to enlarge Originally Posted by bayoubayu Click here to enlarge
    /ip hotspot profile> pri
    Flags: * - default
    0 * name="default" hotspot-address=0.0.0.0 dns-name="" html-directory=hotspot
    rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0
    login-by=cookie,http-chap,trial http-cookie-lifetime=3d
    split-user-domain=no trial-uptime=10m/1d trial-user-profile=trial
    use-radius=no

    1 name="hsprof1" hotspot-address=10.10.11.1 dns-name="medioku"
    html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0
    smtp-server=0.0.0.0 login-by=cookie,http-chap,trial
    http-cookie-lifetime=3d split-user-domain=no trial-uptime=10m/1d
    trial-user-profile=trial use-radius=no
    yg hotspotnya gan jgn yg profile

  7. #7
    Status
    Offline
    bayoubayu's Avatar
    Baru Gabung
    Join Date
    Jun 2009
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by wijil46 Click here to enlarge
    yg hotspotnya gan jgn yg profile
    /ip hotspot> print
    Flags: X - disabled, I - invalid, S - HTTPS
    # NAME INTERFACE ADDRESS-POOL PROFILE IDLE-TIMEOUT
    0 hotspot1 ether2-hotspot hs-pool-2 hsprof1 5m

  8. #8
    Status
    Offline
    wijil46's Avatar
    Member
    Join Date
    Oct 2011
    Location
    Yogyakarta, Indonesia
    Posts
    159
    Reviews
    Read 0 Reviews
    Downloads
    12
    Uploads
    1
    Feedback Score
    0
    Click here to enlarge Originally Posted by bayoubayu Click here to enlarge
    /ip hotspot> print
    Flags: X - disabled, I - invalid, S - HTTPS
    # NAME INTERFACE ADDRESS-POOL PROFILE IDLE-TIMEOUT
    0 hotspot1 ether2-hotspot hs-pool-2 hsprof1 5m
    kok g ada IP of DNS name nya ya Click here to enlarge
    coba gan diliat dari winbox
    ip of DNS namenya berapa

  9. #9
    Status
    Offline
    bayoubayu's Avatar
    Baru Gabung
    Join Date
    Jun 2009
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by wijil46 Click here to enlarge
    kok g ada IP of DNS name nya ya Click here to enlarge
    coba gan diliat dari winbox
    ip of DNS namenya berapa
    10.10.11.1 gan....

    /ip hotspot> print value-list
    name: "hotspot1"
    interface: ether2-hotspot
    address-pool: hs-pool-2
    profile: hsprof1
    idle-timeout: 5m
    keepalive-timeout: none
    addresses-per-mac: 5
    ip-of-dns-name: 10.10.11.1
    proxy-status: "running"

  10. #10
    Status
    Offline
    wijil46's Avatar
    Member
    Join Date
    Oct 2011
    Location
    Yogyakarta, Indonesia
    Posts
    159
    Reviews
    Read 0 Reviews
    Downloads
    12
    Uploads
    1
    Feedback Score
    0
    Click here to enlarge Originally Posted by bayoubayu Click here to enlarge
    10.10.11.1 gan....

    /ip hotspot> print value-list
    name: "hotspot1"
    interface: ether2-hotspot
    address-pool: hs-pool-2
    profile: hsprof1
    idle-timeout: 5m
    keepalive-timeout: none
    addresses-per-mac: 5
    ip-of-dns-name: 10.10.11.1
    proxy-status: "running"
    ane barusan ngetes gan
    klo bisa dibikin medioku.net ato .com
    jgn medioku aj

  11. #11
    Status
    Offline
    bayoubayu's Avatar
    Baru Gabung
    Join Date
    Jun 2009
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by wijil46 Click here to enlarge
    ane barusan ngetes gan
    klo bisa dibikin medioku.net ato .com
    jgn medioku aj
    ketika dicoba berhasil tidak gan...? ane dah coba jadi net tapi enggak bisa juga.

    1 name="hsprof1" hotspot-address=10.10.11.1 dns-name="medioku.net"
    html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0
    smtp-server=0.0.0.0 login-by=cookie,http-chap,trial
    http-cookie-lifetime=3d split-user-domain=no trial-uptime=10m/1d
    trial-user-profile=trial use-radius=no

  12. #12
    Status
    Offline
    wijil46's Avatar
    Member
    Join Date
    Oct 2011
    Location
    Yogyakarta, Indonesia
    Posts
    159
    Reviews
    Read 0 Reviews
    Downloads
    12
    Uploads
    1
    Feedback Score
    0
    di DNS nya udah diganti juga belum gan

    berhasil gan dari dulu pke com
    tadi cuma nyobain tanpa .com g bisa gan

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. <ASK> load balancing fail over
    By d3v4 in forum Scripting @ Mikrotik
    Replies: 27
    Last Post: 14-10-2012, 19:58
  2. [AKS] Hotspot di Load Balancing
    By sopan_46 in forum General Networking
    Replies: 5
    Last Post: 05-04-2012, 16:05
  3. Load-balancing & Fail-over di MikroTik
    By nux in forum Tutorial
    Replies: 8
    Last Post: 11-11-2011, 10:09
  4. Fail-over detection untuk load balancing spidi
    By awarmanf in forum General Networking
    Replies: 8
    Last Post: 11-12-2009, 11:18
  5. load balancing fail over mikrotik
    By parot in forum General Networking
    Replies: 7
    Last Post: 02-05-2009, 13:20

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •