Community discussions

MikroTik App
 
kartxila
just joined
Topic Author
Posts: 1
Joined: Fri Apr 26, 2024 6:21 pm

V6-MPLS Backbone with Cisco BGP Timer and Multicast VPLS problem

Fri Apr 26, 2024 6:50 pm

Dear all,

We have a mpls backbone in production with OSPF, LDP, MP-BGP, L2VPN/L3VPN and route-reflector on Cisco IOSXE stuff.
We want to add some new POPs with Mikrotik routers and we build a lab like this :

RR Cisco <-> MPLS Backbone <-> CCR1072 P router <-> CRS 328 PE Router <-> RB3011 PE Router.
All mikrotik are in version 6.49.13 long-term version, we tried also 6.49.15 but we got the same issues.

On the CRS 328, BGP is not working, we got the following error every three minutes (10.0.0.254 is the Cisco route-reflector), BGP is ok on the two others, reboot doesn't help. :
route,bgp,error HoldTimer expired
route,bgp,error RemoteAddress=10.0.0.254
We try to debug BGP on the router, and we see the Mikrotik sending the packet for the timer, but didn't receive the answer from the Cisco. IP Connectivity through OSPF is perfectly working between both.

Here are the relevant part of the configuration of the three Mikrotik here, we need to figure out what is the cause of the BGP expiration, and then we have another issue with a VPLS/L2VPN containing Multicast traffic that didn't work on router RB3011 where other VPLS are working OK.

ccr1072 :
/interface bridge
add name=Lo0 protocol-mode=none
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] l2mtu=8158 mtu=8158
set [ find default-name=sfp-sfpplus2 ] l2mtu=8158 mtu=8158
set [ find default-name=sfp-sfpplus3 ] l2mtu=8158 mtu=8158
/routing bgp instance
set default as=65999 router-id=10.0.0.51
/routing ospf instance
set [ find default=yes ] distribute-default=if-installed-as-type-1 router-id=10.0.0.51
/ip address
add address=10.0.0.51 interface=Lo0 network=10.0.0.51
add address=10.4.51.51/24 interface=sfp-sfpplus1 network=10.4.51.0
add address=10.17.51.51/24 interface=sfp-sfpplus2 network=10.17.51.0
add address=10.51.52.51/24 interface=sfp-sfpplus3 network=10.51.52.0
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set enabled=yes lsr-id=10.0.0.51 transport-address=10.0.0.51
/mpls ldp advertise-filter
add prefix=10.0.0.0/24
add advertise=no
/mpls ldp interface
add hello-interval=10s hold-time=40s interface=sfp-sfpplus2
add hello-interval=10s hold-time=40s interface=sfp-sfpplus3
add hello-interval=10s hold-time=40s interface=sfp-sfpplus1
/routing bfd interface
set [ find default=yes ] interval=0.05s min-rx=0.05s multiplier=3
add interface=sfp-sfpplus2 interval=0.05s min-rx=0.05s multiplier=3
add interface=sfp-sfpplus1 interval=0.05s min-rx=0.05s multiplier=3
add interface=sfp-sfpplus3 interval=0.05s min-rx=0.05s multiplier=3
/routing bgp peer
add address-families=ip,l2vpn,vpnv4 name=dom01-rr-1 remote-address=10.0.0.254 remote-as=65999 update-source=Lo0
/routing ospf interface
add interface=sfp-sfpplus2 network-type=point-to-point use-bfd=yes
add interface=sfp-sfpplus3 network-type=point-to-point use-bfd=yes
add interface=sfp-sfpplus1 network-type=point-to-point use-bfd=yes
/routing ospf network
add area=backbone network=10.0.0.51/32
add area=backbone network=10.17.51.0/24
add area=backbone network=10.51.52.0/24
add area=backbone network=10.4.51.0/24
crs328 :
/interface bridge
add name=Lo0 protocol-mode=none
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] l2mtu=8158 mtu=8158
set [ find default-name=sfp1 ] l2mtu=8158 mtu=8158
/routing bgp instance
set default as=65999 router-id=10.0.0.52
/routing ospf instance
set [ find default=yes ] distribute-default=if-installed-as-type-1 router-id=10.0.0.52
/ip address
add address=10.0.0.52 interface=Lo0 network=10.0.0.52
add address=10.51.52.52/24 interface=sfp-sfpplus1 network=10.51.52.0
add address=10.52.1.1/30 interface=sfp1 network=10.52.1.0
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set enabled=yes lsr-id=10.0.0.52 transport-address=10.0.0.52
/mpls ldp advertise-filter
add prefix=10.0.0.0/24
add advertise=no
/mpls ldp interface
add hello-interval=10s hold-time=40s interface=sfp-sfpplus1
add hello-interval=10s hold-time=40s interface=sfp1
/routing bfd interface
set [ find default=yes ] interval=0.05s min-rx=0.05s multiplier=3
/routing bgp peer
add address-families=ip,l2vpn,vpnv4 name=dom01-rr-1 remote-address=10.0.0.254 remote-as=65999 update-source=Lo0
/routing ospf interface
add interface=sfp-sfpplus1 network-type=point-to-point use-bfd=yes
add interface=sfp1 network-type=point-to-point use-bfd=yes
/routing ospf network
add area=backbone network=10.0.0.52/32
add area=backbone network=10.51.52.0/24
add area=backbone network=10.52.1.0/30
rb3011 :
/interface bridge
add name=Lo0 protocol-mode=none
/interface ethernet
set [ find default-name=sfp1 ] l2mtu=8158 mtu=8158
/routing bgp instance
set default as=65999 router-id=172.16.52.1
/routing ospf instance
set [ find default=yes ] distribute-default=if-installed-as-type-1 router-id=172.16.52.1
/ip address
add address=10.52.1.2/30 interface=sfp1 network=10.52.1.0
add address=172.16.52.1 interface=Lo0 network=172.16.52.1
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set enabled=yes lsr-id=172.16.52.1 transport-address=172.16.52.1
/mpls ldp advertise-filter
add prefix=10.0.0.0/24
add advertise=no
/mpls ldp interface
add hello-interval=10s hold-time=40s interface=sfp1
/routing bfd interface
set [ find default=yes ] interval=0.05s min-rx=0.05s multiplier=3
add interface=sfp1 interval=0.05s min-rx=0.05s multiplier=3
/routing bgp peer
add address-families=ip,l2vpn,vpnv4 name=dom01-rr-1 remote-address=10.0.0.254 remote-as=65999 update-source=Lo0
/routing ospf interface
add interface=sfp1 network-type=point-to-point use-bfd=yes
/routing ospf network
add area=backbone network=172.16.52.1/32
add area=backbone network=10.52.1.0/30
Can you please help us ?

Who is online

Users browsing this forum: No registered users and 4 guests