Community discussions

MikroTik App
 
canvcol
just joined
Topic Author
Posts: 13
Joined: Fri Oct 11, 2019 11:59 am

Re-programming remote wAP LTE kit as wireless client

Mon Apr 15, 2024 5:08 pm

Hi all

I've got a wAP LTE kit connected to a single camera via ethernet moved to a new remote location with non-technical user. LTE signal is not good enough in the new location. However, the user now has a Starlink for their other work.

I'd like to configure the wAP as a pure wireless client for the camera connecting to the Starlink wifi and would need the user to do this, ideally through their smartphone with the Mikrotik app.

I'm guessing the best way would be to prepare a script which I could send to the user and have them, via the Mikrotik app, set the router to reset to no-defaults and then run the script.

Does this seem sensible? If so, I'm imagining it would be a pretty straightforward script but my scripting skills weren't ever great and are very rusty so I wondered if anyone might be kind enough to whip one up?! I appreciate that is probably a tough ask...

The model is RBwAPR-2nD&R11e-LTE and Router OS version is 6.47.9
 
TheCat12
Member Candidate
Member Candidate
Posts: 196
Joined: Fri Dec 31, 2021 9:13 pm

Re: Re-programming remote wAP LTE kit as wireless client

Tue Apr 16, 2024 11:55 pm

I think I can conjure up some commands for AP with no default configuration but it'll be quite hard for the user to connect via WiFi because the interface is disabled when there's no default config:
/ip address add address=192.168.88.1/24 network=192.168.88.0 interface=ether1

/ip pool add ranges=192.168.88.2-192.168.88.254 name=pool_dhcp

/ip dhcp-server network add address=192.168.88.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.88.1

/ip dhcp-server add address-pool=pool_dhcp interface=ether1 name=dhcp

/interface wireless set [ find name=wlan1 ] disabled=no ssid="Starlink_SSID" mode=station

/interface wireless security-profiles set [ find name=default ] mode=dynamic-key authentication-types=wpa2-psk wpa2-pre-shared-key="WiFi_Password"

/ip dhcp-client add interface=wlan1

/ip firewall nat add action=masquerade chain=srcnat out-interface=wlan1
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3596
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: Re-programming remote wAP LTE kit as wireless client

Wed Apr 17, 2024 1:47 am

Assuming you have not upgrade the wireless drivers...

There should be a QuickSet mode (in upper left) for "PTP Bridge CPE", you should be able to use that to connect to Starlink Wi-Fi's SSID and should bridge it to ether2 (and I think ether1).

Who is online

Users browsing this forum: qfiber, zhongfu and 33 guests