Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 17 12311 ... LastLast
Results 1 to 15 of 254
  1. #1
    Status
    Offline
    adhielesmana's Avatar
    Administrator
    Join Date
    Jan 2009
    Location
    http://www.adhielesmana.com
    Posts
    3,056
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Thumbs up Simple Load Balancing + DNS Resolver + Secret Fiture

    Hi Mikrotikerz.. Selamat Siang para master.. mungkin Konsep Load Balancing pada Router Mikrotik tercinta kita sudah banyak di ulas di Forum ini.. Tapi saya akan mencoba menyampaikan dengan sudut pandang pemahaman saya sebagai newbie. maklum di beberapa Thread teman teman di sini saya pernah mengeluh kenapa MT saya tidak bisa LoadBalancing sendiri.. padahal Versinya sudah sedemikian saya samakan.. ternyata saya yang kurang tanggap akan penjelasan dari thread yang saya baca.. sekarang setelah sukses mencoba saya akan membagi pemahaman saya berdasar ilmu dari teman teman di forum ini serta beberapa logika bodoh saya Click here to enlarge
    Langsung Saja. Konsep ini saya terapkan di warnet saya dengan MT Versi * HARAM * ( jangan tanya asli tidaknya.. silahkan pikir sendiri )

    Konsep LOAD BALANCING
    Sebelum BEraksi Jangan Lupa Setup Ethernet / Interface Card ( NIC ) atau Bahasa Gaulnya ( Lan Card ) dengan konfigurasi Sebagai Berikut :

    Perangkat 3 Lan Card -> 2 Isp ( WAN ), 1 Local ( LAN )

    1. Pake WinBox masuk ke -> IP -> Address
    -> klik [+] -> isikan Address : 192.168.1.1/24 _
    Network : 192.168.1.0 |
    Broadcast : 192.168.1.255 | Konfigurasi LAN ( Local)
    Interface : Ether1 _|
    -> klik [+] -> isikan Address : 192.168.2.2/24 _
    Network : 192.168.2.0 |
    Broadcast : 192.168.2.255 | Konfigurasi WAN 1
    Interface : Ether2 _|
    -> klik [+] -> isikan Address : 192.168.3.2/24 _
    Network : 192.168.3.0 |
    Broadcast : 192.168.3.255 | Konfigurasi WAN 2
    Interface : Ether3 _|

    2. Buat Mangle. Pake WinBox pilih -> New Terminal
    Paste kan Kode Berikut
    /ip firewall mangle [lalu enter]
    add chain=prerouting in-interface="ether1" connection-state=new nth=1,2,0 action=mark-connection new-connection-mark=lb_1 passthrough=yes comment="LB Client" disabled=no
    add chain=prerouting in-interface="ether1" connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no comment="" disabled=no
    add chain=prerouting in-interface="ether1" connection-state=new nth=1,2,1 action=mark-connection new-connection-mark=lb_2 passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface="ether1" connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no comment="" disabled=no [lalu enter]
    3. Buat Nat. Pake WinBox pilih -> New Terminal
    Lagi Lagi Paste kan [ maklum sebagai newbie males nulis ]
    / ip firewall nat
    add chain=srcnat out-interface="ether3" action=masquerade comment="" disabled=no
    add chain=srcnat out-interface="ether2" action=masquerade comment="" disabled=no
    4. Buat Route. Pake WinBox pilih -> New Terminal
    Copy Paste Lagi Bosssss
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=route_lb_1 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=255 target-scope=10 routing-mark=route_lb_2 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=255 target-scope=10 comment="default routing connection" disabled=no

    Sampai Disini Load Balancing Telah Beres...
    Notes : Semua Koneksi WAN dengan IP Static dan Gateway ke IP modem. kalo untuk koneksi PPOE silahkan di configurasi sendiri. Karena PPOE dial saya dari modem semua. jadi MT tinggal Route aja.
    Click here to enlargeClick here to enlarge

    DNS Resolver ( bisa juga disebut DNS Forwarder atau apalah saya juga bingung)
    Pake WinBox masuk ke -> IP -> DNS
    -> Klik Settings
    -> masukkan Primary Dan Secondary DNS dari ISP nya
    -> centang [v] allow remote requests
    Pake WinBox masuk ke -> IP -> Firewall -> NAT
    -> klik [+] -> isikan Chain : dstnat
    protokol : 17(UDP)
    dstport : 53
    ->Pindah Ke Sub Menu Action
    action : redirect
    to ports : 53
    ->Klik OK biar Kesimpen
    -> Bikin Sekali lagi dengan protokol di isi : 6(TCP)

    Sampai Disini DNS Resolvernya success
    kamu bisa tambahkan sendiri Host + NS Resolution dari web web yang sering dibuka biar tambah cepet browsing nya

    Lalu Dimana Secret Featurenya??

    Secret Featurenya adalah
    1. Mencegah YM dan MIRC Diskonek saat Load Balancing
    pada mangle pembuatan connection mark yang telah dibuat di Load Balancing tadi [ bukalah pakai WinBox -> Ip -> Firewall -> mangle ] pada kolom protocol tambahkan 6(TCP) dan dst port 80 ( jangan lupa aplikasikan pada kedua mangle tersebut baik lb_1 maupaun lb_2 )
    apa fungsinya ??
    fungsinya semua koneksi non HTTP (80) akan di routing menggunakan default routing conncetion alias satu IP Route jadi ndak bolak balik drop.

    2. Settingan Gila Ala Manipulasi TOS
    anda sering gagal membuat manipulasi TOS.. pakai ini dijamin berhasil
    pakai WinBox -> Ip -> Firewall -> NAT
    klik [+]
    isikan chain : dstnat
    protocol : 1 (icmp)
    in interface : ether1
    -> di menu action
    action : redirect
    to ports : 1
    klik OK

    lalu silahkan coba PING atau TRACERT dan dijamin anda NGUAKAK KAK KAK KAK.

    3. Fail Over Gateway Backup
    pake WinBox -> IP -> Routes

    [+]
    destination : 0.0.0.0/0
    gateway : 192.168.2.1 <----- Sudah DI edit kemaren salah Click here to enlarge
    distance : 2
    OK

    dah sip lah...
    semoga artikel ini membantu sesama newbie yang nota bene awam dan gaptek betul soal MT..
    buat yang pinter.. pinter.. mohon maap kalo ada yang salah atau menyalahi atau melanggar hukum atau apa aja khehkehehk muup ya...
    untuk mod dan master thanks berat atas kesempatan untuk mengisi artikel ini mohon di aprove Click here to enlargeClick here to enlarge

    untuk yang suka repost dan copy paste.. mohon nama saya di pasang juga.. kasian ibu saya udah melahirkan saya.. membesarkan saya.. menyekolahkan saya.. dan membuat saya bisa menulis disini.. Click here to enlarge( apa hubungannya ?? ) lalu anda comot dengan tidak hormat hkehekhe ... Lemah Teles.. Yang Kuasa Yang Bakal Bales.. Mohon Koreksinya yaaaaaaaaaaaaaaaa

    Notes : (04 Jan 08)
    JANGAN DI CAMPUR AMA PROXY BOSSSS... GA BAKAL JALAN !!

    UPDATE !!

    Prinsip NTH Versi 2.9.* ( menurut saya lo ya, dengan bahasa simple aja biar yang baru belajar cepet ngerti )


    NTH : a,b,c

    a : every - samakan dengan jumlah line LB nya dikurangi 1 ( karena perhitungan dia mulai dari angka 0, jadi misalkan 2 line hitungannya 0 1 berarti di tulis 1 di setiap rule nya)

    b : Counter - Jumlah LB nya.. ( perhitungan normal mulai dari 1, jika 2 line berarti di tulis 2 di setiap rulenya )

    c : Packet - Nomor Urut Antrian Packet ( perhitungan seperti every mulai dari nol, namun penulisan di dasarkan pada siapa rule pertama, jika 2 line. pada rule pertama di tulis 0 rule kedua di tulis 1 )

    jadi apabila kita punya 3 line :
    mangle pertama NTh nya : 2,3,0
    mangle keduanya NThnya: 2,3,1
    mangle ketiganya NThnya: 2,3,2

    Semoga Membantu
    dari berikut keterangannya
    Nth
    From MikroTik Wiki
    Jump to: navigation, search

    example: nth=Every,Counter,Packet nth=2,3,0. 2,3,1 2,3,2

    divide all packets into groups of three (2+1). The packets will be numbered from 0 to 2. So, a sequence of packets the rule matches looks like: (0 1 2)(0 1 2)(0 1 2)(0 1 2)(0 1 2)...

    the first rule will match the first packet in each group ("Packet"=0). The second rule will match the second packet in each group ("Packet"=1) and so on. Each successful match increments the counter. When a value of "Every" is reached, the counter is reset to 0. For this to work, the "Counter" should be the same for all rules (you can pick any value from 0 to 15, IIRC).


    It can be seen in the original manual at Look for nth
    PERHATIAN TUTORIAL INI TIDAK PERLU DI POSTING ULANG DI FORUM INI OLEH SIAPAPUN! - MOHON TIDAK MEMPOSTING TUTORIAL YANG SAMA DENGAN ALASAN MENGUMPULKAN TUTORIAL ATAU ALASAN APAPUN SUPAYA PEMBAHASAN FOKUS DI THREAD INI TERIMA KASIH
    ====== NEW SIMPLE LOAD BALANCING PCC ======
    Sehubungan dengan permintaan beberapa member mengenai konfigurasi PCC yang simpel.. saya akan coba bantu membuat tutorial ini dengan harapan teman teman yang masih awam bisa lebih mudah memahami dan menerapkan pada topologi jaringannya masing masing.

    Pada tutorial kali ini saya contohkan menggunakan 2 Line Load Balancing. Menggunakan PCC sebagai Parameter Load balancingnya. Kita Asumsikan menggunakan 2 Line Speedy yang di PPOE via Mikrotik. Dan 1 Line Output ke sisi Lan / Local

    Kondisi Kita Asumsikan : ( ini hanya asumsi jadi IP nya sengaja saya buat 456 dan 567 )
    Speedy1 : PPoE Via Mikrotik Ip Publik 110.96.123.456
    Speedy2 : PPoE Via Mikrotik Ip Publik 110.96.123.567
    Gateway Speedy1 dan Speedy2 Kebetulan sama 110.96.123.1 ( saya contohkan sama karena banyak pengalaman dari member ter kendala pada gateway yang sama ketika menggunakan 2 spidi )
    Ether1 : Menuju Modem 1 ip : 192.168.11.2/24 ( ip modemnya 192.168.11.1 )
    Ether2 : Menuju Modem 2 ip : 192.168.12.2/24 ( ip modemnya 192.168.12.1 )
    Ether3 : Lan / Local Ip : 192.168.1.1/24 ( ip network di client 192.168.1.0/24 ), perlu saya jelaskan begini soalnya banyak yang masih bingung soal TCP / IP

    Praktek :


    Praktek :
    1. Setting IP Address, sesuaikan Ip Address pada interface dan Modemnya
    Masuk Bagian IP > Address
    2. Setting Modem sebagai Bridge ( Masing2 modem mempunyai karakteristik setting yang berbeda beda silahkan konsultasi dengan telkom atau penjual modemnya ) pastikan VPI / VCI benar.
    3. Setting PPPoE Client pada mikrotik
    Masuk Bagian PPP > lalu + ( add )
    Pilih PPPoE Client
    Pada menu PPPoE New Interface
    - Pada tab menu General
    - Isi name : Speedy1
    - Interface : ether1 ( Pilih interface yang menuju modem )
    - Berpindah ke tab menu Dial Out
    - User : Isikan username dari Telkom Speedy ( dengan di sertai @telkom.net )
    - Password : Isikan password dari Telkom Speedy
    - Aktifkan ( centang : V ) Add default Route Untuk menambahkan Gateway Speedy secara
    otomatis di menu IP Routes
    - Aktifkan ( centang : V ) Use Peer DNS Untuk menambahkan DNS Speedy secara otomatis di
    menu IP DNS
    Begitu juga ketika pembuatan Speedy2. Anda arahkan ke interface modem 2 beserta parameter username dan passwordnya.

    4. Setting NAT

    Karena kita menggunakan 2 Line, maka NAT kita simple kan saja
    add chain=srcnat src-address=192.168.1.0/24 action=masquerade comment="" disabled=no
    jadi nat berdasar Ip network client sebagai Ip sumber

    5. Tidak Perlu Setting default route karena sudah dibuat oleh PPPoE Client secara otomatis

    6. Setting Mangle

    Code:
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Load Balancing" disabled=no dst-port=80 in-interface=ether3 new-connection-mark= LB1 passthrough=yes connection-state=new per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp src-address=192.168.1.0/24
    add action=mark-routing chain=prerouting comment="" connection-mark=LB1 disabled=no in-interface=ether3 new-routing-mark=Route1 passthrough=no src-address=192.168.1.0/24
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=80 in-interface=ether3 new-connection-mark=LB2 passthrough=yes connection-state=new per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp src-address=192.168.1.0/24
    add action=mark-routing chain=prerouting comment="" connection-mark=LB2 disabled=no in-interface=ether3 new-routing-mark=Route2 passthrough=no src-address=192.168.1.0/24
    Supaya tidak memunculkan Pertanyaan kenapa YM Begini kenapa Poker Begitu kenapa Game reconect, maka kita Load balancing Khusus Port 80 ( http / website ) saja.

    7. Setting Route LB

    Code:
    /Ip Routes
    
    add check-gateway=arp comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Speedy1 routing-mark=Route1 scope=255 target-scope=10
    
    add check-gateway=arp comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Speedy2 routing-mark=Route2 scope=255 target-scope=10
    Pada kasus IP Gateway yang sama. Kita tidak perlu menggunakan IP Address gateway sebagai parameter, namun cukup isikan / Pilih nama interface PPPoE yang telah kita buat pada masing masing Route.
    Apabila menggunakan Speedy PPPoE Di mikrotik, tidak perlu menambahkan default gateway, cukup centang add default route, route default akan terbentuk otomatis.

    8. Untuk Failovernya


    Code:
    add check-gateway=arp comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=Speedy2 routing-mark=Route1 scope=255 target-scope=10
    
    add check-gateway=arp comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=Speedy1 routing-mark=Route2 scope=255 target-scope=10
    Failover kita setting cukup mudah. Dengan membuat ulang rule route seperti route LB lalu kita ganti distance menjadi 2 dan gateway saling kita tukar balik.

    Demikian Tutorial Singkat PCC Simple semoga membantu para member yang masih awam mikrotik. mohon koreksi kepada rekan2 yang lebih berpengalaman apabila tutorial ini masih ada kekeliruan. tutorial ini sudah di coba dan diaplikasikan di beberapa kondisi warnet maupun rtrwnet yang mempunyai Line lebih dari satu.

    Mohon maaf min mod yang laen saya taruh tutorial di sini supaya tidak terlalu lama menunggu aproval, karena ada beberapa member yang membutuhkan informasi seputar PCC ini mendesak. nanti silahkan di move oleh pak camat bagian tutorial. terima kasih
    Keterangan PCC :
    from:
    PCC takes selected fields from IP header, and with the help of a hashing algorithm converts selected fields into 32-bit value. This value then is divided by a specified Denominator and the remainder then is compared to a specified Remainder, if equal then packet will be captured. You can choose from src-address, dst-address, src-port, dst-port from the header to use in this operation.
    Terjemahan :
    PCC Mengambil sebuah Keterangan dari sebuah IP Header, lalu mengconvertnya menggunakan alogaritma menjadi 32bit, lalu hasilnya akan di bandingkan dengan Denominator spesifik dan Remainder ( mungkin lebih mudah di sebut catatan traffic secara spesifik ) lalu membandingkannya, apabila sama traffic akan di tandai ( di tangkap ) pada mangle. anda bisa memilih parameter PCC src address, dst address, src port dst port pada opsi IP Headernya.
    Contoh PCC di Wiki :
    /ip firewall mangle add chain=prerouting action=mark-connection \
    new-connection-mark=1st_conn per-connection-classifier=src-address-and-port:3/0
    /ip firewall mangle add chain=prerouting action=mark-connection \
    new-connection-mark=2nd_conn per-connection-classifier=src-address-and-port:3/1
    /ip firewall mangle add chain=prerouting action=mark-connection \
    new-connection-mark=3rd_conn per-connection-classifier=src-address-and-port:3/2
    Keterangan PCC 3/0 = 3 adalah Jumlah LB Mangle yang di buat, 0 adalah Urutan antrian
    misal anda mempunyai 5 line LB PCC maka PCCnya 5/0, 5/1, 5/2, 5/3, 5/4
    Tutorial ini di buat sepenuhnya untuk member yang masih awam mikrotik, Untuk Pembahasan tingkat lanjut, mengenai kombinasi Squid Eksternal, Game Poker, pointblank Dll.. bisa anda pelajari di Tutorial Saudara Teuku Rizal atau Tutorial Akangage
    Terima Kasih
    Last edited by adhielesmana; 21-07-2010 at 08:00. Reason: Sory.. Postingnya sambil ngantuk ngantuk | announcement warning

  2. The Following 246 Users Say Thank You to adhielesmana For This Useful Post:

    + Show/Hide list of the thanked

    3dyx,4512412,4r03l,4rif,5013EX,abuwa,ace.corp,achim,adhan247,adhe zigas,adhicell,adojelek,adyc707,afrinal,Akangage,akbar,all21,ansoel,apayah,are_ritz,arya32,askanagase,B460R,B4d_53ct0r,b4mb5,Bang-Napi,banyak kasus,bebelac3,benhajar,blankcode403,boled,buyungsandy,C4SS4NOV4,cank ole,CaPunG,carmello170,catman,ch-453-m,chan_karno,chestercazz,cinkoenet,cintacici,coeky,cool9and,d4n1d3h,D4wFl1N,darwin.ahmad,Dbest,deeec2,dencow,depalaza,deposter,diwa,dn1ysr,Dr.Geyonk,dreambox,dskymc,duceboy,elgarong,ellabram,EnGkek.Coy,eodz,epay,erunix_unix,eteve,f3r_ry,fadhli,fals99,faqiir,faradilanaureen,faridpay,farrel.farizky,faul,fendy4all,fik.black,firsyah,fr0ch1m,fredy_Doank,fuzzakirach,gedesindhu,Ghoven,gi2n,glendylubis,h4sbr,harlen,harrysupart,hataraku,healm4n,henDra,iebee,ikha,imcaja,indozoner,inetpribumi,Insomniac,inxight,irving,ITeChNoLoGy,iw4n,Jackson,Jati+,jeffry m h,jemmy wahyudi,Joeee,johnmikro,jojo852852,jokotole82,junaidi_924,Junet X,K-45,karim mmj,katrok2009,khocock,kipasjagung,klepon,kokoroso,korekuping,kriwelz,lakibini,laptophang,larassoft,linux3000,lyto,m3tr0mini,mach_hilal,macingtos,mahaadit,maidenisme,manggatal,marteen,matdisini,mazaya,mejabelajarku,melinda201,memorizzer,merky.bolung,Mikrobumi,mikrotikmaniac,mjm_oke,moztru,Mr. WonderFULL,MrKimbo,munyuk,nayawis,netsakom13,niceman,oik_oik,onomlakbok,p4rcom,pakdeKJ,panjulan,papady,parmitu,pasprapatan,pasu,perjaka,pi@n,picazzo,pin7un6,pluckyus,prasetyod,Priaadi,prihiri,prima212,punggawana_kahu,r3dwin3,rablydotconf,Rahmansyah,rahmatfaisal,ramlianoor,rangkayu,rantanplan,ratnoque,RB750,Registerar,ReX,rhiram,rijanarko,ripmanis,rizal90,rudi3000,rystiono,s!mbahNET,s03b,sahuleka,sandal_elek,sanjaya89,scrich,scripthunter,searching,semperfy,sempy26,Siklus,si_mand3n,sonton,speedster,SpinneR,stampan01,stonescomp,subhero,sudosu,supriwae,syafri,syarwin,t1kuZz,tamuluyun,teper,the-osiris,TheKradz,thiwoels,tikoes,tiyo,tjhana,tolabul,Triple_Nine,tyang_dusun,uburcumi,udhi,ulil_2511,umbaZ,unique_leader,unisoft87,utak-atik,valnir,vmobile,Wahyu6120,wahyusemarang,wahyu_mikrotiker,wawanonly,whiely,wilis arf,xarom,xco,xeonx,xscrip,Xtreme,yoga111,yogaponsel,yulley,Yupi,zdienos,ZEXEL,zizaki,[a],_aRye,_daEng_

  3. #2
    Status
    Offline
    korekuping's Avatar
    Member
    Join Date
    May 2008
    Location
    Server
    Posts
    170
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Smile

    waduh makasih banyak nih bro, test ke TKP dulu ah tar kl berhasil gw posting lagi disini deh, thx berat nih bro

    Click here to enlarge

  4. #3
    Status
    Offline
    korekuping's Avatar
    Member
    Join Date
    May 2008
    Location
    Server
    Posts
    170
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by adhielesmana Click here to enlarge
    3. Fail Over Gateway Backup
    pake WinBox -> IP -> Routes

    [+]
    destination : 0.0.0.0/0
    gateway : 192.168.1.2 <----- (mungkin ini maksudnya 192.168.2.1 kali yak)
    distance : 2
    Sori kalo salah

  5. #4
    Status
    Offline
    Bang-Napi's Avatar
    Member
    Join Date
    Sep 2007
    Location
    Wonosobo
    Posts
    168
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    2. Settingan Gila Ala Manipulasi TOS
    anda sering gagal membuat manipulasi TOS.. pakai ini dijamin berhasil
    pakai WinBox -> Ip -> Firewall -> NAT
    klik [+]
    isikan chain : dstnat
    protocol : 1 (icmp)
    in interface : ether1
    -> di menu action
    action : redirect
    to ports : 1
    klik OK

    lalu silahkan coba PING atau TRACERT dan dijamin anda NGUAKAK KAK KAK KAK.
    Kalau ini baru saya praktekkan...emang bikin ngakak....Click here to enlarge

  6. #5
    Status
    Offline
    Priaadi's Avatar
    Member
    Join Date
    May 2008
    Posts
    102
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Thx kk, tutznyah barusan ane cobain n berhasil eeeuy!! Click here to enlarge

    Yg bikin ngakak mang setingan TOSnya,,,,

    mo kmana ajah pasti whuuuuuuzzzz....!!! Click here to enlarge

    Click here to enlarge
    xixixixi

  7. #6
    Status
    Offline
    Akangage's Avatar
    Administrator
    Join Date
    Aug 2007
    Location
    Daerah Khusus Ibukota Jakarta, Indonesia
    Posts
    4,188
    Reviews
    Read 0 Reviews
    Downloads
    210
    Uploads
    87
    Feedback Score
    0
    Click here to enlarge Originally Posted by adhielesmana Click here to enlarge
    Konsep LOAD BALANCING
    Sebelum BEraksi Jangan Lupa Setup Ethernet / Interface Card ( NIC ) atau Bahasa Gaulnya ( Lan Card ) dengan konfigurasi Sebagai Berikut :

    Perangkat 3 Lan Card -> 2 Isp ( WAN ), 1 Local ( LAN )

    1. Pake WinBox masuk ke -> IP -> Address
    -> klik [+] -> isikan Address : 192.168.1.1/24 _
    Network : 192.168.1.0 |
    Broadcast : 192.168.1.255 | Konfigurasi LAN ( Local)
    Interface : Ether1 _|
    -> klik [+] -> isikan Address : 192.168.2.1/24 _
    Network : 192.168.2.0 |
    Broadcast : 192.168.2.255 | Konfigurasi WAN 1
    Interface : Ether2 _|
    -> klik [+] -> isikan Address : 192.168.3.1/24 _
    Network : 192.168.3.0 |
    Broadcast : 192.168.3.255 | Konfigurasi WAN 2
    Interface : Ether3 _|

    2. Buat Mangle. Pake WinBox pilih -> New Terminal
    Paste kan Kode Berikut
    /ip firewall mangle [lalu enter]
    add chain=prerouting in-interface="ether1" connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=lb_1 passthrough=yes comment="LB Client" disabled=no
    add chain=prerouting in-interface="ether1" connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no comment="" disabled=no
    add chain=prerouting in-interface="ether1" connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=lb_2 passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface="ether1" connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no comment="" disabled=no [lalu enter]
    3. Buat Nat. Pake WinBox pilih -> New Terminal
    Lagi Lagi Paste kan [ maklum sebagai newbie males nulis ]
    / ip firewall nat
    add chain=srcnat out-interface="ether3" action=masquerade comment="" disabled=no
    add chain=srcnat out-interface="ether2" action=masquerade comment="" disabled=no
    4. Buat Route. Pake WinBox pilih -> New Terminal
    Copy Paste Lagi Bosssss
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=route_lb_1 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=255 target-scope=10 routing-mark=route_lb_2 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=255 target-scope=10 comment="default routing connection" disabled=no
    Sudah ada banyak yang bahas, namun yang baca pada ga teliti, jadinya sering gagal... udah sampe bergulung-gulung halaman di forum ini, but nice help

    Click here to enlarge Originally Posted by adhielesmana Click here to enlarge
    DNS Resolver ( bisa juga disebut DNS Forwarder atau apalah saya juga bingung)
    Pake WinBox masuk ke -> IP -> DNS
    -> Klik Settings
    -> masukkan Primary Dan Secondary DNS dari ISP nya
    -> centang [v] allow remote requests
    Pake WinBox masuk ke -> IP -> Firewall -> NAT
    -> klik [+] -> isikan Chain : dstnat
    protokol : 17(UDP)
    dstport : 53
    ->Pindah Ke Sub Menu Action
    action : redirect
    to ports : 53
    ->Klik OK biar Kesimpen
    -> Bikin Sekali lagi dengan protokol di isi : 6(TCP)

    Sampai Disini DNS Resolvernya success
    kamu bisa tambahkan sendiri Host + NS Resolution dari web web yang sering dibuka biar tambah cepet browsing nya
    Ini juga pernah dibahas, ya tapi itu lagi, bacanya pada males maunya langsung aksi, once again nice help Click here to enlarge Mengingatkan BAGI YANG MALES baca di forum ini thread dan halaman sebelumnya

    Click here to enlarge Originally Posted by adhielesmana Click here to enlarge
    Secret Featurenya adalah
    1. Mencegah YM dan MIRC Diskonek saat Load Balancing
    pada mangle pembuatan connection mark yang telah dibuat di Load Balancing tadi [ bukalah pakai WinBox -> Ip -> Firewall -> mangle ] pada kolom protocol tambahkan 6(TCP) dan dst port 80 ( jangan lupa aplikasikan pada kedua mangle tersebut baik lb_1 maupaun lb_2 )
    apa fungsinya ??
    fungsinya semua koneksi non HTTP (80) akan di routing menggunakan default routing conncetion alias satu IP Route jadi ndak bolak balik drop.

    2. Settingan Gila Ala Manipulasi TOS
    anda sering gagal membuat manipulasi TOS.. pakai ini dijamin berhasil
    pakai WinBox -> Ip -> Firewall -> NAT
    klik [+]
    isikan chain : dstnat
    protocol : 1 (icmp)
    in interface : ether1
    -> di menu action
    action : redirect
    to ports : 1
    klik OK

    lalu silahkan coba PING atau TRACERT dan dijamin anda NGUAKAK KAK KAK KAK.

    3. Fail Over Gateway Backup
    pake WinBox -> IP -> Routes

    [+]
    destination : 0.0.0.0/0
    gateway : 192.168.1.2
    distance : 2
    OK
    Juga sama.... sering banyak yang tanya tapi pada males nyari jadinya pada tanya lagi... di BOOKMARK DONK!!!! thread ini juga salah satu yang mengingatkan KITA, SO... BOOKMARK YA!! JANGAN MALES

  8. The Following 14 Users Say Thank You to Akangage For This Useful Post:

    + Show/Hide list of the thanked


  9. #7
    Status
    Offline
    all21's Avatar
    Member
    Join Date
    Apr 2008
    Posts
    283
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    mas, saya udah implementasikan settingan lb yang di
    Code:
    http://www.forummikrotik.com/articles/4293-simple-load-balancing-dns-resolver-secret-fiture.html
    tapi kok ngga mau konek????
    settingannya saya ubah jadi seperti ini :
    Code:
    1. Pake WinBox masuk ke -> IP -> Address
    -> klik [+] -> isikan Address : 192.168.0.30/24 _
    Network : 192.168.0.0 |
    Broadcast : 192.168.0.255 | Konfigurasi LAN ( Local)
    Interface : Ether1 _|
    -> klik [+] -> isikan Address : 192.168.1.2/24 _
    Network : 192.168.1.0 |
    Broadcast : 192.168.1.255 | Konfigurasi WAN 1
    Interface : Ether2 _|
    -> klik [+] -> isikan Address : 192.168.5.2/24 _
    Network : 192.168.5.0 |
    Broadcast : 192.168.3.255 | Konfigurasi WAN 2
    Interface : Ether3 _|
    
    2. Buat Mangle. Pake WinBox pilih -> New Terminal
    Paste kan Kode Berikut
    /ip firewall mangle [lalu enter]
    add chain=prerouting in-interface="ether1" connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=lb_1 passthrough=yes comment="LB Client" disabled=no
    add chain=prerouting in-interface="ether1" connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no comment="" disabled=no
    add chain=prerouting in-interface="ether1" connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=lb_2 passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface="ether1" connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no comment="" disabled=no [lalu enter]
    3. Buat Nat. Pake WinBox pilih -> New Terminal
    Lagi Lagi Paste kan [ maklum sebagai newbie males nulis ]
    / ip firewall nat
    add chain=srcnat out-interface="ether3" action=masquerade comment="" disabled=no
    add chain=srcnat out-interface="ether2" action=masquerade comment="" disabled=no
    4. Buat Route. Pake WinBox pilih -> New Terminal
    Copy Paste Lagi Bosssss
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark=route_lb_1 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.5.1 scope=255 target-scope=10 routing-mark=route_lb_2 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.5.1 scope=255 target-scope=10 comment="default routing connection" disabled=no
    DNS Resolver ( bisa juga disebut DNS Forwarder atau apalah saya juga bingung)
    Pake WinBox masuk ke -> IP -> DNS
    -> Klik Settings
    -> masukkan Primary DNS 203.130.209.242san secondary 202.134.1.10 (dari speedy)
    -> centang [v] allow remote requests
    Pake WinBox masuk ke -> IP -> Firewall -> NAT
    -> klik [+] -> isikan Chain : dstnat
    protokol : 17(UDP)
    dstport : 53
    ->Pindah Ke Sub Menu Action
    action : redirect
    to ports : 53
    ->Klik OK biar Kesimpen
    -> Bikin Sekali lagi dengan protokol di isi : 6(TCP)
    
    Secret Featurenya adalah
    1. Mencegah YM dan MIRC Diskonek saat Load Balancing
    pada mangle pembuatan connection mark yang telah dibuat di Load Balancing tadi [ bukalah pakai WinBox -> Ip -> Firewall -> mangle ] pada kolom protocol tambahkan 6(TCP) dan dst port 80 ( jangan lupa aplikasikan pada kedua mangle tersebut baik lb_1 maupaun lb_2 )
    apa fungsinya ??
    fungsinya semua koneksi non HTTP (80) akan di routing menggunakan default routing conncetion alias satu IP Route jadi ndak bolak balik drop.
    
    2. Settingan Gila Ala Manipulasi TOS
    anda sering gagal membuat manipulasi TOS.. pakai ini dijamin berhasil
    pakai WinBox -> Ip -> Firewall -> NAT
    klik [+]
    isikan chain : dstnat
    protocol : 1 (icmp)
    in interface : ether1
    -> di menu action
    action : redirect
    to ports : 1
    klik OK
    
    lalu silahkan coba PING atau TRACERT dan dijamin anda NGUAKAK KAK KAK KAK.
    
    3. Fail Over Gateway Backup
    pake WinBox -> IP -> Routes
    
    [+]
    destination : 0.0.0.0/0
    gateway : 192.168.1.1
    distance : 2
    OK
    tapi tetep ngga mau????
    kenapa yaaaa???? mohon di koreksi...
    boz udah marah² koneksi wnet putus :P

  10. #8
    Status
    Offline
    all21's Avatar
    Member
    Join Date
    Apr 2008
    Posts
    283
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    masih ngga bisa..........
    udah bisa ping ke google.com dari client......
    tapi kalo buka dari browser ngga mau......
    help me plzzzzzzzzClick here to enlargeClick here to enlargeClick here to enlarge
    boz udah marah² koneksi wnet matot.......Click here to enlargeClick here to enlargeClick here to enlargeClick here to enlarge
    btw, dns di client aku kasih dns sapidi
    btw, ini hasil print setingan saya :
    Code:
    [admin@MikroTik] > interface print 
    Flags: X - disabled, D - dynamic, R - running 
     #    NAME                         TYPE             RX-RATE    TX-RATE    MTU  
     0  R lokal                        ether            0          0          1500 
     1  R speedy1                      ether            0          0          1500 
     2  R speedy2                      ether            0          0          1500 
    
    [admin@MikroTik] > ip address pr
    Flags: X - disabled, I - invalid, D - dynamic 
     #   ADDRESS            NETWORK         BROADCAST       INTERFACE
     0   192.168.0.30/24    192.168.0.0     192.168.0.255   lokal    
     1   192.168.1.2/24     192.168.1.0     192.168.1.255   speedy1  
     2   192.168.5.2/24     192.168.5.0     192.168.5.255   speedy2  
    
    [admin@MikroTik] > ip route pr  
    Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf 
     #     DST-ADDRESS        PREFSRC         G GATEWAY         DISTANCE INTERFACE
     0 ADC 192.168.0.0/24     192.168.0.30                               lokal    
     1 ADC 192.168.1.0/24     192.168.1.2                                speedy1  
     2 ADC 192.168.5.0/24     192.168.5.2                                speedy2  
     3 A S 0.0.0.0/0                          r 192.168.1.1              speedy1  
     4 A S 0.0.0.0/0                          r 192.168.5.1              speedy2  
     5 A S ;;; default routing connection
           0.0.0.0/0                          r 192.168.1.1              speedy1  
     6   S ;;; backup routing
           0.0.0.0/0                          r 192.168.5.1     2        speedy2  
    
    [admin@MikroTik] > ip firewall nat print 
    Flags: X - disabled, I - invalid, D - dynamic 
     0   ;;; nat speedy 1
         chain=srcnat out-interface=speedy1 action=masquerade 
    
     1   ;;; nat speedy 2
         chain=srcnat out-interface=speedy2 action=masquerade 
    
     2   chain=dstnat protocol=udp dst-port=53 action=redirect to-ports=53 
    
     3   chain=dstnat protocol=tcp dst-port=53 action=redirect to-ports=53 
    
    [admin@MikroTik] > ip firewall mangle print 
    Flags: X - disabled, I - invalid, D - dynamic 
     0   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no 
    
     1   ;;; LB Client
         chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=lb_1 
         passthrough=yes 
    
     2   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=lb_2 
         passthrough=yes 
    
     3   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no 
    
    [admin@MikroTik] > ip dns print 
                primary-dns: 203.130.249.242
              secondary-dns: 202.134.1.10
      allow-remote-requests: yes
                 cache-size: 2048KiB
              cache-max-ttl: 1w
                 cache-used: 27KiB
    help me plz.........
    can anyone help me????
    Last edited by all21; 04-01-2009 at 12:36.

  11. #9
    Status
    Offline
    Akangage's Avatar
    Administrator
    Join Date
    Aug 2007
    Location
    Daerah Khusus Ibukota Jakarta, Indonesia
    Posts
    4,188
    Reviews
    Read 0 Reviews
    Downloads
    210
    Uploads
    87
    Feedback Score
    0
    hufff........................ coba di komputer client di cmd ketikan nslookup mau resolve IP router sama domain web apa gitu, misalnya saja telkomspeedy.com? kalo ga bisa berarti masalah ada ada di router si boz [kalo dari client] maka naik k router, ping ke telkomspeedy.com mau ga? kalo mau berarti salah ada di DNS, kalo g mau ada 2 mungkinan juga seh, yang pertama Speedy emang down yang kedua salah konfigurasi

    Sebenarnya yang namanya MASQUERADE cukup out-interface=lokal atau src-address=[IP Lokal anda] sudah cukup, tidak perlu didobel2 karena fungsinya hanya TRANSLASI saja, agarIP Publik bisa di pake sekian banyak client, silahkan baca MANUAL Mikrotik untuk Penjelasan pasti
    Last edited by Akangage; 04-01-2009 at 14:59.

  12. The Following 3 Users Say Thank You to Akangage For This Useful Post:


  13. #10
    Status
    Offline
    all21's Avatar
    Member
    Join Date
    Apr 2008
    Posts
    283
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Akangage Click here to enlarge
    hufff........................ coba di komputer client di cmd ketikan nslookup mau resolve IP router sama domain web apa gitu, misalnya saja telkomspeedy.com? kalo ga bisa berarti masalah ada ada di router si boz [kalo dari client] maka naik k router, ping ke telkomspeedy.com mau ga? kalo mau berarti salah ada di DNS, kalo g mau ada 2 mungkinan juga seh, yang pertama Speedy emang down yang kedua salah konfigurasi
    kang......
    udah saya coba ping dari client ke google.com bisa
    dari router ke google.com juga bisa
    tapi kalo dari client saya browsing, dia ngga mau.....
    nahhh.....
    kalo yang awalnya begini
    Code:
    0   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no 
     1   ;;; LB Client
         chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=lb_1 
         passthrough=yes 
     2   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=lb_2 
         passthrough=yes 
     3   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no
    saya rubah jadi seperti ini :
    Code:
    0   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no 
     1   ;;; LB Client
       chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=lb_1 
        passthrough=yes 
     2   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-state=new nth=1,2,1 action=mark-connection new-connection-mark=lb_2 
        passthrough=yes 
     3   chain=prerouting in-interface=lokal protocol=tcp dst-port=80 connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no
    (counter untuk nth yang ke 2 saya bedakan dengan yang pertama)
    baru bisa browsing......

    padahal kedua line pake speedy
    kenapa yaaa???

    trus apa kalo seperti itu dia bisa jalan loadbalancingnya???
    makasih yaaaaaaaaaaaaaaaa
    Last edited by all21; 04-01-2009 at 15:07.

  14. #11
    Status
    Offline
    Akangage's Avatar
    Administrator
    Join Date
    Aug 2007
    Location
    Daerah Khusus Ibukota Jakarta, Indonesia
    Posts
    4,188
    Reviews
    Read 0 Reviews
    Downloads
    210
    Uploads
    87
    Feedback Score
    0
    OOhh... itu NTH-nya Click here to enlarge silahkan mampir ke general networking, dan cari tentang NTH, baca pelan2 dan pahami APA ITU NTH Click here to enlarge jangan asal main LB aja, try learn what is NTH @ there OK!

  15. The Following User Says Thank You to Akangage For This Useful Post:


  16. #12
    Status
    Offline
    all21's Avatar
    Member
    Join Date
    Apr 2008
    Posts
    283
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Akangage Click here to enlarge
    OOhh... itu NTH-nya Click here to enlarge silahkan mampir ke general networking, dan cari tentang NTH, baca pelan2 dan pahami APA ITU NTH Click here to enlarge jangan asal main LB aja, try learn what is NTH @ there OK!
    ok...
    makacih yaa akang.............. maap ngerepotin....
    coz dari semalam saya blom tidur karena si nth ini... Click here to enlargeClick here to enlarge

  17. #13
    Status
    Offline
    adhielesmana's Avatar
    Administrator
    Join Date
    Jan 2009
    Location
    http://www.adhielesmana.com
    Posts
    3,056
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Iya Bro Salah...

    Click here to enlarge Originally Posted by korekuping Click here to enlarge
    Sori kalo salah
    3. Fail Over Gateway Backup
    pake WinBox -> IP -> Routes

    [+]
    destination : 0.0.0.0/0
    gateway : 192.168.1.2 <----- (mungkin ini maksudnya 192.168.2.1 kali yak)
    distance : 2

    Sorry Salah.. Tak Ralat YaaaaakkkClick here to enlarge

    Yang Bener

    3. Fail Over Gateway Backup

    pake WinBox -> IP -> Routes

    [+]

    destination : 0.0.0.0/0
    gateway : 192.168.2.1 <----- (Dah DI Ralat jadi 192.168.2.1)
    distance : 2
    Last edited by adhielesmana; 04-01-2009 at 22:31.

  18. The Following 4 Users Say Thank You to adhielesmana For This Useful Post:


  19. #14
    Status
    Offline
    dencow's Avatar
    Forum Guru
    Join Date
    Jan 2008
    Posts
    1,728
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    thanks tutornya boss... Click here to enlarge
    numpang bookmark dolo Click here to enlarge

  20. #15
    Status
    Offline
    all21's Avatar
    Member
    Join Date
    Apr 2008
    Posts
    283
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    dear all.....
    maap kalo masih nanya...........
    itu tutoril punya mas adhielesmana
    tak rubah jadi seperti ini :

    Code:
    /interface ethernet
    set ether2 name=speedy1
    set ether3 name=speedy2
    set ether1 name=lan
    
    /
    
    /ip address
    add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=speedy1 
    
    comment="" disabled=no
    add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=speedy2 
    
    comment="" disabled=no
    add address=192.168.3.30/24 network=192.168.3.0 broadcast=192.168.3.255 interface=lan 
    
    comment="" disabled=no
    
    /
    
    /ip firewall nat
    add chain=srcnat out-interface=speedy1 action=masquerade
    add chain=srcnat out-interface=speedy2 action=masquerade
    
    /
    
    /ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 comment="ruting 
    
    milik router" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 
    
    routing-mark=speedy1 check-gateway=ping comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 
    
    routing-mark=speedy2 comment="" disabled=no
    
    /
    
    /ip firewall mangle
    add chain=prerouting in-interface=lan connection-state=new nth=1,2,0 action=mark-connection 
    
    new-connection-mark=speedy1 passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=lan connection-mark=speedy1 action=mark-routing 
    
    new-routing-mark=speedy1 passthrough=no comment="loadbalancing1" disabled=no
    add chain=prerouting in-interface=lan connection-state=new nth=1,2,1 action=mark-connection 
    
    new-connection-mark=speedy2 passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=lan connection-mark=speedy2 action=mark-routing 
    
    new-routing-mark=speedy2 passthrough=no comment="loadbalancing2" disabled=no
    
    /
    
    3. DNS Resolver 
    Pake WinBox masuk ke -> IP -> DNS
    -> Klik Settings
    -> masukkan Primary DNS 203.130.209.242 Dan Secondary DNS 202.134.1.10 (dns speedy)
    -> centang [v] allow remote requests
    lalu klik ok
    
    4. Pake WinBox masuk ke -> IP -> Firewall -> NAT
    -> klik [+] -> isikan Chain : dstnat
    protokol : 17(UDP)
    dstport : 53
    ->Pindah Ke Sub Menu Action
    action : redirect
    to ports : 53
    ->Klik OK biar Kesimpen
    -> Bikin Sekali lagi dengan protokol di isi : 6(TCP)
    
    5. Mencegah YM dan MIRC Diskonek saat Load Balancing
    pada mangle pembuatan connection mark yang telah dibuat di Load Balancing tadi 
    [ bukalah pakai WinBox -> Ip -> Firewall -> mangle ] pada kolom protocol tambahkan 
    6(TCP) dan dst port 80 ( jangan lupa aplikasikan pada kedua mangle tersebut baik speedy1 
    maupaun speedy2 )
    apa fungsinya ??
    fungsinya semua koneksi non HTTP (80) akan di routing menggunakan default routing 
    conncetion alias satu IP Route jadi ndak bolak balik drop.
    
    6. Settingan Gila Ala Manipulasi TOS (kalo tidak mangarti jangan!!!! ini cuman buat ba akal
    waktu ping!!!!!!) 
    pakai WinBox -> Ip -> Firewall -> NAT
    klik [+]
    isikan chain : dstnat
    protocol : 1 (icmp)
    in interface : ether1
    -> di menu action
    action : redirect
    to ports : 1
    klik OK
    
    7. Fail Over Gateway Backup
    pake WinBox -> IP -> Routes
    [+]
    destination : 0.0.0.0/0
    gateway : 192.168.2.1
    distance : 2
    OK
    
    ================================================================================
    script untuk client-1 sd 13:
    {
    :local strPC
    :set strPC "client-"
    :local interfacenya
    :set interfacenya "lan"
    :local ipnya
    :set ipnya "192.168.3."
    :local iprouternya
    :set iprouternya 30
    :local limitnya
    :set limitnya "128000/128000"
    :local maxlimitnya
    :set maxlimitnya "256000/256000"
    :local startipnya
    :set startipnya 1
    :local endipnya
    :set endipnya 13
    :for i from=$startipnya to=$endipnya do={
    :if ($i < 10) do={ :set strPC "client-0" } else={ :set strPC "client-" }
    /queue simple add target-addresses=($ipnya . $i) limit-at=$limitnya max-limit=$maxlimitnya 
    
    interface=$interfacenya name=($strPC . $i)}
    }
    
    script untuk game-13 sd 19:
    {
    :local strPC
    :set strPC "game"
    :local interfacenya
    :set interfacenya "lan"
    :local ipnya
    :set ipnya "192.168.3."
    :local iprouternya
    :set iprouternya 30
    :local limitnya
    :set limitnya "64000/64000"
    :local maxlimitnya
    :set maxlimitnya "128000/128000"
    :local startipnya
    :set startipnya 14
    :local endipnya
    :set endipnya 19
    :for i from=$startipnya to=$endipnya do={
    :if ($i < 10) do={ :set strPC "game0" } else={ :set strPC "game" }
    /queue simple add target-addresses=($ipnya . $i) limit-at=$limitnya max-limit=$maxlimitnya 
    
    interface=$interfacenya name=($strPC . $i)}
    }
    
    script untuk client-20 sd 29:
    {
    :local strPC
    :set strPC "client-"
    :local interfacenya
    :set interfacenya "lan"
    :local ipnya
    :set ipnya "192.168.3."
    :local iprouternya
    :set iprouternya 30
    :local limitnya
    :set limitnya "128000/128000"
    :local maxlimitnya
    :set maxlimitnya "256000/256000"
    :local startipnya
    :set startipnya 20
    :local endipnya
    :set endipnya 29
    :for i from=$startipnya to=$endipnya do={
    :if ($i < 10) do={ :set strPC "client-0" } else={ :set strPC "client-" }
    /queue simple add target-addresses=($ipnya . $i) limit-at=$limitnya max-limit=$maxlimitnya 
    
    interface=$interfacenya name=($strPC . $i)}
    }
    itu udah jalan.....
    mohon di koreksi..............Click here to enlargeClick here to enlarge

  21. The Following 7 Users Say Thank You to all21 For This Useful Post:


 

 
Page 1 of 17 12311 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. load balancing yg memusingkan
    By 51ny0 in forum Scripting @ Mikrotik
    Replies: 9
    Last Post: 11-09-2012, 22:46
  2. Another Load Balancing Tutorial
    By Dody in forum Tutorial
    Replies: 30
    Last Post: 12-11-2009, 02:09
  3. (ask) Load Balancing + Squid
    By cyberolog in forum General Networking
    Replies: 3
    Last Post: 20-10-2009, 21:54
  4. (ask) tanya load balancing
    By adiel.nopria in forum General Networking
    Replies: 6
    Last Post: 05-01-2009, 17:35
  5. load balancing yg memusingkan
    By 51ny0 in forum General Networking
    Replies: 2
    Last Post: 27-07-2008, 01:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •