sebelumnya mohon maaf kepada para agan2, para suhu, mimin dan momod kalau ada kekeliruan thread yang saya buat. thread ini thread pertama saya. saya masih newbie dan masih harus banyak belajar. jika dirasa cocok mungkin bisa disticky, mohon masukan dan koreksi dari sesepuh dan teman2 di forum jika ternyata ada yang salah.
saya ingin berbagi pengalaman manajemen hotspot menggunakan queue tree ( nggak recomended buat routerboard yang cpu-nya dibawah 650mhz). bisa juga di kombinasikan dengan user manager.

saya asumsikan setting hotspot sudah benar. disini saya menggunakan interface ether3 dengan alokasi bandwith 2M up dan 5M down dan min rate(limit-at)-nya 64k up dan 128k down(sesuaikan min rate dengan jumlah user agar tidak terjadi kebocoran bandwith karena total limit-at child queue melebihi max-limit parent).
pertama kita buat mangle untuk menandai koneksi yang keluar masuk interface hotspot.

/ip firewall mangle add chain=postrouting action=mark-connection out-interface=ether3 new-connection-mark="hotspot download" passthrough=yes comment="Hotspot Download"
/ip firewall mangle add chain=prerouting action=mark-connection in-interface=ether3 new-connection-mark="hotspot upload" passthrough=yes comment="Hotspot Upload"
sekarang kita buat parent hotspot di queue tree.

/queue tree add name="Hotspot Download" parent=global queue=default-small max-limit=5M
/queue tree add name="Hotspot Upload" parent=global queue=default-small max-limit=2M
selanjutnya kita buat user profilnya. disini saya membagi jadi 3 profil berdasarkan jatah bandwith masing2 user yaitu 512kbps 1mbps dan 2mbps.

/ip hotspot user profile add name="512kbps" transparent-proxy=no on-login=[/queue simple rem "<hotspot-$user>";\ /ip firewall mangle add comment="$user" chain=postrouting dst-address="$address" connection-mark="hotspot down" action=mark-packet new-packet-mark="$user down" passthrough=no;\ /ip firewall mangle add comment="$user" chain=prerouting src-address="$address" connection-mark="hotspot up" action=mark-packet new-packet-mark="$user up" passthrough=no;\ /queue tree add comment="$user" name="$user down" parent="Hotspot Download" packet-mark="$user down" queue=default-small limit-at=128k max-limit=512k;\ /queue tree add comment="$user" name="$user up" parent="Hotspot Upload" packet-mark="$user up" queue=default-small limit-at=64 max-limit=256k;] on-logout=[/ip firewall mangle rem [find comment="$user"];\ /queue tree rem [find comment="$user"];]
/ip hotspot user profile add name="1mbps" transparent-proxy=no on-login=[/queue simple rem "<hotspot-$user>";\ /ip firewall mangle add comment="$user" chain=postrouting dst-address="$address" connection-mark="hotspot down" action=mark-packet new-packet-mark="$user down" passthrough=no;\ /ip firewall mangle add comment="$user" chain=prerouting src-address="$address" connection-mark="hotspot up" action=mark-packet new-packet-mark="$user up" passthrough=no;\ /queue tree add comment="$user" name="$user down" parent="Hotspot Download" packet-mark="$user down" queue=default-small limit-at=128k max-limit=1M;\ /queue tree add comment="$user" name="$user up" parent="Hotspot Upload" packet-mark="$user up" queue=default-small limit-at=64k max-limit=512k;] on-logout=[/ip firewall mangle rem [find comment="$user"];\ /queue tree rem [find comment="$user"];]
/ip hotspot user profile add name="2mbps" transparent-proxy=no on-login=[/queue simple rem "<hotspot-$user>";\ /ip firewall mangle add comment="$user" chain=postrouting dst-address="$address" connection-mark="hotspot down" action=mark-packet new-packet-mark="$user down" passthrough=no;\ /ip firewall mangle add comment="$user" chain=prerouting src-address="$address" connection-mark="hotspot up" action=mark-packet new-packet-mark="$user up" passthrough=no;\ /queue tree add comment="$user" name="$user down" parent="Hotspot Download" packet-mark="$user down" queue=default-small limit-at=128k max-limit=2M;\ /queue tree add comment="$user" name="$user up" parent="Hotspot Upload" packet-mark="$user up" queue=default-small limit-at=64k max-limit=256k;] on-logout=[/ip firewall mangle rem [find comment="$user"];\ /queue tree rem [find comment="$user"];]
terakhir kita buat user dan password dengan profil yang sudah kita buat. kalau pakai user manager kita tambahkan nama user profile tadi ke tabel Group name pada tab limitation..
sekian share dari saya. semoga bermanfaat