Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2
  1. #1
    Status
    Offline
    imanbumen's Avatar
    Baru Gabung
    Join Date
    Feb 2011
    Posts
    4
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    [ASK] load balancing 2 isp Static IP public dan Dinamic IP Public

    Para Master dan Suhu Mikrotik, mohon pencerahan masalah load balancing dengan 2 ISP
    ISP1 IP static dapet ip public 111.111.111.176/29
    ISP2 IP Dinamic (Fastnet)

    Problem :
    Load balancing berjalan dengan baik (semua pc dengan private ip connect internet), tapi PC yang di assign dengan IP Public jadi gak bisa connect (RTO), padahal sebelum di seting load balancing PC tersebut bisa connect. Salah setingan dimananya ya ? mohon pencerahannya, terima kasih sebelumnya

    Code:
    /interface ipip
    add !keepalive local-address=10.2.65.228 name=ipip-isp1 \
        remote-address=10.1.250.52
    
    /interface pptp-server server
    set authentication=pap,chap,mschap1,mschap2 enabled=yes max-mru=1460 max-mtu=\
        1460
    
    /ip address
    add address=10.10.2.1/24 interface=ether4 network=\
        10.10.2.0
    add address=10.10.11.1/24 interface=ether5 network=\
        10.10.11.0
    add address=10.10.12.30/30 interface=ipip-isp1 network=\
        111.111.111.28
    add address=111.111.111.177/29 interface=ether5 network=111.111.111.176
    add address=10.2.65.228/29 comment=to-wireless interface=ether1 network=\
        10.2.65.224
    	
    /ip dhcp-client
    add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
        interface=ether3
    	
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=con_isp1 \
        connection-state=new in-interface=ether4 new-connection-mark=conn_1 nth=\
        1,1
    add action=mark-routing chain=prerouting comment=route_isp1 \
        connection-mark=conn_1 in-interface=ether4 new-routing-mark=route_1
    add action=mark-connection chain=prerouting comment=cont_fasnet \
        connection-state=new in-interface=ether4 new-connection-mark=conn_2 nth=\
        2,1
    add action=mark-routing chain=prerouting comment=route_fastnet \
        connection-mark=conn_2 in-interface=ether4 new-routing-mark=route_2 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=con_isp1 \
        connection-state=new in-interface=ether5 new-connection-mark=conn_1 nth=\
        1,1
    add action=mark-connection chain=prerouting comment=con_fastnet \
        connection-state=new in-interface=ether5 new-connection-mark=conn_2 nth=\
        2,1
    add action=mark-routing chain=prerouting comment=route_isp1 \
        connection-mark=conn_1 in-interface=ether5 new-routing-mark=route_1
    add action=mark-routing chain=prerouting comment=route_fastnet \
        connection-mark=conn_2 in-interface=ether5 new-routing-mark=route_2 \
        passthrough=no
    
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ipip-isp1 \
        to-addresses=0.0.0.0
    add action=src-nat chain=srcnat disabled=yes out-interface=\
        ipip-isp1 src-address-list=lokal to-addresses=111.111.111.30
    add action=masquerade chain=srcnat connection-mark=conn_1 out-interface=\
        ether1
    add action=masquerade chain=srcnat connection-mark=conn_2 out-interface=\
        ether3
    
    /ip route
    add check-gateway=ping distance=1 gateway=111.111.111.29 routing-mark=route_1
    add check-gateway=ping distance=1 gateway=192.168.0.1 routing-mark=route_2
    add distance=1 gateway=111.111.111.29

  2. #2
    Status
    Offline
    donipermono1982's Avatar
    Moderator
    Join Date
    Feb 2008
    Location
    Jakarta Selatan
    Posts
    2,810
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by imanbumen Click here to enlarge
    Para Master dan Suhu Mikrotik, mohon pencerahan masalah load balancing dengan 2 ISP
    ISP1 IP static dapet ip public 111.111.111.176/29
    ISP2 IP Dinamic (Fastnet)

    Problem :
    Load balancing berjalan dengan baik (semua pc dengan private ip connect internet), tapi PC yang di assign dengan IP Public jadi gak bisa connect (RTO), padahal sebelum di seting load balancing PC tersebut bisa connect. Salah setingan dimananya ya ? mohon pencerahannya, terima kasih sebelumnya

    Code:
    /interface ipip
    add !keepalive local-address=10.2.65.228 name=ipip-isp1 \
        remote-address=10.1.250.52
    
    /interface pptp-server server
    set authentication=pap,chap,mschap1,mschap2 enabled=yes max-mru=1460 max-mtu=\
        1460
    
    /ip address
    add address=10.10.2.1/24 interface=ether4 network=\
        10.10.2.0
    add address=10.10.11.1/24 interface=ether5 network=\
        10.10.11.0
    add address=10.10.12.30/30 interface=ipip-isp1 network=\
        111.111.111.28
    add address=111.111.111.177/29 interface=ether5 network=111.111.111.176
    add address=10.2.65.228/29 comment=to-wireless interface=ether1 network=\
        10.2.65.224
    	
    /ip dhcp-client
    add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
        interface=ether3
    	
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=con_isp1 \
        connection-state=new in-interface=ether4 new-connection-mark=conn_1 nth=\
        1,1
    add action=mark-routing chain=prerouting comment=route_isp1 \
        connection-mark=conn_1 in-interface=ether4 new-routing-mark=route_1
    add action=mark-connection chain=prerouting comment=cont_fasnet \
        connection-state=new in-interface=ether4 new-connection-mark=conn_2 nth=\
        2,1
    add action=mark-routing chain=prerouting comment=route_fastnet \
        connection-mark=conn_2 in-interface=ether4 new-routing-mark=route_2 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=con_isp1 \
        connection-state=new in-interface=ether5 new-connection-mark=conn_1 nth=\
        1,1
    add action=mark-connection chain=prerouting comment=con_fastnet \
        connection-state=new in-interface=ether5 new-connection-mark=conn_2 nth=\
        2,1
    add action=mark-routing chain=prerouting comment=route_isp1 \
        connection-mark=conn_1 in-interface=ether5 new-routing-mark=route_1
    add action=mark-routing chain=prerouting comment=route_fastnet \
        connection-mark=conn_2 in-interface=ether5 new-routing-mark=route_2 \
        passthrough=no
    
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ipip-isp1 \
        to-addresses=0.0.0.0
    add action=src-nat chain=srcnat disabled=yes out-interface=\
        ipip-isp1 src-address-list=lokal to-addresses=111.111.111.30
    add action=masquerade chain=srcnat connection-mark=conn_1 out-interface=\
        ether1
    add action=masquerade chain=srcnat connection-mark=conn_2 out-interface=\
        ether3
    
    /ip route
    add check-gateway=ping distance=1 gateway=111.111.111.29 routing-mark=route_1
    add check-gateway=ping distance=1 gateway=192.168.0.1 routing-mark=route_2
    add distance=1 gateway=111.111.111.29
    ip route nya tambahin dst address 8.8.8.8 check gateway = ping

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Load Balancing dua ISP Static IP dan Dinamic IP
    By imanbumen in forum Tutorial
    Replies: 0
    Last Post: 12-06-2015, 16:07
  2. [ASK] Tidak bisa akses ip public di Local (Load Balancing PCC)
    By b46ol in forum Beginner Basics
    Replies: 6
    Last Post: 28-11-2014, 14:24
  3. Load balance 2 WAN menjadi 1 IP public
    By alien.ID in forum Beginner Basics
    Replies: 4
    Last Post: 18-07-2013, 20:06
  4. membuat ip public static walaupun loadbalance
    By juskesemek in forum General Networking
    Replies: 10
    Last Post: 29-06-2013, 11:57
  5. Help......Tanya Setting Mikrotik Untuk ip public to ip public .....?
    By motokare2006 in forum General Networking
    Replies: 10
    Last Post: 19-03-2013, 14:02

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •