Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2
  1. #1
    Status
    Offline
    si_faisal's Avatar
    Contributor
    Join Date
    Jul 2008
    Location
    Jakarta & Sukabumi
    Posts
    486
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Cloud Router Switch Configuration Bonding Trunking LACP

    Cloud Router Switch Configuration, Interoperatbility with RouterBOARD and HP ProCurve Networking

    Kali ini imxpert.co akan membahas mengenai konfigurasi Cloud Router Switch (CRS), yang merupakan new product lineup-nya MikroTik, yang menurut saya adalah switch layer 3 gigabit yang paling murah di dunia saat ini :th_shiny_smile:

    Saya beberapa kali mendapatkan email dan Private messages di chat mengenai konfigurasi VLAN dan Trunking di CRS dan banyak yang kebingungan karena konfigurasi yang kurang tepat menyebabkan load cpu yang tinggi dan troughput network yang kurang baik.

    Pada contoh kasus ini melibatkan RB951-2n sebagai router, CRS125-24G-1S-RM dan HP ProCurve 2610-24. Skenario yang akan dibuat adalah, akan di create 2 VLAN ID (VLAN5 dan VLAN10) kedua vlan tersebut akan diberikan segmen IP yang berbeda, kemudian di VLAN10 akan dijalankan hotspot server. RB951-2n berperan sebagai gateway tiap vlan,

    Sebelum masuk ke konfigurasi, video dibawah ini menunjukkan bahwa konfigurasi bonding LACP, dan port trunking telah berjalan dengan baik.


    Topology 1 - without port channel
    Click here to enlarge

    Konfigurasi RB951-2n
    Code:
    # [reza@imxpert.co RB951-2n]
    # sep/10/2014 19:17:42 by RouterOS 6.19
    # software id = S93G-KFJL
    #
    /interface ethernet
    set [ find default-name=ether2 ] comment="TO CRS" name=ether2-switch
    
    /interface vlan
    add interface=ether2-switch l2mtu=1594 name=vlan05 vlan-id=5
    add interface=ether2-switch l2mtu=1594 name=vlan10 vlan-id=10
    
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n comment="TO INTERNET" \
        disabled=no frequency=2462 l2mtu=2290 name=wlan1-internet \
        security-profile=IMXpert ssid=IMXpert
    
    /ip hotspot profile
    add dns-name=hotspot.imxpert.co hotspot-address=192.168.10.254 name=hsprof1 \
        smtp-server=152.118.24.152
    
    /ip pool
    add name=dhcp_pool1 ranges=192.168.5.1-192.168.5.250
    add name=hs-pool-9 ranges=192.168.10.1-192.168.10.200
    /ip dhcp-server
    add address-pool=dhcp_pool1 disabled=no interface=vlan05 lease-time=10m name=\
        dhcp1
    add address-pool=hs-pool-9 disabled=no interface=vlan10 lease-time=1h name=\
        dhcp2
    /ip hotspot
    add address-pool=hs-pool-9 disabled=no interface=vlan10 name=hotspot1 \
        profile=hsprof1
    /ip address
    add address=192.168.88.1/24 interface=ether2-switch network=192.168.88.0
    add address=192.168.5.254/24 interface=vlan05 network=192.168.5.0
    add address=192.168.10.254/24 interface=vlan10 network=192.168.10.0
    
    /ip dhcp-client
    add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
        interface=wlan1-internet
    /ip dhcp-server network
    add address=192.168.5.0/24 dns-server=4.2.2.1,8.8.8.8 gateway=192.168.5.254
    add address=192.168.10.0/24 comment="hotspot network" gateway=192.168.10.254
    
    /ip dns
    set allow-remote-requests=yes servers=192.168.10.254
    
    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment=\
        "place hotspot rules here" disabled=yes
    
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
        "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat out-interface=wlan1-internet
    
    /ip hotspot user
    add name=admin password=admin1234
    
    /system identity
    set name=RB951-2n
    Click here to enlarge

    Konfigurasi CRS125-24G-1S-RM

    Code:
    # [reza@imxpert.co CRS125-24G-1S-RM]  
    # sep/10/2014 19:17:42 by RouterOS 6.19
    # software id = BNUD-GT8J
    
    /interface ethernet
    set [ find default-name=ether22 ] name=ether22-router
    set [ find default-name=ether23 ] master-port=ether22-router
    set [ find default-name=ether24 ] master-port=ether22-router name=\
        ether24-switch
    set [ find default-name=sfp1 ] master-port=ether22-router
    set [ find default-name=ether1 ] master-port=ether22-router
    set [ find default-name=ether2 ] master-port=ether22-router
    set [ find default-name=ether3 ] master-port=ether22-router
    set [ find default-name=ether4 ] master-port=ether22-router
    set [ find default-name=ether5 ] master-port=ether22-router
    set [ find default-name=ether6 ] master-port=ether22-router
    set [ find default-name=ether7 ] master-port=ether22-router
    set [ find default-name=ether8 ] master-port=ether22-router
    set [ find default-name=ether9 ] master-port=ether22-router
    set [ find default-name=ether10 ] master-port=ether22-router
    set [ find default-name=ether11 ] master-port=ether22-router
    set [ find default-name=ether12 ] master-port=ether22-router
    set [ find default-name=ether13 ] master-port=ether22-router
    set [ find default-name=ether14 ] master-port=ether22-router
    set [ find default-name=ether15 ] master-port=ether22-router
    set [ find default-name=ether16 ] master-port=ether22-router
    set [ find default-name=ether17 ] master-port=ether22-router
    set [ find default-name=ether18 ] master-port=ether22-router
    set [ find default-name=ether19 ] master-port=ether22-router
    set [ find default-name=ether20 ] master-port=ether22-router
    set [ find default-name=ether21 ] master-port=ether22-router
    
    /interface ethernet switch egress-vlan-tag
    add tagged-ports=ether22-router,ether24-switch vlan-id=5
    add tagged-ports=ether22-router,ether24-switch vlan-id=10
    
    /interface ethernet switch ingress-vlan-translation
    add customer-vlan-format=untagged-or-tagged new-customer-vid=5 ports=\
        ether1,ether2,ether3,ether4,ether5,ether6,ether7,e  ther8 sa-learning=yes \
        service-vlan-format=untagged-or-tagged
    add customer-vlan-format=untagged-or-tagged new-customer-vid=10 ports=\
        ether8,ether9,ether10,ether11,ether12,ether13,ethe  r14,ether15,ether16 \
        sa-learning=yes service-vlan-format=untagged-or-tagged
    
    /interface ethernet switch vlan
    add ports=ether22-router,ether24-switch vlan-id=1
    add ports="ether1,ether2,ether3,ether4,ether5,ether6,ether7,e  ther8,ether22-rou\
        ter,ether24-switch" vlan-id=5
    add ports="ether9,ether10,ether11,ether12,ether13,ether14,eth  er15,ether16,ethe\
        r22-router,ether24-switch" vlan-id=10
    
    /ip address
    add address=192.168.88.2/24 interface=ether22-router network=192.168.88.0
    
    /ip route
    add distance=1 gateway=192.168.88.1
    
    /system identity
    set name=CRS125-24G-1S-RM
    Click here to enlarge
    Click here to enlarge
    Click here to enlarge

    Konfigurasi HP ProCurve 2610-24 ;
    Code:
    reza@imxpert.co
    ; J9085A Configuration Editor; Created on release #R.11.25
    hostname "ProCurve 2610-24"
    ip default-gateway 192.168.88.1
    snmp-server community "public" Unrestricted
    vlan 1
       name "DEFAULT_VLAN"
       untagged 9-12,21-28
       ip address 192.168.88.3 255.255.255.0
       no untagged 1-8,13-20
       exit
    vlan 5
       name "VLAN5"
       untagged 1-8
       tagged 25
       exit
    vlan 10
       name "VLAN10"
       untagged 13-20
       tagged 25
       exit


    Topology 2- with Trunk/LAG
    Pada topology 2, kita melakukan port trunking (istilah yang sama untuk Bonding, LAG, atau Port channel, etherchannel) yang fungsinya sebagai link redundancy dan meningkatkan/menggabungkan bandwitdh dari port fisik yang dikoneksikan.
    Click here to enlarge

    Berikut ini konfigurasinya :

    Konfigurasi RB951-2n (dengan Bonding Interface)

    Code:
    # [reza@imxpert.co RB951-2n] 
    # jan/02/1970 01:36:21 by RouterOS 6.19
    # software id = S93G-KFJL
    
    /interface ethernet
    set [ find default-name=ether2 ] comment="TO CRS PORT 21" name=ether2-switch
    set [ find default-name=ether3 ] comment="TO CRS PORT 22" name=ether3-switch
     
    /interface bonding
    add link-monitoring=none mode=802.3ad name=bonding1 slaves=\
        ether2-switch,ether3-switch transmit-hash-policy=layer-3-and-4
    
    /interface vlan
    add interface=bonding1 name=vlan05 vlan-id=5
    add interface=bonding1 name=vlan10 vlan-id=10
    
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n comment="TO INTERNET" \
        disabled=no frequency=2462 l2mtu=2290 name=wlan1-internet \
        security-profile=IMXpert ssid=IMXpert
    
    /ip hotspot profile
    add dns-name=hotspot.imxpert.co hotspot-address=192.168.10.254 name=hsprof1 \
        smtp-server=152.118.24.152
    
    /ip pool
    add name=dhcp_pool1 ranges=192.168.5.1-192.168.5.250
    add name=hs-pool-9 ranges=192.168.10.1-192.168.10.200
    
    /ip dhcp-server
    add address-pool=dhcp_pool1 disabled=no interface=vlan05 lease-time=10m name=\
        dhcp1
    add address-pool=hs-pool-9 disabled=no interface=vlan10 lease-time=1h name=\
        dhcp2
    
    /ip hotspot
    add address-pool=hs-pool-9 disabled=no interface=vlan10 name=hotspot1 \
        profile=hsprof1
    
    /ip address
    add address=192.168.88.1/24 interface=ether2-switch network=192.168.88.0
    add address=192.168.5.254/24 interface=vlan05 network=192.168.5.0
    add address=192.168.10.254/24 interface=vlan10 network=192.168.10.0
    
    /ip dhcp-client
    add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
        interface=wlan1-internet
    
    /ip dhcp-server network
    add address=192.168.5.0/24 dns-server=4.2.2.1,8.8.8.8 gateway=192.168.5.254
    add address=192.168.10.0/24 comment="hotspot network" gateway=192.168.10.254
    
    /ip dns
    set allow-remote-requests=yes servers=192.168.10.254
    
    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment=\
        "place hotspot rules here" disabled=yes
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
        "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat out-interface=wlan1-internet
    
    /ip hotspot user
    add name=admin password=admin1234
    
    /system identity
    set name=RB951-2n
    Click here to enlarge

    Konfigurasi CRS125-24G-1S-RM (with Port Trunking)


    Code:
    # [reza@imxpert.co CRS125-24G-1S-RM] 
    # sep/10/2014 19:17:42 by RouterOS 6.19
    # software id = BNUD-GT8J
    #
    /interface ethernet
    set [ find default-name=ether22 ] name=ether22-router-port3
    set [ find default-name=ether23 ] master-port=ether22-router-port3 name=\
        ether23-procurve-port25
    set [ find default-name=ether24 ] master-port=ether22-router-port3 name=\
        ether24-procurve-port26
    set [ find default-name=sfp1 ] master-port=ether22-router-port3
    set [ find default-name=ether1 ] master-port=ether22-router-port3
    set [ find default-name=ether2 ] master-port=ether22-router-port3
    set [ find default-name=ether3 ] master-port=ether22-router-port3
    set [ find default-name=ether4 ] master-port=ether22-router-port3
    set [ find default-name=ether5 ] master-port=ether22-router-port3
    set [ find default-name=ether6 ] master-port=ether22-router-port3
    set [ find default-name=ether7 ] master-port=ether22-router-port3
    set [ find default-name=ether8 ] master-port=ether22-router-port3
    set [ find default-name=ether9 ] master-port=ether22-router-port3
    set [ find default-name=ether10 ] master-port=ether22-router-port3
    set [ find default-name=ether11 ] master-port=ether22-router-port3
    set [ find default-name=ether12 ] master-port=ether22-router-port3
    set [ find default-name=ether13 ] master-port=ether22-router-port3
    set [ find default-name=ether14 ] master-port=ether22-router-port3
    set [ find default-name=ether15 ] master-port=ether22-router-port3
    set [ find default-name=ether16 ] master-port=ether22-router-port3
    set [ find default-name=ether17 ] master-port=ether22-router-port3
    set [ find default-name=ether18 ] master-port=ether22-router-port3
    set [ find default-name=ether19 ] master-port=ether22-router-port3
    set [ find default-name=ether20 ] master-port=ether22-router-port3
    set [ find default-name=ether21 ] master-port=ether22-router-port3 name=\
        ether21-router-port2
    
    /interface ethernet switch trunk
    add member-ports=ether21-router-port2,ether22-router-port3 name=trunk1
    add member-ports=ether23-procurve-port25,ether24-procurve-port26 name=trunk2
    
    /interface ethernet switch egress-vlan-tag
    add tagged-ports=trunk1,trunk2 vlan-id=5
    add tagged-ports=trunk1,trunk2 vlan-id=10
    
    /interface ethernet switch ingress-vlan-translation
    add customer-vlan-format=untagged-or-tagged new-customer-vid=5 ports=\
        ether1,ether2,ether3,ether4,ether5,ether6,ether7,e  ther8 sa-learning=yes \
        service-vlan-format=untagged-or-tagged
    add customer-vlan-format=untagged-or-tagged new-customer-vid=10 ports=\
        ether8,ether9,ether10,ether11,ether12,ether13,ethe  r14,ether15,ether16 \
        sa-learning=yes service-vlan-format=untagged-or-tagged
    
    /interface ethernet switch vlan
    add ports=trunk1,trunk2 vlan-id=1
    add ports=\
        trunk1,trunk2,ether1,ether2,ether3,ether4,ether5,e  ther6,ether7,ether8 \
        vlan-id=5
    add ports="trunk1,trunk2,ether9,ether10,ether11,ether12,ether  13,ether14,ether1\
        5,ether16" vlan-id=10
    
    /ip address
    add address=192.168.88.2/24 interface=ether22-router-port3 network=\
        192.168.88.0
    
    /ip route
    add distance=1 gateway=192.168.88.1
    
    /system identity
    set name=CRS125-24G-1S-RM
    Click here to enlarge
    Click here to enlarge

    Konfigurasi HP ProCurve 2610-24 (with Port Trunk)
    ;
    Code:
    reza@imxpert.co
    ; J9085A Configuration Editor; Created on release #R.11.25
    
    hostname "ProCurve 2610-24"
    trunk 25-26 Trk1 Trunk
    ip default-gateway 192.168.88.1
    snmp-server community "public" Unrestricted
    vlan 1
       name "DEFAULT_VLAN"
       untagged 9-12,21-24,27-28,Trk1
       ip address 192.168.88.3 255.255.255.0
       no untagged 1-8,13-20
       exit
    vlan 5
       name "VLAN5"
       untagged 1-8
       tagged Trk1
       exit
    vlan 10
       name "VLAN10"
       untagged 13-20
       tagged Trk1
       exit
    spanning-tree Trk1 priority 4
    CRS Performance Tuning
    agar CPU load switch kecil, disable paket di CRS yang tidak perlu, serta matikan/disable semua fitur seperti connection tracking, firewall, dhcp server, dhcp client (default dalam keadaan enable)
    Click here to enlarge

    Kesimpulan
    dengan konfigurasi yang tepat, MikroTik CRS dapat berinteroperasi dengan Switch Lainnya menggunakan protokol standard 802.1Q (VLAN Tagging) dan 802.11ad (LACP) untuk port trunking/bonding/etherchannel

    Selamat Mencoba!!!
    sumber :

  2. The Following 2 Users Say Thank You to si_faisal For This Useful Post:


  3. #2
    Status
    Offline
    warkirasep's Avatar
    Member
    Join Date
    Oct 2009
    Posts
    293
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Mantap, akhirnya mikrotik ngeluarin switch layer 3 juga, boleh di coba nih,

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [ASK] Setting Cloud Router Switch
    By baragajulz in forum General Networking
    Replies: 3
    Last Post: 28-08-2016, 10:46
  2. [SOLVED] [SHARE] CRS125 VLAN & Trunking Configuration
    By si_faisal in forum Beginner Basics
    Replies: 3
    Last Post: 14-03-2016, 13:25
  3. [ASK] Drop Netcut dengan Cloud Router Switch
    By Ikhwan Wiiper in forum General Networking
    Replies: 2
    Last Post: 20-07-2014, 21:46
  4. [ASK] Bisa ngga Trunking lewat unmanageable switch baru ke switch managable
    By ffaradyc in forum General Networking
    Replies: 2
    Last Post: 08-04-2013, 14:07
  5. Bonding 2 IP WAN ( 1 Router dengan 3 eth)
    By yogi_guo in forum General Networking
    Replies: 0
    Last Post: 30-05-2009, 17:50

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •