Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 10 123 ... LastLast
Results 1 to 15 of 142
  1. #1
    Status
    Offline
    kucingGarong's Avatar
    Member
    Join Date
    Jul 2007
    Posts
    235
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    2 Isp In 1 Router With Loadbalancing

    2 ISP IN 1 ROUTER WITH LOADBALANCING


    Click here to enlarge

    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local comment="" \
    disabled=no
    add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 \
    comment="" disabled=no
    add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 \
    comment="" disabled=no
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 \
    action=mark-connection new-connection-mark=odd passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing \
    new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 \
    action=mark-connection new-connection-mark=even passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing \
    new-routing-mark=even passthrough=no comment="" disabled=no
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0.2 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.112.0.2 \
    to-ports=0-65535 comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=odd \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=even \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 comment="" \
    disabled=no

    Mangle

    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local comment="" \
    disabled=no
    add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 \
    comment="" disabled=no
    add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 \
    comment="" disabled=no

    router punya 2 upstream (WAN) interfaces dengan ip address 10.111.0.2/24 and 10.112.0.2/24. dan interface LAN dengan nama interface "Local" dan ip address 192.168.0.1/24.


    / ip firewall mangle

    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 \
    action=mark-connection new-connection-mark=odd passthrough=yes comment="" \
    disabled=no

    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing \
    new-routing-mark=odd passthrough=no comment="" disabled=no

    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 \
    action=mark-connection new-connection-mark=even passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing \
    new-routing-mark=even passthrough=no comment="" disabled=no




    NAT


    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0.2 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.112.0.2 \
    to-ports=0-65535 comment="" disabled=no



    Routing


    / ip route
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=odd \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=even \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 comment="" \
    disabled=no comment="gateway for the router itself"


    thanks to mbah WIKI yg udah nyedian info Click here to enlarge

    HAVE FUN!!!! Click here to enlarge

  2. The Following 62 Users Say Thank You to kucingGarong For This Useful Post:

    + Show/Hide list of the thanked


  3. #2
    Status
    Offline
    jhoe's Avatar
    Baru Gabung
    Join Date
    Jul 2007
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Waduhh.... dah brapa tahun lo... blajar mikrotik, ni sip banget. jangan bosen2 buat tutorial ya. tidak sia2 nama bro kucing garongggggggggggggggrong, salam to mbah wiki ya

  4. The Following User Says Thank You to jhoe For This Useful Post:


  5. #3
    Status
    Offline
    ALOE's Avatar
    Baru Gabung
    Join Date
    Aug 2007
    Posts
    10
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by [a] Click here to enlarge
    2 ISP IN 1 ROUTER WITH LOADBALANCING


    Click here to enlarge

    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local comment="" \
    disabled=no
    add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 \
    comment="" disabled=no
    add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 \
    comment="" disabled=no
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 \
    action=mark-connection new-connection-mark=odd passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing \
    new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 \
    action=mark-connection new-connection-mark=even passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing \
    new-routing-mark=even passthrough=no comment="" disabled=no
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0.2 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.112.0.2 \
    to-ports=0-65535 comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=odd \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=even \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 comment="" \
    disabled=no

    Mangle

    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local comment="" \
    disabled=no
    add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=wlan2 \
    comment="" disabled=no
    add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=wlan1 \
    comment="" disabled=no

    router punya 2 upstream (WAN) interfaces dengan ip address 10.111.0.2/24 and 10.112.0.2/24. dan interface LAN dengan nama interface "Local" dan ip address 192.168.0.1/24.


    / ip firewall mangle

    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 \
    action=mark-connection new-connection-mark=odd passthrough=yes comment="" \
    disabled=no

    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing \
    new-routing-mark=odd passthrough=no comment="" disabled=no

    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 \
    action=mark-connection new-connection-mark=even passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing \
    new-routing-mark=even passthrough=no comment="" disabled=no




    NAT


    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0.2 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.112.0.2 \
    to-ports=0-65535 comment="" disabled=no



    Routing


    / ip route
    add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=odd \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=even \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 comment="" \
    disabled=no comment="gateway for the router itself"


    thanks to mbah WIKI yg udah nyedian info Click here to enlarge

    HAVE FUN!!!! Click here to enlarge
    bisa ga dipake dgn 2 ISP yg sama ???
    sapidi misalnye Click here to enlarge

  6. The Following 3 Users Say Thank You to ALOE For This Useful Post:


  7. #4
    Status
    Offline
    kresek's Avatar
    Baru Gabung
    Join Date
    Aug 2007
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    bro, gimana kalo salah satu line-nya fail..?? support failover engga..??

  8. #5
    Status
    Offline
    usrox's Avatar
    Baru Gabung
    Join Date
    Jul 2007
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Klo ipnya anda gatewaynya dynamic gimana bos ... ?

  9. #6
    Status
    Offline
    Dody's Avatar
    Newbie
    Join Date
    Jul 2007
    Location
    Madiun - East Java
    Posts
    40
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    "nth" itu buat apa ????

    Click here to enlarge

    Dan saya sudah coba terapkan load balancing pake 2 speedy kok berfungsi sebentar kemudian socket error ya ?????
    Last edited by Dody; 23-08-2007 at 07:55.

  10. #7
    Status
    Offline
    dobelden's Avatar
    Newbie
    Join Date
    Aug 2007
    Posts
    40
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    tutorial diatas yg sudah mengamalkan dan berhasil dengan sukses siapa ya?? Click here to enlarge:

    perlu banget nih... nge load antara wlan dengan speedy

  11. #8
    Status
    Offline
    Dody's Avatar
    Newbie
    Join Date
    Jul 2007
    Location
    Madiun - East Java
    Posts
    40
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Nah...itulah repotnya bos, kebanyakan belum pernah coba ..... jadi repot.

  12. #9
    Status
    Offline
    [a]
    [a]'s Avatar
    Administrator
    Join Date
    Jun 2007
    Location
    Jakarta, Indonesia, Indonesia
    Posts
    1,729
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    kaya gini banyak yang belum coba karena agak repot bro...

    jarang yang punya koneksi lebih dari 1...dan kalaupun ada kemungkinan bermasalah di resource, seperti spare pc mikrotik untuk percobaan..atau juga khawatir dengan downtime...

  13. #10
    Status
    Offline
    bdu4punk's Avatar
    Newbie
    Join Date
    Aug 2007
    Posts
    50
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    gw dah coba, pake 2 buah speedy. gw gabungin, pake cara sama seperti yg diatas. dah 2 bulan pake, oke2 aja tuh. kalo download bisa 80 kB lebih....
    oh iya, gw pake alatnya RB 150, gw gak pake PC.

    malahan skrg gw mo tambah line satu lagi, kira2 dari script yg diatas tambahin apa lagi yah biar jalan........??????

  14. #11
    Status
    Offline
    [a]
    [a]'s Avatar
    Administrator
    Join Date
    Jun 2007
    Location
    Jakarta, Indonesia, Indonesia
    Posts
    1,729
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    Click here to enlarge Originally Posted by bdu4punk Click here to enlarge
    gw dah coba, pake 2 buah speedy. gw gabungin, pake cara sama seperti yg diatas. dah 2 bulan pake, oke2 aja tuh. kalo download bisa 80 kB lebih....
    oh iya, gw pake alatnya RB 150, gw gak pake PC.

    malahan skrg gw mo tambah line satu lagi, kira2 dari script yg diatas tambahin apa lagi yah biar jalan........??????
    proxy-nya pake punya mikrotik atau diluar ?

    nambah line ? kayanya okeh...tinggal ubah di nth nya ajahh...

  15. #12
    Status
    Offline
    ilyas's Avatar
    Baru Gabung
    Join Date
    Sep 2007
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    klo 1ip public yang 1ip dinamik gimana tuch...........
    Click here to enlarge

  16. #13
    Status
    Offline
    locantop's Avatar
    Member
    Join Date
    Jul 2007
    Posts
    269
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kalau semuanya ip Dinamic?

  17. #14
    Status
    Offline
    [a]
    [a]'s Avatar
    Administrator
    Join Date
    Jun 2007
    Location
    Jakarta, Indonesia, Indonesia
    Posts
    1,729
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    klo IPk ISPnya dinamis kan tinggal pake dhcp client ajah bro....

  18. #15
    Status
    Offline
    Bang-Napi's Avatar
    Member
    Join Date
    Sep 2007
    Location
    Wonosobo
    Posts
    168
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Saya sudah pakai boss, script diatas dengan 2 ISP, sapidi sama indosat
    hasilnya bro :
    1. Secara umum memuaskan, karena bekerja secara load balancing dan failover-nya juga bekerja (modem sapidi-ku emang jelek, jadi sering minta restart).
    2. bandwidth indosat 512 silver (tahu sendiri kan) dan sapidi paket office (tahu juga), dengan rasio 1:2 untuk indosat, karena :
    - kalo dibuat 1:1 , modem sapidi sering hang ( nggak kuat RX sampai 500kbps)
    - beberapa website sering error kalau pas routing lewat sapidi, karena DNS no record (DNS telkom jelek banget menurut gwe)
    - beberapa website underground (porno, full donlot, warez, rapidshare) nggak bisa kebuka (gak tahu kenapa) kalau lewat sapidi.
    3. DNS nggak bisa bekerja (cache-nya nggak bisa menyimpan) => /ip dns pr padahal sudah tak set dengan primary = 202.155.0.10 (indosat) dan 202.134.0.155 (telkom sapidi). Atau ada yang salah, mohon pencerahan
    4. Mungkin ada tambahan script yang bagus, gwe juga nunggu

    salamClick here to enlarge

  19. The Following User Says Thank You to Bang-Napi For This Useful Post:


 

 
Page 1 of 10 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •