OpenVPN

tutorial ini membahas sekilas mengenai basic pembuatan OpenVPN Server di Mikrotik Router OS dengan menggunakan metode routing (tun device). Di sini saya membuat certificate menggunakan easy-rsa yang sudah terdapat di package openvpn dari ubuntu (apt-get install openvpn) dan open-ssl. Seperti biasa, siapkan rokok 1 bungkus dan kopi 1 gelas sebagai persiapan begadang. Jangan lupa makan malam dulu sebelum nya supaya tidak masuk angin Click here to enlarge

ok, langsung saja to the point:

folder asli easy-rsa biasanya ada di /usr/share/doc/openvpn/examples/easy-rsa. Kita copy dulu folder ini ke /etc/openvpn agar kita tidak kehilangan file asli nya

masuk ke /etc/openvpn/easy-rsa/2.0

edit dulu file vars yang ada di folder tadi. Sesuaikan isinya dengan keinginan anda:
>_
nano vars
source vars
./clean-all
Kemudian kita buat CA (Certificate Authority yang dibutuhkan untuk base certificate yang akan digunakan untuk server dan client)
>_
./pkitool --initca
Lalu kita buat Server Certificate nya :
>_
./pkitool --pass --server RB450
openssl rsa -in keys/RB450.key -out keys/RB450.pem
Kita buat Client Certificate nya :
>_
./pkitool --pass client1
openssl rsa -in keys/client1.key -out keys/client1.pem
hasil dari perintah2 di atas akan otomatis masuk ke dalam folder /etc/openvpn/easy-rsa/2.0/keys

Ok, beres sudah pengerjaan pembuatan certificate untuk server dan client. Selajutnya kita upload file2 :
>_
RB450.crt
RB450.pem
ca.crt
ke server mikrotik, lalu kita masukkan certificate tadi ke dalam mikrotik:
>_
/certificate
import file=RB450.crt
import file=RB450.pem
import file=ca.crt
Selanjutnya kita mulai membuat server ovpn.

Konfigurasi dasar ip address
>_
/ip address add address=192.168.0.1/24 interface=ether1 comment=”GW Client ”
/ip address add address=202.202.202.202/24 interface=ether2 comment=Internet
Siapkan ip pool untuk client openvpn
>_
/ip pool add name=ovpn-pool ranges=192.168.0.4-192.168.0.10
Buat profile PPP

>_
/ppp profile
add change-tcp-mss=default comment="" local-address=192.168.0.3 \
name=”OpenVPN" only-one=default remote-address=ovpn-pool \
use-compression=default use-encryption=required use-vj-compression=default
Untuk client PPP kita buatkan user :

>_
/ppp secret
add caller-id="" comment="" disabled=no limit-bytes-in=0 \
limit-bytes-out=0 name="username" password="password" \
routes="" service=any
terakhir, tapi yang paling penting, kita buat server OpenVpn:

>_
/interface ovpn-server server
set auth=sha1,md5 certificate=cert1 \
cipher=blowfish128,aes128,aes192,aes256 default-profile=your_profile \
enabled=yes keepalive-timeout=disabled max-mtu=1500 mode=ip netmask=24 \
port=1194 require-client-certificate=no
Jangan lupa untuk membuat firewall yang mengijinkan user OpenVPN untuk masuk ke LAN.

>_
/ip firewall filter
add action=accept chain=input comment="OpenVPN" disabled=no dst-port=1194 protocol=tcp
Dan terakhir, supaya bisa masuk ke LAN ubah setingan ether1 menjadi proxy-arp

Thats all... selamat ber vpn ria Click here to enlarge


Sumber:
Terjemahan bebas dari