Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 13 12311 ... LastLast
Results 1 to 15 of 181
  1. #1
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Step by step memprioritaskan trafic Game Online IIX

    Ok, langsung aja... Click here to enlarge

    krn dsni hanya membahas game online IIX maka langkah pertama kita buat address-list yang berisi list IP address IIX. Cara nya, buka New Terminal di winbox dan ketikan perintah bekikut:
    >_
    /tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;

    Kemudian di-import dengan perintah:
    >_
    import nice.rsc


    Setelah address-list nice siap, lanjutkan dengan konfigurasi MANGLE...
    Untuk warnet dengan 1 ISP, kita hanya perlu membedakan antara traffic game & browsing dari prioritas nya di Queue... yang perlu dilakukan antara lain sbb;

    langkah pertama, Tangkap traffic game online berdasarkan port nya masing2 dengan dengan mark-connection...
    (daftar port game yang saya gunakan diambil dari punya bro dingo )

    >_
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Ayo Dance" disabled=no dst-address-list=nice dst-port=18900-18910 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Seal Online" disabled=no dst-address-list=nice dst-port=1818 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Lineage 2" disabled=no dst-address-list=nice dst-port=7777 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=IDS disabled=no dst-address-list=nice dst-port=2001 new-connection-mark=\
    game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=PB-UDP disabled=no dst-address-list=nice dst-port=40000-40010 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment=PB-TCP disabled=no dst-address-list=nice dst-port=39000-40000 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Ghost Online" disabled=no dst-address-list=nice dst-port=19101 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=RF-Elven disabled=no dst-address-list=nice dst-port=27780 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Perfect World" disabled=no dst-address-list=nice dst-port=29000 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=Rohan disabled=no dst-address-list=nice dst-port=22100 new-connection-mark=\
    game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Zeus RO" disabled=no dst-address-list=nice dst-port=5121 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=DOTA disabled=no dst-address-list=nice dst-port=6000-6125 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Crazy Kart" disabled=no dst-address-list=nice dst-port=9600-9602 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="WOW AMPM" disabled=no dst-address-list=nice dst-port=8085 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Drift City" disabled=no dst-address-list=nice dst-port=11011-11041 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=GetAmped disabled=no dst-address-list=nice dst-port=13413 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=Yullgang disabled=no dst-address-list=nice dst-port=19000 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="RAN Online" disabled=no dst-address-list=nice dst-port=5105 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Cross Fire TCP" disabled=no dst-address-list=nice dst-port=\
    10009,13008,16666,28012 new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Cross Fire UDP" disabled=no dst-address-list=nice dst-port=\
    12020-12080,13000-13080 new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="War Rock" disabled=no dst-address-list=nice dst-port=5340-5352 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Fast Black" disabled=no dst-address-list=nice dst-port=6000-6001 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Rose Online" disabled=no dst-address-list=nice dst-port=29200 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Crazy Kart 2" disabled=no dst-address-list=nice dst-port=9600 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Return of Warrior" disabled=no dst-address-list=nice dst-port=10402 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Luna Online" disabled=no dst-address-list=nice dst-port=15000-15002 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Runes of Magic" disabled=no dst-address-list=nice dst-port=16400-16502 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Fresh Ragnarok PS" disabled=no dst-address-list=nice dst-port=5171 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Tantra Online" disabled=no dst-address-list=nice dst-port=3010 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=Atlantica disabled=no dst-address-list=nice dst-port=4300 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="ECO Online" disabled=no dst-address-list=nice dst-port=12011,12110 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Cabal Indonesia" disabled=no dst-address-list=nice dst-port=15000-15002 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=Avalon disabled=no dst-address-list=nice dst-port=9376-9377 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="X-Shot UDP" disabled=no dst-address-list=nice dst-port=7777-7977,30000 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="3 Kingdoms" disabled=no dst-address-list=nice dst-port=15000-15002 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="Grand Chase TCP" disabled=no dst-address-list=nice dst-port=\
    9300,9400,9700 new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Grand Chase UDP" disabled=no dst-address-list=nice dst-port=9401,9600 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment=MAKO disabled=no dst-address-list=nice dst-port=21000-21020 \
    new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp


    Kemudian bikin mark-packet agar dapat ditangkap di Queue berdasarkan mark-connection yang dibuat tadi (dalam contoh disini nama mark-connection nya adalah "game-online-indonesia")

    >_
    /ip firewall mangle add chain=prerouting connection-mark=game-online-indonesia action=mark-packet new-packet-mark=Game


    trus bikin satu lagi mark-packet untuk trafic diluar traffic game yang sudah dibuat tadi:

    >_
    /ip firewall mangle add chain=prerouting connection-mark=[COLOR="Red"][COLOR="Black"]![/COLOR][/COLOR]game-online-indonesia action=mark-packet new-packet-mark=Browsing


    Terakhir, tinggal buat 2 queue berdasarkan 2 packet-mark tadi yaitu Game dan Browsing... berikut contoh untuk warnet yang punya bandwidth 512kbps downstream/upstream...

    >_
    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 \
    interface=all max-limit=512k/512k name=Game packet-marks="Game" parent=none priority=1 \
    queue=default-small/default-small total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 \
    interface=all max-limit=512k/512k name=Browsing packet-marks="Browsing" parent=none priority=8 \
    queue=default-small/default-small total-queue=default-small


    Dengan begitu antara traffic game dan yang bukan game udah terpisahkan namun belum ada pembagian bandwidth per client nya... untuk itu kita tinggal membuat queue child dengan parent "Browsing" kemudian masukan target-address sesuai dengan IP address tiap2 PC-client nya tanpa packet-mark...
    Contoh:

    >_
    /queue simple add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 \
    interface=all limit-at=32k/64k max-limit=64k/128k name=PC-2 parent=Browsing priority=4 queue=default-small/default-small target-addresses=10.0.0.2/32 total-queue=default-small


    Perlu diingat dalam memasukan angka limit-at, akumulasi dari keseluruhan queue child tidak boleh melebihi total max-limit dari queue parent nya...

    Berikutnya, untuk warnet yang punya multi backbone, maka akan kita pisahkan dengan Static Routing...

    Biar halaman ini gak kepanjangan jadi gak usah saya tulis lagi satu2 semua mangle di atas yach... Click here to enlarge
    krn dari mangle dengan action mark-connection di atas kita hanya perlu merubah nya menjadi mark-routing...
    contoh nya 1 aja yach Click here to enlarge

    >_
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Ayo Dance" disabled=no dst-address-list=nice dst-port=18900-18910 \
    new-routing-mark=game-online-indonesia passthrough=yes protocol=tcp


    tinggal ulangi semua yang di atas tadi dengan mengganti mark-connection ke mark-routing dan new-connection-mark ganti ke new-routing-mark...

    Terakhir, bikin Routing nya:

    >_

    /ip route add gateway [ip address gateway ISP-A]
    /ip route add gateway [ip address gateway ISP-B] routing-mark=game-online-indonesia


    Click here to enlarge
    Semoga gak ada yang keliru di tutorial ini... Click here to enlarge
    Last edited by Akangage; 12-11-2011 at 08:12. Reason: Remove basa-basi di header...

  2. The Following 66 Users Say Thank You to Spring For This Useful Post:

    + Show/Hide list of the thanked


  3. #2
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    akhirnya keluar juga... thx om admin... Click here to enlarge

  4. The Following 2 Users Say Thank You to Spring For This Useful Post:


  5. #3
    Status
    Offline
    coenk's Avatar
    Newbie
    Join Date
    Mar 2010
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    untuk trafik selain game di simple kn pake target addrss...nah kalo di quee tree bagaimana bossss....minta pencerahan....

  6. #4
    Status
    Offline
    whiely's Avatar
    Member Senior
    Join Date
    Jun 2010
    Location
    :unidentified:
    Posts
    423
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Lightbulb

    Click here to enlarge Originally Posted by coenk Click here to enlarge
    untuk trafik selain game di simple kn pake target addrss...nah kalo di quee tree bagaimana bossss....minta pencerahan....
    sebenarnya sih utk game online lebih asyik kl main d simple queue aja...
    tapi kl agan pake queue tree sih bisa jg, kl gak salah maen d mangle dulu baru d tangkep d queue tree... CMIIWClick here to enlarge

  7. #5
    Status
    Offline
    xXx
    xXx's Avatar
    Member
    Join Date
    Apr 2010
    Location
    H34VEN'S KNOW
    Posts
    137
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by coenk Click here to enlarge
    untuk trafik selain game di simple kn pake target addrss...nah kalo di quee tree bagaimana bossss....minta pencerahan....



    ubek2 isi forum dolo gan Click here to enlarge
    coba
    coba
    coba
    &
    coba
    kl dah mntok br kt nanya ....



    sesama anak baru saling membantu Click here to enlarge

  8. #6
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kalo mau di manage di queue tree kudu bikin lagi mangle satu-satu yang berisi src-address ip tiap² client... ribet gan... Click here to enlarge

  9. #7
    Status
    Offline
    banyak kasus's Avatar
    Member
    Join Date
    Jun 2008
    Location
    dunia ntah berantah
    Posts
    283
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    maaf gan ..
    ane mau tanya dikit ..mohon tuk dijawab ..

    jika implementasi nya menggunakan 2 jline speedy ..
    apa mungkin lebih bagus jika ??? :
    ip Route nya dibagi ke 2 line tersebut ..
    misal nya total komputer ad 16 unit
    maka kompie 1-8 ke IP Route speedy 1 dan
    kompie 9-16 ke IP Route speedy 2
    supaya merata gan pembebanan di kedua line..
    Code:
    /ip route add gateway [ip address gateway speedy-A]routing-mark=game-online-indonesia 
    /ip route add gateway [ip address gateway speedy-B]routing-mark=game-online-indonesia
    kira2 giman ya gan script nya gan ..Click here to enlargeClick here to enlargeClick here to enlarge
    Last edited by banyak kasus; 21-03-2011 at 19:50.

  10. The Following User Says Thank You to banyak kasus For This Useful Post:


  11. #8
    Status
    Offline
    rerenet's Avatar
    Member
    Join Date
    Feb 2010
    Location
    jaktim
    Posts
    242
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by spring Click here to enlarge
    kalo mau di manage di queue tree kudu bikin lagi mangle satu-satu yang berisi src-address ip tiap² client... ribet gan... Click here to enlarge
    AGAN mau nanya nih.. jika TUTOR Agan itu digabungkan dengan pemisahan koneksi Inter bagaimana karena ditempat saya jika malam pada MANIAK POKER sama Browsing ke situs2 Inter..

  12. #9
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by banyak kasus Click here to enlarge
    maaf gan ..
    ane mau tanya dikit ..mohon tuk dijawab ..

    jika implementasi nya menggunakan 2 jline speedy ..
    apa mungkin lebih bagus jika ??? :
    ip Route nya dibagi ke 2 line tersebut ..
    misal nya total komputer ad 16 unit
    maka kompie 1-8 ke IP Route speedy 1 dan
    kompie 9-16 ke IP Route speedy 2
    supaya merata gan pembebanan di kedua line..
    Code:
    /ip route add gateway [ip address gateway speedy-A]routing-mark=game-online-indonesia 
    /ip route add gateway [ip address gateway speedy-B]routing-mark=game-online-indonesia
    kira2 giman ya gan script nya gan ..Click here to enlargeClick here to enlargeClick here to enlarge
    Bikin 2 buah address-list, misalkan address-list "A" berisi group IP 1-8, address-list "B" IP 9-16 kemudian di mangle dengan action mark-routing:
    contoh:
    Code:
    /ip firewall mangle chain=prerouting src-address-list="A" action=mark-routing new-routing-mark=GROUP-A
    /ip firewall mangle chain=prerouting src-address-list="B" action=mark-routing new-routing-mark=GROUP-B
    next, bikin routing nya berdasarkan routing-mark yg dibikin tadi...
    contoh:
    /ip route add gateway=[Gateway-ISP-1] routing-mark=GROUP-A
    /ip route add gateway=[Gateway-ISP-2] routing mark=GROUP-B

    Click here to enlarge Originally Posted by rerenet Click here to enlarge
    AGAN mau nanya nih.. jika TUTOR Agan itu digabungkan dengan pemisahan koneksi Inter bagaimana karena ditempat saya jika malam pada MANIAK POKER sama Browsing ke situs2 Inter..
    tambahin aja di mangle nya port untuk zynga poker 9339 dst-address-list gak usah diisi... udah deh.. atau, kalau emang malam cuman pada browsing doank jadi tiap malam dibalik aja priority di queue nya.. jadi waktu siang priority tertinggi adalah trafic game, malam nya di balik ke yang non-game... Click here to enlarge

  13. The Following 3 Users Say Thank You to Spring For This Useful Post:


  14. #10
    Status
    Offline
    swordfishx's Avatar
    Baru Gabung
    Join Date
    Mar 2010
    Posts
    2
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    klo digabungin ama LB PCC bisa ga bos? , maksudnya saya pake 2 ISP, 4 line speedy buat International ama 1 line yang kusus buat IIX, jadi yang di LB cuman speedynya..

    kira2 topologinya kek gini bos


    speedy1------|
    speedy2------| LB
    speedy3------|----------|
    speedy4------| |
    |-----HUB----Client
    IIX------------|----------|


    ato harus ganti specific mangle nya?

    maaf bos sbelumnya msh newbie, msih dalam proses belajar...
    tenkyu

    Click here to enlarge

  15. #11
    Status
    Offline
    IZC
    IZC's Avatar
    Newbie
    Join Date
    Mar 2011
    Location
    Bumi-Arema
    Posts
    25
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Kalau Digabung Dengan Loud Balancing Bisa g nie Gan .....

    Takutnya Pengaruh Dengan Loud Balancing Yang Ada Loud Balancing Dengan Sistem Tutorial Akange


    Kalau Digabung Menurut Anda Gimana Kayaknya LEbih Menarik ....
    Misal 3 Speedy Jadi Topologinya LB dulu Baru Tutorial Ini .... Nah Yang Membingungkan Di Ip routenya Kebanyakan .....

    Saya Udah Terapkan Dengan Sistem 2 Speedy LB + 1 Speedy Khusus Game Succes

    Tapi Kalau Untuk 3 Speedy IP ROutenya Jadi Bingung wakaakkakak

    Belajar Lagi Belajar Lagi Kerja Kerassssss Untuk Menuntut Ilmu

    ................
    Share ya Kalau ada Yang Menemukan Topologi Seperti Yang saya Cantumkan
    Maju FMI .............. Regrads

  16. #12
    Status
    Offline
    IZC
    IZC's Avatar
    Newbie
    Join Date
    Mar 2011
    Location
    Bumi-Arema
    Posts
    25
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Kalau Digabung LB By. Akange Gimana Ya Sepertinya Ruwet Di IP Routenya Bingung juga neh


    Belajar lagi GOO FMI

  17. #13
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by IZC Click here to enlarge
    Kalau Digabung LB By. Akange Gimana Ya Sepertinya Ruwet Di IP Routenya Bingung juga neh


    Belajar lagi GOO FMI
    kalo gabungin dgn LB... pilih option pertama, yakni cuma sekedar misahin priority di queue... untuk config LB nya gak usah kita bahas dsni yach, kan udah banyak banget yg kasih tutorial nya... Click here to enlarge

  18. #14
    Status
    Offline
    IZC
    IZC's Avatar
    Newbie
    Join Date
    Mar 2011
    Location
    Bumi-Arema
    Posts
    25
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by spring Click here to enlarge
    kalo gabungin dgn LB... pilih option pertama, yakni cuma sekedar misahin priority di queue... untuk config LB nya gak usah kita bahas dsni yach, kan udah banyak banget yg kasih tutorial nya... Click here to enlarge
    OK deh coba pisah berarti route kita tetap pada jalur LB ya...
    Nice Share Amd Thanks

  19. #15
    Status
    Offline
    whiely's Avatar
    Member Senior
    Join Date
    Jun 2010
    Location
    :unidentified:
    Posts
    423
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Question nanya dikit om

    kalo misal kondisinya lb, speedy[intl] dan isp wireless[iix], bs gak tanpa mangle lb[katakanlah pcc mode], jadi hanya static route doank..??? dan satu lagi, pengaruh gak ke latency..Click here to enlarge??? thanks

 

 
Page 1 of 13 12311 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. First Time RB750/RB450- Step By Step Instalation Guide
    By adhielesmana in forum Beginner Basics
    Replies: 820
    Last Post: 07-02-2016, 18:32
  2. [ SHARE ] Step By Step Upgrade Versi Mikrotik Melalui Tool Fetch
    By adhielesmana in forum Beginner Basics
    Replies: 16
    Last Post: 05-01-2015, 10:10
  3. step by step instal ubuntu server+squid dengan gambar
    By cikruk21 in forum Beginner Basics
    Replies: 0
    Last Post: 21-08-2010, 04:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •