Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 5 of 5

Thread: Tanya:Script

  1. #1
    Status
    Offline
    arcadeva's Avatar
    Baru Gabung
    Join Date
    Aug 2008
    Posts
    2
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Tanya:Script

    Rekan2 pengguna mikrotik, saya kesulitan untuk mengganti rate-limit pada settingan di bawah ini


    10 subscriber=admin name="frmqvbvi" password="7gr3k"
    rate-limit=" 300k/300k" last-seen=never credit-count=0 credit-left=0s
    credit-duration=0s credit-price=0 credit-time-added=0s

    11 subscriber=admin name="frmdux9h" password="9cw26"
    rate-limit=" 300k/300k" last-seen=never credit-count=0 credit-left=0s
    credit-duration=0s credit-price=0 credit-time-added=0s

    12 subscriber=admin name="frm5nid2" password="tami8"
    rate-limit=" 300k/300k" uptime-used=4h26s download-used=427941830
    upload-used=24130541 last-seen=apr/19/2009 17:34:23 credit-count=0
    credit-left=0s credit-duration=0s credit-price=0 credit-time-added=0s

    13 subscriber=admin name="frmkcpvx" password="xmrxb"
    rate-limit=" 300k/300k" uptime-used=1h11m download-used=5271916
    upload-used=3865247 last-seen=apr/21/2009 00:12:10 credit-count=0
    credit-left=0s credit-duration=0s credit-price=0 credit-time-added=0s

    dimana rate-limit="300k/300k" akan digantikan dengan "256k/256k" atau "512k/512k". Untuk kasus di atas, kalo hanya 5 bisa dilakukan set 0,1,2,4,5 rate-limit="512k/512k" sementara user yang ada sekarang hampir 200an, rasanya tidak efisien melakukan dengan cara itu, untuk itu saya mohon bantuan rekan2, apakah ada script yang bisa membantu mempersingkat proses tersebut dengan menggunakan logika?


    Demikian, terima kasih atas bantuannya

  2. #2
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    bisa aja, misalnya cari persamaannya, kemudian pake find.

    contoh:
    Code:
    /tool user-manager user set [/tool user-manager user find rate-limit=300000/300000] rate-limit=256000/256000
    atau

    Code:
    /tool user-manager user
    set [find rate-limit=300000/300000] rate-limit=256000/256000

  3. The Following 2 Users Say Thank You to yosanpro For This Useful Post:


  4. #3
    Status
    Offline
    achim's Avatar
    Member
    Join Date
    Dec 2008
    Location
    Mataram
    Posts
    241
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mantabs... pngen coba dlu..... Click here to enlarge
    Click here to enlarge Originally Posted by yosanpro Click here to enlarge
    bisa aja, misalnya cari persamaannya, kemudian pake find.

    contoh:
    Code:
    /tool user-manager user set [/tool user-manager user find rate-limit=300000/300000] rate-limit=256000/256000
    atau

    Code:
    /tool user-manager user
    set [find rate-limit=300000/300000] rate-limit=256000/256000

  5. #4
    Status
    Offline
    Ye_Nan_Thien's Avatar
    Forum Guru
    Join Date
    May 2008
    Posts
    1,731
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    3 (100%)
    Thanks bro, akhirnya tanggan udah ngak pegel lg, ijin coba dulu dah Click here to enlarge

  6. #5
    Status
    Offline
    arcadeva's Avatar
    Baru Gabung
    Join Date
    Aug 2008
    Posts
    2
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Thx bro, berhasil, ga perlu ganti 1 1 lagi Click here to enlarge

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help in script i have
    By salama900 in forum Scripting @ Mikrotik
    Replies: 1
    Last Post: 23-05-2009, 01:35
  2. script di ROS 3.19 dan 2.9.50
    By awarmanf in forum Scripting @ Mikrotik
    Replies: 0
    Last Post: 20-04-2009, 14:54
  3. Script On/OFF Ip
    By servas in forum Scripting @ Mikrotik
    Replies: 9
    Last Post: 04-05-2008, 11:33
  4. ask: script self destroy
    By adiel.nopria in forum Scripting @ Mikrotik
    Replies: 9
    Last Post: 13-04-2008, 13:39
  5. script web-proxy
    By emruxc in forum Scripting @ Mikrotik
    Replies: 0
    Last Post: 14-11-2007, 14:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •