Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2
  1. #1
    Status
    Offline
    salama900's Avatar
    Baru Gabung
    Join Date
    Jul 2008
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    need help in script i have

    i have script i can do much of it but could not put this part in my 3.13 or 3.22 router os this part is
    / tool netwatch
    add host=196.218.9.25 timeout=2s interval=30s up-script="/ip route set \[find \
    comment=\"Default Route To Internet\"\] gateway=196.218.9.25" \
    down-script="/ip route set \\\[find comment=\"Default Route To \
    Internet\"\] gateway=192.168.0.1 comment=\"\" disabled=no" comment="" \
    disabled=no

    / tool netwatch
    add host=192.168.0.1 timeout=2s interval=30s up-script="/ip route set \[find \
    comment=\"SMTP Traffic out\"\] gateway=192.168.0.1" down-script="/ip route \
    set \\\[find comment=\"SMTP Traffic out\"\] gateway=196.218.9.25 \
    comment=\"\" disabled=no" comment="" disabled=no

    hope any one give me hand how to handle and put this bart
    i tried to put it from termenal but it is not work
    tel me how i can put this part
    thanks so much
    salama

  2. #2
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    Try this syntax, and put everything in one line...

    Code:
    /tool netwatch add host=196.218.9.25 timeout=2s interval=30s up-script="/ip route set [/ip route find comment=\"Default Route To Internet\"] gateway=196.218.9.25" down-script="/ip route set [/ip route find comment=\"Default Route To Internet\"] gateway=192.168.0.1 comment=\"\" disabled=no" comment="" disabled=no
    
    /tool netwatch add host=192.168.0.1 timeout=2s interval=30s up-script="/ip route set [/ip route find comment=\"SMTP Traffic out\"] gateway=192.168.0.1" down-script="/ip route set [/ip route find comment=\"SMTP Traffic out\"] gateway=196.218.9.25 comment=\"\" disabled=no" comment="" disabled=no
    hope this help, CMIIW.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. script mikrotik
    By xeon in forum Scripting @ Mikrotik
    Replies: 351
    Last Post: 14-07-2016, 09:16
  2. script di ROS 3.19 dan 2.9.50
    By awarmanf in forum Scripting @ Mikrotik
    Replies: 0
    Last Post: 20-04-2009, 14:54
  3. Script On/OFF Ip
    By servas in forum Scripting @ Mikrotik
    Replies: 9
    Last Post: 04-05-2008, 11:33
  4. ask: script self destroy
    By adiel.nopria in forum Scripting @ Mikrotik
    Replies: 9
    Last Post: 13-04-2008, 13:39
  5. script web-proxy
    By emruxc in forum Scripting @ Mikrotik
    Replies: 0
    Last Post: 14-11-2007, 14:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •