Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2
  1. #1
    Status
    Offline
    zhugeliang's Avatar
    Baru Gabung
    Join Date
    Dec 2008
    Posts
    1
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    exclude IP from primary route

    Suhu-suhu Mikrotik,

    Bagaimana scriptnya apabila ada satu IP LAN (192.168.1.3) ingin di dedicated ke backup link (internet 2), jadi tidak terpengaruh oleh main link (internet 1).

    Berikut Topologi dan script yang sedang berjalan:

    TOPOLOGI
    ---------


    PROXY
    |
    Gateway Internet 1 --- MIKROTIK -------------- LAN
    |
    Gateway Internet 2



    PARAMETER MIKROTIK
    =================

    LAN = 192.168.1.0/24
    Mikrotik = 192.168.1.1/24
    Internet 1 = 202.159.26.222 gateway 202.159.26.221
    Internet 2 = 10.0.0.2/24 gateway 10.0.0.1
    Proxy = 172.16.4.2/24

    REDIRECT PROXY
    ============

    - Kedua link internet akan diredirect ke sebuah proxy server (172.16.4.2)

    >/ip firewall nat add chain=dstnat in-interface=Lan src-address=!172.16.4.2 protocol=tcp dst-port=80 action=dst-nat to-addresses=172.16.4.2 to-ports=3128

    >/ip firewall nat add chain=srcnat out-interface=Lan src-address=192.168.1.0/24 action=src-nat to-addresses=192.16.1.1 to-ports=0-65535


    LINK FAILOVER
    ===========

    Menjadikan 2 jalur internet dengan teknik Fail Over, dimana link Internet 1 sebagai main, dan Internet 2 sebagai backup

    >/ip route add gateway=10.0.0.1,202.159.26.222,202.159.26.222
    >/ip firewall mangle add chain=prerouting src-address=192.168.1.0/24 action=mark-routing new-routing-mark=SUBNET1-RM
    >/ip route add gateway=202.159.26.221 routing-mark=SUBNET1-RM check-gateway=ping
    >/ip route add gateway=10.0.0.1


    Mohon bantuannya

    Terima Kasih
    Last edited by zhugeliang; 11-12-2008 at 17:34. Reason: dasd

  2. #2
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    Dikasih mangle mark-routing saja, taruh di atas rule-rule routing lainnya:

    misalnya dalam kasus diatas:

    Code:
    /ip firewall mangle add chain=prerouting src-address=192.168.1.3 action=mark-routing new-routing-mark=SUBNET2 passthrough=no place-before=0
    /ip route set [/ip route find gateway=10.0.0.1] routing-mark=SUBNET2

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. static route in mikrotik
    By j14n6 in forum Beginner Basics
    Replies: 7
    Last Post: 30-04-2009, 10:13
  2. [ask] default route harus ada kah?
    By cgs in forum General Networking
    Replies: 1
    Last Post: 11-07-2008, 10:44
  3. Setting primary dan backup link
    By daeaje in forum General Networking
    Replies: 13
    Last Post: 04-07-2008, 13:12
  4. IP route ilang
    By zordine in forum General Networking
    Replies: 4
    Last Post: 17-05-2008, 04:03
  5. [wta] route 3 subnet berbeda
    By sempy26 in forum General Networking
    Replies: 11
    Last Post: 07-03-2008, 00:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •