Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 13 of 13
  1. #1
    Status
    Offline
    aditya57164's Avatar
    Member
    Join Date
    Sep 2008
    Location
    Solo
    Posts
    259
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Lightbulb Script Bikin Queues Tree B/W Limiter

    maap baru gabung, ni coba posting script bikin queues tree buat B/W limiter. semoga bermanfaat.

    kalo masih ada yang salah mohon di benerin yaa...Click here to enlarge

    1. bikin mangle ya dulu, pake script seperti di bawah. (range IP 2 s/d 11)

    :for e from 2 to 11 do={
    /ip firewall mangle add chain=prerouting src-address=(192.168.224. . $e) action=mark-connection new-connection-mark=($e . indosatcon )
    /ip firewall mangle add chain=prerouting connection-mark=($e . indosatcon ) protocol=!1 action=mark-packet new-packet-mark=($e . indosatflow ) passthrough=no
    }

    2. trus bikin queues nya, seperti ini.

    :for e from 2 to 11 do={
    /queue tree add name=("STREAM-DOWN-" . $e) parent=STREAM-DOWN packet-mark=($e . indosatflow)
    /queue tree add name=("STREAM-UP-" . $e) parent=STREAM-UP packet-mark=($e . indosatflow)
    }


    tinggal copy paste di terminal nya... enter...

    trus dah jadi dech... Click here to enlarge

  2. The Following 2 Users Say Thank You to aditya57164 For This Useful Post:


  3. #2
    Status
    Offline
    dna_09's Avatar
    Baru Gabung
    Join Date
    Oct 2007
    Posts
    12
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ko saya bingung bacanya yah ..

    itu ko ada parent dan


    juga

    itu ko IP nya ko g lengkap ???

  4. #3
    Status
    Offline
    aditya57164's Avatar
    Member
    Join Date
    Sep 2008
    Location
    Solo
    Posts
    259
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    :for e from 2 to 11 do={

    yaitu perintah untuk membuat script dari angka atau ip yang angka belakangnya 2 sampe dengan 11

    src-address=(192.168.224. . $e)

    yaitu opsi source ip localnya yang di pakai pada LAN nya, kenapa gak di tulis lengkap, karena untuk alamat ip yang paling belakang udah di buat secara otomatis seperti diatas.

    ooo.. iya maap sedikit tambahan, sebelum kita buat script pada queues, kita buat queues secara manual dulu untuk parrent nya. yaitu parent=STREAM-DOWN dan parent=STREAM-UP.

    hehehe... maap kalo kurang jelas tulisan ne... maklum masih belajar juga mas... Click here to enlarge

  5. #4
    Status
    Offline
    lonthong2002's Avatar
    Member Senior
    Join Date
    Jul 2007
    Location
    Malang
    Posts
    397
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    wahh makin mantep aja newbie sekarang

    trus yang jelas dan komplet gimana dong script nya
    ntar kalau bagus kan bisa dimasukin di halaman tutorial

    Click here to enlargeClick here to enlargeClick here to enlarge

  6. #5
    Status
    Offline
    unique_leader's Avatar
    Member Super Senior
    Join Date
    Jul 2007
    Posts
    639
    Reviews
    Read 0 Reviews
    Downloads
    5
    Uploads
    0
    Feedback Score
    1 (100%)
    mo nanya juga nih. trus untuk ngelimit bw nya. dimana ??

  7. #6
    Status
    Offline
    aditya57164's Avatar
    Member
    Join Date
    Sep 2008
    Location
    Solo
    Posts
    259
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by unique_leader Click here to enlarge
    mo nanya juga nih. trus untuk ngelimit bw nya. dimana ??
    di queues>>queues tree.

    tinggal dobel klik nanti tinggal isi aja limitnya.

  8. #7
    Status
    Offline
    unique_leader's Avatar
    Member Super Senior
    Join Date
    Jul 2007
    Posts
    639
    Reviews
    Read 0 Reviews
    Downloads
    5
    Uploads
    0
    Feedback Score
    1 (100%)
    Click here to enlarge Originally Posted by aditya57164 Click here to enlarge
    di queues>>queues tree.

    tinggal dobel klik nanti tinggal isi aja limitnya.
    oow berarti packet marknya udah tersedia ya. tinggal di masukin aja di queue treenya

  9. #8
    Status
    Offline
    mr toni's Avatar
    Newbie
    Join Date
    Oct 2008
    Location
    denpasar bali
    Posts
    22
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by aditya57164 Click here to enlarge
    maap baru gabung, ni coba posting script bikin queues tree buat B/W limiter. semoga bermanfaat.

    kalo masih ada yang salah mohon di benerin yaa...Click here to enlarge

    1. bikin mangle ya dulu, pake script seperti di bawah. (range IP 2 s/d 11)

    :for e from 2 to 11 do={
    /ip firewall mangle add chain=prerouting src-address=(192.168.224. . $e) action=mark-connection new-connection-mark=($e . indosatcon )
    /ip firewall mangle add chain=prerouting connection-mark=($e . indosatcon ) protocol=!1 action=mark-packet new-packet-mark=($e . indosatflow ) passthrough=no
    }

    2. trus bikin queues nya, seperti ini.

    :for e from 2 to 11 do={
    /queue tree add name=("STREAM-DOWN-" . $e) parent=STREAM-DOWN packet-mark=($e . indosatflow)
    /queue tree add name=("STREAM-UP-" . $e) parent=STREAM-UP packet-mark=($e . indosatflow)
    }


    tinggal copy paste di terminal nya... enter...

    trus dah jadi dech... Click here to enlarge
    tambahin dikit donk biar lengkap
    masih bingung nih bosssClick here to enlargeClick here to enlarge

  10. #9
    Status
    Offline
    aditya57164's Avatar
    Member
    Join Date
    Sep 2008
    Location
    Solo
    Posts
    259
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Siap... Click here to enlarge

    1. kita bikin queue di queue tree dengan name=STREAM-DOWN untuk parrent=global-in
    2. bikin lagi queue di queue tree dengan name=STREAM-UP untuk parrent=global-out
    3.membuat mangle pada /ip firewall. dengan menjalankan script seperti di bawah pada terminal

    untuk miktrotik v 2.9.xx

    :for e from 2 to 11 do={
    /ip firewall mangle add chain=prerouting src-address=(192.168.224. . $e) action=mark-connection new-connection-mark=($e . indosatcon )
    /ip firewall mangle add chain=prerouting connection-mark=($e . indosatcon ) protocol=!1 action=mark-packet new-packet-mark=($e . indosatflow ) passthrough=no
    }


    untuk mikrotik v 3.x

    :for e from=2 to=11 do={
    /ip firewall mangle add chain=prerouting src-address="192.168.224.$e" action=mark-connection new-connection-mark="$e. indosatcon"
    /ip firewall mangle add chain=prerouting connection-mark="$e. indosatcon" protocol=!1 action=mark-packet new-packet-mark="$e. indosatflow" passthrough=no
    }


    cek pada /ip firewall mangle memastikan bahwa script nya berjalan.

    4. kemudian kita buat queue tree nya dengan menjalan kan script seperti di bawah.

    untuk mikrotik v 2.9.xx

    :for e from 2 to 11 do={
    /queue tree add name=(”STREAM-DOWN-” . $e) parent=STREAM-DOWN packet-mark=($e. indosatflow)
    /queue tree add name=(”STREAM-UP-” . $e) parent=STREAM-UP packet-mark=($e. indosatflow)
    }


    untuk mikrotik v 3.xx

    :for e from=2 to=20 do={
    /queue tree add name="STREAM-DOWN-.$e" parent=STREAM-DOWN packet-mark="$e. indosatflow"
    /queue tree add name="STREAM-UP-. $e" parent=STREAM-UP packet-mark="$e. indosatflow"
    }


    cek juga pada queue tree nya apa kah sudah ada list queue nya.

    5. coba melimit salah sati ip dan amati... apakah sudah bener berjalan.

    maap kalo masih pada bingung... baru posting pertama... dan baru sinau... jadi masih hancur nerangin nya..... Click here to enlarge

    semoga para pakar mikrotiker bisa mebantu... Click here to enlarge

  11. #10
    Status
    Offline
    unique_leader's Avatar
    Member Super Senior
    Join Date
    Jul 2007
    Posts
    639
    Reviews
    Read 0 Reviews
    Downloads
    5
    Uploads
    0
    Feedback Score
    1 (100%)
    Click here to enlarge Originally Posted by aditya57164 Click here to enlarge
    Siap... Click here to enlarge

    1. kita bikin queue di queue tree dengan name=STREAM-DOWN untuk parrent=global-in
    2. bikin lagi queue di queue tree dengan name=STREAM-UP untuk parrent=global-out
    3.membuat mangle pada /ip firewall. dengan menjalankan script seperti di bawah pada terminal

    untuk miktrotik v 2.9.xx

    :for e from 2 to 11 do={
    /ip firewall mangle add chain=prerouting src-address=(192.168.224. . $e) action=mark-connection new-connection-mark=($e . indosatcon )
    /ip firewall mangle add chain=prerouting connection-mark=($e . indosatcon ) protocol=!1 action=mark-packet new-packet-mark=($e . indosatflow ) passthrough=no
    }


    untuk mikrotik v 3.x

    :for e from=2 to=11 do={
    /ip firewall mangle add chain=prerouting src-address="192.168.224.$e" action=mark-connection new-connection-mark="$e. indosatcon"
    /ip firewall mangle add chain=prerouting connection-mark="$e. indosatcon" protocol=!1 action=mark-packet new-packet-mark="$e. indosatflow" passthrough=no
    }


    cek pada /ip firewall mangle memastikan bahwa script nya berjalan.

    4. kemudian kita buat queue tree nya dengan menjalan kan script seperti di bawah.

    untuk mikrotik v 2.9.xx

    :for e from 2 to 11 do={
    /queue tree add name=(”STREAM-DOWN-” . $e) parent=STREAM-DOWN packet-mark=($e. indosatflow)
    /queue tree add name=(”STREAM-UP-” . $e) parent=STREAM-UP packet-mark=($e. indosatflow)
    }


    untuk mikrotik v 3.xx

    :for e from=2 to=20 do={
    /queue tree add name="STREAM-DOWN-.$e" parent=STREAM-DOWN packet-mark="$e. indosatflow"
    /queue tree add name="STREAM-UP-. $e" parent=STREAM-UP packet-mark="$e. indosatflow"
    }


    cek juga pada queue tree nya apa kah sudah ada list queue nya.

    5. coba melimit salah sati ip dan amati... apakah sudah bener berjalan.

    maap kalo masih pada bingung... baru posting pertama... dan baru sinau... jadi masih hancur nerangin nya..... Click here to enlarge

    semoga para pakar mikrotiker bisa mebantu... Click here to enlarge
    kalo ngelimitnya juga pake script bisa ga?? juga mo tnya nih kok protocolnya 1 = icmp knp tuh.
    Last edited by unique_leader; 02-11-2008 at 09:56.

  12. The Following 2 Users Say Thank You to unique_leader For This Useful Post:


  13. #11
    Status
    Offline
    adeldian's Avatar
    Member Senior
    Join Date
    Nov 2007
    Posts
    411
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    2 (100%)
    itu maskusnya yang bukan ICMP (!1) === (!) artinya "yang bukan"
    jadi protoclo udp,tcp dll kena limit hehhehe dan icmp tidak kena lmit
    semoga membantu

    teirma kasih

  14. #12
    Status
    Offline
    unique_leader's Avatar
    Member Super Senior
    Join Date
    Jul 2007
    Posts
    639
    Reviews
    Read 0 Reviews
    Downloads
    5
    Uploads
    0
    Feedback Score
    1 (100%)
    Click here to enlarge Originally Posted by adeldian Click here to enlarge
    itu maskusnya yang bukan ICMP (!1) === (!) artinya "yang bukan"
    jadi protoclo udp,tcp dll kena limit hehhehe dan icmp tidak kena lmit
    semoga membantu

    teirma kasih
    aku kira tanda ! [note] itu untuk menandai paket itu. mslhnya ada bbrp script/mangle jika kita memberikan tanda ! baru jalan packet nya. jika di ilangkan malah ga jalan

  15. #13
    Status
    Offline
    pendekar's Avatar
    Baru Gabung
    Join Date
    Dec 2008
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ini kenapa yah....pas jajal yg script

    :for e from 3 to 200 do={
    /queue tree add name=(”STREAM-DOWN-” . $e) parent=STREAM-DOWN packet-mark=($e. indosatflow)
    /queue tree add name=(”STREAM-UP-” . $e) parent=STREAM-UP packet-mark=($e. indosatflow)
    }

    hasilnya

    not enough arguments for difference
    invalid expression
    not enough arguments for difference
    invalid expression


    itu kenapa yah...

  16. The Following User Says Thank You to pendekar For This Useful Post:


 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ASk: PPPOE and Simple Queues
    By cooling in forum General Networking
    Replies: 22
    Last Post: 27-07-2010, 23:55
  2. [ask] bikin bandwitch management pk queue tree
    By Dr.Geyonk in forum Beginner Basics
    Replies: 2
    Last Post: 30-10-2008, 22:49
  3. help me bw limiter
    By motokare2006 in forum Beginner Basics
    Replies: 3
    Last Post: 14-03-2008, 00:30
  4. Bikin Script lagi ???
    By eddysubakir in forum Scripting @ Mikrotik
    Replies: 3
    Last Post: 08-03-2008, 09:04
  5. script mangle - queue tree di ISP
    By ponywaterhouse in forum Scripting @ Mikrotik
    Replies: 1
    Last Post: 06-08-2007, 04:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •