Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 6 of 6
  1. #1
    Status
    Offline
    vade5th's Avatar
    Baru Gabung
    Join Date
    Aug 2008
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Red face HELP: script tidak Jalan

    Dear All,

    saya lagi buat sistem wan failover dengan mikrotik, berikut adalah script-nya :
    script 1:

    :local i 0; {:do {:set i ($i + 1)} while $i < 5) && ([/ping 64.233.169.99 interval=3 count=1]=0)};
    :if ($i=5 && [/ip route get [find comment="Default Route"] distance]=1) do={:log info "Main Gateway down";
    /ip route set [find comment="Default Route"] distance=3}

    script 2:
    :local i 0; {:do {:set i ($i + 1)} while $i < 5) && ([/ping 64.233.169.99 interval=3 count=1]=1)};
    :if ($i=5 && [/ip route get [find comment="Default Route"] distance]=3) do={:log info "Main Gateway up";
    /ip route set [find comment="Default Route"] distance=1}

    dari sumber

    saya menggunakan OS mikrotik Versi 3.X, saya coba ikuti script diatas, tetapi masih salah.

    any suggest, mohon pencerahannya.....Click here to enlarge

  2. #2
    Status
    Offline
    vade5th's Avatar
    Baru Gabung
    Join Date
    Aug 2008
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    can anyone help?

  3. #3
    Status
    Offline
    ponywaterhouse's Avatar
    Forum Guru
    Join Date
    Jul 2007
    Posts
    1,507
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    script nya ga jalan, atau emang salah?

    mungkin di wiki pake mikrotik V2.x ketika dipake di V3.x ada bbrp perubahan, jadinya gak cocok..

  4. #4
    Status
    Offline
    antoz's Avatar
    Baru Gabung
    Join Date
    Nov 2007
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kayaknya scriptnya salah deh.. dah dicoba dijalanin di terminal?

    saya coba di 2.9.46:

    Code:
    [admin@2.9.46] > :local i 0; {:do {:set i ($i + 1)} while $i < 5) && ([/ping 64.233.169.99 interval=3 count=1]=0)};
    expression must be a constant text
    no such argument (<)
    trus di 3.13:
    Code:
    [admin@3.13] > :local i 0; {:do {:set i ($i + 1)} while $i < 5) && ([/ping 64.233.169.99 interval=3 count=1]=0)};
    expected end of command (line 1 column 45)
    Oh ya, di 3.x, perintah nya kudunya:

    Code:
    :while () do={}

  5. #5
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    Coba script diubah gini:

    Code:
    :local i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 64.233.169.99 interval=3 count=1]=0)};
    itu kayaknya cuman (($ diubah jadi karakter tertampil di wiki tersebut.
    Script jalan di 2.9.xx, tidak jalan di 3.xx kayaknya.

  6. #6
    Status
    Offline
    vade5th's Avatar
    Baru Gabung
    Join Date
    Aug 2008
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Ok....untuk sementara saya pake script yg lain.
    Thx Anyway Click here to enlarge

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 13-07-2011, 11:37
  2. setting web proxy, rule firewall jadi tidak jalan
    By carrud in forum General Networking
    Replies: 6
    Last Post: 17-09-2010, 13:39
  3. [REQ] Webproxy tidak jalan
    By poensan in forum Beginner Basics
    Replies: 9
    Last Post: 18-06-2008, 13:45
  4. Replies: 4
    Last Post: 04-05-2008, 22:37
  5. (tanya) outlook tidak bisa jalan
    By gunsie in forum Beginner Basics
    Replies: 28
    Last Post: 04-04-2008, 11:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •