Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 4 of 4
  1. #1
    Status
    Offline
    anakbjm's Avatar
    Baru Gabung
    Join Date
    Jan 2014
    Location
    Kota Banjarmasin, Indonesia
    Posts
    9
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Log auto backup di files mikrotik

    Mohon dishare agan-agan sekalian, script log auto backup di file list mikrotik. Trim's

  2. #2
    Status
    Offline
    brutuz_1's Avatar
    VIP Member
    Join Date
    Feb 2010
    Posts
    790
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by anakbjm Click here to enlarge
    Mohon dishare agan-agan sekalian, script log auto backup di file list mikrotik. Trim's
    gk ngerti... yg mau dibikin apa? log nya apa file backup nya?

  3. #3
    Status
    Offline
    heacker_04's Avatar
    Newbie
    Join Date
    Jun 2010
    Location
    makassar
    Posts
    54
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    coba di cari dulu..

    kayaknya udah ada kok yang share script auto backupnya..

    #----var-var-----
    #:local ts [/system clock get time]
    #:set ts ([Click here to enlargeick $ts 0 0].[Click here to enlargeick $ts 3 5].[Click here to enlargeick $ts 6 8])
    :local ds [/system clock get date]
    :set ds ([Click here to enlargeick $ds 7 11].[Click here to enlargeick $ds 0 3].[Click here to enlargeick $ds 4 6])
    :local sysName [/system identity get name];
    :local destEmail [/tool e-mail get from];
    :local boardName [/system resource get board-name];
    #---------------------------------------------------------------------------------------------
    #-----BackupSystemAll-----
    :local SysAll ($sysName.$boardName."-SysAll-".$ds.".backup")
    /sys backup save name=$SysAll;
    #-----mangle----
    :local Mangle ($sysName.$boardName."-Mangle-".$ds.".rsc")
    /ip firewall mangle export file=$Mangle;
    #-----queue-----
    :local Queue ($sysName.$boardName."-Queue-".$ds.".rsc")
    /queue tree export file=$Queue;
    #-----firewall-----
    :local Firewall ($sysName.$boardName."-Firewall-".$ds.".rsc")
    /ip firewall filter export file=$Firewall;
    #-----script-----
    :local Script ($sysName.$boardName."-Script-".$ds.".rsc")
    /sys script export file=$Script;
    #-----scheduler-----
    :local Scheduler ($sysName.$boardName."-Scheduler-".$ds.".rsc")
    /sys scheduler export file=$Scheduler;
    #-----e-mail-----
    :local Email ($sysName.$boardName."-Email-".$ds.".rsc")
    /tool e-mail export file=$Email;

    :log info "Created $Mangle, $Queue, $Firewall, $Script, $Scheduler, $Email success..";
    #-----send email----
    #-----sysall-----
    :delay 30s
    :log info "Sending e-mail process..please wait."
    /tool e-mail send subject=$SysAll body=$SysAll to=$destEmail tls=yes file=$SysAll
    #-----mangle-----
    :delay 30s
    /tool e-mail send subject=$Mangle body=$Mangle to=$destEmail tls=yes file=$Mangle
    #-----queue-----
    :delay 30s
    /tool e-mail send subject=$Queue body=$Queue to=$destEmail tls=yes file=$Queue
    #-----firewall-----
    :delay 30s
    /tool e-mail send subject=$Firewall body=$Firewall to=$destEmail tls=yes file=$Firewall
    #-----Script-----
    :delay 30s
    /tool e-mail send subject=$Script body=$Script to=$destEmail tls=yes file=$Script
    #-----Scheduler-----
    :delay 30s
    /tool e-mail send subject=$Scheduler body=$Scheduler to=$destEmail tls=yes file=$Scheduler
    #-----Email-----
    :delay 30s
    /tool e-mail send subject=$Email body=$Email to=$destEmail tls=yes file=$Email
    :log info "Sending e-mail $Mangle, $Queue, $Firewall, $Script, $Scheduler, $Email success.."
    :log info "Sending e-mail process...complete."
    #---------------------------------------------------------------------------------------------
    #----Deleting-Deleting----
    #-----deleting file created before----
    :delay 120s
    :if ([:len [/file find name=$SysAll]] > 0) do={/file remove $SysAll}
    :if ([:len [/file find name=$Mangle]] > 0) do={/file remove $Mangle}
    :if ([:len [/file find name=$Queue]] > 0) do={/file remove $Queue}
    :if ([:len [/file find name=$Firewall]] > 0) do={/file remove $Firewall}
    :if ([:len [/file find name=$Script]] > 0) do={/file remove $Script}
    :if ([:len [/file find name=$Scheduler]] > 0) do={/file remove $Scheduler}
    :if ([:len [/file find name=$Email]] > 0) do={/file remove $Email}
    :log info "Deleting file $SysAll, $Mangle, $Queue, $Firewall, $Script, $Scheduler, $Email success.."
    contohnya seperti di atas..

  4. #4
    Status
    Offline
    anakbjm's Avatar
    Baru Gabung
    Join Date
    Jan 2014
    Location
    Kota Banjarmasin, Indonesia
    Posts
    9
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Trim ksih gan izin nyoba script nya dl.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tips Mencari Files Apapun di Internet
    By originalrapidshare in forum Articles
    Replies: 7
    Last Post: 18-05-2011, 21:21
  2. Sharing files antara 2 LAN
    By tanendra in forum Beginner Basics
    Replies: 22
    Last Post: 27-12-2010, 14:38
  3. Replies: 8
    Last Post: 18-08-2010, 10:47
  4. Replies: 3
    Last Post: 09-06-2009, 19:58
  5. Replies: 12
    Last Post: 11-04-2008, 08:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •