Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 4 of 4
  1. #1
    Status
    Offline
    cyberpc's Avatar
    Newbie
    Join Date
    Apr 2010
    Location
    Batam, Indonesia
    Posts
    27
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    [help] script untuk detect download >512kbps dan add ke address list

    newbie mohon bantuannya pada para suhu semua.
    script untuk detect jika user download di lan mencapai 512kbps dan menambahkan ip si user ke address list

  2. #2
    Status
    Offline
    Anto.PJ's Avatar
    Forum Guru
    Join Date
    May 2011
    Location
    macz
    Posts
    1,696
    Reviews
    Read 0 Reviews
    Downloads
    7
    Uploads
    0
    Feedback Score
    0
    goalnya apa?? supaya...

  3. #3
    Status
    Offline
    cyberpc's Avatar
    Newbie
    Join Date
    Apr 2010
    Location
    Batam, Indonesia
    Posts
    27
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Anto.PJ Click here to enlarge
    goalnya apa?? supaya...
    saya pengin memisahkan user yang memakai bandwidth >512kbps karena akan saya kasih priority lebih rendah dibanding yang mengakses <512kbps.
    selama ini saya menerapkan pembagian dengan pcq rate=512k, kadang saya kasih pcq rate=0 bila net lagi sepi.
    untuk info saya menggunakan bandwidth 2mb tanpa proxy.

    saya lihat ada script kayak gini:

    Check bandwidth and add limitations

    This script checks if download on interface is more than 512kbps, if true then queue is added to limit speed to 256kbps.
    Code:
    :foreach i in=[/interface find] do={
        /interface monitor-traffic $i once do={
            :if ($"received-bits-per-second" > 0 ) do={
                :local tmpIP [/ip address get [/ip address find interface=$i] address] ;
    #            :log warning $tmpIP ;
                :for j from=( [:len $tmpIP] - 1) to=0 do={
                    :if ( [:pick $tmpIP $j] = "/") do={
                        /queue simple add name=$i max-limit=256000/256000 dst-address=[:pick $tmpIP 0 $j] ;
                    } 
                }
            }
        }
    }
    Last edited by cyberpc; 27-05-2013 at 00:07.

  4. #4
    Status
    Offline
    Anto.PJ's Avatar
    Forum Guru
    Join Date
    May 2011
    Location
    macz
    Posts
    1,696
    Reviews
    Read 0 Reviews
    Downloads
    7
    Uploads
    0
    Feedback Score
    0
    kalo untuk itu saya pikir ga perlu pake script sih..

    tinggal mainkan aja mangle connection-rate + connection byte

  5. The Following User Says Thank You to Anto.PJ For This Useful Post:


 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SHARE] address list MCSIX untuk mikrotik
    By tanpa_kabel in forum General Networking
    Replies: 8
    Last Post: 24-07-2014, 11:48
  2. Detect dan shapping download dengan connetion byte
    By choi in forum QOS & Traffic Shaping
    Replies: 77
    Last Post: 31-07-2012, 22:44
  3. Script add address-list ?
    By abiytia in forum Scripting @ Mikrotik
    Replies: 8
    Last Post: 21-05-2012, 02:04
  4. (ASK) DNS Settings, Address List, Route List berubah otomatif
    By andiprasetya in forum Beginner Basics
    Replies: 11
    Last Post: 15-12-2011, 02:01
  5. Replies: 12
    Last Post: 11-04-2008, 08:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •