Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 2 12 LastLast
Results 1 to 15 of 29
  1. #1
    Status
    Offline
    ucok_karnadi's Avatar
    ..:: Masih Bodoh ::..
    Join Date
    Jan 2009
    Location
    PATI - JAWA TENGAH
    Posts
    1,187
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Check proxy dari mikrotik (melihat service squid)

    bagi rekan rekan yg ingin melakukan pengecekan proxy dengan melihat service squid dan test dari mikrotik berikut caranya di mesin proxy sudah ada web yg berjalan dan buat file test.txt di root webnya, terserah mau isi apa, tapi saran saya kasih text seminim mungkin di file tersebut

    selanjutnya mari kita buat script beikut

    Code:
    /system clock manual
    set dst-delta=+07:00 dst-end="jan/01/1970 00:00:00" dst-start=\
        "jan/01/1970 00:00:00" time-zone=+07:00
    /system ntp client
    set enabled=yes mode=unicast primary-ntp=202.134.1.10 secondary-ntp=\
        152.118.24.8
    
    /system scheduler
    add comment="" disabled=no interval=10s name=Check_Proxy on-event=PROXY \
        policy=reboot,read,write,policy,test,password,sniff,sensitive start-date=\
        jan/01/1970 start-time=00:00:00
    /system script
    add name=Check-proxy policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
        {\r\
        \n:local checkpage \"test.txt\";\r\
        \n:local found \"0\" ;\r\
        \n:foreach i in=[/file find] do={\r\
        \n:local filename [/file get \$i name];\r\
        \n:if ( \$filename = \$checkpage) do={ \r\
        \n:set found \"1\" ; \r\
        \n:log info \"found\"; \r\
        \n}\r\
        \n}\r\
        \n:log warning \"\$found\";\r\
        \n:if ( \$found = \"0\" ) do={ \r\
        \n:log warning \"Disable rule, service down\"; \r\
        \n/ip fire nat dis 3 ; \r\
        \n/ip fire mang dis 14; \r\
        \n} else={ \r\
        \n:log info \"Enable rule, service up\"; \r\
        \n/ip fire nat en 3; \r\
        \n/ip fire mang en 14; \r\
        \n}\r\
        \n/file remove \$checkpage;\r\
        \n}\r\
        \n"
    add name=Download policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
        {\r\
        \n/tool fetch url=\"http://192.168.99.2/test.txt\" mode=http port=3128\r\
        \n}"
    add name=PROXY policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
        {\r\
        \n/system script run Check-proxy;\r\
        \n:delay delay-time=2\r\
        \n/system script run Download \r\
        \n}\r\
        \n"
    untuk yg saya bold dan warna merah itu sesuaikan dengan nat atau mangle yg ingin anda disable atau enable
    ___________________________________________


  2. The Following 23 Users Say Thank You to ucok_karnadi For This Useful Post:

    + Show/Hide list of the thanked


  3. #2
    Status
    Offline
    c0nf's Avatar
    Contributor
    Join Date
    Jul 2007
    Location
    Bandung, Indonesia
    Posts
    1,816
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    pertamaxxxxxx Click here to enlarge
    Invisible...

  4. #3
    Status
    Offline
    Anto.PJ's Avatar
    Forum Guru
    Join Date
    May 2011
    Location
    macz
    Posts
    1,696
    Reviews
    Read 0 Reviews
    Downloads
    7
    Uploads
    0
    Feedback Score
    0
    kalo script untuk kirim magic packet ada ga om?? untuk WOL..

  5. #4
    Status
    Offline
    ucok_karnadi's Avatar
    ..:: Masih Bodoh ::..
    Join Date
    Jan 2009
    Location
    PATI - JAWA TENGAH
    Posts
    1,187
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Anto.PJ Click here to enlarge
    kalo script untuk kirim magic packet ada ga om?? untuk WOL..
    klo mau WOL bisa kok dari mikrotik juga
    ___________________________________________


  6. #5
    Status
    Offline
    taufiqtgz's Avatar
    Newbie
    Join Date
    Dec 2009
    Location
    635'44.17"S
    Posts
    26
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ini untuk semua jenis mesin proxy external bang
    kuk manggilnya http--://192.168.99.2/test.txt
    alnya dimesin proxy saya ndak bisa dipanggil lewat
    mohon pencerahan.

  7. #6
    Status
    Offline
    ucok_karnadi's Avatar
    ..:: Masih Bodoh ::..
    Join Date
    Jan 2009
    Location
    PATI - JAWA TENGAH
    Posts
    1,187
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by taufiqtgz Click here to enlarge
    ini untuk semua jenis mesin proxy external bang
    kuk manggilnya http--://192.168.99.2/test.txt
    alnya dimesin proxy saya ndak bisa dipanggil lewat
    mohon pencerahan.
    ya install dulu layanan untuk web, bisa pakai apache, lighttpd, atau yg lainnya
    ___________________________________________


  8. The Following User Says Thank You to ucok_karnadi For This Useful Post:


  9. #7
    Status
    Offline
    tyang_dusun's Avatar
    Member Super Senior
    Join Date
    Jun 2008
    Location
    Klaten, Jawa Tengah, Indonesia, Indonesia
    Posts
    521
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Prikitiuwnya dunk ... Gan

  10. #8
    Status
    Offline
    ucok_karnadi's Avatar
    ..:: Masih Bodoh ::..
    Join Date
    Jan 2009
    Location
    PATI - JAWA TENGAH
    Posts
    1,187
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by tyang_dusun Click here to enlarge
    Prikitiuwnya dunk ... Gan
    dah bisa nerapinnya???
    ___________________________________________


  11. #9
    Status
    Offline
    pos_ronda's Avatar
    VIP Member
    Join Date
    Aug 2009
    Location
    Sleman, Indonesia
    Posts
    887
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    brarti nanti bisa di browse dari browser 3128/test.txt

  12. #10
    Status
    Offline
    echozz's Avatar
    Member
    Join Date
    Jul 2008
    Posts
    120
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    apa gak lebih simpel pake netwatch gan?

  13. #11
    Status
    Offline
    fathur rahman's Avatar
    Member
    Join Date
    Apr 2009
    Posts
    253
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Mantabs bener Master yg satu ini,,......Click here to enlarge


    makanan nya Tiap hri text mode mlulu...Click here to enlarge

  14. #12
    Status
    Offline
    pos_ronda's Avatar
    VIP Member
    Join Date
    Aug 2009
    Location
    Sleman, Indonesia
    Posts
    887
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ternyata 11 12 dengan yang di

  15. The Following User Says Thank You to pos_ronda For This Useful Post:


  16. #13
    Status
    Offline
    g_bLunk's Avatar
    Calon Member
    Join Date
    May 2012
    Location
    Bandung
    Posts
    83
    Reviews
    Read 0 Reviews
    Downloads
    5
    Uploads
    0
    Feedback Score
    0
    udah ane terapin di ubuntu serverr (proxy server)
    hasilnya memuaskan.

    thank's Click here to enlarge

  17. #14
    Status
    Offline
    boled's Avatar
    Member
    Join Date
    Aug 2009
    Location
    Cilacap
    Posts
    246
    Reviews
    Read 0 Reviews
    Downloads
    14
    Uploads
    1
    Feedback Score
    0
    terima kasih ide nya bang...

    inspirasi buat sy bang

  18. #15
    Status
    Offline
    madhy's Avatar
    Baru Gabung
    Join Date
    Apr 2009
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    7
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Anto.PJ Click here to enlarge
    kalo script untuk kirim magic packet ada ga om?? untuk WOL..
    ini contoh di MT RB750 ane gan...

    /tool netwatch
    add comment="Wake On LAN for PC Proxy Server" disabled=no down-script=\
    "/tool wol interface=LAN3-Proxy 10:78:d2:8c:ae:6f" host=172.168.0.202 \
    interval=1m timeout=1s up-script=\
    "/tool wol interface=LAN3-Proxy 10:78:d2:8c:ae:6f"
    untuk yg dibold sesuaikan dengan punya agan.... untuk bold warna merah sesuaikan dengan Mac Address Lan Card PC Proxy agan...

 

 
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 14-09-2011, 12:28
  2. Replies: 78
    Last Post: 26-10-2010, 11:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •