Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 3 of 3
  1. #1
    Status
    Offline
    wp11b's Avatar
    Newbie
    Join Date
    Jul 2007
    Posts
    43
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    mohon bantuan untuk buat script

    gua lage belajar bikin script nih...
    rencananya gua mo bikin script buat bikin rule di mangle. jadi gua pengen bikin rule /ip firewall mangle add src-address=192.168.1.x action=mark-packet new-packet-mark=192.168.1.x
    /ip firewall mangle add dst-address=192.168.1.x action=mark-packet new-packet-mark=192.168.1.x

    nah gua mo buat pake command for, jadi variabel x akan mengikuti looping.
    gua dah buat sprt di bwh ini, tp lom jalan.

    for i from=1 to=2 do={ [/ip firewall mangle add src-address="192.168.183."$i action=mark-packet new-packet-mark="192.168.183."$i]}

    salah dimana ya?

  2. The Following User Says Thank You to wp11b For This Useful Post:


  3. #2
    Status
    Offline
    wp11b's Avatar
    Newbie
    Join Date
    Jul 2007
    Posts
    43
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    gua coba script :

    > : for i from=1 to=2 do={Click here to enlargeut {$i} }
    $i
    $i

    kok hasilnya gitu yach? share dunk

  4. #3
    Status
    Offline
    patkai's Avatar
    Verified Account - Partner
    Join Date
    Jul 2007
    Posts
    4
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    untuk concatenation (alias menggabungkan string), pakai karakter "." (aka. titik). Trus perintahnya kurang chain, jadi script lengkapnya kira-kira begini (asumsi chainnya forward):

    :for i from=1 to=2 do={
    /ip firewall mangle add src-address=("192.168.183." . $i) action=mark-packet new-packet-mark=("192.168.183." . $i) chain=forward
    }

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mohon bantuan script auto change dns + flush dns
    By juniorbrother in forum Scripting @ Mikrotik
    Replies: 22
    Last Post: 22-12-2012, 14:33
  2. butuh bantuan buat optimalkan link
    By ree_bood in forum Wireless Networking
    Replies: 19
    Last Post: 24-04-2009, 02:52
  3. Mohon Bantuan : mo pasang wavelan goldcard di mikrotik
    By zulhanif in forum Wireless Networking
    Replies: 1
    Last Post: 04-07-2008, 15:08
  4. Mohon Bantuan: Setting RB333+Speedy
    By H4SL14N in forum Beginner Basics
    Replies: 1
    Last Post: 11-02-2008, 19:22
  5. Mohon Bantuan
    By rezaferd in forum General Networking
    Replies: 4
    Last Post: 21-11-2007, 17:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •