Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 7 of 7
  1. #1
    Status
    Offline
    indrajack's Avatar
    Baru Gabung
    Join Date
    Sep 2010
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Thumbs up 2 isp jadi satu dengan Script modifikasi Failover

    Tolong di bantu para mastah...

    Kondisi :
    menggunakan rb750g

    ether1 sistelindo : 192.168.1.1 (Isp)
    ether2 wimax : 192.168.0.240 (Isp)
    ether3 wifi : 192.168.2.240 (hotspot)
    ether4 VPN :192.168.3.240 (VPN)

    PC client :192.168.0.100 - 192.168.0.140
    Managemen :192.168.3.241 - 192.168.3.245
    skema :

    WImax -------switch------rb750g-------- hotspot
    | | |---------- VPN
    | |
    PC Client -------| |
    |
    Sistelindo

    Saya membuat ip 192.168.0.0/24 untuk tetap menggunakan wimax
    dengan mengunakan mangle :
    /ip firewall mangle add chain=prerouting src-address=192.168.0.0/24 action=mark-routing new-routing-mark=LB-RM

    dengan di routenya saya setting:
    /ip route add gateway=192.168.0.1 routing-mark=LB-RM check-gateway=ping

    dan untuk management menggunakan koneksi sistelindo + vpn.

    semua berjalan dengan baik.

    tapi saya mau membuat jika koneksi wimax down, PC Client (192.168.0.0/24) secara automatis menggunakan koneksi sistelindo dan jika koneksi wimax sudah normal, PC Client kembali menggunakan wimax.
    maka saya mencoba menggunakan Script ini:

    /system script add name=”failover” source={
    :if ([/ip route get [/ip route find comment="utama"] disabled]=”yes”) do={/ip route enable [/ip route find comment="utama"]} else={/ip route disable [/ip route find comment="utama"]}
    /system script add name=”back2main” source={
    :if ([/ip route get [/ip route find comment="utama"] disabled]=”yes”) do={/ip route enable [/ip route find comment="utama"]}
    /tool netwatch add host=61.247.0.4 interval=10s timeout=1s down-script=”failover”
    /tool netwatch add host=61.247.0.4 interval=10s timeout=1s up-script=”back2main”

    Permasalahannya adalah dari script ini ketika test case saya disable koneksi wimax...oke berjalan dengan baik semuanya secara auto pindah ke sistelindo. ketika wimax normal kembali...kenapa sistelindo jadi down, teguran pertamalah keluar dari pihak management... Saya coba kutak katik scriptnya...berhasil...wimax down..pindah auto ke sistelindo..wimax normal..sistelindo tetap normal...tapi kenapa jadi kagak mau pindah ke wimax lagi...puyenggggg...mana kagak ke save lagi yg tadi itu scriptnya. Click here to enlarge

    Tolong di bantu ya para mastah....thx

  2. #2
    Status
    Offline
    indrajack's Avatar
    Baru Gabung
    Join Date
    Sep 2010
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    belum ada yg bantu neh?

  3. #3
    Status
    Offline
    learn2live's Avatar
    Baru Gabung
    Join Date
    Jun 2011
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    that's some good stuff on 2 into 1 router. thanks

  4. #4
    Status
    Offline
    rediroy's Avatar
    Baru Gabung
    Join Date
    May 2011
    Posts
    10
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ane juga puyeng neh

  5. #5
    avril.el.arnmy
    avril.el.arnmy's Avatar
    load balancing selalu bermasalah...... nasib Click here to enlarge

  6. #6
    Status
    Offline
    Firhat Ifanet's Avatar
    Baru Gabung
    Join Date
    Mar 2013
    Location
    Makassar
    Posts
    10
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by indrajack Click here to enlarge
    Tolong di bantu para mastah...

    Kondisi :
    menggunakan rb750g

    ether1 sistelindo : 192.168.1.1 (Isp)
    ether2 wimax : 192.168.0.240 (Isp)
    ether3 wifi : 192.168.2.240 (hotspot)
    ether4 VPN :192.168.3.240 (VPN)

    PC client :192.168.0.100 - 192.168.0.140
    Managemen :192.168.3.241 - 192.168.3.245
    skema :

    WImax -------switch------rb750g-------- hotspot
    | | |---------- VPN
    | |
    PC Client -------| |
    |
    Sistelindo

    Saya membuat ip 192.168.0.0/24 untuk tetap menggunakan wimax
    dengan mengunakan mangle :
    /ip firewall mangle add chain=prerouting src-address=192.168.0.0/24 action=mark-routing new-routing-mark=LB-RM

    dengan di routenya saya setting:
    /ip route add gateway=192.168.0.1 routing-mark=LB-RM check-gateway=ping

    dan untuk management menggunakan koneksi sistelindo + vpn.

    semua berjalan dengan baik.

    tapi saya mau membuat jika koneksi wimax down, PC Client (192.168.0.0/24) secara automatis menggunakan koneksi sistelindo dan jika koneksi wimax sudah normal, PC Client kembali menggunakan wimax.
    maka saya mencoba menggunakan Script ini:

    /system script add name=₝failover₝ source={
    :if ([/ip route get [/ip route find comment="utama"] disabled]=₝yes₝) do={/ip route enable [/ip route find comment="utama"]} else={/ip route disable [/ip route find comment="utama"]}
    /system script add name=₝back2main₝ source={
    :if ([/ip route get [/ip route find comment="utama"] disabled]=₝yes₝) do={/ip route enable [/ip route find comment="utama"]}
    /tool netwatch add host=61.247.0.4 interval=10s timeout=1s down-script=₝failover₝
    /tool netwatch add host=61.247.0.4 interval=10s timeout=1s up-script=₝back2main₝

    Permasalahannya adalah dari script ini ketika test case saya disable koneksi wimax...oke berjalan dengan baik semuanya secara auto pindah ke sistelindo. ketika wimax normal kembali...kenapa sistelindo jadi down, teguran pertamalah keluar dari pihak management... Saya coba kutak katik scriptnya...berhasil...wimax down..pindah auto ke sistelindo..wimax normal..sistelindo tetap normal...tapi kenapa jadi kagak mau pindah ke wimax lagi...puyenggggg...mana kagak ke save lagi yg tadi itu scriptnya. Click here to enlarge

    Tolong di bantu ya para mastah....thx


    Silahkan tambahkan settingan buat rules untuk masing-masing koneksi pada /ip firewall mangle > extra NTH 2,1 (rules pertama) dan NTH=1,1 pada rules kedua.
    Selanjutnya, silahkan coba disable ether salah satu port WAN ( 100% work !)...semoga cara ini bisa membantu anda.

    GodLuck

  7. #7
    Status
    Offline
    fuadh's Avatar
    Baru Gabung
    Join Date
    Dec 2015
    Posts
    3
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Saya menerapkan 2 isp jadi 1 berhasil..tp permasalahnya ping ke google dll dr telnet Rb rto..masalahnya apa ya?? mohon bantuan master2 semua

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Howto] Failover Link dengan Bonding EoIP
    By si_faisal in forum Tutorial
    Replies: 7
    Last Post: 05-07-2013, 11:56
  2. jual modem adsl modifikasi (kondisi baru dengan modifikasi)
    By ronnytefnai45 in forum Lapak serba-serbi
    Replies: 21
    Last Post: 12-10-2012, 08:50
  3. [as] gmn dengan 2 chanel speedy, 1 isp, 3 LAN biar jadi satu aja?
    By glaphak_gluphuk in forum Beginner Basics
    Replies: 6
    Last Post: 08-03-2010, 19:15
  4. Interface lokal dan hotspot jadi satu
    By Xerophie in forum Wireless Networking
    Replies: 3
    Last Post: 09-06-2009, 15:01
  5. [help] gabung 2 adsl dengan mikrotik (tanpa failover)
    By nandong in forum General Networking
    Replies: 3
    Last Post: 10-09-2008, 08:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •