Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 9 of 9
  1. #1
    Status
    Offline
    abiytia's Avatar
    Baru Gabung
    Join Date
    Aug 2010
    Posts
    17
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0

    Script add address-list ?

    ada yang tau ga cara bikin script untuk otomatis add address-list? contohnya kita mau ip facebook yang diakses dari kompie client otomatis ditambahkan ke address-list.

    makasih sebelumnya....Click here to enlarge

  2. #2
    Status
    Offline
    mikroapa's Avatar
    Baru Gabung
    Join Date
    Aug 2010
    Location
    Siantar-Medan-Siantar
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by abiytia Click here to enlarge
    ada yang tau ga cara bikin script untuk otomatis add address-list? contohnya kita mau ip facebook yang diakses dari kompie client otomatis ditambahkan ke address-list.

    makasih sebelumnya....Click here to enlarge

    Gunakan fasilitas Search Click here to enlarge

  3. #3
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    nyampahhh... Click here to enlarge

    kalo bikin bikin thread usahakan yg berbobot... barang gituan udah dibahas sejak 2008...

  4. #4
    Status
    Offline
    s!mbahNET's Avatar
    Newbie
    Join Date
    Nov 2010
    Location
    Bantul, Djogjakarta
    Posts
    62
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kayaknya tulisan search harus di gedein lg nih, biar bisa dilihat & dipakai fungsinyaClick here to enlarge

  5. #5
    Status
    Offline
    irman's Avatar
    Baru Gabung
    Join Date
    Mar 2010
    Posts
    1
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    test

    test aja lahhhh

  6. #6
    Status
    Offline
    kweteng's Avatar
    VIP Member
    Join Date
    Nov 2009
    Location
    batu wae
    Posts
    797
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    sekedar share bisa menggunakan teknik script schdeuler dns capture to dst-addres-list, lebih ringan daripada menggunakan teknik content filter to dst-addres-list



    Code:
    :foreach i in=[/ip dns cache find] do={
    :if ([:find [/ip dns cache get $i name] "facebook.com"] > 0) do={
    :log info ("facebook: " . [/ip dns cache get $i name] . " (ip address " . [/ip dns cache get $i address] . ")")
    /ip firewall address-list add address=[/ip dns cache get $i address] list=facebook disabled=no
    
    }
    tambahakn utk domain facebook CDN lanya nya seperti fbcdn ada game2 dll. trs di schdule misal tiap 10 mnt


    GUDLAK Click here to enlarge

  7. The Following User Says Thank You to kweteng For This Useful Post:


  8. #7
    Status
    Offline
    abiytia's Avatar
    Baru Gabung
    Join Date
    Aug 2010
    Posts
    17
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by kweteng Click here to enlarge
    sekedar share bisa menggunakan teknik script schdeuler dns capture to dst-addres-list, lebih ringan daripada menggunakan teknik content filter to dst-addres-list



    Code:
    :foreach i in=[/ip dns cache find] do={
    :if ([:find [/ip dns cache get $i name] "facebook.com"] > 0) do={
    :log info ("facebook: " . [/ip dns cache get $i name] . " (ip address " . [/ip dns cache get $i address] . ")")
    /ip firewall address-list add address=[/ip dns cache get $i address] list=facebook disabled=no
    
    }
    tambahakn utk domain facebook CDN lanya nya seperti fbcdn ada game2 dll. trs di schdule misal tiap 10 mnt


    GUDLAK Click here to enlarge
    nah ini dia yang gua cari, makasih banyak om...Click here to enlarge...
    bukan dengan content filter melainkan dengan sytem script...

    buat om yang diatas... sory deh kalo pertanyaan gua nyampahClick here to enlarge gua pelajarin lagi nih forum... sory baru gabung...

    ---------- Post added at 16:40 ---------- Previous post was at 16:24 ----------

    Click here to enlarge Originally Posted by kweteng Click here to enlarge
    sekedar share bisa menggunakan teknik script schdeuler dns capture to dst-addres-list, lebih ringan daripada menggunakan teknik content filter to dst-addres-list



    Code:
    :foreach i in=[/ip dns cache find] do={
    :if ([:find [/ip dns cache get $i name] "facebook.com"] > 0) do={
    :log info ("facebook: " . [/ip dns cache get $i name] . " (ip address " . [/ip dns cache get $i address] . ")")
    /ip firewall address-list add address=[/ip dns cache get $i address] list=facebook disabled=no
    
    }
    tambahakn utk domain facebook CDN lanya nya seperti fbcdn ada game2 dll. trs di schdule misal tiap 10 mnt


    GUDLAK Click here to enlarge
    om dah gua coba, tapi kok di address-list ga ada list yang berbau facebook... kenapa ya mas...
    di rb750 gua tambahin kayak gini:
    /system script add name="facebook" owner="admin"
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword,sniff,sensitive
    last-started=jun/11/2011 10:25:00 run-count=9
    source=
    :foreach i in=[/ip dns cache find] do={
    :if ([:find [/ip dns cache get $i name] "facebook.com"] > 0) do={
    :log info ("facebook: " . [/ip dns cache get $i name] . " (ip address ">
    /ip firewall address-list add address=[/ip dns cache get $i address] li>
    }

    trus di scheduler
    /system scheduler add name=facebook start-date=jan/01/1970 start-time=15:00:00 interval=00:05:00 on-event=facebook owner=admin policy=reboot,write,test,sniff,read,policy,passwor d,sensitive

    maksih sebelumnya.
    Last edited by abiytia; 11-06-2011 at 18:11.

  9. #8
    Status
    Offline
    wandi's Avatar
    Member
    Join Date
    Jul 2008
    Location
    Bandung, Indonesia
    Posts
    276
    Reviews
    Read 0 Reviews
    Downloads
    6
    Uploads
    0
    Feedback Score
    0
    Mungkin pengaruh versi mikrotik di sini juga gak jalan scriptnya. kalp yg ini baru jalan
    Code:
    :foreach i in=[/ip dns cache find] do={
        :local bNew "true";
        :local cacheName [/ip dns cache all get $i name] ;
    #    :put $cacheName;
    
        :if (([:find $cacheName "facebook"] != 0) || ([:find $cacheName "fbcdn"] != 0)) do={
    
            :local tmpAddress [/ip dns cache get $i address] ;
    #	:put $tmpAddress;
    
    # if address list is empty do not check
            :if ( [/ip firewall address-list find ] = "") do={
                :log info ("added entry: $[/ip dns cache get $i name] IP $tmpAddress");
                /ip firewall address-list add address=$tmpAddress list=restricted comment=$cacheName;
            } else={
                :foreach j in=[/ip firewall address-list find ] do={
                    :if ( [/ip firewall address-list get $j address] = $tmpAddress ) do={
                        :set bNew "false";
                    }
                }
                :if ( $bNew = "true" ) do={
                    :log info ("added entry: $[/ip dns cache get $i name] IP $tmpAddress");
                    /ip firewall address-list add address=$tmpAddress list=restricted comment=$cacheName;
                }
            }
        }
    }
    di tes di versi 3.2

  10. The Following User Says Thank You to wandi For This Useful Post:


  11. #9
    Status
    Offline
    c0nf's Avatar
    Contributor
    Join Date
    Jul 2007
    Location
    Bandung, Indonesia
    Posts
    1,816
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    betul kata om wandi. ada perbedaan "bahasa" di antara versi2 mikrotik. cuman maap, lupa apa aja dan antar versi berapa aha Click here to enlarge
    Invisible...

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Firewall - Address List
    By Dody in forum Beginner Basics
    Replies: 18
    Last Post: 21-08-2010, 17:03
  2. menampilkan address list tertentu
    By awarmanf in forum Scripting @ Mikrotik
    Replies: 0
    Last Post: 08-05-2010, 20:44
  3. Replies: 12
    Last Post: 11-04-2008, 08:28
  4. address list
    By c0nf in forum General Networking
    Replies: 3
    Last Post: 06-11-2007, 17:50
  5. [ASK] address list vs packet-mark
    By cocorex in forum General Networking
    Replies: 0
    Last Post: 16-10-2007, 11:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •