Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 12 of 12
  1. #1
    Status
    Offline
    awanbiru2007's Avatar
    Calon Member
    Join Date
    Jan 2010
    Posts
    73
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    0

    Cara ganti profile user hotspot dengan uptime tertentu

    Maaf master sekalian, saya nubie mau tanya berhubungan dengan profile user di hotspot. Setting nya seperti ini

    Untuk profile user :

    Code:
    [awanbiru2007@MikroTik] > ip hotspot user profile print
    Flags: * - default 
     0 * name="default" idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 
         transparent-proxy=no 
    
     1   name="Limit" session-timeout=1h30m idle-timeout=none keepalive-timeout=2m 
         status-autorefresh=1m shared-users=unlimited rate-limit="80k/100k" transparent-proxy=no 
    
     2   name="Sedang" session-timeout=1h30m idle-timeout=none keepalive-timeout=2m 
         status-autorefresh=1m shared-users=5 rate-limit="150k/150k" transparent-proxy=no 
    
     3   name="Limit2" session-timeout=1h30m idle-timeout=none keepalive-timeout=2m 
         status-autorefresh=1m shared-users=unlimited rate-limit="32k/64k" transparent-proxy=no
    Dan user yang aktif penampakan nya seperti ini :

    Code:
    [awanbiru2007@MikroTik] > ip hotspot user print where uptime>3d
    Flags: X - disabled, D - dynamic 
     #   SERVER                 NAME               ADDRESS         PROFILE               UPTIME      
     0                          machrus                            default               3d21h19m17s 
     1                          sonde-pc                           Limit                 4d5h36m14s  
     2                          afik-pc                            Limit                 3d7h7m17s   
     3                          aldi-pc                            Limit                 3d3h39m5s   
     4                          indra-pc                           Limit                 3d16h2m45s  
     5                          idris-pc                           Limit                 5d10h31m28s 
     6                          ramadhan-pc                        Limit                 4d6h3m1s
    Pertanyaan nya, bagaimana script agar user yang telah mencapai uptime nya 3 hari atau lebih, maka akan berganti menjadi profile Limit2 setelah sebelum nya dengan profile Limit.

    Jadi sekenario nya adalah, jika ditemui user yang dengan uptime lebih dari 3 hari maka profile nya akan berganti menjadi yang telah kita set.

    Mohon bantuan nya master, Trim's sebelum nya
    Click here to enlarge

  2. #2
    Status
    Offline
    awanbiru2007's Avatar
    Calon Member
    Join Date
    Jan 2010
    Posts
    73
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    0
    Up lagi... mohon master, bimbingan nya
    Click here to enlarge

  3. #3
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by awanbiru2007 Click here to enlarge
    Up lagi... mohon master, bimbingan nya
    Click here to enlarge
    mau jualan multispeed yach???
    kereeenn...
    tapi maaf gak bisa bantu soal scripting.. bantu up aja... Click here to enlarge


    up...up..up...up!!!

  4. #4
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mungkin begini bisa...
    tested on v4.6

    Code:
    :foreach x in=[/ip hotspot user find] do={:if ([/ip hotspot user get $x uptime]>3d ) do={
    :log info ("mengganti user $[/ip hotspot user get $x name] ke profile limit2")
    /ip hotspot user set [/ip hotspot user get $x name] profile=limit2
    }
    }
    ditunggu reviewnya....Click here to enlarge

  5. The Following User Says Thank You to zdienos For This Useful Post:


  6. #5
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    agan zdie... kalo diaplikasikan ke pppoe jadi nya kayak gmna yach??Click here to enlarge

  7. #6
    Status
    Offline
    tyang_dusun's Avatar
    Member Super Senior
    Join Date
    Jun 2008
    Location
    Klaten, Jawa Tengah, Indonesia, Indonesia
    Posts
    521
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    numnggu Prikitiuwnya .. plesss .... Click here to enlarge

  8. #7
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by spring Click here to enlarge
    agan zdie... kalo diaplikasikan ke pppoe jadi nya kayak gmna yach??Click here to enlarge
    kalo pppoe, belum pernah nyoba..
    tadi ngetest bikin user di secret, ternyata variabel "sudah berapa lama pakai"-nya itu tidak ada (seperti uptime-used)

    Code:
    ppp secret print where [tab]
    Click here to enlarge


    CMIIW

    nb: benar yah, bikin usernya di situ ??? Click here to enlarge

  9. #8
    Status
    Offline
    Spring's Avatar
    Contributor
    Join Date
    Oct 2009
    Location
    Manado
    Posts
    964
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Bener gan... uptime nya cuman ada saat user lagi aktiv, pas logout udah kereset lagi. kecuali pake userman.. Click here to enlarge

  10. #9
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    TSnya mana yah??? Click here to enlarge

  11. #10
    Status
    Offline
    awanbiru2007's Avatar
    Calon Member
    Join Date
    Jan 2010
    Posts
    73
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    0
    Maaf baru bisa OL, saya sudah test di ver 3.22 ternyata script nya gak jalan,...
    Click here to enlarge

  12. #11
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    versi 3.22 (pak tani???), maaf kalo curiga....

    kurang tau juga kalo versi itu...,
    saya sudah tes, dan jalan sempurna di v4.6


    update aja gan Click here to enlarge

  13. The Following User Says Thank You to zdienos For This Useful Post:


  14. #12
    Status
    Offline
    awanbiru2007's Avatar
    Calon Member
    Join Date
    Jan 2010
    Posts
    73
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    0
    Ok tar coba lagi, makasih master info nya

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cara ganti IP hotspot jadi nama hotspot kita di halaman web login
    By vkey103 in forum HotSpot, The Dude & User Manager
    Replies: 20
    Last Post: 24-02-2016, 10:37
  2. Replies: 7
    Last Post: 03-05-2010, 19:30
  3. User multi profile
    By nine in forum HotSpot, The Dude & User Manager
    Replies: 4
    Last Post: 16-02-2010, 12:22
  4. ask? di server profile hotspot dan profile user
    By ud1geol in forum Beginner Basics
    Replies: 3
    Last Post: 10-05-2009, 10:22
  5. membatasi jam akses user dengan limit uptime
    By maileary in forum Wireless Networking
    Replies: 0
    Last Post: 05-11-2007, 17:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •