Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 3 of 3
  1. #1
    Status
    Offline
    rantsa's Avatar
    Baru Gabung
    Join Date
    Jun 2010
    Posts
    4
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Script enable/disable ethernet berdasarkan ping?

    Suhu dan Master master ane mau nanya ni:

    Bagaimana cara membuat ethernet otomatis enable dan disable berdasarkan ping ke gateway si mikrotik

    Misalkan ane ingin:
    Gateway Router(172.17.1.1)----(172.17.1.2|ether1)Router(172.17.2.1|ether2)----Client
    1. Jika router tidak bisa ping ke gateway(172.17.1.1) maka disable ethernet yg ngarah ke klient(ether2)
    2. Sebaliknya, jika bisa ping ke gateway maka enable ether1

    Jadi maksdnya biar scriptnya itu berjalan terus, dengan mengecek bisa ping ke gateway ato tidak.

    Tolong dibantu ya master2..

  2. #2
    Status
    Offline
    xeon's Avatar
    Verified Account - Partner
    Join Date
    Mar 2008
    Location
    DKI Jakarta
    Posts
    1,539
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    2 (100%)
    Click here to enlarge Originally Posted by rantsa Click here to enlarge
    Gateway Router(172.17.1.1)----(172.17.1.2|ether1)Router(172.17.2.1|ether2)----Client
    1. Jika router tidak bisa ping ke gateway(172.17.1.1) maka disable ethernet yg ngarah ke klient(ether2)
    2. Sebaliknya, jika bisa ping ke gateway maka enable ether1

    Jadi maksdnya biar scriptnya itu berjalan terus, dengan mengecek bisa ping ke gateway ato tidak.

    Tolong dibantu ya master2..
    /tool netwatch add disabled=no down-script="/interface disable ether2" host=172.17.1.1 interval=5s timeout=1s up-script="/interface enable ether2"

    untuk yang nomor 2, yang di enable adalah juga ether2, karena jika ether2 tidak di enable, maka ether2 tetap akan terdisable, dan ether1 akan selalu enable karena memang tidak pernah di disable.

  3. #3
    Status
    Offline
    rantsa's Avatar
    Baru Gabung
    Join Date
    Jun 2010
    Posts
    4
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by xeon Click here to enlarge
    /tool netwatch add disabled=no down-script="/interface disable ether2" host=172.17.1.1 interval=5s timeout=1s up-script="/interface enable ether2"

    untuk yang nomor 2, yang di enable adalah juga ether2, karena jika ether2 tidak di enable, maka ether2 tetap akan terdisable, dan ether1 akan selalu enable karena memang tidak pernah di disable.
    makasih gan... Click here to enlarge yg no 2 kliru ngetik ane, shrusnya ether2 bukan ether1. segera ke tkp untuk ane coba gan...

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Script enable/disable ethernet berdasarkan jam?
    By prazapreza in forum Scripting @ Mikrotik
    Replies: 13
    Last Post: 14-03-2011, 18:53
  2. Replies: 4
    Last Post: 28-07-2010, 10:07
  3. [share] script disable/enable alarm
    By fagundez in forum Scripting @ Mikrotik
    Replies: 8
    Last Post: 05-07-2010, 12:49
  4. scrip enable disable nat
    By cybersampi in forum Scripting @ Mikrotik
    Replies: 6
    Last Post: 03-06-2009, 18:47
  5. bantu enable n disable script???
    By wpeiche in forum Scripting @ Mikrotik
    Replies: 2
    Last Post: 22-04-2008, 09:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •