Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2

Thread: Remark script

  1. #1
    Status
    Offline
    orang gila's Avatar
    Baru Gabung
    Join Date
    Dec 2010
    Posts
    7
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Post Remark script

    1) ini script / command / apa ini namanya ?
    Code:
    /ip firewall address-list export
    /interface print
    /ip route add gateway=123.123.123.123
    /ip route add gateway=100.100.100.100

    2) Saya dapat script :
    Code:
    /system script add name=namaBaru={
    :local R1
    :local R2
    :if ([/tool netwatch get R1 status]=up) do={:set R1 192.168.0.254}
    :if ([/tool netwatch get R2 status]=up) do={:set R2 203.81.187.1}
    /ip route set [/ip route find dst-address=0.0.0.0/0] \
    gateway=($R1 . , . $R2)
    }


    Pertanyaannya ...

    Bagaimanakah saya mendisable / commentout / remarking no 1 & 2 diatas sehingga tidak dikerjakan/running/execute.

    Kalau dalam DOS mode memakai :
    REM /ip route add gateway=123.123.123.123
    Kalau dalam javascript / php mode memakai :
    PHP Code:
    ///ip route add gateway=123.123.123.123 
    Kalau javascript / php memakai : /* syntax here */

    PHP Code:
    /ip firewall address-list export
    /*
        /interface print
        /ip route add gateway=123.123.123.123
        ini adalah komentar, baris ini dan 2 baris diatasnya tidak bisa jalan
        karena di comment out.
    */
    /ip route add gateway=100.100.100.100
    ;$komentar ="anda akan melihat tulisan berwarna orange/coklat yang berarti di remark,";
    ;
    $komentar.="dan command line tersebut tidak akan di execute oleh winbox, telnet, ssh"
    Kalau dalam html code memakai :

    :local R1
    <!--
    :local R2
    :if ([/tool netwatch get R1 status]=up) do={:set R1 192.168.0.254}
    -->
    :if ([/tool netwatch get R2 status]=up) do={:set R2 203.81.187.1}


    Kalau di dalam mikrotik ?
    Apakah saya harus menyalahkan syntax-nya, contoh :
    Code:
    /ip firewall address-list export
    /interface print ini commandline pasti salah dan gak boleh jalan sama sekali
    /ip route add gateway=123.123.123.123

    Apakah ada editor khusus untuk mikrotik seperti layaknya php dengan dreamweaver, asp dengan frontpage ?

  2. #2
    Status
    Offline
    cw-12's Avatar
    Member Senior
    Join Date
    Jan 2010
    Posts
    391
    Reviews
    Read 0 Reviews
    Downloads
    5
    Uploads
    2
    Feedback Score
    0
    coba liat kitab sakti ini dulu gan.Click here to enlargeClick here to enlarge

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. script error
    By mohamed in forum Scripting @ Mikrotik
    Replies: 2
    Last Post: 30-12-2009, 18:17
  2. script vpn..
    By kopral in forum Scripting @ Mikrotik
    Replies: 1
    Last Post: 09-12-2009, 17:21
  3. need help in script i have
    By salama900 in forum Scripting @ Mikrotik
    Replies: 1
    Last Post: 23-05-2009, 01:35
  4. script di ROS 3.19 dan 2.9.50
    By awarmanf in forum Scripting @ Mikrotik
    Replies: 0
    Last Post: 20-04-2009, 14:54
  5. Script On/OFF Ip
    By servas in forum Scripting @ Mikrotik
    Replies: 9
    Last Post: 04-05-2008, 11:33

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •