Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 3 of 3
  1. #1
    Status
    Offline
    miaowmiaow's Avatar
    Baru Gabung
    Join Date
    Nov 2007
    Posts
    7
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    tanya scrip untuk setting limit simple que sekaligus

    kondisi :
    memakai RB750 ROS 4.9
    menggunakan simple que untuk melimit penggunaan bandwidth IIX & INTL
    keadaan yg ada sekarang ini sbb :

    1 name="01-iix" target-addresses=192.168.0.1/32 packet-marks=indo max-limit=256k/256k

    2 name="01-int" target-addresses=192.168.0.1/32 packet-marks=luar max-limit=256k/512k

    3 ....(dst dst)
    pertanyaan :
    sy udah coba bikin script jadi sewaktu2 mau ubah MAX LIMIT koneksi indo maupun luar jadi gampang

    script nya seperti ini

    :for i from=1 to=40 do= {/queue simple set numbers=($i) max-limit=128000/128000}
    jadi pengennya setelah dijalankan semua client (40 unit) koneksinya langsung terlimit di 128k/128k

    dan setelah sy coba jalankan di terminal hasilnya adalah "interrupted, no such item"

    kira2 dimana yg salah ya ? dan bagaimana script yg bener ?

    kalo feeling sy sih letaknya ada di bagian yg saya bold, yaitu numbers mintanya nilai Numerik sedangkan $i memuntahkan nilai Text (kalo salah istilahnya mohon maap yaa Click here to enlarge)

    trims suhu² mikriting Click here to enlarge

  2. #2
    Status
    Offline
    ucok_karnadi's Avatar
    ..:: Masih Bodoh ::..
    Join Date
    Jan 2009
    Location
    PATI - JAWA TENGAH
    Posts
    1,178
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    hanya sekedar contoh
    Code:
    {
    :local strPC
    :set strPC "Client"
    :local interfacenya
    :set interfacenya "ether1"
    :local ipnya
    :set ipnya "192.168.1."
    :local iprouternya
    :set iprouternya 1
    :local limitnya
    :set limitnya "48000/128000"
    :local maxlimitnya
    :set maxlimitnya "64000/256000"
    :local burstlimit
    :set burstlimit "96000/512000"
    :local timer
    :set timer "10/10"
    :local startipnya
    :set startipnya 1
    :local endipnya
    :set endipnya 3
    :for i from=$startipnya to=$endipnya do={
    :if ($i < 10) do={ :set strPC "Client00" } else={ :if ($i < 100) do={ :set strPC "Client0" } else={:set strPC "Client" } }
    /queue simple add target-addresses=($ipnya . $i) limit-at=$limitnya max-limit=$maxlimitnya interface=$interfacenya burst-threshold=$maxlimitnya burst-limit=$burstlimit burst-time=$timer name=($strPC . $i)}
    /queue simple remove [/queue simple find target-addresses=($ipnya . $iprouternya . "/32")]
    }
    semangat slalu tuk belajar ya bro
    ___________________________________________


  3. #3
    Status
    Offline
    gamebender's Avatar
    Baru Gabung
    Join Date
    Aug 2010
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mikrotik 4 ke atas memang kadang gak jalan kalo scriptnya nembak ke "number"
    coba script ini

    :loc x "192.168.0."; :loc y
    :for z from=1 to=40 do={:set y [queue simple find target-addresses="$x$z/32"]
    :if ([:len $y] > 0) do={queue simple set $y max-limit=512000/512000}}

    cuman script ini rada berat kalo queuenya banyak

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mohon bantu cara setting 2 ISP sekaligus
    By tenlee in forum General Networking
    Replies: 6
    Last Post: 31-05-2010, 22:08
  2. Tanya setting BANWITH LIMIT yang pas...
    By B3MB3NG in forum Beginner Basics
    Replies: 11
    Last Post: 25-09-2009, 11:45
  3. Ask : Limit bandwidth pada client sekaligus gunain nice.rc
    By w1z4rd in forum General Networking
    Replies: 0
    Last Post: 24-03-2009, 22:27
  4. setting limit simple queue speedy statis
    By ciupax in forum Beginner Basics
    Replies: 16
    Last Post: 31-01-2008, 21:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •