Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 2 12 LastLast
Results 1 to 15 of 26
  1. #1
    Status
    Offline
    ahmad210993's Avatar
    Member Senior
    Join Date
    Jun 2009
    Location
    Semarang - www.dyasrtrw.net
    Posts
    435
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Berbagai script Dynamic DNS untuk Mikrotik

    langsung saja..
    mungkin para suhu sudah mengetahuinya, namun saya mencoba berbagi ilmu yang saya ketahui, meskipun beberapa sudah pernah di post sebelumnya.
    __________________________________________________ _____________


    para suhu pasti pernah kan memakai DNS gratisan spt changeip.com ataupun affraid.org?
    kalo kita dapat ip static tak masalah, tak perlu update ip DNS tsb. Click here to enlargeClick here to enlarge
    tapi bagaimana jika ip kita dinamis spt ADSL speedy? Click here to enlarge

    tak perlu bingung untuk update otomatis,
    disini ada berbagai contoh script yang bisa digunakan untuk update DNS secara otomatis untuk DDNS changeip.com dan freedns.affraid.org. Click here to enlarge

    untuk changeip.com
    Code:
    # oct/05/2009 21:28:27 by RouterOS 4.0rc1
    /system script
    
    add name=HomingBeacon-Simple policy=\
        ftp,reboot,read,write,policy,test,winbox,password source="# Dynamic DNS Up\
        date / Simple Edition\r\
        \n# Written by Sam Norris, ChangeIP.com\r\
        \n# Copyright ChangeIP.com 2009\r\
        \n# For support send mail to Support@ChangeIP.com\r\
        \n#\r\
        \n# 2009-06-22 RouterOS 3.25 Tested\r\
        \n# 2009-10-05 RouterOS 4.01rc1 Tested\r\
        \n#\r\
        \n# OVERVIEW:         %\r\
        \n#  This script will update a ChangeIP.com dynamic dns hostname\r\
        \n#  with an ip address located directly on an interface.\r\
        \n#                   %\r\
        \n# NOTES:            %\r\
        \n#  IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT\r\
        \n#  AGAIN.  THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you\r\
        \n#  have created this script and tested that it works by running it\r\
        \n#  manually you can schedule it to run every few minutes.\r\
        \n#                   %\r\
        \n# CONFIGURATION FIELD DEFINITIONS:\r\
        \n#  ddnsuser:  Enter your ChangeIP.com user id.\r\
        \n#  ddnspass:  Enter your ChangeIP.com password.\r\
        \n#  ddnshost:  Enter the hostname (www.example.com) to update.\r\
        \n#  ddnsinterface:  Enter a list of interface names - case sensative.\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#               %   %   %\r\
        \n#                %  %  %\r\
        \n#                 % % %\r\
        \n#                   %\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# EDIT YOUR DETAILS / CONFIGURATION HERE\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n:global ddnsuser \"YourChangeIPUserID\"\r\
        \n:global ddnspass \"PASSWORD\"\r\
        \n:global ddnshost \"MyRouterHostname.example.org\"\r\
        \n:global ddnsinterface \"ether1\"\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# END OF USER DEFINED CONFIGURATION\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n\r\
        \n:global ddnssystem (\"mt-\" . [/system package get [/system package find\
        \_name=system] version] )\r\
        \n:global ddnsip [ /ip address get [/ip address find interface=\$ddnsinter\
        face] address ]\r\
        \n:global ddnslastip\r\
        \n\r\
        \n:if ([:len [/interface find name=\$ddnsinterface]] = 0 ) do={ :log info \
        \"DDNS: No interface named \$ddnsinterface, please check configuration.\" \
        }\r\
        \n\r\
        \n:if ([ :typeof \$ddnslastip ] = \"nothing\" ) do={ :global ddnslastip 0.\
        0.0.0/0 }\r\
        \n\r\
        \n:if ([ :typeof \$ddnsip ] = \"nothing\" ) do={\r\
        \n\r\
        \n:log info (\"DDNS: No ip address present on \" . \$ddnsinterface . \", p\
        lease check.\")\r\
        \n\r\
        \n} else={\r\
        \n\r\
        \n  :if (\$ddnsip != \$ddnslastip) do={\r\
        \n\r\
        \n    :log info \"DDNS: Sending UPDATE!\"\r\
        \n    :log info [ :put [/tool dns-update name=\$ddnshost address=[:pick \$\
        ddnsip 0 [:find \$ddnsip \"/\"] ] key-name=\$ddnsuser key=\$ddnspass ] ]\r\
        \n    :global ddnslastip \$ddnsip\r\
        \n\r\
        \n  } else={ \r\
        \n\r\
        \n    :log info \"DDNS: No changes necessary.\"\r\
        \n\r\
        \n  }\r\
        \n\r\
        \n}"
    
    /system scheduler
    add comment="" disabled=no interval=5m name=DDNS on-event=\
        HomingBeacon-Simple policy=read,write,policy,test,password start-time=\
        startup
    Co-Pas kan pada terminal, Enter.
    jangan lupa edit user id, password, domain, dan interface nya!! Click here to enlarge

    untuk affraid.org,
    ada beberapa tahap yang harus kita lalui.
    pertama, log-in dulu pada Control Panel freedns.affraid.org.
    setelah login, klik Dynamic DNS pada sisi kiri.

    muncul tampilan domain kita, kemudian pilih pada domain yg akan kita update secara otomatis, klik kanan pada Direct URL, klik Copy Link.

    Buka notepad, paste kan link tersebut disana.

    lalu buka lagi notepad, paste kan script berikut
    Code:
    # Update DNS on Freedns.afraid.org
       :global host "freedns.afraid.org"
       :global url "urlddns"
       
       /tool fetch url=$url host=$host
    buka kembali notepad yg berisi link tadi, blok semua dan tekan Ctrl + C.
    masukkan / paste kan link tadi ke script pada bagian yang di Bold.
    contoh yang sudah jadi:
    Code:
    # Update DNS on Freedns.afraid.org
       :global host "freedns.afraid.org"
       :global url "http://freedns.afraid.org/dynamic/update.php?VEdmU24wTVRTTUlBQUs5NHdUczo0ODQxOTgx"
       
       /tool fetch url=$url host=$host
    copy script tsb, kemudian buka winbox, klik menu system => script. add [+]
    beri nama ddns, kemudian paste kan script tadi pada kolom Source.

    Klik OK. kemudian coba jalan script tsb dengan meng-klik Run Script.

    jika pada log muncul pemberitahuan spt pada gambar, berarti script tsb sudah berjalan dg baik, coba jalankan ping ke alamat DNS anda, jika ip yang keluar adalah ip publik anda, anda telah sukses menjalankan script ini.. Click here to enlargeClick here to enlarge

    sudah selesaikah? belum.. kita harus membuat agar script berikut bisa berjalan otomatis. caranya, buka winbox, klik menu System => Scheduler
    klik add [+]
    isikan ddns pada name dan On Event. centang semua policy, Start time pilih startup. Ok.

    selesai.. Click here to enlargeClick here to enlarge

    untuk Every DNS
    dengan cara yang hampir sama dengan yang lain. buat script dengan isi sebagai berikut
    Code:
    # Define user variables
    # Please NOTE that your username and password will be sent cleartext across the internet!
    :local eduser "USERNAME"
    :local edpass "PASS"
    :local eddomain "mydomain.com" 
    :local edinterface "INTERFACE_NAME"
    
    # Change this global variable if you want more than 1 script
    :global edlastip1
    :local str
    :local edip
    :local ip
    
    :if ([ :typeof $edlastip1 ] = nil ) do={ :global edlastip1 "0" }
    
    :local edip [ /ip address get [/ip address find interface=$edinterface ] address ]
    
    :if ([ :typeof $edip ] = nil ) do={
       :log info ("EveryDNS: No ip address on $edinterface .")
    } else={
    
    # strip off netmask correctly (MRz)
       :for i from=( [:len $edip] - 1) to=0 do={ 
          :if ( [:pick $edip $i] = "/") do={ 
    	   :set edip [:pick $edip 0 $i];
          } 
       }
    
      :if ($edip != $edlastip1) do={
    
        :log info ("EveryDNS: $eddomain -> $edip")
    # use url directly and mode http (MRz)
        :local str "/index.php?ver=0.1&ip=$edip&domain=$eddomain"
        /tool fetch url="http://dyn.everydns.net/$str" mode=http user=$eduser password=$edpass \
           dst-path=("/EveryDNS.".$eddomain)
        :delay 1 
    
    # output any error messages received from file
        :local str [/file find name="EveryDNS.$eddomain"];
        :log info [/file get $str contents];
        /file remove $str
        :global edlastip1 $edip
    
      } 
    
    }
    kemudian, Co-Pas script berikut pada Terminal.
    Code:
    system scheduler add name=EveryDNS1 interval=00:01 \
      on-event="/system script run everyDns1\r\n/system script run everyDns2"

  2. The Following 12 Users Say Thank You to ahmad210993 For This Useful Post:

    + Show/Hide list of the thanked


  3. #2
    Status
    Offline
    tyang_dusun's Avatar
    Member Super Senior
    Join Date
    Jun 2008
    Location
    Klaten, Jawa Tengah, Indonesia, Indonesia
    Posts
    518
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Ijin Pertamax incip-incip Gan ..... Click here to enlarge

  4. #3
    Status
    Offline
    oscark007's Avatar
    Member
    Join Date
    Jul 2010
    Posts
    116
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    wah..
    ijin simpen ya..

    aku sudah pakai DynDNS ..

  5. #4
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,247
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ijin nyoba ....

    tx for share Click here to enlarge

  6. #5
    Status
    Offline
    kans's Avatar
    Baru Gabung
    Join Date
    Mar 2011
    Posts
    6
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge ijin nyicip gan

  7. #6
    Status
    Offline
    manakautau's Avatar
    Member
    Join Date
    Aug 2010
    Location
    Pedalaman Hutan Kalimantan tengah
    Posts
    175
    Reviews
    Read 0 Reviews
    Downloads
    7
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ahmad210993 Click here to enlarge
    langsung saja..
    mungkin para suhu sudah mengetahuinya, namun saya mencoba berbagi ilmu yang saya ketahui, meskipun beberapa sudah pernah di post sebelumnya.
    __________________________________________________ _____________


    para suhu pasti pernah kan memakai DNS gratisan spt changeip.com ataupun affraid.org?
    kalo kita dapat ip static tak masalah, tak perlu update ip DNS tsb. Click here to enlargeClick here to enlarge
    tapi bagaimana jika ip kita dinamis spt ADSL speedy? Click here to enlarge

    tak perlu bingung untuk update otomatis,
    disini ada berbagai contoh script yang bisa digunakan untuk update DNS secara otomatis untuk DDNS changeip.com dan freedns.affraid.org. Click here to enlarge

    untuk changeip.com
    Code:
    # oct/05/2009 21:28:27 by RouterOS 4.0rc1
    /system script
    
    add name=HomingBeacon-Simple policy=\
        ftp,reboot,read,write,policy,test,winbox,password source="# Dynamic DNS Up\
        date / Simple Edition\r\
        \n# Written by Sam Norris, ChangeIP.com\r\
        \n# Copyright ChangeIP.com 2009\r\
        \n# For support send mail to Support@ChangeIP.com\r\
        \n#\r\
        \n# 2009-06-22 RouterOS 3.25 Tested\r\
        \n# 2009-10-05 RouterOS 4.01rc1 Tested\r\
        \n#\r\
        \n# OVERVIEW:         %\r\
        \n#  This script will update a ChangeIP.com dynamic dns hostname\r\
        \n#  with an ip address located directly on an interface.\r\
        \n#                   %\r\
        \n# NOTES:            %\r\
        \n#  IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT\r\
        \n#  AGAIN.  THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you\r\
        \n#  have created this script and tested that it works by running it\r\
        \n#  manually you can schedule it to run every few minutes.\r\
        \n#                   %\r\
        \n# CONFIGURATION FIELD DEFINITIONS:\r\
        \n#  ddnsuser:  Enter your ChangeIP.com user id.\r\
        \n#  ddnspass:  Enter your ChangeIP.com password.\r\
        \n#  ddnshost:  Enter the hostname (www.example.com) to update.\r\
        \n#  ddnsinterface:  Enter a list of interface names - case sensative.\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#               %   %   %\r\
        \n#                %  %  %\r\
        \n#                 % % %\r\
        \n#                   %\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# EDIT YOUR DETAILS / CONFIGURATION HERE\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n:global ddnsuser \"YourChangeIPUserID\"\r\
        \n:global ddnspass \"PASSWORD\"\r\
        \n:global ddnshost \"MyRouterHostname.example.org\"\r\
        \n:global ddnsinterface \"ether1\"\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# END OF USER DEFINED CONFIGURATION\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n\r\
        \n:global ddnssystem (\"mt-\" . [/system package get [/system package find\
        \_name=system] version] )\r\
        \n:global ddnsip [ /ip address get [/ip address find interface=\$ddnsinter\
        face] address ]\r\
        \n:global ddnslastip\r\
        \n\r\
        \n:if ([:len [/interface find name=\$ddnsinterface]] = 0 ) do={ :log info \
        \"DDNS: No interface named \$ddnsinterface, please check configuration.\" \
        }\r\
        \n\r\
        \n:if ([ :typeof \$ddnslastip ] = \"nothing\" ) do={ :global ddnslastip 0.\
        0.0.0/0 }\r\
        \n\r\
        \n:if ([ :typeof \$ddnsip ] = \"nothing\" ) do={\r\
        \n\r\
        \n:log info (\"DDNS: No ip address present on \" . \$ddnsinterface . \", p\
        lease check.\")\r\
        \n\r\
        \n} else={\r\
        \n\r\
        \n  :if (\$ddnsip != \$ddnslastip) do={\r\
        \n\r\
        \n    :log info \"DDNS: Sending UPDATE!\"\r\
        \n    :log info [ :put [/tool dns-update name=\$ddnshost address=[:pick \$\
        ddnsip 0 [:find \$ddnsip \"/\"] ] key-name=\$ddnsuser key=\$ddnspass ] ]\r\
        \n    :global ddnslastip \$ddnsip\r\
        \n\r\
        \n  } else={ \r\
        \n\r\
        \n    :log info \"DDNS: No changes necessary.\"\r\
        \n\r\
        \n  }\r\
        \n\r\
        \n}"
    
    /system scheduler
    add comment="" disabled=no interval=5m name=DDNS on-event=\
        HomingBeacon-Simple policy=read,write,policy,test,password start-time=\
        startup
    Co-Pas kan pada terminal, Enter.
    jangan lupa edit user id, password, domain, dan interface nya!! Click here to enlarge

    untuk affraid.org,
    ada beberapa tahap yang harus kita lalui.
    pertama, log-in dulu pada Control Panel freedns.affraid.org.
    setelah login, klik Dynamic DNS pada sisi kiri.

    muncul tampilan domain kita, kemudian pilih pada domain yg akan kita update secara otomatis, klik kanan pada Direct URL, klik Copy Link.

    Buka notepad, paste kan link tersebut disana.

    lalu buka lagi notepad, paste kan script berikut
    Code:
    # Update DNS on Freedns.afraid.org
       :global host "freedns.afraid.org"
       :global url "urlddns"
       
       /tool fetch url=$url host=$host
    buka kembali notepad yg berisi link tadi, blok semua dan tekan Ctrl + C.
    masukkan / paste kan link tadi ke script pada bagian yang di Bold.
    contoh yang sudah jadi:
    Code:
    # Update DNS on Freedns.afraid.org
       :global host "freedns.afraid.org"
       :global url "http://freedns.afraid.org/dynamic/update.php?VEdmU24wTVRTTUlBQUs5NHdUczo0ODQxOTgx"
       
       /tool fetch url=$url host=$host
    copy script tsb, kemudian buka winbox, klik menu system => script. add [+]
    beri nama ddns, kemudian paste kan script tadi pada kolom Source.

    Klik OK. kemudian coba jalan script tsb dengan meng-klik Run Script.

    jika pada log muncul pemberitahuan spt pada gambar, berarti script tsb sudah berjalan dg baik, coba jalankan ping ke alamat DNS anda, jika ip yang keluar adalah ip publik anda, anda telah sukses menjalankan script ini.. Click here to enlargeClick here to enlarge

    sudah selesaikah? belum.. kita harus membuat agar script berikut bisa berjalan otomatis. caranya, buka winbox, klik menu System => Scheduler
    klik add [+]
    isikan ddns pada name dan On Event. centang semua policy, Start time pilih startup. Ok.

    selesai.. Click here to enlargeClick here to enlarge

    untuk Every DNS
    dengan cara yang hampir sama dengan yang lain. buat script dengan isi sebagai berikut
    Code:
    # Define user variables
    # Please NOTE that your username and password will be sent cleartext across the internet!
    :local eduser "USERNAME"
    :local edpass "PASS"
    :local eddomain "mydomain.com" 
    :local edinterface "INTERFACE_NAME"
    
    # Change this global variable if you want more than 1 script
    :global edlastip1
    :local str
    :local edip
    :local ip
    
    :if ([ :typeof $edlastip1 ] = nil ) do={ :global edlastip1 "0" }
    
    :local edip [ /ip address get [/ip address find interface=$edinterface ] address ]
    
    :if ([ :typeof $edip ] = nil ) do={
       :log info ("EveryDNS: No ip address on $edinterface .")
    } else={
    
    # strip off netmask correctly (MRz)
       :for i from=( [:len $edip] - 1) to=0 do={ 
          :if ( [:pick $edip $i] = "/") do={ 
    	   :set edip [:pick $edip 0 $i];
          } 
       }
    
      :if ($edip != $edlastip1) do={
    
        :log info ("EveryDNS: $eddomain -> $edip")
    # use url directly and mode http (MRz)
        :local str "/index.php?ver=0.1&ip=$edip&domain=$eddomain"
        /tool fetch url="http://dyn.everydns.net/$str" mode=http user=$eduser password=$edpass \
           dst-path=("/EveryDNS.".$eddomain)
        :delay 1 
    
    # output any error messages received from file
        :local str [/file find name="EveryDNS.$eddomain"];
        :log info [/file get $str contents];
        /file remove $str
        :global edlastip1 $edip
    
      } 
    
    }
    kemudian, Co-Pas script berikut pada Terminal.
    Code:
    system scheduler add name=EveryDNS1 interval=00:01 \
      on-event="/system script run everyDns1\r\n/system script run everyDns2"
    kalau pake Change IP ini, yang dimasukkan apakah domain hostnya??
    contoh xxxx.changeip.net ataukah www,xxxx.changeip.net
    dan ini apakah free atau berbayar brooo??

  8. #7
    Status
    Offline
    mustikanet's Avatar
    Member Senior
    Join Date
    Oct 2010
    Location
    http://mustikanet.com
    Posts
    430
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ahmad210993 Click here to enlarge
    langsung saja..
    mungkin para suhu sudah mengetahuinya, namun saya mencoba berbagi ilmu yang saya ketahui, meskipun beberapa sudah pernah di post sebelumnya.
    __________________________________________________ _____________


    para suhu pasti pernah kan memakai DNS gratisan spt changeip.com ataupun affraid.org?
    kalo kita dapat ip static tak masalah, tak perlu update ip DNS tsb. Click here to enlargeClick here to enlarge
    tapi bagaimana jika ip kita dinamis spt ADSL speedy? Click here to enlarge

    tak perlu bingung untuk update otomatis,
    disini ada berbagai contoh script yang bisa digunakan untuk update DNS secara otomatis untuk DDNS changeip.com dan freedns.affraid.org. Click here to enlarge

    untuk changeip.com
    Code:
    # oct/05/2009 21:28:27 by RouterOS 4.0rc1
    /system script
    
    add name=HomingBeacon-Simple policy=\
        ftp,reboot,read,write,policy,test,winbox,password source="# Dynamic DNS Up\
        date / Simple Edition\r\
        \n# Written by Sam Norris, ChangeIP.com\r\
        \n# Copyright ChangeIP.com 2009\r\
        \n# For support send mail to Support@ChangeIP.com\r\
        \n#\r\
        \n# 2009-06-22 RouterOS 3.25 Tested\r\
        \n# 2009-10-05 RouterOS 4.01rc1 Tested\r\
        \n#\r\
        \n# OVERVIEW:         %\r\
        \n#  This script will update a ChangeIP.com dynamic dns hostname\r\
        \n#  with an ip address located directly on an interface.\r\
        \n#                   %\r\
        \n# NOTES:            %\r\
        \n#  IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT\r\
        \n#  AGAIN.  THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you\r\
        \n#  have created this script and tested that it works by running it\r\
        \n#  manually you can schedule it to run every few minutes.\r\
        \n#                   %\r\
        \n# CONFIGURATION FIELD DEFINITIONS:\r\
        \n#  ddnsuser:  Enter your ChangeIP.com user id.\r\
        \n#  ddnspass:  Enter your ChangeIP.com password.\r\
        \n#  ddnshost:  Enter the hostname (www.example.com) to update.\r\
        \n#  ddnsinterface:  Enter a list of interface names - case sensative.\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#               %   %   %\r\
        \n#                %  %  %\r\
        \n#                 % % %\r\
        \n#                   %\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# EDIT YOUR DETAILS / CONFIGURATION HERE\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n:global ddnsuser \"YourChangeIPUserID\"\r\
        \n:global ddnspass \"PASSWORD\"\r\
        \n:global ddnshost \"MyRouterHostname.example.org\"\r\
        \n:global ddnsinterface \"ether1\"\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# END OF USER DEFINED CONFIGURATION\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n\r\
        \n:global ddnssystem (\"mt-\" . [/system package get [/system package find\
        \_name=system] version] )\r\
        \n:global ddnsip [ /ip address get [/ip address find interface=\$ddnsinter\
        face] address ]\r\
        \n:global ddnslastip\r\
        \n\r\
        \n:if ([:len [/interface find name=\$ddnsinterface]] = 0 ) do={ :log info \
        \"DDNS: No interface named \$ddnsinterface, please check configuration.\" \
        }\r\
        \n\r\
        \n:if ([ :typeof \$ddnslastip ] = \"nothing\" ) do={ :global ddnslastip 0.\
        0.0.0/0 }\r\
        \n\r\
        \n:if ([ :typeof \$ddnsip ] = \"nothing\" ) do={\r\
        \n\r\
        \n:log info (\"DDNS: No ip address present on \" . \$ddnsinterface . \", p\
        lease check.\")\r\
        \n\r\
        \n} else={\r\
        \n\r\
        \n  :if (\$ddnsip != \$ddnslastip) do={\r\
        \n\r\
        \n    :log info \"DDNS: Sending UPDATE!\"\r\
        \n    :log info [ :put [/tool dns-update name=\$ddnshost address=[:pick \$\
        ddnsip 0 [:find \$ddnsip \"/\"] ] key-name=\$ddnsuser key=\$ddnspass ] ]\r\
        \n    :global ddnslastip \$ddnsip\r\
        \n\r\
        \n  } else={ \r\
        \n\r\
        \n    :log info \"DDNS: No changes necessary.\"\r\
        \n\r\
        \n  }\r\
        \n\r\
        \n}"
    
    /system scheduler
    add comment="" disabled=no interval=5m name=DDNS on-event=\
        HomingBeacon-Simple policy=read,write,policy,test,password start-time=\
        startup
    Co-Pas kan pada terminal, Enter.
    jangan lupa edit user id, password, domain, dan interface nya!! Click here to enlarge
    yang perlu di edit mana bos mohon petunjuknya maklum baru belajar..

  9. #8
    Status
    Offline
    aanset's Avatar
    Baru Gabung
    Join Date
    Oct 2012
    Location
    depok, id
    Posts
    2
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    terima kasih suhu Click here to enlarge
    ini yang dicari

  10. #9
    Status
    Offline
    sujiex's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    56
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mas gimana caranya agar tidak kedrop firewall

  11. #10
    codeck
    codeck's Avatar
    nah ini ya mungkin paling pas untuk mengatasi IP dinamis Speedol, matur thankyu Master ahmad210993

    tapi kira2 jalan ga di routerOS ver 6.orc7 ?
    Last edited by codeck; 12-02-2013 at 09:47.

  12. #11
    Status
    Offline
    Fikanet's Avatar
    Newbie
    Join Date
    Apr 2011
    Location
    Curup-Bengkulu-Indonesia
    Posts
    64
    Reviews
    Read 0 Reviews
    Downloads
    5
    Uploads
    1
    Feedback Score
    0
    tak perlu bingung untuk update otomatis,
    disini ada berbagai contoh script yang bisa digunakan untuk update DNS secara otomatis untuk DDNS changeip.com dan freedns.affraid.org. Click here to enlarge

    untuk changeip.com
    Code:
    # oct/05/2009 21:28:27 by RouterOS 4.0rc1
    /system script
    
    add name=HomingBeacon-Simple policy=\
        ftp,reboot,read,write,policy,test,winbox,password source="# Dynamic DNS Up\
        date / Simple Edition\r\
        \n# Written by Sam Norris, ChangeIP.com\r\
        \n# Copyright ChangeIP.com 2009\r\
        \n# For support send mail to Support@ChangeIP.com\r\
        \n#\r\
        \n# 2009-06-22 RouterOS 3.25 Tested\r\
        \n# 2009-10-05 RouterOS 4.01rc1 Tested\r\
        \n#\r\
        \n# OVERVIEW:         %\r\
        \n#  This script will update a ChangeIP.com dynamic dns hostname\r\
        \n#  with an ip address located directly on an interface.\r\
        \n#                   %\r\
        \n# NOTES:            %\r\
        \n#  IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT\r\
        \n#  AGAIN.  THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you\r\
        \n#  have created this script and tested that it works by running it\r\
        \n#  manually you can schedule it to run every few minutes.\r\
        \n#                   %\r\
        \n# CONFIGURATION FIELD DEFINITIONS:\r\
        \n#  ddnsuser:  Enter your ChangeIP.com user id.\r\
        \n#  ddnspass:  Enter your ChangeIP.com password.\r\
        \n#  ddnshost:  Enter the hostname (www.example.com) to update.\r\
        \n#  ddnsinterface:  Enter a list of interface names - case sensative.\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#               %   %   %\r\
        \n#                %  %  %\r\
        \n#                 % % %\r\
        \n#                   %\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# EDIT YOUR DETAILS / CONFIGURATION HERE\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n:global ddnsuser \"YourChangeIPUserID\"\r\
        \n:global ddnspass \"PASSWORD\"\r\
        \n:global ddnshost \"MyRouterHostname.example.org\"\r\
        \n:global ddnsinterface \"ether1\"\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# END OF USER DEFINED CONFIGURATION\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n\r\
        \n:global ddnssystem (\"mt-\" . [/system package get [/system package find\
        \_name=system] version] )\r\
        \n:global ddnsip [ /ip address get [/ip address find interface=\$ddnsinter\
        face] address ]\r\
        \n:global ddnslastip\r\
        \n\r\
        \n:if ([:len [/interface find name=\$ddnsinterface]] = 0 ) do={ :log info \
        \"DDNS: No interface named \$ddnsinterface, please check configuration.\" \
        }\r\
        \n\r\
        \n:if ([ :typeof \$ddnslastip ] = \"nothing\" ) do={ :global ddnslastip 0.\
        0.0.0/0 }\r\
        \n\r\
        \n:if ([ :typeof \$ddnsip ] = \"nothing\" ) do={\r\
        \n\r\
        \n:log info (\"DDNS: No ip address present on \" . \$ddnsinterface . \", p\
        lease check.\")\r\
        \n\r\
        \n} else={\r\
        \n\r\
        \n  :if (\$ddnsip != \$ddnslastip) do={\r\
        \n\r\
        \n    :log info \"DDNS: Sending UPDATE!\"\r\
        \n    :log info [ :put [/tool dns-update name=\$ddnshost address=[:pick \$\
        ddnsip 0 [:find \$ddnsip \"/\"] ] key-name=\$ddnsuser key=\$ddnspass ] ]\r\
        \n    :global ddnslastip \$ddnsip\r\
        \n\r\
        \n  } else={ \r\
        \n\r\
        \n    :log info \"DDNS: No changes necessary.\"\r\
        \n\r\
        \n  }\r\
        \n\r\
        \n}"
    
    /system scheduler
    add comment="" disabled=no interval=5m name=DDNS on-event=\
        HomingBeacon-Simple policy=read,write,policy,test,password start-time=\
        startup
    Co-Pas kan pada terminal, Enter.
    jangan lupa edit user id, password, domain, dan interface nya!! Click here to enlarge

    Click here to enlargeClick here to enlarge sebelumnya terimakasih om tutorialnya... review ane om.. udah di test di mikrotik di v.5 untuk script yg di atas n running sampe sekarang... g pusing lg klo mau remote dari luar jaringan....Click here to enlargeClick here to enlarge sekalian ane izin share yach om... Click here to enlargeClick here to enlarge

  13. #12
    Status
    Offline
    antoni3's Avatar
    Baru Gabung
    Join Date
    Mar 2013
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Master? kalau script buat dyndns or dlinkddns gmana ya ? apakah sama ?
    Saya mau set supaya cctv bisa diakses dari mana saja, pake ip dynamic soalnya dari speedy.
    Mohon bantuannya Master sekalian.. Urgent soalnya

    Thanks

  14. #13
    Status
    Offline
    mustikanet's Avatar
    Member Senior
    Join Date
    Oct 2010
    Location
    http://mustikanet.com
    Posts
    430
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ahmad210993 Click here to enlarge
    langsung saja..
    mungkin para suhu sudah mengetahuinya, namun saya mencoba berbagi ilmu yang saya ketahui, meskipun beberapa sudah pernah di post sebelumnya.
    __________________________________________________ _____________


    para suhu pasti pernah kan memakai DNS gratisan spt changeip.com ataupun affraid.org?
    kalo kita dapat ip static tak masalah, tak perlu update ip DNS tsb. Click here to enlargeClick here to enlarge
    tapi bagaimana jika ip kita dinamis spt ADSL speedy? Click here to enlarge

    tak perlu bingung untuk update otomatis,
    disini ada berbagai contoh script yang bisa digunakan untuk update DNS secara otomatis untuk DDNS changeip.com dan freedns.affraid.org. Click here to enlarge

    untuk changeip.com
    Code:
    # oct/05/2009 21:28:27 by RouterOS 4.0rc1
    /system script
    
    add name=HomingBeacon-Simple policy=\
        ftp,reboot,read,write,policy,test,winbox,password source="# Dynamic DNS Up\
        date / Simple Edition\r\
        \n# Written by Sam Norris, ChangeIP.com\r\
        \n# Copyright ChangeIP.com 2009\r\
        \n# For support send mail to Support@ChangeIP.com\r\
        \n#\r\
        \n# 2009-06-22 RouterOS 3.25 Tested\r\
        \n# 2009-10-05 RouterOS 4.01rc1 Tested\r\
        \n#\r\
        \n# OVERVIEW:         %\r\
        \n#  This script will update a ChangeIP.com dynamic dns hostname\r\
        \n#  with an ip address located directly on an interface.\r\
        \n#                   %\r\
        \n# NOTES:            %\r\
        \n#  IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT\r\
        \n#  AGAIN.  THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you\r\
        \n#  have created this script and tested that it works by running it\r\
        \n#  manually you can schedule it to run every few minutes.\r\
        \n#                   %\r\
        \n# CONFIGURATION FIELD DEFINITIONS:\r\
        \n#  ddnsuser:  Enter your ChangeIP.com user id.\r\
        \n#  ddnspass:  Enter your ChangeIP.com password.\r\
        \n#  ddnshost:  Enter the hostname (www.example.com) to update.\r\
        \n#  ddnsinterface:  Enter a list of interface names - case sensative.\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#                   %\r\
        \n#               %   %   %\r\
        \n#                %  %  %\r\
        \n#                 % % %\r\
        \n#                   %\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# EDIT YOUR DETAILS / CONFIGURATION HERE\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n:global ddnsuser \"YourChangeIPUserID\"\r\
        \n:global ddnspass \"PASSWORD\"\r\
        \n:global ddnshost \"MyRouterHostname.example.org\"\r\
        \n:global ddnsinterface \"ether1\"\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n# END OF USER DEFINED CONFIGURATION\r\
        \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
        \n\r\
        \n:global ddnssystem (\"mt-\" . [/system package get [/system package find\
        \_name=system] version] )\r\
        \n:global ddnsip [ /ip address get [/ip address find interface=\$ddnsinter\
        face] address ]\r\
        \n:global ddnslastip\r\
        \n\r\
        \n:if ([:len [/interface find name=\$ddnsinterface]] = 0 ) do={ :log info \
        \"DDNS: No interface named \$ddnsinterface, please check configuration.\" \
        }\r\
        \n\r\
        \n:if ([ :typeof \$ddnslastip ] = \"nothing\" ) do={ :global ddnslastip 0.\
        0.0.0/0 }\r\
        \n\r\
        \n:if ([ :typeof \$ddnsip ] = \"nothing\" ) do={\r\
        \n\r\
        \n:log info (\"DDNS: No ip address present on \" . \$ddnsinterface . \", p\
        lease check.\")\r\
        \n\r\
        \n} else={\r\
        \n\r\
        \n  :if (\$ddnsip != \$ddnslastip) do={\r\
        \n\r\
        \n    :log info \"DDNS: Sending UPDATE!\"\r\
        \n    :log info [ :put [/tool dns-update name=\$ddnshost address=[:pick \$\
        ddnsip 0 [:find \$ddnsip \"/\"] ] key-name=\$ddnsuser key=\$ddnspass ] ]\r\
        \n    :global ddnslastip \$ddnsip\r\
        \n\r\
        \n  } else={ \r\
        \n\r\
        \n    :log info \"DDNS: No changes necessary.\"\r\
        \n\r\
        \n  }\r\
        \n\r\
        \n}"
    
    /system scheduler
    add comment="" disabled=no interval=5m name=DDNS on-event=\
        HomingBeacon-Simple policy=read,write,policy,test,password start-time=\
        startup
    Co-Pas kan pada terminal, Enter.
    jangan lupa edit user id, password, domain, dan interface nya!! Click here to enlarge

    Mantep om is Work u ver 5.22 karena sapidy dah ramdom ip public paket yang 3mb
    jadi bisa remote mikrotik waluaupun si sapidy gonta ganti ip publicnya.
    Last edited by mustikanet; 24-04-2013 at 19:54.

  15. #14
    Status
    Offline
    wijaya_daniel's Avatar
    Baru Gabung
    Join Date
    Jul 2011
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    gan ane sudah coba untuk script ini dan menggunakan changeip, ane juga sudah bisa ping dari alamat changeip, dan untuk modem sudah ane buat ke nat vitual server dengan port 8291, tetapi waktu mau konek ke mikrotik menggunakan winbox, kenapa selalu error "could not fetch index from 111.111.111.111 (port 80): not found, tolong di bantu ya gan

  16. #15
    Status
    Offline
    karaeng's Avatar
    VIP Member
    Join Date
    Jun 2010
    Posts
    949
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by wijaya_daniel Click here to enlarge
    gan ane sudah coba untuk script ini dan menggunakan changeip, ane juga sudah bisa ping dari alamat changeip, dan untuk modem sudah ane buat ke nat vitual server dengan port 8291, tetapi waktu mau konek ke mikrotik menggunakan winbox, kenapa selalu error "could not fetch index from 111.111.111.111 (port 80): not found, tolong di bantu ya gan
    apa sudah di aktifin DDNSnya di modem yah... dan masukan data anda sesuai dengan data pada pendaftaran di changeip...

 

 
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. <ASK> Cara Ngakalin Mikrotik untuk Fastnet yg IP nya Dynamic
    By bdu4punk in forum General Networking
    Replies: 41
    Last Post: 18-03-2014, 00:33
  2. Ada yg tau cara buat Dynamic DNS di mikrotik
    By indrasakti in forum Beginner Basics
    Replies: 1
    Last Post: 20-07-2012, 14:31
  3. Replies: 7
    Last Post: 13-07-2011, 11:37
  4. [ask] script mikrotik untuk schedule dengan hari yang berbeda
    By bzard72 in forum Scripting @ Mikrotik
    Replies: 1
    Last Post: 16-05-2009, 11:35
  5. kk tolongin script mikrotik untuk BF2 Online donk ^_^
    By nisaqiyar in forum Beginner Basics
    Replies: 1
    Last Post: 09-09-2007, 08:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ads