Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 2 of 2 FirstFirst 12
Results 16 to 30 of 30
  1. #16
    Status
    Offline
    wijaya_daniel's Avatar
    Baru Gabung
    Join Date
    Jul 2011
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kalau di modem di aktifin ddns itu belum, apa bisa minta cara nya gan ? thanks

  2. #17
    Status
    Offline
    uckons's Avatar
    Baru Gabung
    Join Date
    Mar 2008
    Posts
    10
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    suhu, ada yang tahu kenapa script no-ip di v6.0rc14 ngga jalan ya, padahal pakai rc13 masih bisa jalan, berikut scriptnya:

    # No-IP automatic Dynamic DNS update

    #--------------- Change Values in this section to match your setup ------------------

    # No-IP User account info
    :local noipuser "your_no-ip_user"
    :local noippass "your_no-ip_pass"

    # Set the hostname or label of network to be updated.
    # Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
    # To specify multiple hosts, separate them with commas.
    :local noiphost "hostname.no-ip.net"

    # Change to the name of interface that gets the dynamic IP address
    :local inetinterface "your_external_interface"

    #------------------------------------------------------------------------------------
    # No more changes need

    :global previousIP

    :if ([/interface get $inetinterface value-name=running]) do={
    # Get the current IP on the interface
    :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

    # Strip the net mask off the IP address
    :for i from=( [:len $currentIP] - 1) to=0 do={
    :if ( [Click here to enlargeick $currentIP $i] = "/") do={
    :set currentIP [Click here to enlargeick $currentIP 0 $i]
    }
    }

    :if ($currentIP != $previousIP) do={
    :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
    :set previousIP $currentIP

    # The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
    :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
    :local noiphostarray
    :set noiphostarray [:toarray $noiphost]
    :foreach host in=$noiphostarray do={
    :log info "No-IP: Sending update for $host"
    /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
    :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
    }
    } else={
    :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
    }
    } else={
    :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
    }

  3. #18
    Status
    Offline
    bluephantom's Avatar
    Newbie
    Join Date
    Jun 2012
    Location
    Malang
    Posts
    22
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    nice post gan ijin cobak Click here to enlarge

  4. #19
    Status
    Offline
    akaseto's Avatar
    Baru Gabung
    Join Date
    Feb 2013
    Posts
    14
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Ijin berbagi ya om, ini script bisa di pake 3 server sekaligus

    Code:
    #************************************************************************************************
    # Parameters
    #************************************************************************************************
    :local username "user"
    :local password "pass"
    :local hostname "subdomain.provider.net"
    
    #availabe options: "http" or "iface"
    # - http: will query an external server and discover you public ip (userful for NATted connections)
    # - iface: will use the ip address assigned to the $iface interface (see below)
    
    :local discoverBy "ether1"
    
    # interface yang di pake buat dapet ip-pub (only if discoverBy = iface)
    
    :local iface "pppoe-out1"
    
    # Service yang tersedia: "dyndns", "noip" and "changeip"
    :local service "noip"
    
    # Berapa hari sekali mau update
    :local forceUpdate 15
    
    #************************************************************************************************
    # Jangan di ganti kalo ga tau apa-apa
    #************************************************************************************************
    
    :local force
    :global lastUpdate
    :local currentIP
    
    :if ($discoverBy="http") do={
       /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
       :local result [/file get dyndns.checkip.html contents]
       :local resultLen [:len $result]
       :local startLoc [:find $result ": " -1]
       :set startLoc ($startLoc + 2)
       :local endLoc [:find $result "</body>" -1]
       :set currentIP [:pick $result $startLoc $endLoc]
    } else={
       :set currentIP [ /ip[ address get [find interface=$iface disabled=no] address ]
       :for i from=( [:len $currentIP] - 1) to=0 do={
          :if ( [:pick $currentIP $i] = "/") do={ :set currentIP [:pick $currentIP 0 $i] }
       }
    }
    
    #get IP from DynDNS for our hostname
    :local resolvedIP [:resolve $hostname]
    
    # get current date in format mm/DD/YYYY
    :local date [ /system clock get date ]
    
    # convert to YYYYMMDD
    :local months ("jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec");
    :local month [ :pick $date 0 3 ]; :local day [ :pick $date 4 6 ]; :local year [ :pick $date 7 11 ];
    :local mm ([ :find $months $month -1 ] + 1);
    :if ($mm < 10) do={ :set month ("0" . $mm); } else={ :set month $mm; }
    :set date ($year . $month . $day);
    
    :if ([ :typeof $lastUpdate ]=[:nothing] || (($date-$lastUpdate) >= $forceUpdate  && $forceUpdate > 0)) do={
       :set force true
    }
    
    :put ("Current IP: $currentIP ($discoverBy), Last update: $lastUpdate")
    
    # Determine if dyndns update is needed
    :if (($currentIP != $resolvedIP) || ($force = true)) do={
       
        :if ($service = "dyndns") do={
           /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
                src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/output.txt"
        }
        :if ($service = "noip") do={
           /tool fetch user=$username password=$password mode=http address="dynupdate.no-ip.com" \
                src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/output.txt"
        }
        :if ($service = "changeip") do={
           /tool fetch user=$username password=$password mode=http address="nic.changeip.com" \
                src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/output.txt"
        }
       
        :local result [/file get output.txt contents]
        :log info ("dynamic-dns-updater: Service = $service, Hostname = $hostname")
        :log info ("dynamic-dns-updater: CurrentIP = $currentIP, Resolved IP = $resolvedIP")
        :log info ("dynamic-dns-updater: Update result: ".$result)
        /ip dns cache flush
        :set lastUpdate $date
    }
    NOTE :
    Settingan MODEM harus bridge, jadi semua diatur menggunakan router, lebih memudahkan untuk forwarding bagi yang ip public nya dynamis
    sesuaikan bagian yang tebal dengan milik anda
    FAQ : bisa di pakai lebih dari 1 server ddns ga gan? "bisa kok tapi, cuma support noip,changeip,sama dyndns {Sesuaikan dengan kebutuhan}
    :local username "user"
    :local password "pass"
    :local hostname "subdomain.provider."
    :local service "noip"
    :local service "dyndns"
    :local service "changeip"
    Last edited by akaseto; 02-10-2013 at 21:03.

  5. The Following User Says Thank You to akaseto For This Useful Post:


  6. #20
    Status
    Offline
    p1lk0's Avatar
    Baru Gabung
    Join Date
    Apr 2011
    Posts
    17
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    @ akaseto
    script yang diatas bisa jalan di ROS 6.4 gak?

  7. #21
    Status
    Offline
    akaseto's Avatar
    Baru Gabung
    Join Date
    Feb 2013
    Posts
    14
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by p1lk0 Click here to enlarge
    @ akaseto
    script yang diatas bisa jalan di ROS 6.4 gak?
    di coba aja, soalnya Router OS 6.4 banyak bug nya

  8. #22
    Status
    Offline
    p1lk0's Avatar
    Baru Gabung
    Join Date
    Apr 2011
    Posts
    17
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by akaseto Click here to enlarge
    di coba aja, soalnya Router OS 6.4 banyak bug nya
    sudah saya coba di ROS 6.4 tapi gak update ipnya,
    Agan pakai ROS berapa jalani script ini? trus provider pakai speedy gak?

  9. #23
    Status
    Offline
    akaseto's Avatar
    Baru Gabung
    Join Date
    Feb 2013
    Posts
    14
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by p1lk0 Click here to enlarge
    sudah saya coba di ROS 6.4 tapi gak update ipnya,
    Agan pakai ROS berapa jalani script ini? trus provider pakai speedy gak?
    emang pake brp server DDNS ? kalo ROS 6.4 bisanya pake 1 script buat 1 server, tapi kalo host name bisa banyak

  10. #24
    Status
    Offline
    p1lk0's Avatar
    Baru Gabung
    Join Date
    Apr 2011
    Posts
    17
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by akaseto Click here to enlarge
    emang pake brp server DDNS ? kalo ROS 6.4 bisanya pake 1 script buat 1 server, tapi kalo host name bisa banyak
    belum bisa jalan di ane gan.mohon bantuan klw script di bawah untuk NO-IP..
    dulu bisa jalan sekarang gak bisa lagi.
    Code:
    # DNS no-ip automatic DNS updates
    # Informasi account di no-ip.com
    :global usernoip "username"
    :global passnoip "pass"
    :global hostnamenoip "subdomain.provider.net"
    # Edit variabel selesai di sini
    
    :global previousIP
    
    # Print di log untuk debug
    :log info "DNSNoIP: Updating dynamic IP on DNS for host $hostnamenoip"
    :log info "DNSNoIP: Pass $passnoip"
    :log info "DNSNoIP: Last IP $previousIP"
    
    # mendapatkan IP public di intenet, bisa juga dengan script PHP jika punya hosting support PHP
    /tool fetch url="http://checkip.dyndns.org/" dst-path="/ddnsnoip.html"
    
    :local hasil [/file get ddnsnoip.html contents]
    
    # Edit untuk mendapatkan IP terbaru
    :local hasilLen [:len $hasil]
    :local startLoc [:find $hasil ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $hasil "</body>" -1]
    :global currentIP [:pick $hasil $startLoc $endLoc]
    :log info "DNSNoIP: IP sekarang $currentIP"
    
    # persiapan update
    :local str "/nic/update?hostname=$hostnamenoip&myip=$currentIP"
    
    :if ($currentIP != $previousIP) do={
    :log info "DNSNoIP: Dibutuhkan Update"
    :set previousIP $currentIP
    :log info "DNSNoIP: Kirim Update $currentIP"
    :log info [:put [/tool fetch user="$usernoip" password="$passnoip" url="http://dynupdate.no-ip.com/$str" dst-path="/$hostnamenoip"]]
    :log info "DNSNoIP: Host $hostnamenoip telah terupdate di DNSNoIP dengan IP $currentIP"
    }  else={
    :log info "DNSNoIP: IP sebelumnya $previousIP dan IP sekarang $currentIP sama, tidak dibutuhkan update"

  11. #25
    Status
    Offline
    ahmad210993's Avatar
    Member Senior
    Join Date
    Jun 2009
    Location
    Semarang - www.dyasrtrw.net
    Posts
    440
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    waaah.. banyak juga ya peminatnya..
    Mau update lagi ah....
    Untuk yang punya domain berbayar, (domainAnda.com, domainSaya.net, dll)..
    silahkan gunakan Free DNS dari HE.NET, dns.he.net
    arahkan NS ke ns server He.net..
    Selanjutnya, update ada langsung di halaman pertama. Click here to enlarge

  12. #26
    Status
    Offline
    agoesbali's Avatar
    Newbie
    Join Date
    Mar 2010
    Location
    Suroboyo
    Posts
    41
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    sebenernya bisa dibikin simple, jalankan aja scripts ini di system--Shceduler misalnya setiap 5 menit sekali, buat testing jajal di terminal aja dulu, jangan lupa daftar dulu (pake changeip.com) :P

    /tool dns-update name=namasaya.changeip.name address=192.168.0.8 key-name=usersaya key=passwordsaya ;

    ** ip 192.168.0.8 adalah ip interfacce lokal mikrotik.

    trus di check ;

    :~$ host namasaya.changeip.name 8.4.4.4
    Using domain server:
    Name: 8.4.4.4
    Address: 8.4.4.4#53
    Aliases:

    namasaya.changeip.name has address 36.74.187.65

    Salaman, Click here to enlarge
    Last edited by agoesbali; 13-10-2013 at 14:22. Reason: update

  13. #27
    Status
    Offline
    dna765mb's Avatar
    Baru Gabung
    Join Date
    Oct 2012
    Posts
    6
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by akaseto Click here to enlarge
    Ijin berbagi ya om, ini script bisa di pake 3 server sekaligus

    Code:
    #************************************************************************************************
    # Parameters
    #************************************************************************************************
    :local username "user"
    :local password "pass"
    :local hostname "subdomain.provider.net"
    
    #availabe options: "http" or "iface"
    # - http: will query an external server and discover you public ip (userful for NATted connections)
    # - iface: will use the ip address assigned to the $iface interface (see below)
    
    :local discoverBy "ether1"
    
    # interface yang di pake buat dapet ip-pub (only if discoverBy = iface)
    
    :local iface "pppoe-out1"
    
    # Service yang tersedia: "dyndns", "noip" and "changeip"
    :local service "noip"
    
    # Berapa hari sekali mau update
    :local forceUpdate 15
    
    #************************************************************************************************
    # Jangan di ganti kalo ga tau apa-apa
    #************************************************************************************************
    
    :local force
    :global lastUpdate
    :local currentIP
    
    :if ($discoverBy="http") do={
       /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
       :local result [/file get dyndns.checkip.html contents]
       :local resultLen [:len $result]
       :local startLoc [:find $result ": " -1]
       :set startLoc ($startLoc + 2)
       :local endLoc [:find $result "</body>" -1]
       :set currentIP [:pick $result $startLoc $endLoc]
    } else={
       :set currentIP [ /ip[ address get [find interface=$iface disabled=no] address ]
       :for i from=( [:len $currentIP] - 1) to=0 do={
          :if ( [:pick $currentIP $i] = "/") do={ :set currentIP [:pick $currentIP 0 $i] }
       }
    }
    
    #get IP from DynDNS for our hostname
    :local resolvedIP [:resolve $hostname]
    
    # get current date in format mm/DD/YYYY
    :local date [ /system clock get date ]
    
    # convert to YYYYMMDD
    :local months ("jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec");
    :local month [ :pick $date 0 3 ]; :local day [ :pick $date 4 6 ]; :local year [ :pick $date 7 11 ];
    :local mm ([ :find $months $month -1 ] + 1);
    :if ($mm < 10) do={ :set month ("0" . $mm); } else={ :set month $mm; }
    :set date ($year . $month . $day);
    
    :if ([ :typeof $lastUpdate ]=[:nothing] || (($date-$lastUpdate) >= $forceUpdate  && $forceUpdate > 0)) do={
       :set force true
    }
    
    :put ("Current IP: $currentIP ($discoverBy), Last update: $lastUpdate")
    
    # Determine if dyndns update is needed
    :if (($currentIP != $resolvedIP) || ($force = true)) do={
       
        :if ($service = "dyndns") do={
           /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
                src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/output.txt"
        }
        :if ($service = "noip") do={
           /tool fetch user=$username password=$password mode=http address="dynupdate.no-ip.com" \
                src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/output.txt"
        }
        :if ($service = "changeip") do={
           /tool fetch user=$username password=$password mode=http address="nic.changeip.com" \
                src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/output.txt"
        }
       
        :local result [/file get output.txt contents]
        :log info ("dynamic-dns-updater: Service = $service, Hostname = $hostname")
        :log info ("dynamic-dns-updater: CurrentIP = $currentIP, Resolved IP = $resolvedIP")
        :log info ("dynamic-dns-updater: Update result: ".$result)
        /ip dns cache flush
        :set lastUpdate $date
    }
    NOTE :
    Settingan MODEM harus bridge, jadi semua diatur menggunakan router, lebih memudahkan untuk forwarding bagi yang ip public nya dynamis

    FAQ : bisa di pakai lebih dari 1 server ddns ga gan? "bisa kok tapi, cuma support noip,changeip,sama dyndns {Sesuaikan dengan kebutuhan}
    berhasil gan......
     
    Click here to enlarge
    Last edited by dna765mb; 23-09-2014 at 21:21.

  14. #28
    Status
    Offline
    kita's Avatar
    Baru Gabung
    Join Date
    Feb 2015
    Location
    bali
    Posts
    1
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    gan gan.. punya saya kok gak bisa buka ya lewat web....muter loading terus. padahal di changeip uda ke detek..
    saya make ROS 5.26 RB750, ..

  15. #29
    Status
    Offline
    blanksix's Avatar
    Baru Gabung
    Join Date
    Jan 2016
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    naro jejak dulu mas Click here to enlarge

  16. #30
    Status
    Offline
    adiewcen's Avatar
    Baru Gabung
    Join Date
    Feb 2016
    Location
    Sumedang, Jawa Barat
    Posts
    7
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by karaeng Click here to enlarge
    apa sudah di aktifin DDNSnya di modem yah... dan masukan data anda sesuai dengan data pada pendaftaran di changeip...
    Nah gan, kalo modemnya udh support DDNS [maksudnya udh ada fitur untuk settingannya], apa msh perlu juga menerapkan script seperti ini?

 

 
Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. <ASK> Cara Ngakalin Mikrotik untuk Fastnet yg IP nya Dynamic
    By bdu4punk in forum General Networking
    Replies: 42
    Last Post: 25-03-2015, 19:39
  2. Ada yg tau cara buat Dynamic DNS di mikrotik
    By indrasakti in forum Beginner Basics
    Replies: 1
    Last Post: 20-07-2012, 14:31
  3. Replies: 7
    Last Post: 13-07-2011, 11:37
  4. [ask] script mikrotik untuk schedule dengan hari yang berbeda
    By bzard72 in forum Scripting @ Mikrotik
    Replies: 1
    Last Post: 16-05-2009, 11:35
  5. kk tolongin script mikrotik untuk BF2 Online donk ^_^
    By nisaqiyar in forum Beginner Basics
    Replies: 1
    Last Post: 09-09-2007, 08:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •