Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 12 of 12
  1. #1
    Status
    Offline
    psycronicx's Avatar
    Newbie
    Join Date
    Mar 2008
    Posts
    27
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Auto-Update DynDNS IP

    Smaleman ngutakngatik script buat autoupdate ip yg ada di dyndns klo IP kita ber-ubah2 (dynamic), akhirnya jalan jg. Tadinya kan gw pake built-in yg ada di modem tp-link, sedangkan klo mao dial PPPoE di mikrotik uda ga ada gunanya lg tu settingan dyndns di modem (CMIIW)...lgsg aja gw share disini deh biar ga ilang (referensi ada di paling bawah).


    di /system/scripts isi ini:

    name :
    Code:
    dynDNS
    policy :
    Code:
    centang smua (sebenernya si ga perlu smua, tp tes2 aja lg
    source:
    Code:
    :local ddnsuser "<ddns-username>"
    :local ddnspass "<ddns-password>"
    :local theinterface "<pppoe-interface>"
    :local ddnshost "<host.di.ddns.org>"
    
    :local ipddns [:resolve $ddnshost];
    :local ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
    
    :if ([ :typeof $ipfresh ] = nil ) do={
       :log info ("DynDNS: No ip address on $theinterface .")
    } else={
       :for i from=( [:len $ipfresh] - 1) to=0 do={ 
          :if ( [:pick $ipfresh $i] = "/") do={ 
    	   :set ipfresh [:pick $ipfresh 0 $i];
          } 
    }
        
    :if ($ipddns != $ipfresh) do={
        :log info ("DynDNS: IP-DynDNS = $ipddns")
        :log info ("DynDNS: IP-Fresh = $ipfresh")
      	:log info "DynDNS: Update IP needed, Sending UPDATE...!"
        :local str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
        /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
        :delay 1
        :local str [/file find name="DynDNS.$ddnshost"];
        /file remove $str
        :global ipddns $ipfresh
     	:log info "DynDNS: IP updated to $ipfresh!"
        } else={
         :log info "DynDNS: No need to update";
        }
    }

    di terminal paste ini:
    Code:
    /system scheduler add name=dynDNS interval=00:01 on-event="/system script run dynDNS\r\n"

    klo ada yg salah mohon dikoreksi, maklum masi belajar2 mikrotik jg Click here to enlarge

    NB: gw pake mikrotik 4.5 klo ada yg error mungkin beda versi aja kli ya.

    referensi:



  2. The Following 3 Users Say Thank You to psycronicx For This Useful Post:


  3. #2
    Status
    Offline
    psycronicx's Avatar
    Newbie
    Join Date
    Mar 2008
    Posts
    27
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    klo mo skalian ganti NATnya:

    search:
    Code:
    :local ipfresh
    tambahin bawahnya:
    Code:
    :local natID [/ip fi nat find comment="blabla"];
    search:
    Code:
    :log info "DynDNS: IP updated to $ipfresh!"
    tambahin bawahnya:
    Code:
    /ip fi nat set $natID dst-address=$ipfresh;
    :log info "Mikrotik: NAT updated to $ipfresh!"

    semoga membantu..... Click here to enlarge

  4. The Following User Says Thank You to psycronicx For This Useful Post:


  5. #3
    Status
    Offline
    fanizar's Avatar
    Newbie
    Join Date
    Feb 2010
    Location
    Bandung
    Posts
    67
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    manteb gan. boleh aku coba ya gan.
    Click here to enlargeClick here to enlarge

  6. #4
    Status
    Offline
    Shima's Avatar
    Newbie
    Join Date
    May 2008
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    wew..manteb... running di MT v3.3 en 4.6. Click here to enlarge

  7. #5
    Status
    Offline
    xopal's Avatar
    Member
    Join Date
    Jan 2010
    Posts
    245
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    --Kalo untuk model non-ppoe ini bisa di pake gak gan ?

    --Apa masih perlu setting DMZ dan virtual server di modem gan ?

  8. #6
    Status
    Offline
    Shima's Avatar
    Newbie
    Join Date
    May 2008
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    @xopal : ga harus pppoe koq en ga harus setting di modem lg...cuma aja u bridging aja modem nya.



    CMIIW ya

  9. #7
    Status
    Offline
    wkcs007's Avatar
    Baru Gabung
    Join Date
    Aug 2009
    Location
    Denpasar, Bali, Indonesia, Indonesia
    Posts
    12
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Question Mohon Penjelasannya suhu...

    Click here to enlarge Originally Posted by psycronicx Click here to enlarge
    di terminal paste ini:
    Code:
    /system scheduler add name=dynDNS interval=00:01 on-event="/system script run dynDNS\r\n"
    gan... yang \r\n itu gunanya apa ya? Click here to enlargeClick here to enlarge

    Makasi tutorialnya ya... Click here to enlarge

  10. #8
    Status
    Offline
    tyang_dusun's Avatar
    Member Super Senior
    Join Date
    Jun 2008
    Location
    Klaten, Jawa Tengah, Indonesia, Indonesia
    Posts
    521
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Akhirnya ketemu juga yg ane cari .... numpang baca2 dul ne Gan ,,,

  11. #9
    Status
    Offline
    Hdj
    Hdj's Avatar
    Baru Gabung
    Join Date
    Aug 2010
    Posts
    1
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Tanya dong Master, Kalo buat DnsExit script nya gimana sama Ngak ?
    Thank's

  12. #10
    Status
    Offline
    iamspa's Avatar
    Member Super Senior
    Join Date
    Jan 2010
    Location
    MEDAN DONK AH....
    Posts
    685
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kayak nya registrasi di dydns.com dah bayar ya bro....
    udah gak da lagi yang gratis......

    kalo masih gratis mohon share tutor reges nya donk bro....
    dah 3 hari ngutak ngatik reges di dydns masih aja tetep bayar....
    Last edited by iamspa; 25-12-2011 at 01:14.

  13. #11
    Status
    Offline
    prv
    prv's Avatar
    Newbie
    Join Date
    Aug 2007
    Posts
    31
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    klo script utk no-ip [ ada ga ya?

  14. #12
    Status
    Offline
    hobigratis's Avatar
    Baru Gabung
    Join Date
    Nov 2010
    Posts
    4
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by prv Click here to enlarge
    klo script utk no-ip [ ada ga ya?
    Ini gan untuk script No-IP

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [How-to] Auto Update Address-List IIX di Router Mikrotik
    By tajid.yakub in forum QOS & Traffic Shaping
    Replies: 24
    Last Post: 06-03-2013, 15:45
  2. NEW Update --> Setting PPPoE dan Load Balance Speedy --NEW UPDATE--
    By arman_cilik in forum General Networking
    Replies: 36
    Last Post: 10-06-2009, 06:29
  3. auto limit
    By venziro in forum Scripting @ Mikrotik
    Replies: 2
    Last Post: 05-04-2009, 09:39
  4. Replies: 14
    Last Post: 18-08-2008, 13:16
  5. Replies: 12
    Last Post: 11-04-2008, 08:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •