Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1
    Status
    Offline
    kYo-Abhiem's Avatar
    Newbie
    Join Date
    Dec 2010
    Location
    Cibinong, Indonesia
    Posts
    29
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0

    Wink (Share) 3 baris queue simple utk [game online + browsing] = nyegir

    saya mencoba untuk breksperimen dengan menggabungkan beberapa tutz yang ada di forum ini
    dan sangat berharap untuk para master mengkoreksinya Click here to enlarge

    Di test ini menggunakan
    warnet
    1 mb dedicated untuk IIX (lokal)
    1 mb up to untuk IX (inter)
    RB750G (RouterOS 5.7)
    tanpa proxy

    Untuk Mangel + beberapa port game

    Code:
    /ip f m
    add action=mark-connection chain=forward comment=IIX connection-bytes=\
        245760-4294967295 connection-mark=!ALL.int.c disabled=no \
        dst-address-list=nice new-connection-mark=ALL.iix.c \
        packet-mark=!Game_pkt passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=ALL.iix.c disabled=no \
        new-packet-mark=ALL.iix.p packet-mark=\
        !Game_pkt passthrough=no
    add action=mark-connection chain=forward comment=INT connection-bytes=\
        245760-4294967295 disabled=no dst-address-list=!nice new-connection-mark=\
        ALL.int.c passthrough=yes protocol=tcp src-address-list=warnet
    add action=mark-packet chain=prerouting connection-mark=ALL.int.c disabled=no \
        new-packet-mark=ALL.int.p passthrough=no
    add action=mark-connection chain=game comment="Fifa2 Online" disabled=no \
        dst-address=202.158.252.131-202.158.252.133 dst-port=6215,6217 \
        new-connection-mark=Game passthrough=yes protocol=tcp
    add action=mark-connection chain=game comment=CF disabled=no dst-port=\
        10009,13008,16666,28012 new-connection-mark=Game passthrough=yes \
        protocol=tcp
    add action=mark-connection chain=game disabled=no dst-port=12020-12080,13000 \
        new-connection-mark=Game passthrough=yes protocol=udp
    add action=mark-connection chain=game comment="Lost Saga" disabled=no \
        dst-address=203.89.146.0/23 dst-port=14009-14010 new-connection-mark=Game \
        passthrough=yes protocol=tcp
    add action=mark-connection chain=game disabled=no dst-address=203.89.146.0/23 \
        dst-port=40000-40010 new-connection-mark=Game passthrough=yes protocol=\
        udp
    add action=mark-connection chain=game comment="Point Blank" disabled=no \
        dst-address=203.89.146.0/23 dst-port=39190 new-connection-mark=Game \
        passthrough=yes protocol=tcp
    add action=mark-connection chain=game disabled=no dst-address=203.89.146.0/23 \
        dst-port=40000-40010 new-connection-mark=Game passthrough=yes protocol=\
        udp
    add action=mark-packet chain=game connection-mark=Game disabled=no \
        new-packet-mark=Game_pkt passthrough=no
    add action=jump chain=prerouting disabled=no jump-target=game
    queue types
    Code:
    /que typ
    add name="pcq-Down" kind=pcq pcq-rate=0 pcq-limit=50 \
    pcq-classifier=dst-address,dst-port pcq-total-limit=2000 pcq-burst-rate=0 \
    pcq-burst-threshold=0 pcq-burst-time=10s pcq-src-address-mask=32 \
    pcq-dst-address-mask=32 pcq-src-address6-mask=128 pcq-dst-address6-mask=128 \
    add name="pcq-Up" kind=pcq pcq-rate=0 pcq-limit=50 \
    pcq-classifier=src-address,src-port pcq-total-limit=2000 pcq-burst-rate=0 \
    pcq-burst-threshold=0 pcq-burst-time=10s pcq-src-address-mask=32 \
    pcq-dst-address-mask=32 pcq-src-address6-mask=128 pcq-dst-address6-mask=128 \
    Dan untuk queue simple
    Code:
    /que si
    add name="IX" interface=Lan parent=none packet-marks=ALL.int.p direction=both \
    priority=8 queue=pcq-Up/pcq-Down limit-at=0/0 max-limit=614k/614k \
    burst-limit=768k/768k burst-threshold=461k/461k burst-time=15s/15s \
    total-queue=default-small
    
    add name="IIX" interface=Lan parent=none packet-marks=ALL.iix.p \
    direction=both priority=8 queue=pcq-Up/pcq-Down limit-at=0/0 \
    max-limit=250k/250k burst-limit=352k/352k burst-threshold=188k/188k burst-time=15s/15s \
    total-queue=default-small
    
    add name="Game" interface=Lan parent=none packet-marks=Game_pkt \
    direction=both priority=1 queue=default/default limit-at=0/0 \
    max-limit=0/0 burst-limit=0/0 burst-threshold=0/0 \
    burst-time=0s/0s total-queue=default
    jangan lupa untuk memasukan nice pada address list
    bisa di lihat / di download di

    Note :
    coba pada terminal di winbox ketik /que "tab| si "tab" agar memudahkan pengertiannya

    Special Thanks For
     

    Click here to enlarge Originally Posted by dingo Click here to enlarge
    Langsung aja ah.....
    Test running well di RB750 OS ver.4.5
    ISP= SAPIDI EXECUTIVE 512 - 2M

    Mangle:
    GAME
    contoh buat Point Blank, game lain sesuaikan aja port/ip nya
    chain=prerouting action=jump jump-target=game
    chain=game action=mark-connection new-connection-mark=Game passthrough=yes protocol=tcp dst-address=203.89.146.0/23 dst-port=39190 comment="Point Blank"
    chain=game action=mark-connection new-connection-mark=Game passthrough=yes protocol=udp dst-address=203.89.146.0/23 dst-port=40000-40010
    chain=game action=mark-packet new-packet-mark=Game_pkt passthrough=no connection-mark=Game

    POKER

    chain=forward action=mark-connection new-connection-mark=Poker_con passthrough=yes protocol=tcp dst-address-list=LOAD POKER comment="POKER"
    chain=forward action=mark-connection new-connection-mark=Poker_con passthrough=yes protocol=tcp content=statics.poker.static.zynga.com
    chain=forward action=mark-packet new-packet-mark=Poker passthrough=no connection-mark=Poker_con

    BROWSING

    chain=forward action=mark-connection new-connection-mark=http passthrough=yes protocol=tcp in-interface=WAN out-interface=Lan packet-mark=!Game_pkt connection-mark=!Game connection-bytes=0-262146 comment="BROWSE"
    chain=forward action=mark-packet new-packet-mark=http_pkt passthrough=no protocol=tcp connection-mark=http

    LIMIT DOWNLOAD

    chain=forward action=mark-connection new-connection-mark=Download passthrough=yes protocol=tcp in-interface=WAN out-interface=Lan packet-mark=!Game_pkt connection-mark=!Poker_con connection bytes=262146-4294967295 comment="LIMIT DOWNLOAD"
    chain=forward action=mark-packet new-packet-mark=Download_pkt passthrough=no packet-mark=!Game_pk> connection-mark=Download

    UPLOAD

    chain=prerouting action=mark-packet new-packet-mark=Upload passthrough=no protocol=tcp src-address=192.168.0.0/24 in-interface=Lan packet-mark=!icmp_pkt comment="UPLOAD"

    QUEUE:

    queue type

    name="Download" kind=pcq pcq-rate=256000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000
    name="Http" kind=pcq pcq-rate=1M pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000
    name="Game" kind=pcq pcq-rate=0 pcq-limit=50 pcq-classifier=src-address,dst-address,src-port,dst-port pcq-total-limit=2000
    name="Upload" kind=pcq pcq-rate=0 pcq-limit=50 pcq-classifier=src-address pcq-total-limit=2000

    Queue Tree

    name="Main Browse" parent=Lan limit-at=0 priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
    name="Browse" parent=Main Browse packet-mark=http_pkt limit-at=0 queue=Http priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
    name="Game" parent=global-total packet-mark=Game_pkt limit-at=0 queue=Game priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
    name="Poker" parent=global-out packet-mark=Poker limit-at=0 queue=Game priority=3 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s
    name="Download" parent=global-out packet-mark=Download_pkt limit-at=0 queue=Download priority=8 max-limit=256k burst-limit=0 burst-threshold=0 burst-time=0s
    name="Main Upload" parent=global-in limit-at=0 priority=8 max-limit=256k burst-limit=0 burst-threshold=0 burst-time=0s
    name="Upload" parent=Main Upload packet-mark=Upload limit-at=0 queue=Upload priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s


    HASILNYA
    BROWSING 1Mbs bagi rata sekampung (baca: satu jaringan)
    DOWNLOAD 256Kbps bagi rata sekampung
    GAME seadanya bandwith sesuai kebutuhan sekampung
    POKER seadanya bandwith sesuai kebutuhan sekampung
    UPLOAD seadanya bandwith bagi rata sesuai kebutuhan sekampung

    GA PAKE PROXY

    DITUNGGU KOREKSI DAN REVIEWNYA.Click here to enlarge
    DITULIS JUGA DI

    nb: TIDAK BEKERJA PADA VERSI BAJAKAN !!!!

    AND
     

    Click here to enlarge Originally Posted by indrasakti Click here to enlarge
    Menghitung Burst untuk simple queue

    Lama waktu ideal untuk mengakses sebuah situs harusnya tidaklah lebih dari 10 hitungan jari atau 10 detik. Hal ini diperlukan untuk memberikan kenyamanan bagi user dalam melakukan aktivitas browsing. Maka tak ada salahnya kita memberikan aliran Bandwidth yang cukup besar pada 10 detik pertama, dan selanjutnya kita batasi untuk memberikan download file yang biasanya lebih dari 10 detik.

    Burst pada simple Queue bertujuan untuk mengijinkan aliran data tertinggi untuk beberapa periode waktu. Fasilitas ini berguna untuk membatasi pemakaian bandwidth secara berlebihan dan terus menerus bagi user-user yang rakus akan bandwidth. Hanya pada beberapa periode waktu tertentu sajalah user mendapatkan jatah b/w yang cukup besar.

    Pada fitur Burst terdapat beberapa variabel yang harus ditentukan nilainya, antara lain Burst Limit, Burst Threshold dan Burst Time. Yang perlu diperhatikan adalah, jika rata-rata aliran data lebih rendah dari “Burst Threshold“, Burst akan secara aktual mengikuti “Burst Limit”, dimana setiap detik router akan menghitung rata-rata data yang dicapai melalui burst time yang terakhir.
    Click here to enlarge
    Click here to enlarge

    Penulis menggunakan rumus tersendiri yang di buat di excel

    Dimana :

    N = Interval time

    X = Burst Limit

    Y = Burst Threshold

    Z = Burst Time

    M = Max Limit

    Rumus : Y = (X*N) / Z

    M = 4/3 * Y

    Contoh :

    X = 1024 kbps

    N = 10 detik

    Z = 40 s

    Y = (1024*10) / 40 = 256 kbps

    Maka di dapat Burst Threshold = 256 kbps

    M = 4/3 * 256 = 342 kbps

    Maka di dapat Max Limit = 342kbps

    Jika di set maka hasil yang di dapat :

    Click here to enlarge

    Click here to enlarge

    Click here to enlarge

    Dari grafik di atas di liat waktu buka website bandwidth langsung naik dari 256 kbps ke 1024 kbps trus makin lama makin turun ke max limit 342 kbps. Teknis ini dapat menghemat bandwidth agar tidak banyak user mengambil bandwidth untuk download.

    Untuk limit at dapat di hitung dengan cara misalkan ada 6 komputer. Bandwidth yang kita punya max 1 Mbps (1024 kbps) maka bagi 6 (1024/6) = 170 kbps kita set limit at tidak boleh lebih dari 170 kbps atau kasih rata-rata = 128 kbps. Sehingga user minimal dapat bandwidth 128 kbps.

    Untuk mendownload rumusnya via excel silakan download

    Semoga artikel ini berguna untuk para mikrotiker….

    Referensi :

     

    Click here to enlarge Originally Posted by lucubrb Click here to enlarge
    Semoga program mini ini bisa membantu sesepuh disini. Click here to enlarge

    Mohon masukan bila menemukan bugs yg ada didalamnya. Thx.

    Click here to enlarge
     

    Screenshot :
    Click here to enlarge

    Click here to enlarge

    Click here to enlarge

    Click here to enlarge

    Click here to enlarge

    Click here to enlarge

    Click here to enlarge


    Download v3Click here to enlarge
    -
    -
    -
    -
    -
    -

    Filesize : 56,5 KB (57.856 bytes)
    CRC32 : 1f867aca
    MD5 : 1c49504f92422a558abd8b922f130191
    SHA128 : 2947b7a22e22d9999bfe1916a24fe4a4a9bc420f

     

    -
    -

    Filesize : 45,0 KB (46.080 bytes)
    CRC32 : C50CBC6D
    MD5 : 6A2AA7D32D47FE86845634C2CDFC5FB7
    SHA128 : 4aaa281a15c1de13821b250b18b29e897f2acfb2


     

    -
    -

    Info :
    Filename : MikrotikScriptMaker.exe
    Version : 1.1.0.11
    Filesize : 66.5 KB (68,096 bytes)
    CRC32 : 39b3d082
    MD5 : c05b4d007c495ca6cf661431b82423b9
    SHA128 : 9ec6361089f19cf80d2ea830211f5f5af55dd5dc






    Suka atau terbantu dengan adanya program ini? Mau donasi? Seikhlasnya aja gan, yang penting ridho. Bisa diserahkan donasi-nya ke Bro Akbar Azwir ato Bro Doni Kuswaryadi aja buat keperluan maintenance server forum tercinta kita ini. Click here to enlarge
    Last edited by kYo-Abhiem; 28-05-2012 at 06:29. Reason: mqfifo + burst ix & iix

  2. The Following 9 Users Say Thank You to kYo-Abhiem For This Useful Post:


  3. #2
    Status
    Offline
    tyang_dusun's Avatar
    Member Super Senior
    Join Date
    Jun 2008
    Location
    Klaten, Jawa Tengah, Indonesia, Indonesia
    Posts
    521
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    ane trial error dul Gan ....

  4. #3
    Status
    Offline
    kYo-Abhiem's Avatar
    Newbie
    Join Date
    Dec 2010
    Location
    Cibinong, Indonesia
    Posts
    29
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by tyang_dusun Click here to enlarge
    ane trial error dul Gan ....
    maksudnnya pas di masukin script error gan ?
    atow cari kekurangan dari setingan ini gan ?
    hehe kurang ngerti maksud agan

    sebelumnnya
    ip lost saga kan saya loss dgn maksud open launcher lbh cepat
    sekarang saya ubah limit IIXnnya agar engga ke loss tkt pas update client lost sgnya

    tapi kalo ada orang buka web local contoh yg paling makan gede itu game browser yg lagi tenar2nnya itu n1njakit4

    traffic langsung terasa aga naek
    cuma dari isp saya ternyata di limit juga Click here to enlarge
    saya minta loss katannya tkt flooding & virus
    saya kurang tw untuk limitan dari isp tsbt

    permasalahan lain yg saya temui itu sama pb & lost sg ==
    kalo di masukin ke grup "game"
    pb dan lost sg lah yg paling nyedod bw
    mungkin para master punya solusi untuk masalah yg satu ini ?

  5. #4
    Status
    Offline
    r1kudou's Avatar
    Baru Gabung
    Join Date
    Oct 2011
    Posts
    10
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kalo ane sekarang pake PCQ + HTB (parent-child) tetep pemisahan browsing/donlod and game masih lancar bro...

    ane pake MT v2.9

  6. #5
    Status
    Offline
    AhsanDoank's Avatar
    Baru Gabung
    Join Date
    Oct 2011
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    gan, kok script queue type nya eror di rb ane?? ane kopas di new terminal rb ane katanya syntax error

    ane pake RB750 gan, thx

  7. #6
    Status
    Offline
    oktama's Avatar
    Forum Guru
    Join Date
    Jul 2008
    Location
    Jayapura
    Posts
    1,928
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by AhsanDoank Click here to enlarge
    gan, kok script queue type nya eror di rb ane?? ane kopas di new terminal rb ane katanya syntax error

    ane pake RB750 gan, thx
    jangan asal copas baca dulu masing2 script maksud dan tujuannya gimana, sesuaikan parameter dengan tempat anda, biasanya karena kebiasaan kopas /ip f m harusnya penulisannya /ip firewall mangle
    juga perhatikan interface, kl nama interface gak sama ya jangan dipaksakan sesuaikan dulu nama interface
    perhatikan script2 yang disingkat2 kl asal maen copas ya hancurlah Click here to enlarge

  8. The Following User Says Thank You to oktama For This Useful Post:


  9. #7
    Status
    Offline
    AhsanDoank's Avatar
    Baru Gabung
    Join Date
    Oct 2011
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by oktama Click here to enlarge
    jangan asal copas baca dulu masing2 script maksud dan tujuannya gimana, sesuaikan parameter dengan tempat anda, biasanya karena kebiasaan kopas /ip f m harusnya penulisannya /ip firewall mangle
    juga perhatikan interface, kl nama interface gak sama ya jangan dipaksakan sesuaikan dulu nama interface
    perhatikan script2 yang disingkat2 kl asal maen copas ya hancurlah Click here to enlarge
    ane gak asal kopas gan,
    cuman itu kind yang di queue type mq-pfifo ga' bisa,
    di masukkin manual di winbox juga ga ada pilihan mq-pfifo yang ada cuman pfifo,

    oh iy, maap gan ane blum bgitu paham mengenai queue type,
    mohon pencerahannya Click here to enlarge

  10. #8
    Status
    Offline
    oktama's Avatar
    Forum Guru
    Join Date
    Jul 2008
    Location
    Jayapura
    Posts
    1,928
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by AhsanDoank Click here to enlarge
    ane gak asal kopas gan,
    cuman itu kind yang di queue type mq-pfifo ga' bisa,
    di masukkin manual di winbox juga ga ada pilihan mq-pfifo yang ada cuman pfifo,

    oh iy, maap gan ane blum bgitu paham mengenai queue type,
    mohon pencerahannya Click here to enlarge
    mqfifo adanya di 5.7 keatas kl masih make dibawah 5.7 ya gak bakal ada :P

  11. #9
    Status
    Offline
    AhsanDoank's Avatar
    Baru Gabung
    Join Date
    Oct 2011
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by oktama Click here to enlarge
    mqfifo adanya di 5.7 keatas kl masih make dibawah 5.7 ya gak bakal ada :P
    owh, tq gan Click here to enlarge
    brarti RB ane ga cocok yah buat rule di atas

    gan klo trit yang ngebahas tentang queue type ada gak? dah search tapi gak nemu Click here to enlarge

  12. #10
    Status
    Offline
    oktama's Avatar
    Forum Guru
    Join Date
    Jul 2008
    Location
    Jayapura
    Posts
    1,928
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    bukan RB-nya tapi mikrotik versionnya Click here to enlarge

  13. #11
    Status
    Offline
    burgerkill's Avatar
    Newbie
    Join Date
    Jun 2011
    Posts
    54
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    blom brani upgrade mikrotik nya om, tp versi rb nya sama..

    versi mikrotik yg ane punya 4.10 om Click here to enlarge

    makasih tutorialnya

  14. #12
    Status
    Offline
    n4z4r's Avatar
    Calon Member
    Join Date
    Jan 2012
    Location
    Sidikalang, Medan, Sumut
    Posts
    79
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mqfifo saya jugak gak ada. gimana ni pak?

  15. #13
    Status
    Offline
    profbins's Avatar
    Baru Gabung
    Join Date
    May 2012
    Posts
    2
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    matur thankyu gan....... mantab pokoknya.... sering2 sharenya maklum newbi perlubnyak ref.....

  16. #14
    Status
    Offline
    kYo-Abhiem's Avatar
    Newbie
    Join Date
    Dec 2010
    Location
    Cibinong, Indonesia
    Posts
    29
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge mq-pofifo tidak ush di pakai pas bwt tutor ini msh belom ngerti juga hehe tp pengen share sekaligus minta koreksi
    tp belom ada yg koreksi sampe sekarang hehe

    que sim gunakan yang ini
    add name="Game" interface=Lan parent=none packet-marks=Game_pkt \
    direction=both priority=1 queue=default/default limit-at=0/0 \
    max-limit=0/0 burst-limit=0/0 burst-threshold=0/0 \
    burst-time=0s/0s total-queue=default

    kenapa pake default ? biar muncul aja trafiknnya hehe

    dan que typ yg di bawah ini g perlu di pake
    add name="Game" kind=mq-pfifo mq-pfifo-limit=200

    sudah di edit juga yang di atas untuk mq-pofifo dan burstnya

    sisanya kembangkan sendiri yaa piss masbor Click here to enlarge hehe
    soale tkt salah2 lagi wkwkwk msh niewbie juga saya hanya bisa memodifikasi dan mencontek bukan membuat suatu hal yg baru

  17. #15
    Status
    Offline
    lamno's Avatar
    Calon Member
    Join Date
    Feb 2008
    Posts
    81
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kasian yg remote winbox kalo koneksi lagi penuh.. dijamin mau remote timed out terus... dibikin priority port itu penting lho gan Click here to enlarge

 

 
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. share perbedaan simple queue dan queue tree
    By irsalkerenz in forum Beginner Basics
    Replies: 34
    Last Post: 15-05-2014, 14:08
  2. [share]antara simple queue dengan queue tree
    By Anto.PJ in forum Beginner Basics
    Replies: 65
    Last Post: 02-02-2013, 14:28
  3. Load balancing sederhana+port game+queue tree +simple queue
    By yohanexz in forum General Networking
    Replies: 39
    Last Post: 24-02-2012, 13:34
  4. Membedakan Game Online dengan Browsing
    By rofiqazhari in forum Beginner Basics
    Replies: 5
    Last Post: 25-09-2011, 23:33
  5. [ask] Setting mikrotik buat game online dan browsing
    By nitaufan in forum General Networking
    Replies: 6
    Last Post: 03-01-2010, 22:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •