Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 3 123 LastLast
Results 1 to 15 of 35
  1. #1
    Status
    Offline
    bherz's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    23
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Transparent Proxy squid gak bisa

    Allo para master skalian... saya ada masalah dengan transparent proxy di mikrotik. Saya menggunakan Mikrotik 2.97 sbgai router dan Squid di Ubuntu. Kalau di set di Browser, squidnya bisa jalan,. Tapi pada saat saya meredirect ke Mikrotik kgak konek dah semua.
    Berikut toplogi net saya

    Modem-----Mikrotik-----Switch----Client
    =====================|-----------Proxy

    Mohon bantuannya yah para suhu skalian....
    Last edited by bherz; 16-09-2010 at 19:02.

  2. #2
    Status
    Offline
    Blauwz's Avatar
    Member
    Join Date
    Jan 2010
    Location
    Arema Indonesia
    Posts
    141
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by bherz Click here to enlarge
    Allo para master skalian... saya ada masalah dengan transparent proxy di mikrotik. Saya menggunakan Mikrotik 2.97 sbgai router dan Squid di Ubuntu. Kalau di set di Browser, squidnya bisa jalan,. Tapi pada saat saya meredirect ke Mikrotik kgak konek dah semua.
    Berikut toplogi net saya

    Modem-----Mikrotik-----Switch----Client
    |
    |______ Proxy

    Mohon bantuannya yah para suhu skalian....
    coba bantu gan..

    edit port pada squid.conf
    Code:
    http_port 3128 transparent
    tambahkan seperti yang d atas(yg d warna merah)

  3. #3
    Status
    Offline
    bherz's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    23
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Blauwz Click here to enlarge
    coba bantu gan..

    edit port pada squid.conf
    Code:
    http_port 3128 transparent
    tambahkan seperti yang d atas(yg d warna merah)
    sudah ada gan.. Tapi tetap aja gak bisa..

  4. #4
    Status
    Offline
    Blauwz's Avatar
    Member
    Join Date
    Jan 2010
    Location
    Arema Indonesia
    Posts
    141
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by bherz Click here to enlarge
    sudah ada gan.. Tapi tetap aja gak bisa..
    Coba di paste aja d sini gan untuk squid.conf nya
    atau kalo udah di rasa set squid udah bnr cek juga nat d mt nya...

  5. #5
    Status
    Offline
    bherz's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    23
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Blauwz Click here to enlarge
    Coba di paste aja d sini gan untuk squid.conf nya
    atau kalo udah di rasa set squid udah bnr cek juga nat d mt nya...
    Ip squid = 192.168.1.80
    Ip MT = 192.168.1.200

    Ini Script natnya di mt

    Code:
    /ip firewall nat add chain=dst-nat src-address=!192.168.1.80 protocol=tcp dst-port=80 in-interface=lan action=dst-nat to-address=192.168.1.80 to-port=3128
    /ip firewall nat add chain=src-nat src-address=192.168.1.0/24 out-interface=lan action=srcnat src-address=192.168.1.200 to-port=3128
    
    /ip firewall filter add chain=forward src-address=192.168.1.0/24 dst-address=192.168.1.81 dst-port=3128 in-interface=lan action=accept

    Script di squid

    Code:
    http_port 3128 transparent
    server_http11 on
    icp_port 0
    
    pid_filename /var/run/squid.pid
    coredump_dir /var/spool/squid/
    error_directory /usr/share/squid/errors/en/
    icon_directory /usr/share/squid/icons
    mime_table /usr/share/squid/mime.conf
    visible_hostname proxy
    
    access_log /var/log/squid/access.log
    cache_log /dev/null
    cache_store_log /dev/null
    
    log_fqdn off
    log_icp_queries off
    buffered_logs off
    emulate_httpd_log off
    
    ftp_list_width 32
    ftp_passive on
    ftp_sanitycheck on
    
    acl localnet src 192.168.1.0/24
    
    uri_whitespace strip
    dns_nameservers /etc/resolv.conf
    
    cache_mem 64 MB
    maximum_object_size_in_memory 32 KB
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    
    cache_dir aufs /cache1 15000 16 256
    cache_dir aufs /cache2 15000 16 256
    cache_dir aufs /cache3 15000 16 256
    
    minimum_object_size 0 bytes
    maximum_object_size 1024 MB
    offline_mode off
    cache_swap_low 98
    cache_swap_high 99
    
    acl all src 0.0.0.0/0
    acl localhost src 127.0.0.1/32
    acl safeports port 21 70 80 81 210 280 443 488 563 591 631 777 901 3128 1025-65535
    acl sslports port 443 563 81
    acl manager proto cache_object
    acl purge method PURGE
    acl connect method CONNECT
    acl dynamic urlpath_regex cgi-bin \?
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !safeports
    http_access deny CONNECT !sslports
    http_access allow localhost
    http_access allow localnet
    http_access deny all
    
    
    tcp_outgoing_tos 0x30 localnet
    zph_mode tos
    zph_local 0x30
    Last edited by kdebugx86; 16-09-2010 at 20:54.

  6. #6
    Status
    Offline
    Blauwz's Avatar
    Member
    Join Date
    Jan 2010
    Location
    Arema Indonesia
    Posts
    141
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    cek pm biar lbh detail gan...

  7. #7
    Status
    Offline
    bherz's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    23
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Mohon dibantu yah para suhu2 skalian Click here to enlarge Click here to enlarge Click here to enlarge

  8. #8
    Status
    Offline
    bherz's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    23
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Tolong donk suhu2 skalianClick here to enlargeClick here to enlarge

  9. #9
    Status
    Offline
    xco
    xco's Avatar
    Calon Member
    Join Date
    Apr 2008
    Location
    city of heroes
    Posts
    76
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by bherz
    Code:
    /ip firewall nat add chain=src-nat src-address=192.168.1.0/24 out-interface=lan action=srcnat src-address=192.168.1.200 to-port=3128
    /ip firewall filter add chain=forward src-address=192.168.1.0/24 dst-address=192.168.1.81 dst-port=3128 in-interface=lan action=accept
    coba yang itu sementara di disable, bisa ga?
    semoga membantu.. Click here to enlarge

  10. #10
    Status
    Offline
    Jati+'s Avatar
    Newbie
    Join Date
    Oct 2007
    Posts
    39
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kasus nya sama neh ma si sayah...klo saya sih squid di fedora

    apa memang klo topologi sejajar klien ngga bisa dijadiin transparan yah

  11. #11
    Status
    Offline
    bherz's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    23
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Jati+ Click here to enlarge
    kasus nya sama neh ma si sayah...klo saya sih squid di fedora

    apa memang klo topologi sejajar klien ngga bisa dijadiin transparan yah
    Iya tuh.. Padahal kalau squid dipasang dibelakang MT, lancar2 aja. Mungkin para suhu skalian punya solusi yah..Click here to enlarge

  12. #12
    Status
    Offline
    Jati+'s Avatar
    Newbie
    Join Date
    Oct 2007
    Posts
    39
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    gmn klo squid sejajar klien tp beda class IP ... trus di squid nya setting nat iptables .... bisa ngga yah, blum dicoba sih Click here to enlarge

  13. #13
    Status
    Offline
    kdebugx86's Avatar
    Moderator
    Join Date
    Oct 2008
    Location
    greyarea
    Posts
    1,283
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    gak konek gimana?
    coba paste access.log dan cache.log dari squid.

  14. #14
    Status
    Offline
    bherz's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    23
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by kdebugx86 Click here to enlarge
    gak konek gimana?
    coba paste access.log dan cache.log dari squid.
    Gak konek kalau udah di nat di MT. script Natnya ada di atas gan

    Ini Access Lognya. Tapi diclient yang di set manual proxy di browser..
    1284714430.523 107 192.168.0.3 TCP_REFRESH_HIT/304 282 GET - DIRECT/203.84.158.50 -
    1284714430.702 153 192.168.0.3 TCP_REFRESH_HIT/304 282 GET - DIRECT/203.84.158.50 -
    1284714430.829 108 192.168.0.3 TCP_REFRESH_HIT/304 281 GET - DIRECT/203.84.158.50 -
    1284714430.923 378 192.168.0.3 TCP_MISS/200 583 GET - DIRECT/72.14.203.154 text/html
    1284714431.214 378 192.168.0.3 TCP_MISS/200 392 GET - DIRECT/203.84.158.50 image/gif
    1284714431.245 355 192.168.0.3 TCP_MISS/200 488 GET - DIRECT/72.14.203.101 image/gif
    1284714431.392 1983 192.168.0.3 TCP_MISS/200 2799 GET - DIRECT/203.84.158.50 text/html
    1284714434.101 3541 192.168.0.3 TCP_MISS/200 343 POST - DIRECT/125.160.11.46 text/html
    1284714434.638 4076 192.168.0.3 TCP_MISS/200 343 POST - DIRECT/125.160.11.46 text/html
    1284714437.651 597 192.168.0.3 TCP_MISS/200 781 POST - DIRECT/69.17.117.207 text/html
    1284714439.015 964 192.168.0.3 TCP_MISS/200 22739 GET - DIRECT/69.17.117.207

    Click here to enlarge Originally Posted by Jati+ Click here to enlarge
    gmn klo squid sejajar klien tp beda class IP ... trus di squid nya setting nat iptables .... bisa ngga yah, blum dicoba sih Click here to enlarge
    Ditest Click here to enlarge
    Last edited by bherz; 17-09-2010 at 17:25.

  15. #15
    Status
    Offline
    bherz's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    23
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Dibantu kk e.. segala macam cara telah dilakukan. Adakah solusi yang baik... Click here to enlarge Click here to enlarge Click here to enlarge

 

 
Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 37
    Last Post: 25-04-2014, 17:30
  2. (ask) HOTSPOT ga bisa lewat proxy squid
    By cikruk21 in forum Wireless Networking
    Replies: 15
    Last Post: 08-05-2011, 09:20
  3. [help] SQUID tidak bisa di Transparent
    By andy in forum General Networking
    Replies: 8
    Last Post: 07-08-2010, 08:15
  4. Problem squid transparent
    By brain_lord2000 in forum Wireless Networking
    Replies: 0
    Last Post: 23-07-2010, 13:47
  5. Squid sejajar Client, bisa gak di set transparent??
    By Xerophie in forum General Networking
    Replies: 12
    Last Post: 02-08-2008, 13:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •