Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 4 of 4
  1. #1
    Status
    Offline
    adiel.nopria's Avatar
    Calon Member
    Join Date
    Sep 2007
    Posts
    85
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    ask: tanya bandwith limiter

    Met pagi sesepuh mikrotik...

    mo tanya nih...gw dah banyak baca tutorial ttg bandwith limiter (queu/pcq) tp masih bingung nih kan hampir semua nya diterapin ke transparent proxy, sedangkan di ktr gw pake multiple vlan dari catalyst cisco, jadi murni web proxy aja (setting proxy manual di browser).

    pertanyaannya, rule2x tsb jalan ga klo mikrotik yg gw terapin non transparent proxy alias murni web proxy ??? apa harus ada settingan khusus gt???

    thanks ya....

  2. #2
    Status
    Offline
    d3v4's Avatar
    Forum Guru
    Join Date
    Jul 2007
    Location
    di alam baka
    Posts
    1,015
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    tutor yg mana ya ?

  3. #3
    Status
    Offline
    adiel.nopria's Avatar
    Calon Member
    Join Date
    Sep 2007
    Posts
    85
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by d3v4 Click here to enlarge
    tutor yg mana ya ?
    hampir disemua tutor bandwith limiter pasti menggunakan masquerade dan redirecting port berarti kan itu pake transparent proxy.

    klo gw terapin non transparent proxy kira2x rule2x tsb jalan ga ya??

  4. #4
    Status
    Offline
    maman's Avatar
    Calon Member
    Join Date
    Nov 2007
    Posts
    86
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by adiel.nopria Click here to enlarge
    hampir disemua tutor bandwith limiter pasti menggunakan masquerade dan redirecting port berarti kan itu pake transparent proxy.

    klo gw terapin non transparent proxy kira2x rule2x tsb jalan ga ya??
    Mikrotik bisa juga di gunakan untuk bandwith limiter pada bridge.
    Ini contoh kasus nya :

    TransparentTrafficShaper

    Introduction

    This example shows how to configure a transparent traffic shaper. The transparent traffic shaper is essentially a bridge that is able to differentiate and prioritize traffic that passes through it.

    Consider the following network layout:

    Click here to enlarge

    We will configure one queue limiting the total throughput to the client and three sub-queues that limit HTTP, P2P and all other traffic separately.

    Quick Start for Impatient

    Configuration snippet from the MikroTik router:

    /interface bridge
    add name="bridge1"
    /interface bridge port
    add interface=ether2 bridge=bridge1
    add interface=ether3 bridge=bridge1

    /ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-connection \
    new-connection-mark=http_conn passthrough=yes
    add chain=prerouting connection-mark=http_conn action=mark-packet \
    new-packet-mark=http passthrough=no
    add chain=prerouting p2p=all-p2p action=mark-connection \
    new-connection-mark=p2p_conn passthrough=yes
    add chain=prerouting connection-mark=p2p_conn action=mark-packet \
    new-packet-mark=p2p passthrough=no
    add chain=prerouting action=mark-connection new-connection-mark=other_conn \
    passthrough=yes
    add chain=prerouting connection-mark=other_conn action=mark-packet \
    new-packet-mark=other passthrough=no

    / queue simple
    add name="main" target-addresses=10.0.0.12/32 max-limit=256000/512000
    add name="http" parent=main packet-marks=http max-limit=240000/500000
    add name="p2p" parent=main packet-marks=p2p max-limit=64000/64000
    add name="other" parent=main packet-marks=other max-limit=128000/128000

    Explanation

    Each piece of code is followed by the explanation of what it actually does.

    Bridge

    /interface bridge
    add name="bridge1"
    /interface bridge port
    add interface=ether2 bridge=bridge1
    add interface=ether3 bridge=bridge1

    We create a new bridge interface and assign two ethernet interfaces to it. Thus the prospective traffic shaper will be completely transparent to the client.

    Mangle

    /ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-connection \
    new-connection-mark=http_conn passthrough=yes
    add chain=prerouting connection-mark=http_conn action=mark-packet \
    new-packet-mark=http passthrough=no

    All traffic destined to TCP port 80 is likely to be HTTP traffic and therefore is being marked with the packet mark http. Note, that the first rule has passthrough=yes while the second one has passthrough=no. (You can obtain additional information about mangle at )

    /ip firewall mangle
    add chain=prerouting p2p=all-p2p action=mark-connection \
    new-connection-mark=p2p_conn passthrough=yes
    add chain=prerouting connection-mark=p2p_conn action=mark-packet \
    new-packet-mark=p2p passthrough=no
    add chain=prerouting action=mark-connection new-connection-mark=other_conn \
    passthrough=yes
    add chain=prerouting connection-mark=other_conn action=mark-packet \
    new-packet-mark=other passthrough=no

    Same as above, P2P traffic is marked with the packet mark p2p and all other traffic is marked with the packet mark other.

    Queues

    /queue simple
    add name="main" target-addresses=10.0.0.12/32 max-limit=256000/512000

    We create a queue that limits all the traffic going to/from the client (specified by the target-address) to 256k/512k.

    /queue simple
    add name="http" parent=main packet-marks=http max-limit=240000/500000
    add name="p2p" parent=main packet-marks=p2p max-limit=64000/64000
    add name="other" parent=main packet-marks=other max-limit=128000/128000

    All sub-queues have the main queue as the parent, thus the aggregate data rate could not exceed limits specified in the main queue. Note, that http queue has higher priority than other queues, meaning that HTTP downloads are prioritized.

    Sumber dari :

    Semoga bermanfaat

    | m | a | m | a | n |
    Last edited by maman; 04-02-2008 at 12:37.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bandwith Management pada Mikrotik
    By Howl in forum General Networking
    Replies: 5
    Last Post: 23-07-2013, 06:19
  2. [ASK] Bagaimana Bagi Bandwith
    By gun in forum Beginner Basics
    Replies: 5
    Last Post: 27-12-2010, 14:30
  3. <ask> Pengaturan Bandwith
    By palzum in forum Beginner Basics
    Replies: 11
    Last Post: 12-11-2007, 21:09
  4. Misah Bandwith
    By diki in forum General Networking
    Replies: 5
    Last Post: 31-10-2007, 19:51
  5. gabung 2 bandwith
    By shincan^_^ in forum Beginner Basics
    Replies: 3
    Last Post: 16-09-2007, 17:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •