Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 8 of 8
  1. #1
    Status
    Offline
    xxx123's Avatar
    Member
    Join Date
    Aug 2007
    Posts
    156
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    KK mohon dibantu sebungan dengan treat implementas PCQ untuk medapatklan bw yg maksi

    saya telah terapkan di threat :


    Pertama-tama lakukan mangle :
    Untuk trafik upload corporate
    /ip firewall mangle add chain=prerouting src-address=192.168.1.10 in-interface=Local action=mark-packet new-packet-mark=corporate-up passthrough=no
    Untuk trafik download corporate
    /ip firewall mangle add chain=forward src-address=192.168.1.10 action=mark-connection new-connection-mark=corporate-conn passthrough=yes
    /ip firewall mangle add chain=forward connection-mark=corporate-conn in-interface=Public action=mark-packet new-packet-mark=corporate-down passthrough=no

    Untuk trafik upload personal
    /ip firewall mangle add chain=prerouting src-address=192.168.1.20 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no
    /ip firewall mangle add chain=prerouting src-address=192.168.1.21 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no
    /ip firewall mangle add chain=prerouting src-address=192.168.1.22 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no
    /ip firewall mangle add chain=prerouting src-address=192.168.1.23 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no


    Untuk trafik download personal
    ( tidak perlu dinyatakan interfacen yang mana ini ??
    /ip firewall mangle add chain=forward src-address=192.168.1.20 action=mark-connection new-connection-mark=personal-conn passthrough=yes
    /ip firewall mangle add chain=forward src-address=192.168.1.21 action=mark-connection new-connection-mark=personal-conn passthrough=yes
    /ip firewall mangle add chain=forward src-address=192.168.1.22 action=mark-connection new-connection-mark=personal-conn passthrough=yes
    /ip firewall mangle add chain=forward src-address=192.168.1.23 action=mark-connection new-connection-mark=personal-conn passthrough=yes
    /ip firewall mangle add chain=forward connection-mark=personal-conn

    ini apa ya ?? di bagian mangle-down kok ada setingan ini ??
    in-interface=Public action=mark-packet new-packet-mark=personal-down passthrough=no

    Harpa diperhatikan untuk mark-packet maka passthrough=no sedangkan untuk mark-connection passthrough=yes

    Nah setelah beres urusan mangling ini, kita lanjut ke pembuatan queue tree :
    /queue tree add name=down parent=Local queue=default
    /queue tree add name=up parent=global-in queue=default

    sampe pd seting queue tree ini tidak ada traifc yang lewat di queue down mengapa ya ??

    mohon penjelasan

    regard

  2. #2
    Status
    Offline
    okto_2005's Avatar
    Member Super Senior
    Join Date
    Jul 2007
    Posts
    655
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    /ip firewall mangle add chain=forward connection-mark=personal-conn

    ini apa ya ?? di bagian mangle-down kok ada setingan ini ??
    in-interface=Public action=mark-packet new-packet-mark=personal-down passthrough=no
    harusnya nyambung atuh.....
    /ip firewall mangle add chain=forward connection-mark=personal-conn in-interface=Public action=mark-packet new-packet-mark=personal-down passthrough=no
    masih kurang queue tree nya...

    Nah setelah beres urusan mangling ini, kita lanjut ke pembuatan queue tree :
    /queue tree add name=down parent=Local queue=default
    /queue tree add name=up parent=global-in queue=default
    itu baru sampe pembuatan parent queue, tambahin rule queue untuk tiap share bandwidth en dedicated nya masukin di bagian queee tree, nanti parent queuenya pake yang down sama up
    Last edited by okto_2005; 09-11-2007 at 09:36.

  3. #3
    Status
    Offline
    xxx123's Avatar
    Member
    Join Date
    Aug 2007
    Posts
    156
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by okto_2005 Click here to enlarge
    harusnya nyambung atuh.....

    masih kurang queue tree nya...


    itu baru sampe pembuatan nama queue
    tambahin rule queue masukin di bagian queee tree

    setingan mangle saya ud spt yang diatas dan queue tree sbb :


    [admin@yahuu.net] queue tree> pr
    Flags: X - disabled, I - invalid
    0 X name="down" parent=ether2 packet-mark="" limit-at=0 queue=default
    priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

    1 X name="up" parent=global-in packet-mark="" limit-at=0 queue=default
    priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

    2 X name="CLIENT-DOWN" parent=down packet-mark=personal-down limit-at=0
    queue=PCQ_download priority=8 max-limit=400000 burst-limit=0
    burst-threshold=0 burst-time=0s

    3 X name="CLIENT-UP" parent=up packet-mark=personal-up limit-at=0
    queue=PCQ_upload priority=8 max-limit=70000 burst-limit=0
    burst-threshold=0 burst-time=0s


    ( sementara saya disabledkan sebab tidk ada trafic yang lewat dengan setingan mangle spt diatas )


    Tetapi kalo setingan spt di di bwah ini semua trafic lancar cuma bw tdk berbagi rata :

    MANGLE LIMITER :
    1 ;;; D0WN-CLIENT
    chain=forward src-address=192.168.0.0/24 action=mark-connection
    new-connection-mark=down-client passthrough=yes

    2 ;;; DIRECT -DOWN
    chain=forward in-interface=pppoe-speedy connection-mark=down-client
    action=mark-packet new-packet-mark=down-direct passthrough=no

    3 ;;; DOWN-PROXY
    chain=output out-interface=ether2 dst-address=192.168.0.0/24
    action=mark-packet new-packet-mark=down-direct passthrough=no

    QUEUE TREE :
    [admin@yahuu.net] queue tree> pr
    Flags: X - disabled, I - invalid
    0 X name="down" parent=ether2 packet-mark="" limit-at=0 queue=default
    priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

    1 X name="up" parent=global-in packet-mark="" limit-at=0 queue=default
    priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

    2 X name="CLIENT-DOWN" parent=down packet-mark=personal-down limit-at=0
    queue=PCQ_download priority=8 max-limit=400000 burst-limit=0
    burst-threshold=0 burst-time=0s



    mohon pencrahan
    saya ingin mencoba setingan mangle spt di tuz yang ada di web :



    sekiranya mohon dibantu

    regard

  4. #4
    Status
    Offline
    okto_2005's Avatar
    Member Super Senior
    Join Date
    Jul 2007
    Posts
    655
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    hmmm gue dulu pernah ngalamin script error.... (baca thread gue di bagian scripting). abis itu gue hapus lagi sciptnya lalu di buat ulang scriptnya. script jalan lancar sampai sekarang, padahal isi scriptnya sama.

    pas gue juga buat sama persis di thread itu, gue apply ke mikrotik gue, di mangle banyak packet yg selalu 0 byte en 0 packet... terus gue export rulenya..... gue hapus rule yg lama, hasil exportnya gue masukin lagi lewat terminal ssh mulai keliatan packetnya ada yg lewat. hehehehe.

    coba aja cara gue.....

  5. #5
    Status
    Offline
    xxx123's Avatar
    Member
    Join Date
    Aug 2007
    Posts
    156
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by okto_2005 Click here to enlarge
    hmmm gue dulu pernah ngalamin script error.... (baca thread gue di bagian scripting). abis itu gue hapus lagi sciptnya lalu di buat ulang scriptnya. script jalan lancar sampai sekarang, padahal isi scriptnya sama.

    pas gue juga buat sama persis di thread itu, gue apply ke mikrotik gue, di mangle banyak packet yg selalu 0 byte en 0 packet... terus gue export rulenya..... gue hapus rule yg lama, hasil exportnya gue masukin lagi lewat terminal ssh mulai keliatan packetnya ada yg lewat. hehehehe.

    coba aja cara gue.....

    waduh akyaknya ilmu wa lom sampe sana

    bisa di jelasin detailnya om

  6. #6
    Status
    Offline
    okto_2005's Avatar
    Member Super Senior
    Join Date
    Jul 2007
    Posts
    655
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    maksut gue mikrotiknya munkin nge-bug.

    coba di terminal ssh diexport rulenya, lalu copy paste ke notepad dulu rule yg sudah ada di mikrotik di delete semua., kl udah di delete hasil past di notepad tade di paste ke terminal.

    utk export: /ip fire man exp

  7. #7
    Status
    Offline
    xxx123's Avatar
    Member
    Join Date
    Aug 2007
    Posts
    156
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by okto_2005 Click here to enlarge
    maksut gue mikrotiknya munkin nge-bug.

    coba di terminal ssh diexport rulenya, lalu copy paste ke notepad dulu rule yg sudah ada di mikrotik di delete semua., kl udah di delete hasil past di notepad tade di paste ke terminal.

    utk export: /ip fire man exp
    gitu ya om ?? mohon di koreksi apa bener gitu terus di deletenya caranya gmn om??

    [admin@yahuu.net] ip firewall mangle> ex
    # nov/11/2007 00:46:02 by RouterOS 2.9.27
    # software id = 65FE-ZAT
    #
    / ip firewall mangle
    add chain=forward src-address=192.168.0.0/24 action=mark-connection \
    new-connection-mark=down-client passthrough=yes comment="D0WN-CLIENT" \
    disabled=no
    add chain=prerouting src-address=192.168.0.0/24 action=mark-packet \
    new-packet-mark=up-client passthrough=no comment="UP-CLIENT" disabled=yes
    add chain=forward out-interface=ether2 dst-address=192.168.0.0/24 \
    connection-mark=down-client action=mark-packet new-packet-mark=down-direct \
    passthrough=no comment="DIRECT -DOWN" disabled=no
    add chain=output out-interface=ether2 dst-address=192.168.0.0/24 \
    action=mark-packet new-packet-mark=down-direct passthrough=no \
    comment="DOWN-PROXY" disabled=no
    add chain=prerouting in-interface=pppoe-speedy dst-address-list=nice \
    action=mark-connection new-connection-mark=iix-con passthrough=yes \
    comment="TEST IIX" disabled=yes
    add chain=prerouting in-interface=pppoe-speedy connection-mark=iix-con \
    src-address-list=nice action=mark-connection new-connection-mark=iix-con \
    passthrough=yes comment="" disabled=yes
    add chain=prerouting connection-mark=iix-con action=mark-packet \
    new-packet-mark=iix-paket passthrough=no comment="" disabled=yes
    add chain=prerouting src-address-list=!nice action=mark-connection \
    new-connection-mark=int-con passthrough=yes comment="TEST-IIX" \
    disabled=yes
    add chain=prerouting dst-address-list=!nice action=mark-connection \
    new-connection-mark=int-con passthrough=yes comment="" disabled=yes
    add chain=prerouting connection-mark=int-con action=mark-packet \
    new-packet-mark=int-paket passthrough=no comment="" disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.2 \
    action=mark-packet new-packet-mark=personal-up passthrough=no \
    comment="UP-MANGLE" disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.12 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.3 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.4 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.5 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.6 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.7 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.125 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.8 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.9 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.10 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.11 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.13 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=prerouting in-interface=ether2 src-address=192.168.0.14 \
    action=mark-packet new-packet-mark=personal-up passthrough=no comment="" \
    disabled=yes
    add chain=forward src-address=192.168.0.2 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="DOWN-MANGLE" \
    disabled=yes
    add chain=forward src-address=192.168.0.12 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.3 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.4 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.5 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.6 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.125 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.7 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.8 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.9 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.10 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.11 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.13 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward src-address=192.168.0.14 action=mark-connection \
    new-connection-mark=personal-conn passthrough=yes comment="" disabled=yes
    add chain=forward in-interface=pppoe-speedy connection-mark=personal-conn \
    action=mark-packet new-packet-mark=personal-down passthrough=no comment="" \
    disabled=yes
    add chain=prerouting action=mark-packet new-packet-mark=all passthrough=no \
    comment="" disabled=yes

  8. #8
    Status
    Offline
    okto_2005's Avatar
    Member Super Senior
    Join Date
    Jul 2007
    Posts
    655
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ouhhh kok gado gado gitu mo buat pemisahan bw iix-ix sama pcq mo dishare rata???? kalo mangle gitu ga bisa bro........ kalo mo dibuat pemisahan bandwidth iix-ix sama share pcq gitu ada caranya sendiri....

    gue udah buat di thread tuts, hasil dari wikinya mikrotik. cuman harus disesuaiin dulu sama address-listnya indo.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [ask] failover load balance
    By iannilianto in forum General Networking
    Replies: 15
    Last Post: 29-05-2011, 18:33
  2. Replies: 40
    Last Post: 23-02-2010, 15:27
  3. mohon pencerahan AP mikrotik nih ..
    By jurigjarian in forum Wireless Networking
    Replies: 5
    Last Post: 04-07-2008, 16:20
  4. Mohon bantuannya
    By sonny in forum Beginner Basics
    Replies: 5
    Last Post: 08-11-2007, 22:33
  5. Mohon pemcerahan dung
    By steve_luck_boy in forum General Networking
    Replies: 11
    Last Post: 06-07-2007, 07:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •