Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2
  1. #1
    Status
    Offline
    Prabu_yudistira's Avatar
    Baru Gabung
    Join Date
    Mar 2014
    Posts
    2
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    pemisahan BW download, streaming dan browsing tidak berjalan sempurna

    Dear rekan mikrotikers

    saya mau tanya soal pembagian traffic di queue tree. traffic download, streaming dan browsing sudah di tentukan besaran bandwidthnya tetapi pada prakteknya, streaming dan download masih berjalan di satu jalur (browsing). begitu juga downloadnya

    Click here to enlarge


    berikut scriptnya,barangkali ada kesalahan mohon bantuan dikoreksi. makasih

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="CONNECTION-IN" disabled=no dst-address-list=!MikroTik in-interface=SPEEDY new-connection-mark=All-Inconn passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=All-Inconn disabled=no new-packet-mark=All-inpkt passthrough=yes
    add action=mark-connection chain=forward comment="CONNECTION-OUT" disabled=no new-connection-mark=All-Outconn out-interface=LAN passthrough=yes
    add action=mark-packet chain=forward comment="" connection-mark=All-Outconn disabled=no new-packet-mark=All-Outpkt passthrough=yes
    /queue tree
    add name=All-Bandwidth parent=global-out packet-mark=All-Outpkt queue=default priority=1 max-limit=1M
    /ip firewall mangle
    add action=mark-connection chain=forward comment="Billing" disabled=no dst-address=192.168.10.120 new-connection-mark=Billing-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark=Billing-pkt passthrough=yes connection-mark=Billing-conn
    add action=mark-connection chain=forward comment="Client1" disabled=no dst-address=192.168.10.111 new-connection-mark=Client1-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark=Client1-pkt passthrough=yes connection-mark=Client1-conn
    add action=mark-connection chain=forward comment="Client2" disabled=no dst-address=192.168.10.112 new-connection-mark=Client2-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark=Client2-pkt passthrough=yes connection-mark=Client2-conn
    add action=mark-connection chain=forward comment="Client3" disabled=no dst-address=192.168.10.113 new-connection-mark=Client3-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark=Client3-pkt passthrough=yes connection-mark=Client3-conn
    add action=mark-connection chain=forward comment="Client4" disabled=no dst-address=192.168.10.114 new-connection-mark=Client4-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark=Client4-pkt passthrough=yes connection-mark=Client4-conn
    add action=mark-connection chain=forward comment="Client5" disabled=no dst-address=192.168.10.115 new-connection-mark=Client5-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark=Client5-pkt passthrough=yes connection-mark=Client5-conn
    add action=mark-connection chain=forward comment="Client6" disabled=no dst-address=192.168.10.116 new-connection-mark=Client6-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark=Client6-pkt passthrough=yes connection-mark=Client6-conn
    add action=mark-connection chain=forward comment="Client7" disabled=no dst-address=192.168.10.117 new-connection-mark=Client7-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark= Client7-pkt passthrough=yes connection-mark=Client7-conn
    add action=mark-connection chain=forward comment="Client8" disabled=no dst-address=192.168.10.118 new-connection-mark=Client8-conn passthrough=yes connection-mark=All-Outconn
    add action=mark-packet chain=forward comment="" new-packet-mark= Client8-pkt passthrough=yes connection-mark=Client8-conn


    /queue tree
    add name=Billing parent=All-Bandwidth packet-mark=Billing-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name=Client1 parent=All-Bandwidth packet-mark=Client1-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name=Client2 parent=All-Bandwidth packet-mark=Client2-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name=Client3 parent=All-Bandwidth packet-mark=Client3-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name=Client4 parent=All-Bandwidth packet-mark=Client4-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name=Client5 parent=All-Bandwidth packet-mark=Client5-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name=Client6 parent=All-Bandwidth packet-mark=Client6-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name=Client7 parent=All-Bandwidth packet-mark=Client7-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name=Client8 parent=All-Bandwidth packet-mark=Client8-pkt queue=default priority=1 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s

    /ip firewall layer7-protocol
    add comment="" name=download regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|flv|mkv|a vi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"

    /ip firewall mangle
    add comment=Billing-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=billing-dpkt passthrough=no connection-mark=Billing-conn
    add comment=Client1-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client1-dpkt passthrough=no connection-mark=Client1-conn
    add comment=Client2-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client2-dpkt passthrough=no connection-mark=Client2-conn
    add comment=Client3-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client3-dpkt passthrough=no connection-mark=Client3-conn
    add comment=Client4-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client4-dpkt passthrough=no connection-mark=Client4-conn
    add comment=Client5-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client5-dpkt passthrough=no connection-mark=Client5-conn
    add comment=Client6-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client6-dpkt passthrough=no connection-mark=Client6-conn
    add comment=Client7-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client7-dpkt passthrough=no connection-mark=Client7-conn
    add comment=Client8-Down chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client8-dpkt passthrough=no connection-mark=Client8-conn


    /queue tree
    add name=Billing-Down parent=Billing packet-mark=billing-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
    add name=Client1-Down parent=Client1 packet-mark=client1-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
    add name=Client2-Down parent=Client2 packet-mark=client2-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
    add name=Client3-Down parent=Client3 packet-mark=client3-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
    add name=Client4-Down parent=Client4 packet-mark=client4-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
    add name=Client5-Down parent=Client5 packet-mark=client5-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
    add name=Client6-Down parent=Client6 packet-mark=client6-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
    add name=Client7-Down parent=Client7 packet-mark=client7-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
    add name=Client8-Down parent=Client8 packet-mark=client8-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s

    /ip firewall layer7-protocol
    add comment="" name=streaming regexp="^.*get.+\\.(c.youtube.com|cdn.dailymotion. com|metacafe.com|mccont.com).*\$"

    /ip firewall mangle
    add comment=Billing-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=billing-spkt passthrough=no connection-mark=Billing-conn
    add comment=Client1-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client1-spkt passthrough=no connection-mark=Client1-conn
    add comment=Client2-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client2-spkt passthrough=no connection-mark=Client2-conn
    add comment=Client3-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client3-spkt passthrough=no connection-mark=Client3-conn
    add comment=Client4-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client4-spkt passthrough=no connection-mark=Client4-conn
    add comment=Client5-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client5-spkt passthrough=no connection-mark=Client5-conn
    add comment=Client6-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client6-spkt passthrough=no connection-mark=Client6-conn
    add comment=Client7-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client7-spkt passthrough=no connection-mark=Client7-conn
    add comment=Client8-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client8-spkt passthrough=no connection-mark=Client8-conn


    /queue tree
    add name=Billing-Streams parent=Billing packet-mark=billing-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client1-Streams parent=Client1 packet-mark=client1-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client2-Streams parent=Client2 packet-mark=client2-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client3-Streams parent=Client3 packet-mark=client3-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client4-Streams parent=Client4 packet-mark=client4-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client5-Streams parent=Client5 packet-mark=client5-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client6-Streams parent=Client6 packet-mark=client6-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client7-Streams parent=Client7 packet-mark=client7-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client8-Streams parent=Client8 packet-mark=client8-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s

    /ip firewall mangle
    add action=mark-connection chain=forward new-connection-mark=Game-conn out-interface=LAN passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 comment="Online Game Portal"
    add action=mark-connection chain=forward new-connection-mark=Game-conn out-interface=LAN passthrough=yes protocol=tcp dst-port=39190,27780,29000,22100,10009,4300,15001,1500 2,7341,7451
    add action=mark-connection chain=forward new-connection-mark=Game-conn out-interface=LAN passthrough=yes protocol=tcp dst-port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822
    add action=mark-connection chain=forward new-connection-mark=Game-conn out-interface=LAN passthrough=yes protocol=tcp dst-port=47611,16666,20000,5105,29000,18901-18909,9015
    add action=mark-connection chain=forward new-connection-mark=Game-conn out-interface=LAN passthrough=no protocol=udp dst-port=27005,27015
    add action=mark-connection chain=forward new-connection-mark=Game-conn out-interface=LAN passthrough=no protocol=udp dst-port=27005-27020,13055,7800-7900,12060-12070
    add action=mark-connection chain=forward new-connection-mark=Game-conn out-interface=LAN passthrough=no protocol=udp dst-port=8005-8010,9068,1293,1479,9401,9600,30000
    add action=mark-connection chain=forward new-connection-mark=Game-conn out-interface=LAN passthrough=no protocol=udp dst-port=14009-14030,42051-42052,40000-40050,13000-13080

    /ip firewall mangle
    add action=mark-packet chain=forward new-packet-mark=billing-gpkt passthrough=no src-address=192.168.10.120 connection-mark=Game-conn comment=Billing-Game
    add action=mark-packet chain=forward new-packet-mark=client1-gpkt passthrough=no src-address=192.168.10.111 connection-mark=Game-conn comment=Client1-Game
    add action=mark-packet chain=forward new-packet-mark=client2-gpkt passthrough=no src-address=192.168.10.112 connection-mark=Game-conn comment=Client2-Game
    add action=mark-packet chain=forward new-packet-mark=client3-gpkt passthrough=no src-address=192.168.10.113 connection-mark=Game-conn comment=Client3-Game
    add action=mark-packet chain=forward new-packet-mark=client4-gpkt passthrough=no src-address=192.168.10.114 connection-mark=Game-conn comment=Client4-Game
    add action=mark-packet chain=forward new-packet-mark=client5-gpkt passthrough=no src-address=192.168.10.115 connection-mark=Game-conn comment=Client5-Game
    add action=mark-packet chain=forward new-packet-mark=client6-gpkt passthrough=no src-address=192.168.10.116 connection-mark=Game-conn comment=Client6-Game
    add action=mark-packet chain=forward new-packet-mark=client7-gpkt passthrough=no src-address=192.168.10.117 connection-mark=Game-conn comment=Client7-Game
    add action=mark-packet chain=forward new-packet-mark=client8-gpkt passthrough=no src-address=192.168.10.118 connection-mark=Game-conn comment=Client8-Game

    /queue tree
    add name=Billing-Game parent=Billing packet-mark=billing-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client1-Game parent=Client1 packet-mark=client1-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client2-Game parent=Client2 packet-mark=client2-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client3-Game parent=Client3 packet-mark=client3-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client4-Game parent=Client4 packet-mark=client4-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client5-Game parent=Client5 packet-mark=client5-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client6-Game parent=Client6 packet-mark=client6-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client7-Game parent=Client7 packet-mark=client7-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
    add name=Client8-Game parent=Client8 packet-mark=client8-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s

    /ip firewall mangle
    add action=mark-connection chain=forward comment="BILLING-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Billing-bconn connection-mark=Billing-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=billing-bpkt packet-mark=!billing-spkt,billing-dpkt,billing-gpkt passthrough=no connection-mark=Billing-conn
    add action=mark-connection chain=forward comment="CLIENT1-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Client1-bconn connection-mark=Client1-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=client1-bpkt packet-mark=!client1-spkt,client1-dpkt,client1-gpkt passthrough=no connection-mark=Client1-conn
    add action=mark-connection chain=forward comment="CLIENT2-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Client2-bconn connection-mark=Client2-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=client2-bpkt packet-mark=!client2-spkt,client2-dpkt,client2-gpkt passthrough=no connection-mark=Client2-conn
    add action=mark-connection chain=forward comment="CLIENT3-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Client3-bconn connection-mark=Client3-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=client3-bpkt packet-mark=!client3-spkt,client3-dpkt,client3-gpkt passthrough=no connection-mark=Client3-conn
    add action=mark-connection chain=forward comment="CLIENT4-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Client4-bconn connection-mark=Client4-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=client4-bpkt packet-mark=!client4-spkt,client4-dpkt,client4-gpkt passthrough=no connection-mark=Client4-conn
    add action=mark-connection chain=forward comment="CLIENT5-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Client5-bconn connection-mark=Client5-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=client5-bpkt packet-mark=!client5-spkt,client5-dpkt,client5-gpkt passthrough=no connection-mark=Client5-conn
    add action=mark-connection chain=forward comment="CLIENT6-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Client6-bconn connection-mark=Client6-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=client6-bpkt packet-mark=!client6-spkt,client6-dpkt,client6-gpkt passthrough=no connection-mark=Client6-conn
    add action=mark-connection chain=forward comment="CLIENT7-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Client7-bconn connection-mark=Client7-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=client7-bpkt packet-mark=!client7-spkt,client7-dpkt,client7-gpkt passthrough=no connection-mark=Client7-conn
    add action=mark-connection chain=forward comment="CLIENT8-BROWSING-CONN" connection-bytes=0-1000000 dst-port=80,443 passthrough=no protocol=tcp new-connection-mark=Client8-bconn connection-mark=Client8-conn
    add action=mark-packet chain=forward comment="" new-packet-mark=client8-bpkt packet-mark=!client8-spkt,client8-dpkt,client8-gpkt passthrough=no connection-mark=Client8-conn

    /queue tree
    add name="Billing-Browsing" parent=Billing packet-mark=billing-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name="Client1-Browsing" parent=Client1 packet-mark=client1-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name="Client2-Browsing" parent=Client2 packet-mark=client2-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name="Client3-Browsing" parent=Client3 packet-mark=client3-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name="Client4-Browsing" parent=Client4 packet-mark=client4-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name="Client5-Browsing" parent=Client5 packet-mark=client5-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name="Client6-Browsing" parent=Client6 packet-mark=client6-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name="Client7-Browsing" parent=Client7 packet-mark=client7-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
    add name="Client8-Browsing" parent=Client8 packet-mark=client8-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s

  2. #2
    Status
    Offline
    patrick's Avatar
    Newbie
    Join Date
    Jun 2010
    Posts
    60
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0


    Last edited by patrick; 27-05-2014 at 13:52.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tampilan yahoo tidak sempurna
    By choera in forum Beginner Basics
    Replies: 2
    Last Post: 02-12-2013, 12:15
  2. Nanya cara limit download,streaming
    By Berry_MT in forum General Networking
    Replies: 12
    Last Post: 13-11-2013, 21:21
  3. [ASK] setting prioritas PING tidak sempurna
    By atut in forum General Networking
    Replies: 15
    Last Post: 07-09-2012, 09:50
  4. Replies: 2
    Last Post: 30-08-2012, 22:43
  5. NAT tidak berjalan semestinya..
    By andriputra in forum Beginner Basics
    Replies: 4
    Last Post: 05-02-2011, 21:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •