topologi :

speedy1-------(192.168.2.1) vlan1(192.168.5.1)(karyawan)
speedy2-------(192.168.3.1)--------(load balancing)-----vlan2(192.168.6.1)(mhs)
speedy3-------(192.168.4.1)
bagaimana konfigurasi yang tepat agar load balancing 3 line dapat berjalan dengan baik pada jaringan hotspot dan vlan seperti topologi di atas?
apakah konfigurasi di bawah ini sudah betul? mohon pencerahan para mastah.

maaf kk mastah semua, baru pertama kali posting d forum Click here to enlarge

----Konfigurasi Router Mikotik --------

Nama interface :
/interface set ether1 name=speedy1
/interface set ether2 name=speedy2
/interface set ether3 name=speedy3
/interface set ether3 name=lan

Ip address :
/ip address add address=192.168.1.1/24 interface=lan
/ip address add address=192.168.2.2/29 interface=speedy1
/ip address add address=192.168.3.2/29 interface=speedy2
/ip address add address=192.168.4.2/29 interface=speedy3


/ip dns set servers=203.134.193.74,202.134.0.155

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 distance=2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 distance=2 check-gateway=ping


/ip firewall nat
add action=masquerade chain=srcnat out-interface=speedy1
add action=masquerade chain=srcnat out-interface=speedy2
add action=masquerade chain=srcnat out-interface=speedy3




/ip firewall address-list
add address=192.168.2.0/29 list=lokal
add address=192.168.3.0/29 list=lokal
add address=192.168.4.0/29 list=lokal
add address=192.168.1.0/24 list=lokal

/ip firewall mangle
add action=accept chain=prerouting dst-address-list=lokal in-interface=lan comment=”trafik lokal”
add action=accept chain=output dst-address-list=lokal

/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=speedy1 new-connection-mark=con-from-isp1 passthrough=yes comment=”trafik dari isp1”
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=speedy2 new-connection-mark=con-from-isp2 passthrough=yes comment=”trafik dari isp2”
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=speedy3 new-connection-mark=con-from-isp3 passthrough=yes comment=”trafik dari isp3”

/ip firewall mangle
add action=jump chain=prerouting comment=”lompat ke client-lb” connection-mark=no-mark in-interface=lan jump-target=client-lb
/ip firewall mangle
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:6/0 comment=”awal loadbalancing klien”
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:6/1
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:6/2
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=both-addresses:6/3
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=both-addresses:6/4
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp3 passthrough=yes per-connection-classifier=both-addresses:6/5
add action=return chain=client-lb comment=”akhir dari loadbalancing”

mangle mark-route
/ip firewall mangle
add action=jump chain=prerouting comment=”marking route client” connection-mark=!no-mark in-interface=lan jump-target=route-client
add action=mark-routing chain=route-client connection-mark=to-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=to-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=mark-routing chain=route-client connection-mark=to-isp3 new-routing-mark=route-to-isp3 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp3 new-routing-mark=route-to-isp3 passthrough=no
add action=return chain=route-client disabled=no

routing dengan backup gateway
/ip route
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=route-to-isp1 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=route-to-isp1 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=route-to-isp1 distance=3
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=route-to-isp2 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=route-to-isp2 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=route-to-isp2 distance=3
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=route-to-isp3 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=route-to-isp3 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=route-to-isp3 distance=3


bandwidth management untuk hotspot

/ip firewall mangle
add chain=prerouting action=jump jump-target=hotspot comment=”Hotspot Jump Mangle”
add chain=postrouting action=jump jump-target=hotspot
add chain=prerouting action=mark-connection new-connection-mark=conn-up passthrough=yes dst-address=192.168.10.0/24 comment=”Hotspot Connections”
add chain=postrouting action=mark-connection new-connection-mark=conn-down passthrough=yes src-address=192.168.10.0/24
add chain=prerouting action=mark-packet new-packet-mark=packet-up passthrough=yes connection-mark=conn-up comment=”Hotspot Packets”
add chain=postrouting action=mark-packet new-packet-mark=packet-down passthrough=yes connection-mark=conn-down
add chain=prerouting action=mark-packet new-packet-mark=hotspot-up passthrough=no connection-mark=conn-up
add chain=postrouting action=mark-packet new-packet-mark=hotspot-down passthrough=no connection-mark=conn-down
layer 7
ip firewall layer7-protocol
add name=Download regexp=”^.*(get|GET).+\\.(exe|rar|zip|7z|cab|asf|m ov|wmv|mpg|mpeg|mkv|avi|flv|pdf|wav|rm|mp3|mp4|ram |rmvb|dat|daa|iso|nrg|bin|vcd|mp2|3gp|mpe|qt|raw|w ma|ogg|doc|deb|tar|bzip|gzip|gzip2|0[0-1][0-1]).*\$”
add name=Facebook regexp=”^.*get.+.facebook.com.*\$|^.*get.+.zynga.c om.*\$|^.*get.+.fbcdn.net.*\$”
add name=Youtube regexp=”^.*get.+.c.youtube.com.*\$”

mangle layer 7
/ip firewall mangle
add chain=hotspot action=mark-packet new-packet-mark=facebook passthrough=no protocol=tcp layer7-protocol=Facebook comment=”Facebook”
add chain=hotspot action=mark-packet new-packet-mark=youtube passthrough=no protocol=tcp layer7-protocol=Youtube comment=”Youtube”
add chain=hotspot action=mark-packet new-packet-mark=download passthrough=no protocol=tcp layer7-protocol=Download comment=”Download”

Queue type
add name=”pcq-down” kind=pcq pcq-rate=1M pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000 pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-src-address-mask=32 pcq-dst-address-mask=32 pcq-src-address-mask=64 pcq-dst-address6-mask=64
add name=”pcq-up” kind=pcq pcq-rate=1M pcq-limit=50 pcq-classifier=src-address pcq-total-limit=2000 pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-src-address-mask=32 pcq-dst-address-mask=32 pcq-src-address6-mask=64 pcq-dst-address6-mask=64

queue tree
/queue tree
add name=”Hotspot Down” parent=global-out packet-mark=”" limit-at=0 priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
add name=”Hotspot Up” parent=global-in packet-mark=”" limit-at=0 priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
add name=”Hotspot Browsing” parent=”Hotspot Down” packet-mark=hotspot-down limit-at=256k queue=pcq-down priority=2 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
add name=”Hotspot Facebook” parent=”Hotspot Down” packet-mark=facebook limit-at=256k queue=pcq-down priority=2 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
add name=”Hotspot Youtube” parent=”Hotspot Down” packet-mark=youtube limit-at=128k queue=pcq-down priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
add name=”Hotspot Download” parent=”Hotspot Down” packet-mark=download limit-at=128k queue=pcq-down priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s
add name=”Hotspot Upload” parent=”Hotspot Up” packet-mark=hotspot-up limit-at=256k queue=pcq-up priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0sueue tree nya

pembuatan vlan pada mikrotik
/interface vlan
add arp=enabled disabled=no interface=lan l2mtu=1516 mtu=1500 name=\
manajemen use-service-tag=no vlan-id=10
add arp=enabled disabled=no interface=lan l2mtu=1516 mtu=1500 name=\
mhs use-service-tag=no vlan-id=20
add arp=enabled disabled=no interface=lan l2mtu=1516 mtu=1500 name=\
karyawan use-service-tag=no vlan-id=30
add arp=enabled disabled=no interface=lan l2mtu=1516 mtu=1500 name=\
no-inet use-service-tag=no vlan-id=40