Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 4 of 4
  1. #1
    Status
    Offline
    romariun's Avatar
    Baru Gabung
    Join Date
    Jul 2010
    Posts
    4
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Mekanisme perjalanan paket data

    Curhat sikit gan, saya baru membaca buku panduan mikrotik yg di tulis oleh saudara Rendra Towidjojo terbitan Jasakom (baru kluar kitab 1 dan kitab 2, ditunggu edisi selanjutnya gan...). Menurut saya buku itu sangat bagus karena memberikan pemahaman secara mendetil tentang panduan/option2 yg ada pada mikrotik. Nah disini aku ada yg kurang jelas sebenarnya, mau nanya ke mas rendranya ga tau cara konteknya, kalo tau YMnya kan enak... Karena itu aku jadi nanya di forum ini, mungkin agan2 yg dah mahir bs memberi penjelasan.

    Kasusnya begini: Ini berkaitan dengan cara marking connection/paket
    Topologinya kira2 seperti ini :Click here to enlarge

    Tampak pada gambar router menggunakan PC, sehingga internal proxynya aktif. Bagaimana cara marking position yg bener sesuai alur perjalanan data?
    Maka kita lihat dulu bagaimana perjalanan sebuah paket data dengan topologi seperti itu.
    - Asumsi ip address telah di deklarasi pada masing2 interface router:
    /ip address add address=192.168.1.3/24 interface=eth0
    /ip address add address=10.35.1.250/254 interface=eth1
    - Routing ke internet dengan menambah baris perintah berikut:
    /ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1
    - Setting DNS supaya dapat menerjemahkan nama domain menjadi sederetan no IP Public
    /ip DNS set address=xxx.xxx.xxx.xxx,xxx.xxx.xxx.xxx
    kondisi sekarang router telah konek ke internet, tapi client belum maka ditambah 1 rule NAT:
    /ip firewall nat add chain=srcnat out-interface=eth1 action=masquerade

    Proxy belum di aktifkan.
    Saya belum bahas konfigurasi manglenya utk menandai paket2 yg lalu lalang, ini pertanyaan pertama utk kita bahas: rule dgn nat seperti itu bagai mana mekanisme sebenarnya perjalanan paket datanya?
    Andaikan client 1 dgn ip 10.35.1.1 browsing google(ip google = 110.232.86.29), mekanismenya awalnya client 1 mengirim paket data request dgn parameter2 sbb: src-address=10.35.1.1, dst-address=110.232.86.29, protocol=tcp/ip, dst-port=80 ke router melalui interface eth1. Setelah itu karena rule NAT itu, router mengubah parameter src-address dari 10.35.1.1 menjadi 192.168.1.3, parameter lain tidak diubah, kemudian paket data request itu dikirim ke modem.
    Nah yg saya tidak jelas bagaimana sebenarnya paramater2 paket data responsenyasrc-addressnya dan dst-addressnya.

    Ayo suhu2 bantu saya baru bisa melaju ke pertanyaan keduanya dan konf. manglenya.
    Last edited by romariun; 17-08-2013 at 04:47.

  2. #2
    Status
    Offline
    romariun's Avatar
    Baru Gabung
    Join Date
    Jul 2010
    Posts
    4
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Pertanyaan pertama saya itu sangat mendasar lohh, krn akan menentukan bagaimana cara membuat marking datanya/ menandai paketnya.

  3. #3
    Status
    Offline
    Anto.PJ's Avatar
    Forum Guru
    Join Date
    May 2011
    Location
    macz
    Posts
    1,696
    Reviews
    Read 0 Reviews
    Downloads
    7
    Uploads
    0
    Feedback Score
    0
    itu namanya packet forwarding..
    10.35.1.1--->110.232.86.29

    contoh ip publik ente : 202.101.44.55
    protokol HTTP:
    10.35.1.5:7745-->192.168.1.3:36045(route via gateway 10.35.1.1)-->202.101.44.55:22473(NAT)-----------> 110.232.86.29:80

    110.232.86.29:80--------> 202.101.44.55:22473 --> 192.168.1.3:36045(NAT) -->10.35.1.5:7745(route via gateway 10.35.1.1).. selesai.

    110.232.86.29 bisa berkomunikasi langsung dengan 202.101.44.55 karena sama2 ip publik
    tapi tidak bisa komunikasi langsung dengan 10.35.1.5, karena itu ip privat.
    pelajari NAT

  4. #4
    Status
    Offline
    RendraT's Avatar
    Baru Gabung
    Join Date
    Jun 2012
    Posts
    15
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    nggak sengaja googling, nemu pertanyaan ini, untuk menjelaskan masalah src-nat atau alur packet, sebenarnya kita harus melihat dari diagram packet flow dari mikrotik (kernel linux), untuk buku kitab 1 dan 2 saya sengaja tidak memasukkan bahasan ini, takutnya akan membuat rumit buku tersebut, buku kitab 1 dan 2 memang dirancang untuk pemula.

    Untuk kitab 3 akan sy bahas lebih mendalam ttg konsep dari traffic control pada router mikrotik, lengkap dengan ip flow, sehingga bisa menentukan di mana akan melakukan mangle, di mana akan melakukan queue....

    regards
    Rendra Towidjojo
    (rtowidjojo@gmail.com)
    Last edited by RendraT; 13-09-2013 at 16:21.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 04-03-2013, 20:42
  2. Paket Umroh Murah 2011 & Biro Perjalanan Haji Plus 2011
    By riyadiyo in forum Lapak serba-serbi
    Replies: 0
    Last Post: 28-02-2011, 15:22
  3. Ask : Mekanisme membangun Infrastruktur IDC Di cyber
    By originalrapidshare in forum ISP / Network Link
    Replies: 5
    Last Post: 05-09-2010, 12:44
  4. Paket data Loss Heellllpppp
    By harryarifin79 in forum Beginner Basics
    Replies: 2
    Last Post: 13-06-2010, 03:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •