Salam kenal,

Saya dihadapkan permasalahan jaringan di tempat kerja. Di kantor ada 3 koneksi internet, dan setiap bagian di kantor memiliki subnet jaringan masing2.
Berikut diagram topologi jaringan yang ada:
Click here to enlarge

Untuk mengatur kelancaran berinternet saya berniat untuk membagi koneksi internet.
Subnet 1 dan 2 menggunakan gateway line speedy 1,
Subnet 3 dan 4 menggunakan gateway line speedy 2,
Subnet 5 dan 6 menggunakan gateway line fastnet.

Saya coba menerapkan metode yang ada di
Setting mikrotik untuk routing LAN lokal sudah dilakukan dan ditest dengan melakukan PING dari masing masing subnet hingga ping ke modem speedy line 1 dan 2.
Saat ini setting yang berhasil dilakukan di R01 hanya menggunakan default gateway ke salah satu ISP saja.

Berikut setting yang sudah diterapkan:
Pada R01:
Code:
/ip firewall mangle
add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=Route-SUBNET1 passthrough=no src-address=192.168.1.0/24
add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=Route-SUBNET2 passthrough=no src-address=192.168.2.0/24
add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=Route-SUBNET3 passthrough=no src-address=192.168.3.0/24
add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=Route-SUBNET4 passthrough=no src-address=192.168.4.0/24
add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=Route-SUBNET5 passthrough=no src-address=192.168.5.0/24
add action=mark-routing chain=prerouting comment="" disabled=no \
    new-routing-mark=Route-SUBNET6 passthrough=no src-address=192.168.6.0/24
Code:
/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    10.0.1.1 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    10.0.1.1 routing-mark=Route-SUBNET1 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    10.0.1.1 routing-mark=Route-SUBNET2 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    10.0.2.1 routing-mark=Route-SUBNET3 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    10.0.2.1 routing-mark=Route-SUBNET4 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    99.99.99.1 routing-mark=Route-SUBNET5 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    99.99.99.1 routing-mark=Route-SUBNET6 scope=30 target-scope=10
Sedangkan pada R02 dan R03 tidak dilakukan setting apapun kecuali routing statis untuk ke subnet lain atau subnet modem speedy.

Yang jadi pertanyaan kenapa seluruh koneksi masih menggunakan koneksi dari line speedy 1 untuk semua subnet?
Dan jika default gateway yang ada di R01 saya disable atau hapus maka seluruh internet akan mati.

regards,
ayrus02

NB: Maaf mungkin saya termasuk newbie di mikrotik. mohon bantuan master-master mikrotik di sini.