Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 4 of 4
  1. #1
    zulfa_inanda
    zulfa_inanda's Avatar

    Smile Queue Tree gabung Load balancing gimana gan??

    Maap para master ane mohon bantuannya,
    ane lagi bikin Tugas Akhir tentang konfigurasi queue tree pada PC Router Mikrotik yang udah di konfigurasiin load balancing,
    konfigurasi LB nya gini gan..:


    01 /ip address
    02 add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
    03
    add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
    04
    add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
    05
    add address=192.168.3.2/24 network=192.168.3.0 broadcast=192.168.3.255 interface=WAN3
    06
    add address=192.168.4.2/24 network=192.168.4.0 broadcast=192.168.4.255 interface=WAN4
    07

    08
    /ip firewall mangle
    09
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    10
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
    11
    add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=WAN3_conn
    12
    add chain=input in-interface=WAN4 action=mark-connection new-connection-mark=WAN4_conn
    13

    14
    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    15
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
    16
    add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
    17
    add chain=output connection-mark=WAN4_conn action=mark-routing new-routing-mark=to_WAN4
    18

    19
    add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
    20
    add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
    21
    add chain=prerouting dst-address=192.168.3.0/24 action=accept in-interface=Local
    22
    add chain=prerouting dst-address=192.168.4.0/24 action=accept in-interface=Local
    23

    24
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    25
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
    26
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/2 action=mark-connection new-connection-mark=WAN3_conn passthrough=yes
    27
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/3 action=mark-connection new-connection-mark=WAN4_conn passthrough=yes
    28
    add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
    29
    add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
    30
    add chain=prerouting connection-mark=WAN3_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN3
    31
    add chain=prerouting connection-mark=WAN4_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN4
    32

    33
    /ip route
    34
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
    35
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
    36
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_WAN3 check-gateway=ping
    37
    add dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=to_WAN4 check-gateway=ping
    38

    39
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
    40
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
    41
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 distance=3 check-gateway=ping
    42
    add dst-address=0.0.0.0/0 gateway=192.168.4.1 distance=4 check-gateway=ping
    43

    44
    /ip firewall nat
    45
    add chain=srcnat out-interface=WAN1 action=masquerade
    46
    add chain=srcnat out-interface=WAN2 action=masquerade
    47
    add chain=srcnat out-interface=WAN3 action=masquerade
    48
    add chain=srcnat out-interface=WAN4 action=masquerade



    Konfigurasi Untuk Queue tree gini gan :

    /mangel

    //(menangkap semua traffic/koneksi untuk semua client)

    add chain=forward action=mark-connection new-connection-mark=all-internet passthrough=yes dst-address=192.168.0.2-192.168.0.50
    add chain=forward action=mark-packet new-packet-mark=all-internet passthrough=no connection-mark=all-internet

    (menangkap semua traffic/koneksi client satu persatu)

    add chain=forward action=mark-connection new-connection-mark=client1 passthrough=yes dst-address=192.168.0.2
    add chain=forward action=mark-packet new-packet-mark=client1 passthrough=no connection-mark=client1

    add chain=forward action=mark-connection new-connection-mark=client2 passthrough=yes dst-address=192.168.0.3
    add chain=forward action=mark-packet new-packet-mark=client2 passthrough=no connection-mark=client2


    add chain=forward action=mark-connection new-connection-mark=client3 passthrough=yes dst-address=192.168.0.4
    add chain=forward action=mark-packet new-packet-mark=client3 passthrough=no connection-mark=client3


    add chain=forward action=mark-connection new-connection-mark=client4 passthrough=yes dst-address=192.168.0.5
    add chain=forward action=mark-packet new-packet-mark=client4 passthrough=no connection-mark=client4


    add chain=forward action=mark-connection new-connection-mark=client5 passthrough=yes dst-address=192.168.0.6
    add chain=forward action=mark-packet new-packet-mark=client5 passthrough=no connection-mark=client5


    add chain=forward action=mark-connection new-connection-mark=client6 passthrough=yes dst-address=192.168.0.7
    add chain=forward action=mark-packet new-packet-mark=client6 passthrough=no connection-mark=client6

    /queue tree

    //membuat parent untuk client :

    add name="all-internett" parent=global-out packet-mark=all-internet limit-at=0 queue=default priority=8 max-limit=3072000

    (membatasi bandwidth per client)

    add name="client1" parent=all-internet packet-mark=client1 limit-at=256000 queue=default priority=3 max-limit=3072000
    add name="client2" parent=all-internet packet-mark=client2 limit-at=256000 queue=default priority=3 max-limit=3072000
    add name="client3" parent=all-internet packet-mark=client3 limit-at=256000 queue=default priority=3 max-limit=3072000
    add name="client4" parent=all-internet packet-mark=client4 limit-at=256000 queue=default priority=3 max-limit=3072000
    add name="client5" parent=all-internet packet-mark=client5 limit-at=256000 queue=default priority=3 max-limit=3072000
    add name="client6" parent=all-internet packet-mark=client6 limit-at=256000 queue=default priority=3 max-limit=3072000


    masalahnya gini gan :

    kalo dikonfigurasi kayak diatas, clientnya ga bisa masuk ke queue nya gan (maksudnya ga ada banwidth yang jalan pada average nya), baik pada mangel ataupun queue tree nya gan,,

    ane mohon bahentuannya pada para master2,, helep me plisssss,,, Click here to enlarge Click here to enlarge Click here to enlarge Click here to enlarge
    Last edited by zulfa_inanda; 12-12-2012 at 23:01.

  2. #2
    Status
    Offline
    pos_ronda's Avatar
    VIP Member
    Join Date
    Aug 2009
    Location
    Sleman, Indonesia
    Posts
    887
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    coba ganti dst-address jadi src-address.
    Gunakan FreeRadius sebagai pengganti user manager

  3. #3
    Status
    Offline
    Anto.PJ's Avatar
    Forum Guru
    Join Date
    May 2011
    Location
    macz
    Posts
    1,696
    Reviews
    Read 0 Reviews
    Downloads
    7
    Uploads
    0
    Feedback Score
    0
    sekali lagi pelajari packet-flow yg berlaku di mikrotik/linux

    Local-->prerouting(mark-connection=wan1-4)-->postrouting(con-mark=wan1-4, jump=upload)-->upload(mark-packet=client1-6)-->(global-out/interface)queueHTB(1-6)-->WAN1-4
    WAN1-4-->prerouting(con-mark=wan1-4, jump=download)-->download(mark-packet=client1-6)-->(global-out/interface)queueHTB(1-6)--Local

    logis..

  4. The Following User Says Thank You to Anto.PJ For This Useful Post:


  5. #4
    zulfa_inanda
    zulfa_inanda's Avatar
    Click here to enlarge Originally Posted by Anto.PJ Click here to enlarge
    sekali lagi pelajari packet-flow yg berlaku di mikrotik/linux

    Local-->prerouting(mark-connection=wan1-4)-->postrouting(con-mark=wan1-4, jump=upload)-->upload(mark-packet=client1-6)-->(global-out/interface)queueHTB(1-6)-->WAN1-4
    WAN1-4-->prerouting(con-mark=wan1-4, jump=download)-->download(mark-packet=client1-6)-->(global-out/interface)queueHTB(1-6)--Local

    logis..
    Tq Master,

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mohon Koreksinya (Load Balancing dan Queue Tree) NEWBIE
    By brojowl in forum Beginner Basics
    Replies: 7
    Last Post: 23-11-2012, 15:26
  2. membagi bandwith di load balancing menggunakan Queue tree
    By nazief in forum General Networking
    Replies: 3
    Last Post: 02-03-2012, 10:04
  3. Load balancing sederhana+port game+queue tree +simple queue
    By yohanexz in forum General Networking
    Replies: 39
    Last Post: 24-02-2012, 13:34
  4. Replies: 27
    Last Post: 13-08-2010, 12:12
  5. help : queue tree gimana cara nya?
    By flytosky in forum General Networking
    Replies: 4
    Last Post: 17-04-2008, 16:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •