Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 6 of 6
  1. #1
    Status
    Offline
    Mil Dus's Avatar
    Baru Gabung
    Join Date
    Apr 2012
    Posts
    16
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Smile scrip tidak jalan dengan semestinya

    Hallo master,Click here to enlarge

    Ane butuh bantuan ne Click here to enlarge , ane ada setting mikrotik untuk dns auto change nya,
    jadi pada jam 8 pagi sampai 9 malam client mendapat kan dnsnya nawala dan pada jam 9 malam sampai 8pagi memakai dns dari speedy
    ane sudah setting tapi scrip nya tidak berjalan semestinya, di bagian mana nya ya kesalahannya?

    berikut conf yang ane buat.

    saat jam santai, dengan asumsi jam 08.00 - 21.00 WIB memakai Nawala, dan jam 21.00 - 08.00 WIB memakai DNS Telkom lagi.
    Langkah - langkahnya adalah sebagai berikut:

    - Bikin script dulu dengan nama "proteksi" dengan source code seperti dibawah ini:

    /ip dns cache flush
    /ip dns set primary-dns=180.131.144.144
    /ip dns set secondary-dns=180.131.145.145

    - Bikin satu script lagi dengan nama "bebas", source code seperti dibawah ini:

    /ip dns cache flush
    /ip dns set primary-dns=203.130.208.18
    /ip dns set secondary-dns=202.134.1.10

    - Kemudian bikin schedule nya, seperti dibawah ini:

    /system scheduler add name="perlindungan" interval=1d start-time=08:00:00 on-event=proteksi
    /system scheduler add name="pembebasan" interval=1d start-time=21:00:00 on-event=bebas


    untuk DNS client diarahkan ke Mikrotiknya, dan /ip dns di set allow-remote-requests=yes.

  2. #2
    Status
    Offline
    c0nf's Avatar
    Contributor
    Join Date
    Jul 2007
    Location
    Bandung, Indonesia
    Posts
    1,816
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    script schedule nya salah gan. coba jalanin salah satu script (bebas or proteksi) di console.
    Invisible...

  3. #3
    Status
    Offline
    shingchi8's Avatar
    Calon Member
    Join Date
    Dec 2011
    Location
    Negeri Atap Langit
    Posts
    76
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    /ip dns di set allow-remote-requests=yes.
    itu yang jangan dicentang/di-yes om.

  4. #4
    Status
    Offline
    Mil Dus's Avatar
    Baru Gabung
    Join Date
    Apr 2012
    Posts
    16
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by c0nf Click here to enlarge
    script schedule nya salah gan. coba jalanin salah satu script (bebas or proteksi) di console.
    Kalau scrip nya jalan gan,cuman schedule nya saja yg gak berjalan.

  5. #5
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    system clocknya dah bener kan ?? (pake NTP client maksudnya)

    gimana, kalo coba scriptnya gak usah dibuat, tetapi langsung dimasukkan ke schedulernya, jadi seperti ini :
    Code:
    /system scheduler
    add disabled=no interval=0s name=proteksi on-event="/ip dns cache flush\r\
        \n/ip dns set primary-dns=180.131.144.144\r\
        \n/ip dns set secondary-dns=180.131.145.145\r\
        \n" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=jun/19/2012 start-time=08:00:0
    add disabled=no interval=0s name=bebas on-event="/ip dns cache flush\r\
        \n/ip dns set primary-dns=203.130.208.18\r\
        \n/ip dns set secondary-dns=202.134.1.10\r\
        \n" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=jun/19/2012 start-time=21:00:00
    untuk ngeceknya, setting start-timenya diseting sekitar 1 menit sebelum jam sekarang (system clock)..

    CMIIW

  6. #6
    Status
    Offline
    pak-kole's Avatar
    Newbie
    Join Date
    Apr 2012
    Location
    Karawang
    Posts
    66
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge ikutan nyimak om,,, mumpung gi ga ada kerjaan

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [ASK] [HELP] MIKROTIK dengan 5 AP tidak jalan.
    By yekai2000 in forum Wireless Networking
    Replies: 11
    Last Post: 09-05-2012, 17:10
  2. Replies: 1
    Last Post: 07-06-2011, 11:33
  3. sebagain queue tidak jalan dengan semestinya
    By finaliscom in forum Beginner Basics
    Replies: 9
    Last Post: 06-05-2011, 16:48
  4. NAT tidak berjalan semestinya..
    By andriputra in forum Beginner Basics
    Replies: 4
    Last Post: 05-02-2011, 21:02
  5. Replies: 8
    Last Post: 08-11-2008, 09:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •