Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 13 12311 ... LastLast
Results 1 to 15 of 189
  1. #1
    Status
    Offline
    ndasjowo's Avatar
    Member
    Join Date
    Mar 2010
    Location
    Boyolali - Solo - Sragen
    Posts
    267
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    tproxy single interface/ethernet

    lama gak absen nih ...

    disini saya akan coba share ngebuat tpoxy 1 ethernet.
    mungkin temen udah sering/biasa make proxy external.
    tapi pernah kan anda meng-alami kasus di mana baddwith ( yang memang request client) habis kesedot oleh proxy ( yg biasanya proxy posisi los dan client dilimit)
    kenapa bisa terjadi...?
    - Pada saat client melakukan request web/file oleh mikrotik diredirect ke proxy ekternal.
    - jika web/file belum tersedia di cache maka proxy melakukan request ke internet ( dimanaproxy request keinternet los/not shaping). Click here to enlarge
    - karena kondisi file belum ke cache, maka bw yang di teruskan ke-client akan mengikuti shaping di mikrotik.
    - maka akan timbul kejadian aneh ....
    - bandwith yang masuk akan lebih besar ( di sedot proxy) daripada bandwith yang di kirim ke-client ( terlimit mikrotik karena blm posisi hit)
    -
    Udah ngomel nya ....
    lsg ke solusi aja bagaimana ngebuat real shaping ke client
    solosinya kita gunakan tproxy.....!

    topologi jaringan:

    internet => Mikrotik -> client
    . .|.
    . pcbox/tproxy

    Langkah :
    ( di-mikrotik )
    1. buat routing untuk tproxy
    2. buat mangle untuk routing tproxy
    [ code]
    /ip route add dst-address=0.0.0.0/0 gateway=(ip-proxy) routing-mark="VIA_TPROXY";
    /ip firewall mangle add chain=prerouting protocol=tcp dst-port=80 src-address-list="ip-client" dst-address-list="no-proxy" in-interface=(ether-client) action=mark-routing new-routing-mark=VIA_TPROXY;
    /ip firewall mangle add chain=prerouting in-interface=(ether-proxy) action=mark-connection new-connection-mark=VIA_TPROXY;
    /ip firewall add chain=prerouting in-interface=(ether-internet) connection-mark=VIA_TPROXY action=mark-routing new-routing-mark=VIA_TPROXY;
    [/code]

    ( di pcbox/tproxy )
    Syarat :
    kernel dan iptables support tproxy:
    pengecekan ...
    cat /boot/config-2.6.XX `uname -r` | grep -E '(NF_CONNTRACK=|TPROXY|XT_MATCH_SOCKET|XT_TARGET_T PROXY)'
    jika muncul pesen gini berarti support
    Code:
    CONFIG_NF_CONNTRACK=m
    CONFIG_NETFILTER_TPROXY=m
    CONFIG_NETFILTER_XT_TARGET_TPROXY=m
    CONFIG_NETFILTER_XT_MATCH_SOCKET=m
    u tuk build squid 2.7.XX/ lusca
    ./configure --enable-linux-tproxy4
    u tuk build squid 3.XX
    ./configure --enable-linux-netfilter
    untuk konfig squid ( squid.conf )
    http_port 0.0.0.0:3129 transparent tproxy ( u/ lusca/squid2.7.XX )
    http_port localhost:3128
    atau
    http_port 0.0.0.0:3129 tproxy ( u/ squid3.XX )
    http_port localhost:3128

    Sedangakn untuk iptables nya bisa load dari file ini:
    Code:
    # Generated by nDasJoWo
    *nat
    :PREROUTING ACCEPT [541:35450]
    :POSTROUTING ACCEPT [796:56114]
    :OUTPUT ACCEPT [795:56050]
    COMMIT
    # Completed 
    # Generated by nDasJoWo
    *mangle
    :PREROUTING ACCEPT [51:11203]
    :INPUT ACCEPT [5711:2016323]
    :FORWARD ACCEPT [3:1580]
    :OUTPUT ACCEPT [8347:3818817]
    :POSTROUTING ACCEPT [8350:3820397]
    :DIVERT - [0:0]
    -A PREROUTING -p tcp -m socket -j DIVERT 
    -A PREROUTING -p tcp -m tcp --dport 80 -j TPROXY --on-port 3129 --on-ip 0.0.0.0 --tproxy-mark 0x1/0xffffffff 
    -A DIVERT -j MARK --set-xmark 0x1/0xffffffff 
    -A DIVERT -j ACCEPT 
    COMMIT
    # Completed
    atau download di sini ....

    simpan dengan nama iptables-TPROXY
    kemudian load iptabes tersebut
    Code:
    #iptables-restore < /(path-file)/iptables-TPROXY
    untuk pengecekan apakah iptables sudah masuk
    Code:
    #iptables -t mangle -L
    untuk yg belom sukses biasa tammbahkan ini
    Code:
    ip rule add fwmark 1 lookup 100
    ip route add local 0.0.0.0/0 dev lo table 100
    
    sysctl net.ipv4.ip_nonlocal_bind=1
    sysctl net.ipv4.ip_forward=1
    tralala ... sukses ...

    regrad
    ym : heddy_joe@yahoo.com
    Last edited by ndasjowo; 13-04-2012 at 23:54.

  2. The Following 23 Users Say Thank You to ndasjowo For This Useful Post:

    + Show/Hide list of the thanked


  3. #2
    Status
    Offline
    ucok_karnadi's Avatar
    ..:: Masih Bodoh ::..
    Join Date
    Jan 2009
    Location
    PATI - JAWA TENGAH
    Posts
    1,187
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    perubahan dikit

    Code:
    cat /boot/config-2.6.XX `uname -r` | grep -E '(NF_CONNTRACK=|TPROXY|XT_MATCH_SOCKET|XT_TARGET_T PROXY)'
    menjadi

    Code:
    cat /boot/config-`uname -r` | grep -E '(NF_CONNTRACK=|TPROXY|XT_MATCH_SOCKET|XT_TARGET_T PROXY)'
    dan sepertinya untuk squid 2.7 harus di patch dulu dech om.

    Click here to enlarge mirip tproxy thundercache + mikrotik
    ___________________________________________


  4. The Following 12 Users Say Thank You to ucok_karnadi For This Useful Post:

    + Show/Hide list of the thanked


  5. #3
    Status
    Offline
    dhopack's Avatar
    Forum Guru
    Join Date
    Dec 2010
    Location
    KUDUS
    Posts
    1,919
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ucok_karnadi Click here to enlarge
    ...
    dan sepertinya untuk squid 2.7 harus di patch dulu dech om.
    ...
    apakah squid 2.7stable9 yang sudah dipatch yang banyak beredar diforum ini sudah support tproxy?

    @ TS
    jika sebelumnya pake squid 2.7stable9 dan beralih ke yang support tproxy apakah cachenya harus dihapus dulu?apa cache yang lama te2p ngeHIT?
    thx b4,


    Click here to enlarge

  6. The Following User Says Thank You to dhopack For This Useful Post:


  7. #4
    Status
    Offline
    ndasjowo's Avatar
    Member
    Join Date
    Mar 2010
    Location
    Boyolali - Solo - Sragen
    Posts
    267
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ucok_karnadi Click here to enlarge
    perubahan dikit

    Code:
    cat /boot/config-2.6.XX `uname -r` | grep -E '(NF_CONNTRACK=|TPROXY|XT_MATCH_SOCKET|XT_TARGET_T PROXY)'
    menjadi

    Code:
    cat /boot/config-`uname -r` | grep -E '(NF_CONNTRACK=|TPROXY|XT_MATCH_SOCKET|XT_TARGET_T PROXY)'
    dan sepertinya untuk squid 2.7 harus di patch dulu dech om.

    Click here to enlarge mirip tproxy thundercache + mikrotik
    betul betul betul ....

  8. The Following 3 Users Say Thank You to ndasjowo For This Useful Post:


  9. #5
    Status
    Offline
    ucok_karnadi's Avatar
    ..:: Masih Bodoh ::..
    Join Date
    Jan 2009
    Location
    PATI - JAWA TENGAH
    Posts
    1,187
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    up Click here to enlarge
    ___________________________________________


  10. The Following 2 Users Say Thank You to ucok_karnadi For This Useful Post:


  11. #6
    Status
    Offline
    oktama's Avatar
    Forum Guru
    Join Date
    Jul 2008
    Location
    Jayapura
    Posts
    1,929
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    sangat membantu di tingkatan ISP yang ingin memberikan HIT loss kepada client meskipun tetap melakukan distribusi ip publik Click here to enlarge

  12. The Following 2 Users Say Thank You to oktama For This Useful Post:


  13. #7
    Status
    Offline
    why_you's Avatar
    Member
    Join Date
    May 2010
    Posts
    130
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    icip-icip dulu ah, thanks om ndasjowo

  14. #8
    Status
    Offline
    Stillhard's Avatar
    Newbie
    Join Date
    Sep 2007
    Posts
    47
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ndasjowo Click here to enlarge
    Syarat :
    kernel dan iptables support tproxy:
    pengecekan ...
    cat /boot/config-`uname -r` | grep -E '(NF_CONNTRACK=|TPROXY|XT_MATCH_SOCKET|XT_TARGET_T PROXY)'
    jika muncul pesen gini berarti support
    Code:
    CONFIG_NF_CONNTRACK=m
    CONFIG_NETFILTER_TPROXY=m
    CONFIG_NETFILTER_XT_TARGET_TPROXY=m
    CONFIG_NETFILTER_XT_MATCH_SOCKET=m
    Mohon bimbingannya... Saya sudah coba:
    Code:
    stillhard@proxy:~/LUSCA_FMI# cat /boot/config-`uname -r` | grep -E '(NF_CONNTRACK=|ROXY|XT_MATCH_SOCKET|XT_TARGET_T PROXY)'
    CONFIG_NF_CONNTRACK=m
    CONFIG_NETFILTER_TPROXY=m
    CONFIG_NETFILTER_XT_TARGET_TPROXY=m
    CONFIG_NETFILTER_XT_MATCH_SOCKET=m
    Hasil ./configure ...
    Code:
    checking if TPROXY header files are installed... no
    WARNING: Cannot find TPROXY headers, you need to patch your kernel with the
    tproxy package from:
     - lynx http://www.balabit.com/downloads/files/tproxy/
    Click here to enlarge masih mentok...

  15. #9
    Status
    Offline
    ndasjowo's Avatar
    Member
    Join Date
    Mar 2010
    Location
    Boyolali - Solo - Sragen
    Posts
    267
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    coba di dmesg...
    Code:
    # dmesg | grep PROXY
    NF_TPROXY: Transparent proxy support initialized, version 4.1.0
    NF_TPROXY: Copyright (c) 2006-2007 BalaBit IT Ltd.
    pastikan juga squid udah di patch ( ver 2.XX )

  16. #10
    Status
    Offline
    Stillhard's Avatar
    Newbie
    Join Date
    Sep 2007
    Posts
    47
    Reviews
    Read 0 Reviews
    Downloads
    4
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ndasjowo Click here to enlarge
    coba di dmesg...
    Code:
    # dmesg | grep PROXY
    NF_TPROXY: Transparent proxy support initialized, version 4.1.0
    NF_TPROXY: Copyright (c) 2006-2007 BalaBit IT Ltd.
    pastikan juga squid udah di patch ( ver 2.XX )
    Nah, ini yang kurang Click here to enlarge jadi bisa ditambahkan di first post bang... terima kasih, ditunggu petunjuk-petunjuk berikutnya...

  17. #11
    Status
    Offline
    why_you's Avatar
    Member
    Join Date
    May 2010
    Posts
    130
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ndasjowo Click here to enlarge
    /ip route add dst-address=0.0.0.0/0 gateway=(ip-proxy) routing-mark="VIA_TPROXY";
    /ip firewall mangle add chain=prerouting protocol=tcp dst-port=80 src-address-list="ip-client" dst-address-list="no-proxy" in-interface=(ether-client) action=mark-routing new-routing-mark=VIA_TPROXY;
    /ip firewall mangle add chain=prerouting in-interface=(ether-proxy) action=mark-connection new-connection-mark=VIA_TPROXY;
    /ip firewall add chain=prerouting in-interface=(ether-internet) connection-mark=VIA_TPROXY action=mark-routing new-routing-mark=VIA_TPROXY;
    rule yang kedua itu yang dst-address-list diisi apaan ya om dasjowo, thanks

    ---------- Post added at 09:49 ---------- Previous post was at 08:29 ----------

    om ndasjowo, berdasarkan disini
    confignya cuman pake ini

    http_port 3128
    http_port 3129 tproxy
    dan ini explainnya
    NP: The Balabit document still refers to using options tproxy transparent. Do not do this. It was only needed short-term for a bug which is now fixed
    CMIIW

  18. #12
    Status
    Offline
    ndasjowo's Avatar
    Member
    Join Date
    Mar 2010
    Location
    Boyolali - Solo - Sragen
    Posts
    267
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by why_you Click here to enlarge
    rule yang kedua itu yang dst-address-list diisi apaan ya om dasjowo, thanks

    ---------- Post added at 09:49 ---------- Previous post was at 08:29 ----------

    om ndasjowo, berdasarkan disini
    confignya cuman pake ini



    dan ini explainnya


    CMIIW
    dst-address-list="no-proxy" (ip/web yang direct lsg )

    http_port 3128
    http_port 3129 tproxy
    ( untuk squid 3.XX )
    http_port 0.0.0.0:3129 transparent tproxy
    http_port localhost:3128
    ( u/ lusca/squid2.7.XX )

  19. The Following 2 Users Say Thank You to ndasjowo For This Useful Post:


  20. #13
    Status
    Offline
    kweteng's Avatar
    VIP Member
    Join Date
    Nov 2009
    Location
    batu wae
    Posts
    797
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    nambahin biar lebih responsif dan mencegah terjadinya sync attack virus upload port 80 yang bikin proxy KO!!, biasanya dari installer dialer situs2 porn / file crack bervirus,

    HaPPY Cache.
    Code:
    *mangle
    :PREROUTING ACCEPT [0:0]
    :INPUT ACCEPT [0:0]
    :FORWARD ACCEPT [0:0]
    :OUTPUT ACCEPT [0:0]
    :POSTROUTING ACCEPT [0:0]
    :DIVERT - [0:0]
    -A PREROUTING -p tcp -m tcp --dport 80 ! --tcp-flags FIN,SYN,RST,ACK SYN -m socket -j DIVERT 
    -A PREROUTING -p tcp -m tcp --sport 80 ! --tcp-flags FIN,SYN,RST,ACK SYN -m socket -j DIVERT 
    -A PREROUTING -p tcp -m tcp --dport 80 -j TPROXY --on-port 3129 --on-ip 0.0.0.0 --tproxy-mark 0x1/0xffffffff 
    -A DIVERT -j MARK --set-xmark 0x1/0xffffffff 
    -A DIVERT -j ACCEPT 
    COMMIT
    
    *filter
    :INPUT ACCEPT [0:0]
    :FORWARD ACCEPT [0:0]
    :OUTPUT ACCEPT [0:0]
    COMMIT
    # Completed on Thu Mar 1 12:57:37 2012
    untuk OS bsd 8.2 update sources via csup, dapetnya Freebsd 8.3-PRERELEASE4
    di patch dari sini langsung mak erot , urutanya sudah berubah.

    hasil penyesuian silahkan sedot disini
    Code:
     http://squid-proxy-pkg.googlecode.com/files/tproxy-bsd-8.3-PRERELEASE4.patch
    pada bagian option kernel tambahkan parameter ini
    Code:
    on option kernel add parameter :
    options         LIBALIAS
    options         IPDIVERT
    options         IPFIREWALL
    options         IPFIREWALL_NAT
    options         IPFIREWALL_VERBOSE
    options         IPFIREWALL_FORWARD
    options         IPFIREWALL_DEFAULT_TO_ACCEPT
    dan jangan lupa di make config squid centang 'enable freebsd tproxy'

    untuk ipfw example :
    Code:
    ipfw add fwd 192.168.100.2,3128 tcp from 192.168.0.0/24 to any 80 in via bce0
    info tproxy bsd jadul :
    tproxy work prefect with FreeBSD 8.3 single interfaces Click here to enlarge
    Last edited by kweteng; 07-04-2012 at 15:52. Reason: patch freebsd

  21. The Following 12 Users Say Thank You to kweteng For This Useful Post:

    + Show/Hide list of the thanked


  22. #14
    Status
    Offline
    tolabul's Avatar
    Newbie
    Join Date
    Apr 2010
    Location
    blitar
    Posts
    59
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ndasjowo Click here to enlarge
    lama gak absen nih ...
    mohon maap kalo adadole posting ...

    disini saya akan coba share ngebuat tpoxy 1 ethernet.
    mungkin temen udah sering/biasa make proxy external.
    tapi pernah kan anda meng-alami kasus di mana baddwith ( yang memang request client) habis kesedot oleh proxy ( yg biasanya proxy posisi los dan client dilimit)
    kenapa bisa terjadi...?
    - Pada saat client melakukan request web/file oleh mikrotik diredirect ke proxy ekternal.
    - jika web/file belum tersedia di cache maka proxy melakukan request ke internet ( dimanaproxy request keinternet los/not shaping). Click here to enlarge
    - karena kondisi file belum ke cache, maka bw yang di teruskan ke-client akan mengikuti shaping di mikrotik.
    - maka akan timbul kejadian aneh ....
    - bandwith yang masuk akan lebih besar ( di sedot proxy) daripada bandwith yang di kirim ke-client ( terlimit mikrotik karena blm posisi hit)
    -
    Udah ngomel nya ....
    lsg ke solusi aja bagaimana ngebuat real shaping ke client
    solosinya kita gunakan tproxy.....!

    topologi jaringan:

    internet => Mikrotik -> client
    . .|.
    . pcbox/tproxy

    Langkah :
    ( di-mikrotik )
    1. buat routing untuk tproxy
    2. buat mangle untuk routing tproxy
    [ code]
    /ip route add dst-address=0.0.0.0/0 gateway=(ip-proxy) routing-mark="VIA_TPROXY";
    /ip firewall mangle add chain=prerouting protocol=tcp dst-port=80 src-address-list="ip-client" dst-address-list="no-proxy" in-interface=(ether-client) action=mark-routing new-routing-mark=VIA_TPROXY;
    /ip firewall mangle add chain=prerouting in-interface=(ether-proxy) action=mark-connection new-connection-mark=VIA_TPROXY;
    /ip firewall add chain=prerouting in-interface=(ether-internet) connection-mark=VIA_TPROXY action=mark-routing new-routing-mark=VIA_TPROXY;
    [/code]

    ( di pcbox/tproxy )
    Syarat :
    kernel dan iptables support tproxy:
    pengecekan ...
    cat /boot/config-2.6.XX `uname -r` | grep -E '(NF_CONNTRACK=|TPROXY|XT_MATCH_SOCKET|XT_TARGET_T PROXY)'
    jika muncul pesen gini berarti support
    Code:
    CONFIG_NF_CONNTRACK=m
    CONFIG_NETFILTER_TPROXY=m
    CONFIG_NETFILTER_XT_TARGET_TPROXY=m
    CONFIG_NETFILTER_XT_MATCH_SOCKET=m
    u tuk build squid 2.7.XX/ lusca
    ./configure --enable-linux-tproxy4
    u tuk build squid 3.XX
    ./configure --enable-linux-netfilter
    untuk konfig squid ( squid.conf )
    http_port 0.0.0.0:3129 transparent tproxy ( u/ lusca/squid2.7.XX )
    http_port localhost:3128
    atau
    http_port 0.0.0.0:3129 tproxy ( u/ squid3.XX )
    http_port localhost:3128

    Sedangakn untuk iptables nya bisa load dari file ini:
    Code:
    # Generated by nDasJoWo
    *nat
    :PREROUTING ACCEPT [541:35450]
    :POSTROUTING ACCEPT [796:56114]
    :OUTPUT ACCEPT [795:56050]
    COMMIT
    # Completed 
    # Generated by nDasJoWo
    *mangle
    :PREROUTING ACCEPT [51:11203]
    :INPUT ACCEPT [5711:2016323]
    :FORWARD ACCEPT [3:1580]
    :OUTPUT ACCEPT [8347:3818817]
    :POSTROUTING ACCEPT [8350:3820397]
    :DIVERT - [0:0]
    -A PREROUTING -p tcp -m socket -j DIVERT 
    -A PREROUTING -p tcp -m tcp --dport 80 -j TPROXY --on-port 3129 --on-ip 0.0.0.0 --tproxy-mark 0x1/0xffffffff 
    -A DIVERT -j MARK --set-xmark 0x1/0xffffffff 
    -A DIVERT -j ACCEPT 
    COMMIT
    # Completed
    atau download di sini ....

    simpan dengan nama iptables-TPROXY
    kemudian load iptabes tersebut
    Code:
    #iptables-restore < /(path-file)/iptables-TPROXY
    untuk pengecekan apakah iptables sudah masuk
    Code:
    #iptables -t mangle -L
    untuk yg belom sukses biasa tammbahkan ini
    Code:
    ip rule add fwmark 1 lookup 100
    ip route add local 0.0.0.0/0 dev lo table 100
    
    sysctl net.ipv4.ip_nonlocal_bind=1
    sysctl net.ipv4.ip_forward=1
    tralala ... sukses ...

    regrad
    ym : heddy_joe@yahoo.com
    akhirnya racun tproxy dirilis juga ...........

    ikut menyimak dan mencoba

    thanks




    ___________________________
    [SIZE=5]maaf gak pandai komen[/SIZE]

  23. #15
    Status
    Offline
    lmandhika's Avatar
    Baru Gabung
    Join Date
    May 2010
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Wah ini yg saya cari, tapi ada bbrp pertanyaan, maklum masih nubi...
    Itu topologinya brti Modem harus dipakein HUB yah supaya bisa nyambung ke Tproxy dan MT secara terpisah ? soalnya :
    INTERNET- MIKROTIK
    |
    TPROXY

    Brti tproxy dan mikrotik lgsg nyambung modem dengan jalur terpisah ?

    Terus, traffic client tetap di shape atau gausah ?

 

 
Page 1 of 13 12311 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [WTS] Interface Card Intel Chipset Single/Dual port
    By warnet in forum Others Hardware
    Replies: 67
    Last Post: 05-07-2014, 14:27
  2. Mengembalikan Interface Ethernet yang terdisable semua..
    By adhielesmana in forum Beginner Basics
    Replies: 43
    Last Post: 06-01-2011, 13:50
  3. [JUAL] SFP LX (single mode) 1310nm 1.25g up to 20KM
    By rosesana in forum Lapak serba-serbi
    Replies: 0
    Last Post: 31-08-2010, 05:54
  4. Sale radio microwave PDH ethernet,sdh optical/ethernet
    By tommyblack in forum Others Hardware
    Replies: 0
    Last Post: 18-04-2010, 10:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •