Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2
  1. #1
    Status
    Offline
    benmikrotik's Avatar
    Baru Gabung
    Join Date
    Aug 2011
    Location
    Philippine Islands
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Question Policy based routing

    Hi All,

    I have a current 1 ISP setup. I want to add 1 more ISP but I won't do load balancing. This 1 additional ISP will be exclusive to a biz subscriber.

    The biz subscriber and the residential subscribers will be sharing the same x86 mikrotik box, firewall, DHCP, Qos, L7, web proxycache settings. I want the biz subscriber will connect only to ISP2, and residential subscribers to ISP 1. Any ideas how to do it?

    I only have one LAN setup so basically every subscriber is on the same subnet. For example I want 192.168.30.5 to access ISP2. All the others will access ISP1.

    Please help me.

    Thanks in advance.
    (Please reply in English, sorry I don't understand Bahasa)

  2. #2
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    Click here to enlarge Originally Posted by benmikrotik Click here to enlarge
    Hi All,

    I have a current 1 ISP setup. I want to add 1 more ISP but I won't do load balancing. This 1 additional ISP will be exclusive to a biz subscriber.

    The biz subscriber and the residential subscribers will be sharing the same x86 mikrotik box, firewall, DHCP, Qos, L7, web proxycache settings. I want the biz subscriber will connect only to ISP2, and residential subscribers to ISP 1. Any ideas how to do it?

    I only have one LAN setup so basically every subscriber is on the same subnet. For example I want 192.168.30.5 to access ISP2. All the others will access ISP1.

    Please help me.

    Thanks in advance.
    (Please reply in English, sorry I don't understand Bahasa)
    You can mark the connection and routing in mangle similar way as another load balancing method (PCC, NTH), except that instead specifying NTH or PCC, you specify src-address or src-address-list.

    Here's an example:
    Code:
    /ip firewall mangle
    add chain=prerouting src-address-list="IP-for-ISP1" in-interface="local" action=mark-connection new-connection-mark="ISP-1" passthrough=yes
    add chain=prerouting src-address-list="IP-for-ISP2" in-interface="local" action=mark-connection new-connection-mark="ISP-2" passthrough=yes
    add chain=prerouting in-interface="local" connection-mark="ISP-1" action=mark-routing new-routing-mark="ISP1" passthrough=no
    add chain=prerouting in-interface="local" connection-mark="ISP-2" action=mark-routing new-routing-mark="ISP2" passthrough=no
    
    /ip route
    add routing-mark="ISP1" gateway=xxx.xxx.xxx.xxx
    add routing-mark="ISP2" gateway=yyy.yyy.yyy.yyy
    add comment="default" gateway=xxx.xxx.xxx.xxx
    And then you can add list of addresses to be routed to ISP1 and ISP2 at IP->Firewall->Address List
    Last edited by yosanpro; 17-08-2011 at 14:26.
    A person's junk is another person's treasure.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 85
    Last Post: 24-07-2015, 08:55
  2. Replies: 5
    Last Post: 11-12-2010, 22:57
  3. interface based routing
    By boyke in forum General Networking
    Replies: 4
    Last Post: 24-03-2009, 19:40
  4. Confused.. Policy Routing
    By brian in forum Beginner Basics
    Replies: 9
    Last Post: 13-08-2008, 02:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •