Model Jaringan

Modem ------ -------------Mikrotik----- Switch------Client
........................................|
........................................|
........................................|
............................Proxy Ubuntu 11 Natty


/ip firewall nat
add action=masquerade chain=srcnat comment=MASQUERADE1 disabled=no out-interface=pppoe_1

# interface = Lokal (Transparent - 1)
add action=dst-nat chain=dstnat comment=TRANSPARENT-DNS-RB disabled=no dst-port=53 in-interface=MyMyLan protocol=udp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 in-interface=MyLan protocol=tcp to-ports=53

# interface = Proxy (Transparent - 2)
add action=dst-nat chain=dstnat comment="TRANSPARENT-DNS-PROXY" disabled=no dst-port=53 in-interface=proxy protocol=udp to-ports=53
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 in-interface=proxy protocol=tcp to-ports=53

add action=dst-nat chain=dstnat comment=TRANSPARENT-proxy disabled=no dst-address-list=!List-proxyNET dst-port=80 in-interface=MyLan \
protocol=tcp to-addresses=179.10.10.3 to-ports=8080


Salam Kenal, ane mo bertanya nih pada suhu2 mt , saya punya jaringan seperti gambar dan sedikit nat ..itu hasil copz sedikit dari mr teukurizal@yahoo.com.sg kalau gk salah hehe
cuma di ubah2 dikit aja berdasarkan topologi jaringan ane.

yang ingin saya tanya tentang transparent DNS 1 dan transparent DNS 2 ,
kalau transparent 1 di arahakan ke DNS local Router kalau gk salah ...dan DNS di RB sudah saya di set ke 8.8.8.8 / 8.8.4.4
kalau transparent 2 di arahakan ke DNS local nya Proksi ???? apa benar yaa ... , hihihihih (akibat nyontek gini nih...)
---> kalau benar berarti DNS juga harus di aktifkan di Server Proxy Externalnya ? misal BIND,DJBDNS,UNBOUND dll..apa tidak terjadi pengecekan host 2X jadinya (menurut ane nih)
kalau di server proxynya di set bukan sama dengan DNS mikrotik misal : dns nawala kira-2 begitu ..

jadi saya kurang faham aturannya DNS nya hihihihih ..di RB dns Google , apa di Server Proxy jg harus DNS google .. ?

kira-2 begitu Mohon Penjelasannya kalau bisa detail nya wkwkwkwk (maksa saya) para suhu-2 ?

Click here to enlarge