Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 14 of 14
  1. #1
    Status
    Offline
    choi's Avatar
    Calon Member
    Join Date
    Nov 2007
    Posts
    80
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    loadbalance nth + queue tree

    Akhirnya mentok juga nih...
    Ada nggak temen-temen yang punya pengalaman loadbalance dengan nth dan untuk pembagian bandwith menggunakan queue tree.
    masalahnya setelah loadbalance jalan, setiap pengaktifan mark connection di mangle selalu membuat balance ancur...

  2. #2
    Status
    Offline
    nux
    nux's Avatar
    Member
    Join Date
    Jul 2007
    Posts
    268
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    iya nih, blom nemu resepnya yg mantep, sementara loadbalancing sendiri limiter sendiri, 2 kompi, boros resource..

  3. #3
    Status
    Offline
    choi's Avatar
    Calon Member
    Join Date
    Nov 2007
    Posts
    80
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Kemarin sempet mikir gitu, untuk loadbalancer sendiri terus untuk bagi bandwidth sendiri, cuman kok jadinya nggak mikrotik beneran ya...??
    mikrotik kan spesialis router, seharusnya kan bisa....Click here to enlargeClick here to enlarge
    Uji-uji coba masih berjalan, sementara dering telepon dari client masih terus terjadi... dan udah dua malem nggak bisa tidur.. hehehehe..
    Sementara ini sudah nemu sih sedikit metode, cuman kayaknya nggak maksimal...

  4. #4
    Status
    Offline
    Akangage's Avatar
    Administrator
    Join Date
    Aug 2007
    Location
    Daerah Khusus Ibukota Jakarta, Indonesia
    Posts
    4,195
    Reviews
    Read 0 Reviews
    Downloads
    210
    Uploads
    87
    Feedback Score
    0
    Yah.... masalah ini mah udah lama dibahas!! Ga disearch dulu ya Click here to enlarge coba main kesini sama ke sini

    Pelan2 bro kalo nyari Click here to enlarge

  5. The Following 3 Users Say Thank You to Akangage For This Useful Post:


  6. #5
    Status
    Offline
    choi's Avatar
    Calon Member
    Join Date
    Nov 2007
    Posts
    80
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Akang, Kayaknya udah bolak balik deh saya baca disitu. Click here to enlarge
    Tapi disitu kayaknya khusus membahas loadbalance-nya aja, sementara untuk queue tidak dibahas.
    Kemungkinan loadbalance nth bisa dengan queue simple, cuman kayaknya kok gak sreg make simple.

    Jika menggunakan model seperti ini :
    range ip 192.168.1.0/24 lewat isp A,
    range ip 192.168.2.0/24 lewat isp B.
    emang lancar make queue tree, cuman kan sayang, client jadinya nggak akan bisa mendapatkan full bandwith jika jalur lagi kosong.

    Jika menggunakan loadbalance nth, setiap melakukan mark connection dengan chain forward atau postrouting, selalu kacau hasilnya.
    Bagi yang udah make loadbalance nth dengan queue tree, bagi-bagi ilmunya dong... Click here to enlargeClick here to enlarge
    Gak usah detail deh, cukup konsep/logikanya aja deh... pasti akan sangat berguna... hehehehe

  7. #6
    Status
    Offline
    Akangage's Avatar
    Administrator
    Join Date
    Aug 2007
    Location
    Daerah Khusus Ibukota Jakarta, Indonesia
    Posts
    4,195
    Reviews
    Read 0 Reviews
    Downloads
    210
    Uploads
    87
    Feedback Score
    0
    Akang pake settingan standar aja tuh mau kok, kaya gini (Ini akang pake LB nth, 3 ISP jadi 1)

    Code:
    / queue simple 
    add name="Client 01" target-addresses=192.178.40.1/32 dst-address=0.0.0.0/0 interface=all parent=none direction=both \
        priority=8 queue=default-small/default-small limit-at=0/0 max-limit=0/90000 burst-limit=0/600000 \
        burst-threshold=0/150000 burst-time=4s/4s total-queue=default-small disabled=no
    udah gitu doank.... emang perlu yang kaya apa Queue-nya? Akang pake kaya gitu ga pernah kebobolan kok... cuman setiap kali abis nambah rule queue jangan lupa di restart MT-nya kalo ga di restart ya ga kena queue

    Kalo lagi kosong lepas aja full deh dapet 1,5 mb/s Click here to enlarge

  8. The Following 2 Users Say Thank You to Akangage For This Useful Post:


  9. #7
    Status
    Offline
    choi's Avatar
    Calon Member
    Join Date
    Nov 2007
    Posts
    80
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Akhirnya dapat juga... "Loadbalance nth + queue tree"
    konsepnya gini :

    Karena aturan ditempat saya berbasis port, maka yang saya balance cuman port 80 sementara port-port lain lewat default gateaway;
    1. Bikin chain prerouting dst-port=80 conn-state=new nth=2,0,0 action="mark connection", diteruskan dengan aturan mark routing; ==>aturan loadbalance nth pada umumnya... (ada dalam tutor...!!!)
    2. Bikin satu chain prerouting dengan action=mark connection untuk menangkap trafick selain yang diloadbalance. ===>(disimpan dibawah aturan loadbalance)
    3. lakukan chain postrouting atau forward, action="mark packet" dengan conn-mark point 1 ===>(seluruh pengaturan queue port 80 disini, jika postrouting dst-address=lan, jika fordward src-address=lan);
    4. lakukan chain postrouting atau forward, action="mark packet" dengan conn-mark point 2 (seluruh queue port selain port 80 disini, jika postrouting dst-address=lan, jika fordward src-address=lan).

    Masih uji coba.... baru berjalan beberapa jam...
    knp saya ngotot make queue tree..???
    karena dengan queue tree pengaturan download sangat mudah dilakukan, terutama make connection byte.

  10. #8
    Status
    Offline
    monoxs's Avatar
    Calon Member
    Join Date
    Mar 2008
    Posts
    76
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by choi Click here to enlarge
    Akhirnya dapat juga... "Loadbalance nth + queue tree"
    konsepnya gini :

    Karena aturan ditempat saya berbasis port, maka yang saya balance cuman port 80 sementara port-port lain lewat default gateaway;
    1. Bikin chain prerouting dst-port=80 conn-state=new nth=2,0,0 action="mark connection", diteruskan dengan aturan mark routing; ==>aturan loadbalance nth pada umumnya... (ada dalam tutor...!!!)
    2. Bikin satu chain prerouting dengan action=mark connection untuk menangkap trafick selain yang diloadbalance. ===>(disimpan dibawah aturan loadbalance)
    3. lakukan chain postrouting atau forward, action="mark packet" dengan conn-mark point 1 ===>(seluruh pengaturan queue port 80 disini, jika postrouting dst-address=lan, jika fordward src-address=lan);
    4. lakukan chain postrouting atau forward, action="mark packet" dengan conn-mark point 2 (seluruh queue port selain port 80 disini, jika postrouting dst-address=lan, jika fordward src-address=lan).

    Masih uji coba.... baru berjalan beberapa jam...
    knp saya ngotot make queue tree..???
    karena dengan queue tree pengaturan download sangat mudah dilakukan, terutama make connection byte.
    ==============================

    kalau berhasil
    bagi bagi yaah conf nya

  11. #9
    Status
    Offline
    rj-45's Avatar
    Moderator
    Join Date
    Jul 2007
    Posts
    885
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    sampe sekrng gw juga lom tembus ...ck ck bener2 gw masih lom mudang soalnya gw bikin 4 rule di mangle untuk 1 ip..ga ada yang masuk packetnya zzz...giliran 1 link mah jalan Click here to enlarge

  12. The Following User Says Thank You to rj-45 For This Useful Post:


  13. #10
    Status
    Offline
    Akangage's Avatar
    Administrator
    Join Date
    Aug 2007
    Location
    Daerah Khusus Ibukota Jakarta, Indonesia
    Posts
    4,195
    Reviews
    Read 0 Reviews
    Downloads
    210
    Uploads
    87
    Feedback Score
    0
    Perasaan pake simple queue juga mudah kok..... Buktinya sampe sekarang gpp, no offense bro, settingan orang memang beda2 kok Click here to enlarge

  14. The Following User Says Thank You to Akangage For This Useful Post:


  15. #11
    Status
    Offline
    cyber4rt's Avatar
    Baru Gabung
    Join Date
    Nov 2009
    Posts
    19
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    wah akangage hebat yach... jd tmbah smangadh mw jd kya akang...Click here to enlargeClick here to enlargeClick here to enlargeClick here to enlargeClick here to enlargeClick here to enlargeClick here to enlargeClick here to enlargeClick here to enlargeClick here to enlargeClick here to enlargetp mohon bimbingan'a yach akangClick here to enlarge

  16. #12
    Status
    Offline
    awarmanf's Avatar
    Member
    Join Date
    Apr 2008
    Posts
    222
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by choi Click here to enlarge
    Akhirnya mentok juga nih...
    Ada nggak temen-temen yang punya pengalaman loadbalance dengan nth dan untuk pembagian bandwith menggunakan queue tree.
    masalahnya setelah loadbalance jalan, setiap pengaktifan mark connection di mangle selalu membuat balance ancur...
    Saya pernah buat koneksi 7 WAN spidi dengan nth pakai RB439. Tidak pakai queue tree melainkan queue simple. Screen shootnya:

    Click here to enlarge
    Click here to enlarge
    Click here to enlarge

    Code:
    /ip firewall mangle
    add action=mark-packet chain=output comment="" disabled=no new-packet-mark=\
        local-icmp passthrough=no protocol=icmp
    add action=mark-packet chain=prerouting comment=\
        "MARK UP clients (must be on top at all)" disabled=no dst-address-list=\
        !local in-interface=lan new-packet-mark=clients-up passthrough=yes \
        src-address-list=clients
    add action=mark-packet chain=postrouting comment="Proxy Cache Hits Mark" \
        disabled=no dscp=12 new-packet-mark=proxy-hit passthrough=no protocol=tcp \
        src-port=8080
    add action=mark-packet chain=forward comment="Mark packet local from clients" \
        disabled=no dst-address-list=local dst-port=!8080 new-packet-mark=\
        to-local passthrough=no protocol=tcp src-address-list=clients
    add action=mark-packet chain=forward comment=\
        "Mark packet local from local server (proxy)" disabled=no \
        dst-address-list=clients new-packet-mark=from-local passthrough=no \
        protocol=tcp src-address-list=proxy src-port=!8080
    add action=mark-packet chain=postrouting comment=\
        "MARK PACKET clients down from proxy" disabled=no dst-address-list=\
        clients new-packet-mark=clients-down passthrough=no protocol=tcp \
        src-address-list=proxy src-port=8080
    add action=mark-packet chain=postrouting comment="MARK PACKET clients down" \
        disabled=no dst-address-list=clients new-packet-mark=clients-down \
        passthrough=no src-address-list=!local
    add action=mark-packet chain=prerouting comment=proxy_external disabled=no \
        dst-address-list=!bypasswww dst-port=80 in-interface=lan new-packet-mark=\
        to-www passthrough=no protocol=tcp src-address-list=clients-proxy
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-port=25 in-interface=lan new-connection-mark=irc-con \
        passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-port=6600-7000 in-interface=lan new-connection-mark=\
        irc-con passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        irc-con disabled=no in-interface=lan new-routing-mark=wan1 passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=rapidshare in-interface=lan \
        new-connection-mark=rapid-1-con passthrough=yes protocol=tcp \
        src-address-list=clients-rapidshare-1
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        rapid-1-con disabled=no in-interface=lan new-routing-mark=wan1 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=rapidshare in-interface=lan \
        new-connection-mark=rapid-2-con passthrough=yes protocol=tcp \
        src-address-list=clients-rapidshare-2
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        rapid-2-con disabled=no in-interface=lan new-routing-mark=wan2 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=rapidshare in-interface=lan \
        new-connection-mark=rapid-3-con passthrough=yes protocol=tcp \
        src-address-list=clients-rapidshare-3
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        rapid-3-con disabled=no in-interface=lan new-routing-mark=wan3 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=lan \
        new-connection-mark=wan7-con nth=7,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan7-con disabled=no in-interface=lan new-routing-mark=wan7 passthrough=\
        no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=proxy \
        new-connection-mark=wan7-con nth=7,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan7-con disabled=no in-interface=proxy new-routing-mark=wan7 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=lan \
        new-connection-mark=wan6-con nth=6,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan6-con disabled=no in-interface=lan new-routing-mark=wan6 passthrough=\
        no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=proxy \
        new-connection-mark=wan6-con nth=6,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan6-con disabled=no in-interface=proxy new-routing-mark=wan6 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=lan \
        new-connection-mark=wan5-con nth=5,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan5-con disabled=no in-interface=lan new-routing-mark=wan5 passthrough=\
        no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=proxy \
        new-connection-mark=wan5-con nth=5,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan5-con disabled=no in-interface=proxy new-routing-mark=wan5 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=lan \
        new-connection-mark=wan4-con nth=4,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan4-con disabled=no in-interface=lan new-routing-mark=wan4 passthrough=\
        no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=proxy \
        new-connection-mark=wan4-con nth=4,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan4-con disabled=no in-interface=proxy new-routing-mark=wan4 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=lan \
        new-connection-mark=wan3-con nth=3,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan3-con disabled=no in-interface=lan new-routing-mark=wan3 passthrough=\
        no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=proxy \
        new-connection-mark=wan3-con nth=3,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan3-con disabled=no in-interface=proxy new-routing-mark=wan3 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=lan \
        new-connection-mark=wan2-con nth=2,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan2-con disabled=no in-interface=lan new-routing-mark=wan2 passthrough=\
        no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=proxy \
        new-connection-mark=wan2-con nth=2,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan2-con disabled=no in-interface=proxy new-routing-mark=wan2 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=lan \
        new-connection-mark=wan1-con nth=1,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan1-con disabled=no in-interface=lan new-routing-mark=wan1 passthrough=\
        no
    add action=mark-connection chain=prerouting comment=LB_NTH connection-state=\
        new disabled=no dst-address-list=!local in-interface=proxy \
        new-connection-mark=wan1-con nth=1,1 passthrough=yes
    add action=mark-routing chain=prerouting comment=LB_NTH connection-mark=\
        wan1-con disabled=no in-interface=proxy new-routing-mark=wan1 \
        passthrough=no
    Code:
    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
        direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
        0/0 max-limit=128000/128000 name=p2p p2p=all-p2p parent=none priority=8 \
        queue=default-small/default-small target-addresses=192.168.0.0/24 \
        total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
        direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
        1024000/4000000 max-limit=1024000/4000000 name=Root packet-marks=\
        clients-up,clients-down parent=none priority=1 queue=default/default \
        total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
        direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
        0/0 max-limit=128000/750000 name=client-1 parent=Root priority=8 queue=\
        default-small/default-small target-addresses=192.168.0.1/32 total-queue=\
        default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
        direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
        0/0 max-limit=128000/750000 name=client-2 parent=Root priority=8 queue=\
        default-small/default-small target-addresses=192.168.0.2/32 total-queue=\
        default-small
    ...
    Salam,

    Arief Yudhawarman

  17. The Following 2 Users Say Thank You to awarmanf For This Useful Post:


  18. #13
    Status
    Offline
    happiers07's Avatar
    Member
    Join Date
    Apr 2009
    Posts
    162
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0
    @atas
    di terapin di mikrotik versi yg itu anu...Click here to enlarge hit proxynya bisa ga ya hehe

  19. #14
    Status
    Offline
    adiputrolds's Avatar
    Forum Guru
    Join Date
    Oct 2008
    Posts
    1,485
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    khusus untuk Local interface ada hubungan antara mark-con LB dan mark-con QOS
    tidak boleh sama2 di gunakan karena mark-con LB akan tertimpa / lenyap karena di mark-con ulang untuk QOS

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. queue tree or queue simple
    By c0nf in forum General Networking
    Replies: 116
    Last Post: 21-04-2013, 00:06
  2. HOTSPOT+mangle+pcq+queue tree
    By sartugiono in forum General Networking
    Replies: 11
    Last Post: 19-03-2008, 09:37
  3. Replies: 3
    Last Post: 29-09-2007, 16:25
  4. [ask] Beda Simple Queue deengan Queue Tree
    By tobi_cjr in forum General Networking
    Replies: 1
    Last Post: 09-08-2007, 16:37
  5. script mangle - queue tree di ISP
    By ponywaterhouse in forum Scripting @ Mikrotik
    Replies: 1
    Last Post: 06-08-2007, 04:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •