Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 7 of 7
  1. #1
    Status
    Offline
    back2arie's Avatar
    Baru Gabung
    Join Date
    Nov 2010
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Static route, tapi tidak directly connected?

    Mohon bantuan teman-teman...

    Gw punya Mikrotik dengan interface IP 192.168.23.3/24

    Kurang lebih topologiya begini:
    Client == Mikrotik == Gateway == Cloud == VPN

    Dalam hal ini Client kita hiraukan dulu.
    Nah, gw pengen masuk dari Mikrotik ke VPN dengan network 192.168.200.0/24

    Dan gw cuma dikasih tau kalau pengen menghubungkan Mikrotik gw dengan VPN maka gw harus masukin gateway 192.168.20.1/24, yang notabene ada di Cloud, Cloud disini tidak hanya satu router, tapi banyak dan gw juga ga tahu pasti.

    Lanjut, untuk menghubungi network 192.168.20.0/24, gw juga terlebih dahulu harus melalui gateway 192.168.23.1 (Gateway) yang tentu saja directly connected (reachable) dan sudah terbukti bisa di ping dan traceroute.

    Code:
    > /ip route add dst-address=192.168.20.0/24 gateway=192.168.23.1
    Code:
    > /tool traceroute interface=ether2-vpn 192.168.20.1
         ADDRESS                                    STATUS
       1    192.168.23.1 9ms 1ms 1ms 
       2    172.16.79.49 3ms 3ms 3ms 
       3    192.168.20.1 31ms 30ms 25ms
    Terbukti kalau Cloud lebih dari satu router.

    Nah, yang jadi pertanyaan adalah bagaimana memasukkan route dst-address=192.168.200.0/24 gateway=192.168.20.1? Sementara 192.168.20.1 tidak directly connected (unreachable)?

  2. #2
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    Bisa diperjelas topologinya? Apakah VPN dilakukan di "Gateway" ataukah "Mikrotik"? IP 192.168.200.0/24 itu IP yang ada di network sana atau lokal sini?

    Kalau static routing tanpa NAT sudah dilakukan oleh mereka, dalam hal ini mereka telah mengkonfigurasi kurang lebih begini di VPN: /ip route add dst-address=192.168.23.0/24 gateway=192.168.20.xx ;(IP "Gateway" yang mengarah ke cloud), maka jika anda melakukan VPN dari "Mikrotik" ke "VPN", trafik akan dilewatkan langsung ke "VPN" di sana. CMIIW...

    Untuk jawaban pertanyaan anda, mungkin ada baiknya anda melengkapi informasi yang terlewatkan.
    A person's junk is another person's treasure.

  3. #3
    Status
    Offline
    back2arie's Avatar
    Baru Gabung
    Join Date
    Nov 2010
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Sebenarnya VPN disini bukan VPN dalam arti sebenarnya, karena intinya hanya ingin menghubungkan network yang berbeda saja.

    Kurang lebih begini setelah ditambah informasi di post awal:
    Client == Mikrotik (192.168.23.3) == (192.168.23.1) Gateway (xx) == (172.16.79.49) Cloud (xx) == (192.168.20.1) Cloud (xx) == (Cloud2 yang lain) == (xx) VPN (192.168.200.0/24)

    (xx) artinya gw tidak tahu detil IP nya berapa.
    Dan lagi, gw tidak punya akses ke alat-alat selain Mikrotik dan Client, jadi gw tidak bisa menambahkan informasi routing di selain alat-alat tersebut.

    Admin disananya hanya memberitahukan bahwa untuk menghubungi 192.168.200.0/24 harus lewat 192.168.20.1.

  4. #4
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    Wah, kalau tidak memiliki akses ke router selain "Mikrotik", agak susah bro, soalnya kalau static routing tanpa NAT musti memasukkan entry IP lokal masing-masing di routernya, kecuali kalau di mesin-mesin yang dilewati tersebut menggunakan NAT (atau Masquerade), maka anda cukup memasukkan seperti ini:

    Code:
    /ip route add dst-address=192.168.200.0/24 gateway=192.168.23.1
    plus beberapa subnet IP yang dilewati jika memang diperlukan untuk mengaksesnya.

    Namun bila setting mereka tidak menggunakan NAT/Masquerade, anda musti memberitahukan IP lokal anda untuk dimasukkan Admin mereka ke masing-masing router.
    A person's junk is another person's treasure.

  5. The Following User Says Thank You to yosanpro For This Useful Post:


  6. #5
    Status
    Offline
    ch4rli3's Avatar
    Member
    Join Date
    Jul 2007
    Posts
    158
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by back2arie Click here to enlarge
    Mohon bantuan teman-teman...

    Gw punya Mikrotik dengan interface IP 192.168.23.3/24

    Kurang lebih topologiya begini:
    Client == Mikrotik == Gateway == Cloud == VPN

    Dalam hal ini Client kita hiraukan dulu.
    Nah, gw pengen masuk dari Mikrotik ke VPN dengan network 192.168.200.0/24
    berdasarkan skema di atas mikrotik bisa menggunakan route lsng ke cloud. caranya dg merubah setingan scope dan target scope di route.
    dengan catatan : semuanya full route.

  7. #6
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    nah, sepertinya bro ch4rli3 punya solusi untuk anda yang tidak memiliki hak akses router mereka, coba konsultasi sama beliau lewat posting ini, biar saya juga ikut belajar...
    A person's junk is another person's treasure.

  8. #7
    Status
    Offline
    back2arie's Avatar
    Baru Gabung
    Join Date
    Nov 2010
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Maap baru balik lagi..

    Click here to enlarge Originally Posted by yosanpro Click here to enlarge
    Code:
    /ip route add dst-address=192.168.200.0/24 gateway=192.168.23.1
    Sebelumnya sudah saya coba cara ini tapi hasilnya di traceroute malah muncul subnet-subnet yang berbeda lagi dan paketnya tidak sampai


    Click here to enlarge Originally Posted by ch4rli3 Click here to enlarge
    berdasarkan skema di atas mikrotik bisa menggunakan route lsng ke cloud. caranya dg merubah setingan scope dan target scope di route.
    dengan catatan : semuanya full route.
    Mohon kiranya bro ch4rli3 bisa memberikan penjelasan detil teknis-nya, ya minimal kulit luarnya, biar saya ada gambaran Click here to enlarge

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blok Browser tapi YM tidak
    By g3m1n1 in forum Scripting @ Mikrotik
    Replies: 26
    Last Post: 13-09-2011, 14:19
  2. [ask] sinyal penuh tapi tidak nyambung ??
    By upikbiru in forum Wireless Networking
    Replies: 32
    Last Post: 03-07-2010, 17:35
  3. Wireless Dengan Static Route
    By isayuti in forum General Networking
    Replies: 5
    Last Post: 13-09-2009, 04:43
  4. ngeroute dari AP route ke AP route yang lain...
    By Mr. Bus in forum Wireless Networking
    Replies: 2
    Last Post: 29-07-2009, 11:32
  5. static route in mikrotik
    By j14n6 in forum Beginner Basics
    Replies: 7
    Last Post: 30-04-2009, 10:13

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •