Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 4 of 4
  1. #1
    Status
    Offline
    wadooke's Avatar
    Baru Gabung
    Join Date
    Aug 2007
    Posts
    16
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0

    [Ask] LoadBalancing 2 Speedy + Exkternal Proxy----> Poker gak jalan!

    Assalamualaikum Wr.Wb

    Selama dua hari ini sy disibukkan setting 2 Spedy jadi satu (Load Balancing) untuk warnet di kota sy.
    Kemudian sy mencoba mengkombinasikan dengan Eksternal Proxy Ubuntu Server.
    Sebenarnya untuk client sudah bisa jalan, dan agaknya load balancing dan proxy-HIT nya juga jalan.

    Yang jadi kendala adalah :
    1. Maen Poker tidak jalan. padahal status server poker sudah connected.
    Loading...muter muter terusss......
    Click here to enlarge
    2. Buka kaskus.com dan beberapa website lain gak bisa...
    3. Remote ssh ke mesin proxy dari client ..gak bisa... kalo pingin remote ssh harus matikan semua manggle dulu, baru bisa remote ssh.
    4. Bagaimana setting limit download untuk semua client..

    Keterangan :
    1. Modem ADSL mode bridge
    - modem 1 : SPEEDY1 = 192.168.11.1
    - modem 2 : SPEEDY2 = 192.168.12.1
    2. Mikrotik RB750 version 4.10
    - ip ke lan = 192.168.10.1
    - ip ke modem 1 = 192.168.11.2
    - ip ke modem 2 = 192.168.12.2
    - ip ke proxy = 192.168.13.1
    3. Mesin Proxy Ubuntu Server 9.10
    - ip proxy = 192.168.13.100
    Untuk Settingan di mikrotik adalah sebagai berikut :

    1. IP Address
    /ip address
    add address=192.168.10.1/24 broadcast=192.168.10.255 comment="" disabled=no \
    interface=lan network=192.168.10.0
    add address=192.168.11.2/24 broadcast=192.168.11.255 comment="" disabled=no \
    interface=SPEEDY1 network=192.168.11.0
    add address=192.168.12.2/24 broadcast=192.168.12.255 comment="" disabled=no \
    interface=SPEEDY2 network=192.168.12.0
    add address=192.168.13.1/24 broadcast=192.168.13.255 comment="" disabled=no \
    interface=proxy network=192.168.13.0
    2. Address List
    /ip firewall address-list
    add address=192.168.10.0/24 comment="" disabled=no list=lanNET
    add address=192.168.13.0/24 comment="" disabled=no list=proxyNET
    3. Firewall mangle
    /ip firewall mangle
    add action=mark-connection chain=forward comment=proxy-HIT-DSCP-12 disabled=\
    no in-interface=proxy new-connection-mark=Hit out-interface=lan \
    passthrough=yes protocol=tcp
    add action=mark-packet chain=forward comment="" connection-mark=Hit disabled=\
    no in-interface=proxy new-packet-mark=proxy-hit out-interface=lan \
    passthrough=no protocol=tcp
    add action=mark-connection chain=input comment="PCC-RULE-MARK ALL PPPoE CONN" \
    connection-state=new disabled=no in-interface=pppoe_1 \
    new-connection-mark=pppoe1_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe_2 new-connection-mark=pppoe2_conn \
    passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-state=\
    established disabled=no in-interface=pppoe_1 new-connection-mark=\
    pppoe1_conn passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-state=\
    established disabled=no in-interface=pppoe_2 new-connection-mark=\
    pppoe2_conn passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-state=\
    related disabled=no in-interface=pppoe_1 new-connection-mark=pppoe1_conn \
    passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-state=\
    related disabled=no in-interface=pppoe_2 new-connection-mark=pppoe2_conn \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=pppoe1_conn \
    disabled=no new-routing-mark=pppoe_1 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=pppoe2_conn \
    disabled=no new-routing-mark=pppoe_2 passthrough=no
    add action=mark-connection chain=prerouting comment=\
    "PCC-RULE- MARK ALL HTTP CONN" connection-state=new disabled=no \
    dst-address-type=!local dst-port=80 in-interface=proxy \
    new-connection-mark=pr_pppoe_1 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=no dst-address-type=!local dst-port=80 in-interface=proxy \
    new-connection-mark=pr_pppoe_2 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/1 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    established disabled=no dst-address-type=!local dst-port=80 in-interface=\
    proxy new-connection-mark=pr_pppoe_1 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    established disabled=no dst-address-type=!local dst-port=80 in-interface=\
    proxy new-connection-mark=pr_pppoe_2 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    related disabled=no dst-address-type=!local dst-port=80 in-interface=\
    proxy new-connection-mark=pr_pppoe_1 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    related disabled=no dst-address-type=!local dst-port=80 in-interface=\
    proxy new-connection-mark=pr_pppoe_2 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
    add action=mark-connection chain=prerouting comment=\
    "PCC-RULE- MARK ALL NON HTTP CONN" connection-state=new disabled=no \
    dst-address-type=!local dst-port=!80 in-interface=lan \
    new-connection-mark=pr_pppoe_11 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=no dst-address-type=!local dst-port=!80 in-interface=lan \
    new-connection-mark=pr_pppoe_21 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    established disabled=no dst-address-type=!local dst-port=!80 \
    in-interface=lan new-connection-mark=pr_pppoe_11 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    related disabled=no dst-address-type=!local dst-port=!80 in-interface=lan \
    new-connection-mark=pr_pppoe_11 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    established disabled=no dst-address-type=!local dst-port=!80 \
    in-interface=lan new-connection-mark=pr_pppoe_21 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    related disabled=no dst-address-type=!local dst-port=!80 in-interface=lan \
    new-connection-mark=pr_pppoe_21 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
    add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=\
    pr_pppoe_11 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0 protocol=udp
    add action=mark-connection chain=prerouting comment="" connection-state=new \
    disabled=no dst-address-type=!local in-interface=lan new-connection-mark=\
    pr_pppoe_21 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/1 protocol=udp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan \
    new-connection-mark=pr_pppoe_11 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0 protocol=udp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    established disabled=no dst-address-type=!local in-interface=lan \
    new-connection-mark=pr_pppoe_21 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1 protocol=udp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    related disabled=no dst-address-type=!local in-interface=lan \
    new-connection-mark=pr_pppoe_11 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/0 protocol=udp
    add action=mark-connection chain=prerouting comment="" connection-state=\
    related disabled=no dst-address-type=!local in-interface=lan \
    new-connection-mark=pr_pppoe_21 passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1 protocol=udp
    add action=mark-packet chain=forward comment="PCC-RULE- MARK-HTTP" \
    connection-mark=pr_pppoe_1 disabled=no new-packet-mark=http_pppoe1_pkt \
    passthrough=no
    add action=mark-packet chain=forward comment="" connection-mark=pr_pppoe_2 \
    disabled=no new-packet-mark=http_pppoe2_pkt passthrough=no
    add action=mark-routing chain=prerouting comment="PCC-RULE-MARK HTTP ROUTE" \
    connection-mark=pr_pppoe_1 disabled=no new-routing-mark=pppoe_1 \
    passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    pr_pppoe_2 disabled=no new-routing-mark=pppoe_2 passthrough=yes
    add action=mark-routing chain=prerouting comment=\
    "PCC-RULE-MARK NON HTTP ROUTE" connection-mark=pr_pppoe_11 disabled=no \
    new-routing-mark=pppoe_1 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    pr_pppoe_21 disabled=no new-routing-mark=pppoe_2 passthrough=yes
    add action=mark-connection chain=prerouting comment="POKER + POINT BLANK" \
    disabled=no dst-address-list="Poker + PB" dst-port=49100 \
    new-connection-mark="Trafik PB + POKER" passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-list="Poker + PB" dst-port=40000-40010 new-connection-mark=\
    "Trafik PB + POKER" passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" content=\
    statics.poker.static.zynga.com disabled=no dst-address-list="Poker + PB" \
    dst-port=39190 new-connection-mark="Trafik PB + POKER" passthrough=yes \
    protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    "Trafik PB + POKER" disabled=no new-packet-mark="PB + Poker" passthrough=\
    yes
    add action=mark-routing chain=prerouting comment=\
    "ROUTING POKER + POINT BLANK" connection-mark="Trafik PB + POKER" \
    disabled=no dst-address-list="Poker + PB" in-interface=lan \
    new-routing-mark="Poker + PB" passthrough=no src-address=192.168.10.0/24
    add action=add-dst-to-address-list address-list="Poker + PB" \
    address-list-timeout=0s chain=forward comment=\
    "SCANNER POKER + POINT BLANK" disabled=no dst-port=843 protocol=tcp
    add action=add-dst-to-address-list address-list="Poker + PB" \
    address-list-timeout=0s chain=forward comment="" disabled=no dst-port=\
    9339 protocol=tcp
    add action=add-dst-to-address-list address-list="Poker + PB" \
    address-list-timeout=0s chain=forward comment="" disabled=no dst-port=\
    39190 protocol=tcp
    add action=add-dst-to-address-list address-list="Poker + PB" \
    address-list-timeout=0s chain=forward comment="" disabled=no dst-port=\
    49100 protocol=tcp
    add action=add-dst-to-address-list address-list="Poker + PB" \
    address-list-timeout=0s chain=forward comment="" disabled=no dst-port=\
    40000-40010 protocol=tcp
    4. Firewall NAT
    /ip firewall nat
    add action=masquerade chain=srcnat comment=MASQUERADE1 disabled=no \
    out-interface=pppoe_1
    add action=masquerade chain=srcnat comment=MASQUERADE2 disabled=no \
    out-interface=pppoe_2
    add action=masquerade chain=srcnat comment=MASQUERADE3 disabled=no \
    out-interface=proxy
    add action=dst-nat chain=dstnat comment=TRANSPARENT-proxy disabled=no \
    dst-address-list=!proxyNET dst-port=80,8080,3128 in-interface=lan \
    protocol=tcp to-addresses=192.168.13.100 to-ports=3128
    add action=dst-nat chain=dstnat comment="DMZ ubuntu server" disabled=no \
    dst-port=22 in-interface=lan protocol=tcp to-addresses=192.168.13.254 \
    to-ports=22
    add action=dst-nat chain=dstnat comment=TRANSPARENT-DNS disabled=no dst-port=\
    53 in-interface=lan protocol=udp to-ports=53
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=lan protocol=tcp to-ports=53
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=proxy protocol=udp to-ports=53
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=53 \
    in-interface=proxy protocol=tcp to-ports=53
    5. IP Route
    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=pppoe_1 routing-mark=pppoe_1 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=pppoe_1 routing-mark=pppoe_1 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=pppoe_2 routing-mark=pppoe_2 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=pppoe_2 routing-mark=pppoe_2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe_1 \
    routing-mark="Poker + PB" scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe_2 \
    routing-mark="Poker + PB" scope=30 target-scope=10
    add check-gateway=ping comment=Default-Route-pppoe1-Distance-1 disabled=no \
    distance=1 dst-address=0.0.0.0/0 gateway=pppoe_1 scope=30 target-scope=10
    add check-gateway=ping comment=Default-Route-pppoe2-Distance-2 disabled=no \
    distance=2 dst-address=0.0.0.0/0 gateway=pppoe_2 scope=30 target-scope=10
    6. Queue Tree Proxy-HIT
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="Proxy Hit" packet-mark=proxy-hit parent=global-out \
    priority=1 queue=default
    Sambung di post #2....

  2. #2
    Status
    Offline
    buyungsandy's Avatar
    Member
    Join Date
    Dec 2009
    Location
    FirlyNET SAMARINDA
    Posts
    214
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    843 sma 9339 bikinin route ke salah satu line Click here to enlarge

  3. #3
    Status
    Offline
    wadooke's Avatar
    Baru Gabung
    Join Date
    Aug 2007
    Posts
    16
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0
    ok. gan.,.
    makasih infonya...
    ternyata salah di setting mangle dan proxynya.

  4. #4
    Status
    Offline
    m3tr0mini's Avatar
    Member Super Senior
    Join Date
    Sep 2007
    Posts
    660
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    makasih udah [solved] Click here to enlarge


    @MOD: pls mohon di closed udah solved neh..Click here to enlarge

  5. The Following User Says Thank You to m3tr0mini For This Useful Post:


 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. konfigurasi loadbalancing fasnet dan speedy
    By kadal_culun in forum Beginner Basics
    Replies: 16
    Last Post: 15-07-2011, 21:53
  2. Replies: 11
    Last Post: 23-02-2008, 21:40
  3. Loadbalancing yang terbaik untuk warnet speedy ??
    By sinapit in forum General Networking
    Replies: 10
    Last Post: 12-02-2008, 03:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •