Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 3 of 3
  1. #1
    Status
    Offline
    gushid's Avatar
    Baru Gabung
    Join Date
    Feb 2009
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Mohon bantuan seting server dan mikrotik

    Mohon bantuannya dong…

    Saya baru dapat tugas dari kantor untuk pegang server ubuntu 10.04 (ini kali pertama saya pegang server dan linux). Tugas yang diberikan adalah agar server bisa diakses pakai nama domain kantor sebab dipakai untuk database sebuah system informasi (diakses dari cabang kantor). Kebetulan dikantor ada jaringan hotspot pakai mikrotik RB 750, jadi saya berusaha menggabungkannya dengan DMZ. Topologinya seperti ini :

    Modem ADSL (bridge)
    | |
    | |
    | Mikrotik (pppoe)
    | |
    | Bridge Hotspot ----Hub Lan ---AP (wifi)
    | |
    | |
    | AP(wifi)
    |
    |
    Server-----Hub Lan-----8 klien

    IP Publik dari telkom 110.139.xxx.xx
    IP Modem 192.168.1.1 ---- 192.68.1.10 IP Mikrotik eth1
    IP Mikrotik eth2 192.168.150.10 ----- 192.168.150.100 IP Server eth0
    IP Mikrotik Bridge (eth4 dan eth5) 25.25.25.10 (hotspot) ------ Klien DHCP
    IP Server eth1 192.168.10.1 ------ Klien Static 192.168.10.0/24

    Dari topologi diatas semua klien sudah bisa mengakses internet dan berbagi file (bagi yang sharing) dan Ketika diakses dari browser di luar jaringan kantor ke IP Publik atau ke nama domain It Work !

    Permasalahan yang saya alami :
    1. Kenapa klien dibawah server (192.168.10.0/24) bisa langsung akses internet tanpa login ke hotspot ya? Pengennya semua klien untuk internetnya harus melalui login page hotspot (biar terkontrol) kecuali server. Ketika saya bridge eth2 Mikrotik dengan hotspot yang ada, semua klien dibawah server bisa masuk internet lewat login page termasuk sever. Tetapi kalo ip server saya binding, ip klien dibawah server kok jadi free juga ya? Bagaimana ya kira-kira solusinya agar hanya server saja yang bisa ke internet tanpa login hotspot?
    2. Ketika saya mencoba untuk ftp ataupun remot server dari luar ke ip publik atau nama domain kok nyangkutnya ke Mikrotik ya? Bukan ke Server?! Tapi kalo saya PPTP dulu lalu ftp ataupun remot dengan ip lokal bisa langsung ke server. Kira-kira apa yang harus diseting lagi ya?

    Mohon arahan para senior dan terima kasih.

  2. #2
    Status
    Offline
    vzouh's Avatar
    Member Super Senior
    Join Date
    Jun 2009
    Location
    Solo-Sragen PP
    Posts
    682
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by gushid Click here to enlarge
    Mohon bantuannya dong…

    Saya baru dapat tugas dari kantor untuk pegang server ubuntu 10.04 (ini kali pertama saya pegang server dan linux). Tugas yang diberikan adalah agar server bisa diakses pakai nama domain kantor sebab dipakai untuk database sebuah system informasi (diakses dari cabang kantor). Kebetulan dikantor ada jaringan hotspot pakai mikrotik RB 750, jadi saya berusaha menggabungkannya dengan DMZ. Topologinya seperti ini :

    Modem ADSL (bridge)
    | |
    | |
    | Mikrotik (pppoe)
    | |
    | Bridge Hotspot ----Hub Lan ---AP (wifi)
    | |
    | |
    | AP(wifi)
    |
    |
    Server-----Hub Lan-----8 klien

    IP Publik dari telkom 110.139.xxx.xx
    IP Modem 192.168.1.1 ---- 192.68.1.10 IP Mikrotik eth1
    IP Mikrotik eth2 192.168.150.10 ----- 192.168.150.100 IP Server eth0
    IP Mikrotik Bridge (eth4 dan eth5) 25.25.25.10 (hotspot) ------ Klien DHCP
    IP Server eth1 192.168.10.1 ------ Klien Static 192.168.10.0/24

    Dari topologi diatas semua klien sudah bisa mengakses internet dan berbagi file (bagi yang sharing) dan Ketika diakses dari browser di luar jaringan kantor ke IP Publik atau ke nama domain It Work !

    Permasalahan yang saya alami :
    1. Kenapa klien dibawah server (192.168.10.0/24) bisa langsung akses internet tanpa login ke hotspot ya? Pengennya semua klien untuk internetnya harus melalui login page hotspot (biar terkontrol) kecuali server. Ketika saya bridge eth2 Mikrotik dengan hotspot yang ada, semua klien dibawah server bisa masuk internet lewat login page termasuk sever. Tetapi kalo ip server saya binding, ip klien dibawah server kok jadi free juga ya? Bagaimana ya kira-kira solusinya agar hanya server saja yang bisa ke internet tanpa login hotspot?
    2. Ketika saya mencoba untuk ftp ataupun remot server dari luar ke ip publik atau nama domain kok nyangkutnya ke Mikrotik ya? Bukan ke Server?! Tapi kalo saya PPTP dulu lalu ftp ataupun remot dengan ip lokal bisa langsung ke server. Kira-kira apa yang harus diseting lagi ya?

    Mohon arahan para senior dan terima kasih.
    1. linux servernya harus jalan sbg bridge bukan router supaya mac client masuk arp mikrotik.
    2. secara default klo dial pppoe di MT otomatis akses dari ip public nyangkutnya di MT, klo mo diteruskan ke server linux harus di NAT di MTnya.
    3. CMIIW Click here to enlarge

  3. The Following User Says Thank You to vzouh For This Useful Post:


  4. #3
    Status
    Offline
    gushid's Avatar
    Baru Gabung
    Join Date
    Feb 2009
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Originally Posted by vzouh
    1. linux servernya harus jalan sbg bridge bukan router supaya mac client masuk arp mikrotik.
    2. secara default klo dial pppoe di MT otomatis akses dari ip public nyangkutnya di MT, klo mo diteruskan ke server linux harus di NAT di MTnya.
    Terima kasih atas responnya, maksud server sbg bridge gimana ya? maklum saya baru kali ini pegang server. Ini saya sertakan setingan ip address server dan NAT Mikrotiknya...mohon dikoreksi dimana error nya :

    Setingan di interface server :

    # The loopback network interface
    auto lo eth0 eth1
    iface lo inet loopback

    # The primary network interface
    iface eth0 inet static
    address 192.168.150.100
    netmask 255.255.255.0
    network 192.168.150.0
    broadcast 192.168.150.255
    dns-nameservers 180.131.144.144 180.131.145.145 25.25.25.10 192.168.150.10
    post-up iptables-restore < /etc/iptables.up.rules
    gateway 192.168.150.10
    # dns-* options are implemented by the resolvconf package, if installed

    #The secondary network interface
    iface eth1 inet static
    address 192.168.10.1
    netmask 255.255.255.0
    broadcast 192.168.10.255
    network 192.168.10.0

    Setingan NAT di Mikrotik :

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    192.168.150.100
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    25.25.25.0/24
    add action=dst-nat chain=dstnat comment="" disabled=no dst-address=\
    110.139.xxx.xx dst-port=80 protocol=tcp to-addresses=192.168.150.100 \
    to-ports=0-65535
    add action=dst-nat chain=dstnat comment="" disabled=no dst-address=\
    110.139.xxx.xx dst-port=23 protocol=tcp to-addresses=192.168.150.100 \
    to-ports=21
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    add action=redirect chain=dstnat comment="masquerade hotspot network" \
    disabled=yes protocol=tcp src-port=80 to-ports=8080
    add action=redirect chain=dstnat comment="masquerade hotspot network" \
    disabled=yes protocol=tcp src-port=8080 to-ports=8080
    add action=redirect chain=dstnat comment="masquerade hotspot network" \
    disabled=yes protocol=tcp src-port=3128 to-ports=8080
    Last edited by gushid; 07-09-2010 at 16:54.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mohon bantuan konfigurasi pada hotspot mikrotik
    By helmisubiakto in forum Wireless Networking
    Replies: 9
    Last Post: 15-09-2013, 02:32
  2. [ASK] PPPoe Server + PCQ seting... mohon koreksinya...
    By fanatiCanz in forum General Networking
    Replies: 7
    Last Post: 02-11-2010, 01:27
  3. Mohon bantuan Seting RB 800 nga bisa browsing
    By YU5R1L in forum Beginner Basics
    Replies: 5
    Last Post: 20-07-2010, 23:22
  4. Minta bantuan(seting mikrotik 3 LAN Card )
    By noto in forum General Networking
    Replies: 4
    Last Post: 04-03-2008, 16:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •