Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1
    Status
    Offline
    3dyx's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    3 line 3 Fungsi NO LOAD BALANCING

    Terimakasih sebelumnya untuk Forum Mikrotik yang telah banyak menyediakan tutorial dan triknya.
    Spesial thanks buat Mas Doni Permono yang setia di YM menerima pertanyaan newbie seperti saya.
    Spesial thanks juga buat nice tutor: mas beben, mas dingo, om uburcumi dan suhu2 di forum ini.

    Saya pengen berbagi pengalaman untuk yang mau setting mikrotik buat 3 fungsi berbeda tapi tidak menggunakan Loadbalancing.
    Alasan tersendiri buat saya tidak menggunakan Loadbalancing karna masalah ISP yang digunakan berbeda dan tidak stabil yang sangat merugikan para gamer.
    Semoga dengan postingan ini banyak masukkan yang dapat membuat lebih maximal hasilnya.

    Masing-masing fungsi
    Speedy1 = browsing
    Speedy2 = Poker + Game Selain PB
    WanXp = PB only

    Topologi jaringan

    speedy1(2mbps) ---|
    +++++++++++++++|
    speedy2(3mbps) ---|--Mikrotik ----HUB---Client 80unit
    +++++++++++++++|++++|
    wanxp (1mbps)----|++++|
    ++++++++++++++++++++|
    ++++++++++++Proxy Transparant

    Untuk IP Address masing-masing Interfaces
    Code:
    /ip address print
    Flags: X - disabled, I - invalid, D - dynamic 
     #   ADDRESS            NETWORK         BROADCAST       INTERFACE                                                                                             
     0   192.168.20.11/24   192.168.20.0    192.168.20.255  speedy1                                                                                               
     1   172.20.88.254/16   172.20.0.0      172.20.255.255  lokal                                                                                                 
     2   192.168.2.11/24    192.168.2.0     192.168.2.255   speedy2                                                                                               
     3   192.168.69.70/24   192.168.69.0    192.168.69.255  wanxp                                                                                                 
     4   192.168.4.1/24     192.168.4.0     192.168.4.255   proxy
    Untuk Routing yang pengen menggunakan backup gateway silahkan ditambah.
    Click here to enlarge

    Berikut settingan mangle untuk proxy hit dan pemisah antara speedy1 dan jaringan wan
    Code:
    /ip firewall mangle
    add action=marks-packet chain=postrouting comment="PROXY HIT LUSCA" disabled=no \
        dscp=12 new-packet-mark=proxy-hit passthrough=no
    add action=marks-routing chain=prerouting comment="Point Blank WANXP ONLY" \
        disabled=no dst-address-list=PB new-routing-mark=PB-WANXP passthrough=no \
        src-address=172.20.0.0/16
    add action=marks-connection chain=forward comment=\
        "Browsing SPEEDY1 ONLY - NO WANXP" disabled=no dst-address-list=!PB \
        new-connection-mark=Browsing passthrough=yes src-address=172.20.0.0/16
    add action=marks-connection chain=forward comment=\
        "Browsing SPEEDY1 ONLY - NO SPEEDY2" disabled=no dst-address-list=!game \
        new-connection-mark=Browsing passthrough=yes src-address=172.20.0.0/16
    automatic add IP game to address-list
    Code:
    /ip firewall filter
    add action=add-dst-to-address-list address-list=PB address-list-timeout=0s \
        chain=forward comment="AUTOMATIC ADD IP GAME" disabled=no dst-port=\
        40000-40010 protocol=udp
    add action=add-dst-to-address-list address-list=PB address-list-timeout=0s \
        chain=forward comment=PB disabled=no dst-port=\
        39100,39110,39220,39190,49100 protocol=tcp
    add action=add-dst-to-address-list address-list=nice address-list-timeout=0s \
        chain=forward comment="Ayo Dance" disabled=no dst-port=18901-18909 \
        protocol=tcp
    add action=add-dst-to-address-list address-list=nice address-list-timeout=0s \
        chain=forward comment="AUTOMATIC ADD IP POKER" disabled=no dst-port=9339 \
        protocol=tcp
    add action=add-dst-to-address-list address-list=nice address-list-timeout=0s \
        chain=forward comment="" disabled=no dst-port=843 protocol=tcp
    
    dst ..... (sesuaikan dengan game yg ada)
    Rule untuk mengarahkan game selain PB ke speedy2
    Code:
    /ip firewall mangle
    add action=marks-connection chain=prerouting comment="Ayo Dance" disabled=no \
        dst-address-list=nice dst-port=18901-18909 new-connection-mark=Game \
        passthrough=yes protocol=tcp
    add action=marks-connection chain=prerouting comment=SealOnline disabled=no \
        dst-address-list=nice dst-port=1818 new-connection-mark=Game passthrough=\
        yes protocol=tcp
    add action=marks-connection chain=prerouting comment=LineAge2 disabled=no \
        dst-address-list=nice dst-port=7777 new-connection-mark=Game passthrough=\
        yes protocol=tcp
    add action=marks-connection chain=prerouting comment=Poker disabled=no \
        dst-address-list=nice dst-port=9339 new-connection-mark=Game passthrough=\
        yes protocol=tcp
    add action=marks-connection chain=prerouting comment=Poker disabled=no \
        dst-address-list=nice dst-port=843 new-connection-mark=Game passthrough=\
        yes protocol=tcp
    
    dst ..... (sesuaikan dengan game yg ada)
    
    add action=marks-routing chain=prerouting comment="ROUTING Game selain PB" \
        connection-mark=Game disabled=no in-interface=lokal new-routing-mark=nice \
        passthrough=no src-address=172.20.0.0/16
    add action=marks-connection chain=forward comment="Poker dan Game Selain PB" \
        disabled=no dst-address-list=nice new-connection-mark=Poker-OtherGame \
        passthrough=yes src-address=172.20.0.0/16
    add action=marks-packet chain=postrouting comment="" connection-mark=\
        Poker-OtherGame disabled=no new-packet-mark=Poker-OtherGame passthrough=no

    Nat masing-masing interface + transparant proxy
    Code:
    /ip firewall nat
    add action=masquerade chain=srcnat comment="Masquerade PB-WANXP" disabled=no dst-address-list=PB out-interface=wanxp routing-mark=PB-WANXP src-address=\
        172.20.0.0/16
    add action=masquerade chain=srcnat comment="Masquerade Poker-Game - Speedy2" disabled=no out-interface=speedy2 routing-mark=nice src-address=172.20.0.0/16
    add action=masquerade chain=srcnat comment="Masquerade Proxy" disabled=no src-address=192.168.4.0/24
    add action=masquerade chain=srcnat comment="Masquerade Browsing Speedy1" disabled=no out-interface=speedy1 src-address=172.20.0.0/16
    add action=dst-nat chain=dstnat comment="TRANSPARENT PROXY HIT" disabled=no dst-port=80,8080,81 protocol=tcp routing-mark=!PB-WANXP src-address=!192.168.4.2 \
        to-addresses=192.168.4.2 to-ports=3128

    Hasilnya dengan menggunakan torch sebagai berikut:
    Semoga dengan settingan di atas tidak ada jalur yang tersesat

    1. Torch ke speedy1 = browsing
    Click here to enlarge

    2. Torch ke speedy2 = Poker + game selain PB
    Click here to enlarge

    3. Torch ke WanXP = PB Only
    Click here to enlarge

    Kalau ada yang salah mohon di koreksi maklum masih newbie..
    Untuk BW management mohon di sesuaikan sendiri tergantung kesukaan masing-masing dan di forum ini sudah sangat melimpah tutorialnya.

    Semoga bermanfaat dan semoga yg copas lebih teliti Click here to enlarge

    Catatan: untuk address list nice adalah address game saja.

    Refrensi:





  2. The Following 12 Users Say Thank You to 3dyx For This Useful Post:

    + Show/Hide list of the thanked


  3. #2
    Status
    Offline
    tawa's Avatar
    Member
    Join Date
    Jul 2008
    Location
    www.wifi-bengkulu.blogspot.com
    Posts
    141
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    mantap boos...
    automatic detect,,, Click here to enlarge

  4. The Following User Says Thank You to tawa For This Useful Post:


  5. #3
    Status
    Offline
    funky_monks's Avatar
    Newbie
    Join Date
    Jun 2010
    Posts
    52
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mantap gan... ijin bookmark dl...
    Click here to enlarge

  6. #4
    Status
    Offline
    supermanVSspiderman's Avatar
    Member
    Join Date
    Jun 2010
    Posts
    121
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge[/CENTER]

  7. The Following User Says Thank You to supermanVSspiderman For This Useful Post:


  8. #5
    Status
    Offline
    3dyx's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Maksih om ..

    silahkan di coba dan share ya kelemahan ke kurangannya ...

  9. The Following User Says Thank You to 3dyx For This Useful Post:


  10. #6
    Status
    Offline
    akank's Avatar
    Newbie
    Join Date
    Oct 2009
    Location
    pekanbaru
    Posts
    27
    Reviews
    Read 0 Reviews
    Downloads
    8
    Uploads
    0
    Feedback Score
    0
    mantap keknya ne mo coba dulu Click here to enlarge

  11. #7
    Status
    Offline
    3dyx's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by akank Click here to enlarge
    mantap keknya ne mo coba dulu Click here to enlarge
    Silahkan om .. di tunggu review nya ..
    Click here to enlarge

  12. #8
    Status
    Offline
    supermanVSspiderman's Avatar
    Member
    Join Date
    Jun 2010
    Posts
    121
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ngomomg2 kalo pake squid gmn kofig nya gan.. Click here to enlarge

  13. The Following User Says Thank You to supermanVSspiderman For This Useful Post:


  14. #9
    Status
    Offline
    3dyx's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by supermanVSspiderman Click here to enlarge
    ngomomg2 kalo pake squid gmn kofig nya gan.. Click here to enlarge
    walah .. untuk dimangle ga ngaruh ko sama squid .. kan tinggal di NAT saha tuh om .. diarahin ke squid internal apa squid external ...

    kalo rule scriptnya dah banyak di forum ini .. tinggal copas ...

    Click here to enlarge

  15. #10
    Status
    Offline
    untungslamet's Avatar
    Member
    Join Date
    Nov 2009
    Posts
    271
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Pengen nyoba ni.....

  16. #11
    Status
    Offline
    3dyx's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by untungslamet Click here to enlarge
    Pengen nyoba ni.....
    silahkan om .. di tunggu review nya ..

  17. #12
    Status
    Offline
    alvis adelio's Avatar
    Member
    Join Date
    May 2010
    Posts
    100
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Mohon bantuannya OM.
    saya punya 2 line speedy, pingin nya membagi user ke masing2 speedy tsb dan saya juga pingin memakai proxy.

    SPEEDY-A = IP LAN 192.168.10.1 - 192.168.10.10
    SPEEDY-B = IP LAN 192.168.10.11 - 192.168.10.20

    PROXY =192.168.4.1

    sekali mohon bantuannya om bagimana mangle nya, maklum newbie..tq

  18. #13
    Status
    Offline
    3dyx's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    68
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by alvis adelio Click here to enlarge
    Mohon bantuannya OM.
    saya punya 2 line speedy, pingin nya membagi user ke masing2 speedy tsb dan saya juga pingin memakai proxy.

    SPEEDY-A = IP LAN 192.168.10.1 - 192.168.10.10
    SPEEDY-B = IP LAN 192.168.10.11 - 192.168.10.20

    PROXY =192.168.4.1

    sekali mohon bantuannya om bagimana mangle nya, maklum newbie..tq

    Walah om .. dah ada di forum ini juga .. kalo ga salah suhu akangage yg nulis ... lupa judulnya .. pisahkan gateway berdasarkan segmen client itu ya ...
    Last edited by 3dyx; 22-08-2010 at 02:09.

  19. #14
    Status
    Offline
    vmobile's Avatar
    Newbie
    Join Date
    Dec 2008
    Posts
    28
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    om klo 3 line speedy + eksternal proxy .. tapi 2 line untuk browsing dan 1 line untuk game bisa dipake ga konfig nya??? klo bisa mangle sama rule nya gmn ya OM
    ternyata udah bisa om....
    [operator@MikroTik] > ip fir ma print
    Flags: X - disabled, I - invalid, D - dynamic
    3 ;;; gameonlyyyy
    chain=prerouting action=mark-routing new-routing-mark=gameonly
    passthrough=no dst-address-list=game in-interface=lokal

    9 ;;; Packet Proxy HIT
    chain=prerouting action=mark-packet new-packet-mark=proxy-hit
    passthrough=no protocol=tcp in-interface=proxy dscp=12

    10 chain=forward action=mark-packet new-packet-mark=proxy-hit passthrough=no
    protocol=tcp in-interface=proxy dscp=12
    15 ;;; Mangle NTH PROXY
    chain=prerouting action=mark-connection new-connection-mark=modem1
    passthrough=yes connection-state=new in-interface=proxy nth=2,1

    16 chain=prerouting action=mark-routing new-routing-mark=modem1
    passthrough=no in-interface=proxy connection-mark=modem1

    17 chain=prerouting action=mark-connection new-connection-mark=modem2
    passthrough=yes connection-state=new in-interface=proxy nth=1,1

    18 chain=prerouting action=mark-routing new-routing-mark=modem2
    passthrough=no in-interface=proxy connection-mark=modem2

    0 ;;; NAT to PROXY
    chain=dstnat action=dst-nat to-addresses=192.168.3.1 to-ports=3128
    protocol=tcp src-address=192.168.0.0/24 routing-mark=!gameonly
    dst-address-list=!ip_noproxy dst-port=80

    1 ;;; game only
    chain=srcnat action=masquerade routing-mark=gameonly
    dst-address-list=game out-interface=pppoe-speedy_3

    2 ;;; Masquerade LAN
    chain=srcnat action=masquerade out-interface=pppoe-speedy1

    3 chain=srcnat action=masquerade out-interface=pppoe-speedy2
    tapi kira2 bisa ga untuk update game nya tetap lewat proxy??? karena klo ada yang update game nya koneksi game langsung parah...
    Last edited by vmobile; 22-11-2010 at 10:17.

  20. #15
    Status
    Offline
    bag10's Avatar
    Baru Gabung
    Join Date
    Nov 2010
    Location
    /home/dolly
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    tanya juga om, kalau pake pppoe bisa nggak ya ?

 

 
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 47
    Last Post: 27-09-2012, 11:19
  2. Load balancing 4 line speedy
    By nyak_muchlis in forum General Networking
    Replies: 15
    Last Post: 27-08-2011, 17:10
  3. Replies: 14
    Last Post: 02-12-2010, 07:23
  4. [ask for checking] 3 line speedy load balancing + ppoe
    By ketombe in forum Beginner Basics
    Replies: 6
    Last Post: 04-08-2010, 19:51
  5. Replies: 18
    Last Post: 11-01-2010, 01:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •