Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 2 12 LastLast
Results 1 to 15 of 30
  1. #1
    Status
    Offline
    adiputrolds's Avatar
    Forum Guru
    Join Date
    Oct 2008
    Posts
    1,485
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Post passthrough=no yg rada aneh

    sebenernya saya gk ada masalah lagi gan

    Masalah :
    Jika saya membuat mangle untuk menangkap traffic Direct-Down tanpa disertakan connection-mark=no-mark kenapa traffic seperti poker atau traffic lain yang telah saya buat di chain=prerouting bisa tertangkap lagi di mangle Direct-Down jika tanpa menyertakan connection-mark=no-mark padahal semua mangle untuk traffic poker dan traffic lain diatas telah di passthrough=no

    contoh :
    Code:
    /ip fir mangle
    add chain=postrouting action=mark-connection new-connection-mark=Direct-Down out-interface=Local passthrough=yes
    add chain=postrouting action=mark-packet new-packet-mark=direct-down connection-mark=Direct-Down out-interface=Local passthrough=no

    Tetapi dengan menyertakan connection-mark=no-mark masalah teratasi.
    Code:
    /ip fir mangle
    add chain=postrouting action=mark-connection new-connection-mark=Direct-Down out-interface=Local connection-mark=no-mark passthrough=yes
    add chain=postrouting action=mark-packet new-packet-mark=direct-down connection-mark=Direct-Down out-interface=Local passthrough=no

    mohon pembahasan dari master2 mikrotik disini
    Last edited by adiputrolds; 21-07-2010 at 19:54.

  2. #2
    Status
    Offline
    president voice's Avatar
    Newbie
    Join Date
    Jul 2010
    Posts
    50
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by electrix_85 Click here to enlarge
    sebenernya saya gk ada masalah lagi gan

    Masalah :
    Jika saya membuat mangle untuk menangkap traffic Direct-Down tanpa disertakan connection-mark=no-mark kenapa traffic seperti poker atau traffic lain yang telah saya buat di chain=prerouting bisa tertangkap lagi di mangle Direct-Down jika tanpa menyertakan connection-mark=no-mark padahal semua mangle untuk traffic poker dan traffic lain diatas telah di passthrough=no

    contoh :
    Code:
    /ip fir mangle
    add chain=postrouting action=mark-connection new-connection-mark=Direct-Down out-interface=Local passthrough=yes
    add chain=postrouting action=mark-packet new-packet-mark=direct-down connection-mark=Direct-Down out-interface=Local passthrough=no

    Tetapi dengan menyertakan connection-mark=no-mark masalah teratasi.
    Code:
    /ip fir mangle
    add chain=postrouting action=mark-connection new-connection-mark=Direct-Down out-interface=Local connection-mark=no-mark passthrough=yes
    add chain=postrouting action=mark-packet new-packet-mark=direct-down connection-mark=Direct-Down out-interface=Local passthrough=no

    mohon pembahasan dari master2 mikrotik disini
    yang gw tebalin itu rulenya mana bung?kalo nulis script jangan di [code] tapi pake [quote]
    Last edited by president voice; 21-07-2010 at 20:30.

  3. #3
    Status
    Offline
    adiputrolds's Avatar
    Forum Guru
    Join Date
    Oct 2008
    Posts
    1,485
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by president voice Click here to enlarge
    yang gw tebalin itu rulenya mana bung?kalo nulis script jangan di [code] tapi pake quote
    kok pakek quote sich
    pakek code malah lebih rapih
    aneh lu !!!

    itu mangle direct-down

    tolong baca dulu pertanyaannya !!

  4. #4
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    sepertinya logis kalau tertangkap lagi, karena chain postrouting berada di belakang prerouting, sehingga trafik yang sudah di-mark di prerouting akan di-mark lagi di postrouting, kecuali itu tadi, dikasih connection-mark=no-mark, sehingga yang dikasih mark di postrouting cuma connection yang tanpa label. Passthrough=no di atasnya kan hanya berlaku untuk packet-mark, bukan connection-mark. CMIIW...

    Anyway, problem solved dikasih connection-mark=no-mark kan?
    A person's junk is another person's treasure.

  5. #5
    Status
    Offline
    adiputrolds's Avatar
    Forum Guru
    Join Date
    Oct 2008
    Posts
    1,485
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by yosanpro Click here to enlarge
    sepertinya logis kalau tertangkap lagi, karena chain postrouting berada di belakang prerouting, sehingga trafik yang sudah di-mark di prerouting akan di-mark lagi di postrouting, kecuali itu tadi, dikasih connection-mark=no-mark, sehingga yang dikasih mark di postrouting cuma connection yang tanpa label. Passthrough=no di atasnya kan hanya berlaku untuk packet-mark, bukan connection-mark. CMIIW...

    Anyway, problem solved dikasih connection-mark=no-mark kan?
    iya mas yosan
    saya kan bilang emang gk ada masalah
    cuman ingin tahu aja
    soalnya agak aneh aja......
    biar jadi referensi aja
    Last edited by adiputrolds; 21-07-2010 at 21:16.

  6. #6
    Status
    Offline
    dingo's Avatar
    Member Super Senior
    Join Date
    Jan 2008
    Location
    Puncak Kesejukan
    Posts
    641
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Sependapat dengan mas Yosan...
    Saya hanya menambahkan sedikit...
    Prerouting menangkap paket sebelum masuk ke router....
    Sedangkan Postrouting menangkap paket yg keluar dari router...
    jika kita terapkan chain postrouting setelah mangle prerouting tentunya akan tertangkap lagi paket nya jika tanpa kita deklarasikan pengecualian...
    Simplenya.. prerouting=input, postrouting=output..
    Cmiww....

  7. The Following User Says Thank You to dingo For This Useful Post:


  8. #7
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    yup, thanks telah menambah penjelasannya bro dingo, maaf kalau penjelasanku tentang pre dan postrouting tadi masih agak rancu (nulisnya disambi nge-game sih Click here to enlarge), dan cuman berlaku untuk trafik dari luar router ke luar router, terima kasih untuk koreksinya.

    Kalau yang dipermasalahkan passthrough=no yah seperti yang saya sebut tadi, yang di passthrough=no kan cuman mark-packet, sementara mark-connection nya kan passthrough=yes (dan memang harus passthrough=yes untuk bisa diproses di rule selanjutnya).
    A person's junk is another person's treasure.

  9. #8
    Status
    Offline
    president voice's Avatar
    Newbie
    Join Date
    Jul 2010
    Posts
    50
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by electrix_85 Click here to enlarge
    kok pakek quote sich
    pakek code malah lebih rapih
    aneh lu !!!

    itu mangle direct-down

    tolong baca dulu pertanyaannya !!
    loh mau di bantu malah gitu!!!Click here to enlarge

    untuk semuanya, coba anda perhatikan lebih jelas pertanyaannya :
    Pertanyaan pertama :
    Jika saya membuat mangle untuk menangkap traffic Direct-Down tanpa disertakan connection-mark=no-mark kenapa traffic seperti poker atau traffic lain yang telah saya buat di chain=prerouting bisa tertangkap lagi di mangle Direct-Down jika tanpa menyertakan connection-mark=no-mark padahal semua mangle untuk traffic poker dan traffic lain diatas telah di passthrough=no
    analisa saya :
    1. Ini kan tergantung dari anda menyeting mangle anda seperti apa,
    kalo anda membuat mangle seperti ini misalkan :
    chain=prerouting protocol=tcp dst-port=9339 in-interface=Lan action=mark-connection new-mark-connection=game_poker => ini untuk menandakan sebuah koneksi yang berasal dari lan [lokal] yang berjalan di port 9339
    Lalu anda menangkapnya untuk di jadikan sebuah paket yg akan di eksekusi di queue, misalkan :
    chain=prerouting conection-mark=game_poker action=mark-packet new-mark-packet=game_poker_packet

    dari rule kedua jelas sekali dia menangkap sebuah koneksi yang bernama game_poker lalu di jadikan sebuah paket.
    Kedua Rule itu sudah harga mati!!!
    Kalo ada beberapa koneksi yang tertangkap oleh rule kedua dan koneksi itu bukan berasal dari rule yang pertama, berarti perlu di tinjau kembali setingan mangle anda seperti apa!!!

    MAKA DARI ITU SAYA TANYA,,,,RULE POKER DAN TRAFIC-TRAFIC ANDA YANG LAIN GIMANA DAN DIMANA?KOK GAK DI PAMPANG AJA SEKALIAN!!!
    Anda bertanya jangan setengah2!!!
    Secara teori penjelasan saudara yosan dan dingo benar, tapi itu kan secara teori...kalo pada kenyataan setingan anda yang salah....apa anda masih tetep bersikeras pada teori???

    Silahkan Di jawab.

    -= President Voice =-
    Last edited by president voice; 22-07-2010 at 00:22.

  10. #9
    Status
    Offline
    awarmanf's Avatar
    Member
    Join Date
    Apr 2008
    Posts
    222
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Sebenarnya ada dua model peng-mangle-an di mikrotik.
    1. Mangle prerouting baik untuk connection marking dan mark packet.
    2. Mangle prerouting untuk mark packet dan forward untuk connection marking dan mark packet


    Gak percaya? Ok, saya sertakan sumbernya:
    ##############################
    # #
    # Dari manual mikrotik (pdf) #
    # #
    ##############################

    In this example we will guarantee 256Kib/s download (128Kib/s for the server, 64Kib/s
    for the Workstation and also 64Kib/s for the Laptop) and 128Kib/s for upload (64/32/32Kib/s,
    respectivelly) for local network devices. Additionally, if there is spare bandwidth, share it among
    users equally. For example, if we turn off the laptop, share its 64Kib/s download and 32Kib/s
    upload to the Server and Workstation.

    When using masquerading, you have to mark the outgoing connection with new-connection-mark
    and take the mark-connection action. When it is done, you can mark all packets which belong to
    this connection with the new-packet-mark and use the mark-packet action.

    /ip firewall mangle
    add chain=prerouting src-address=192.168.0.1 action=mark-connection new-connection-mark=server-con
    add chain=prerouting connection-mark=server-con action=mark-packet new-packet-mark=server
    add chain=prerouting src-address=192.168.0.2 action=mark-connection new-connection-mark=lap_works-con
    add chain=prerouting src-address=192.168.0.3 action=mark-connection new-connection-mark=lap_works-con
    add chain=prerouting connection-mark=lap_works-con action=mark-packet new-packet-mark=lap_work

    /queue tree
    add name="Server-Download" parent=Local packet-mark=server limit-at=131072 \
    queue=default priority=8 max-limit=262144 burst-limit=0 burst-threshold=0 burst-time=0s
    add name="Server-Upload" parent=Public packet-mark=server limit-at=65536 \
    queue=default priority=8 max-limit=131072 burst-limit=0 burst-threshold=0 burst-time=0s
    add name="Laptop-Wkst-Down" parent=Local packet-mark=lap_work limit-at=65535 \
    queue=default priority=8 max-limit=262144 burst-limit=0 burst-threshold=0 burst-time=0s
    add name="Laptop-Wkst-Up" parent=Public packet-mark=lap_work limit-at=32768 \
    queue=default priority=8 max-limit=131072 burst-limit=0 burst-threshold=0 burst-time=0s

    ################################################## ##############################
    # #
    # #
    # #
    ################################################## ##############################

    [admin@instaler] > ip firewall mangle print
    Flags: X - disabled, I - invalid, D - dynamic
    1 ;;; UP TRAFFIC
    chain=prerouting in-interface=lan
    src-address=172.21.1.0/24 action=mark-packet
    new-packet-mark=test-up passthrough=no

    2 ;;; CONN-MARK
    chain=forward src-address=172.21.1.0/24
    action=mark-connection
    new-connection-mark=test-conn passthrough=yes

    3 ;;; DOWN-DIRECT CONNECTION
    chain=forward in-interface=public
    connection-mark=test-conn action=mark-packet
    new-packet-mark=test-down passthrough=no

    4 ;;; DOWN-VIA PROXY
    chain=output out-interface=lan
    dst-address=172.21.1.0/24 action=mark-packet
    new-packet-mark=test-down passthrough=no

    [admin@instaler] > queue tree pr
    Flags: X - disabled, I - invalid
    0 name="downstream" parent=lan packet-mark=test-down
    limit-at=32000 queue=default priority=8
    max-limit=32000 burst-limit=0
    burst-threshold=0 burst-time=0s

    1 name="upstream" parent=global-in
    packet-mark=test-up limit-at=32000
    queue=default priority=8
    max-limit=32000 burst-limit=0
    burst-threshold=0 burst-time=0s
    Pertama kali kenal mikrotik, selalu saya dihadapkan ini, mau pakai model peng-mangle-an yang mana ?
    Sampai akhirnya sewaktu membuat tulisan traffic control di linux saya juga membuat pemodelan pakai mangle prerouting dan forward.


    Semoga membantu.

    Salam,

    Arief Yudhawarman
    Last edited by awarmanf; 21-07-2010 at 23:43.

  11. The Following User Says Thank You to awarmanf For This Useful Post:


  12. #10
    Status
    Offline
    kdebugx86's Avatar
    Moderator
    Join Date
    Oct 2008
    Location
    greyarea
    Posts
    1,283
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    electrix, president voice ... slow aja fren Click here to enlarge

    btw, jadi dejavu inget chat gw ma neo dan mas yosan, tentang penggunaan postrouting di mangle untuk zph. forward atau postrouting yang paling efektif.? Click here to enlarge
    tapi ini pokok bahasan lain kali ya..

    okelah.
    Last edited by kdebugx86; 22-07-2010 at 00:05.

  13. #11
    Status
    Offline
    karaeng's Avatar
    VIP Member
    Join Date
    Jun 2010
    Posts
    958
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by kdebugx86 Click here to enlarge
    electrix, president voice ... slow aja fren Click here to enlarge
    Click here to enlargeClick here to enlargeClick here to enlarge

    nunggu yg di bawah .... mudah2an ada tambahan lagi.......

  14. #12
    Status
    Offline
    president voice's Avatar
    Newbie
    Join Date
    Jul 2010
    Posts
    50
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by awarmanf Click here to enlarge
    Sebenarnya ada dua model peng-mangle-an di mikrotik.
    1. Mangle prerouting baik untuk connection marking dan mark packet.
    2. Mangle prerouting untuk mark packet dan forward untuk connection marking dan mark packet


    Gak percaya? Ok, saya sertakan sumbernya:


    Pertama kali kenal mikrotik, selalu saya dihadapkan ini, mau pakai model peng-mangle-an yang mana ?
    Sampai akhirnya sewaktu membuat tulisan traffic control di linux saya juga membuat pemodelan pakai mangle prerouting dan forward.


    Semoga membantu.

    Salam,

    Arief Yudhawarman
    coba perhatikan :
    1 ;;; UP TRAFFIC
    chain=prerouting in-interface=lan
    src-address=172.21.1.0/24 action=mark-packet
    new-packet-mark=test-up passthrough=no

    1 name="upstream" parent=global-in
    packet-mark=test-up limit-at=32000
    queue=default priority=8
    max-limit=32000 burst-limit=0
    burst-threshold=0 burst-time=0s
    dan ini :
    3 ;;; DOWN-DIRECT CONNECTION
    chain=forward in-interface=public
    connection-mark=test-conn action=mark-packet
    new-packet-mark=test-down passthrough=no

    4 ;;; DOWN-VIA PROXY
    chain=output out-interface=lan
    dst-address=172.21.1.0/24 action=mark-packet
    new-packet-mark=test-down passthrough=no

    0 name="downstream" parent=lan packet-mark=test-down
    limit-at=32000 queue=default priority=8
    max-limit=32000 burst-limit=0
    burst-threshold=0 burst-time=0s
    saya yakin kedua rule ini bisa membuat warnet gulung tikar.
    anda tau kenapa???karena smua aktivitas di limit, percuma beli BW 2MB dari ISP, perbulan bayar 1,1jt kalo semua aktivitas di limit di angka sekecil itu.

    CMIWW....terkadang teori tidak sesuai kenyatann ya pak awarmanf....Click here to enlarge

  15. #13
    Status
    Offline
    president voice's Avatar
    Newbie
    Join Date
    Jul 2010
    Posts
    50
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by kdebugx86 Click here to enlarge
    electrix, president voice ... slow aja fren Click here to enlarge

    btw, jadi dejavu inget chat gw ma neo dan mas yosan, tentang penggunaan postrouting di mangle untuk zph. forward atau postrouting yang paling efektif.? Click here to enlarge
    tapi ini pokok bahasan lain kali ya..

    okelah.
    saya mau bantu eh malah di kasarin bung mod...Click here to enlarge, saya bela diri dikit...Click here to enlarge

  16. #14
    Status
    Offline
    siber's Avatar
    Member Super Senior
    Join Date
    Oct 2009
    Location
    www.hikmah-teknologi.com
    Posts
    616
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by president voice Click here to enlarge
    coba perhatikan :

    dan ini :


    saya yakin kedua rule ini bisa membuat warnet gulung tikar.
    anda tau kenapa???karena smua aktivitas di limit, percuma beli BW 2MB dari ISP, perbulan bayar 1,1jt kalo semua aktivitas di limit di angka sekecil itu.

    CMIWW....terkadang teori tidak sesuai kenyatann ya pak awarmanf....Click here to enlarge

    gan itu khan contoh, yang penting konsepnya,
    kecuali kalau orangnya hobi copy paste tanpa di telaah Click here to enlarge
    mungkin yang buat example itu linknya pake GPRS, jadi perlu di set segitu nilainya, biar bandwithnya terkendali huehehe

    buts thank to TS dan lainnya, dengan thread ini jadi memberikan pemahaman baru tentang packet flow,

    cool calm down brother,
    ayo kapan2 ngupi2 bareng sambil cangkrukan cuci mata pake bayclin hahaha

  17. #15
    Status
    Offline
    adiputrolds's Avatar
    Forum Guru
    Join Date
    Oct 2008
    Posts
    1,485
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by president voice Click here to enlarge
    loh mau di bantu malah gitu!!!Click here to enlarge

    untuk semuanya, coba anda perhatikan lebih jelas pertanyaannya :
    Pertanyaan pertama :

    analisa saya :
    1. Ini kan tergantung dari anda menyeting mangle anda seperti apa,
    kalo anda membuat mangle seperti ini misalkan :
    chain=prerouting protocol=tcp dst-port=9339 in-interface=Lan action=mark-connection new-mark-connection=game_poker => ini untuk menandakan sebuah koneksi yang berasal dari lan [lokal] yang berjalan di port 9339
    Lalu anda menangkapnya untuk di jadikan sebuah paket yg akan di eksekusi di queue, misalkan :
    chain=prerouting conection-mark=game_poker action=mark-packet new-mark-packet=game_poker_packet

    dari rule kedua jelas sekali dia menangkap sebuah koneksi yang bernama game_poker lalu di jadikan sebuah paket.
    Kedua Rule itu sudah harga mati!!!
    Kalo ada beberapa koneksi yang tertangkap oleh rule kedua dan koneksi itu bukan berasal dari rule yang pertama, berarti perlu di tinjau kembali setingan mangle anda seperti apa!!!

    MAKA DARI ITU SAYA TANYA,,,,RULE POKER DAN TRAFIC-TRAFIC ANDA YANG LAIN GIMANA DAN DIMANA?KOK GAK DI PAMPANG AJA SEKALIAN!!!
    Anda bertanya jangan setengah2!!!
    Secara teori penjelasan saudara yosan dan dingo benar, tapi itu kan secara teori...kalo pada kenyataan setingan anda yang salah....apa anda masih tetep bersikeras pada teori???

    Silahkan Di jawab.

    -= President Voice =-
    anda mempermasalahkan yg mana
    masalah mangle yg harus di tulis di code atau quote
    kok marah2 sendiri

    yg jadi pertanyaan itu ??
    kenapa connection pada prerouting yg udah di stop di dengan passthrough=no msh tertangkap lagi di postrouting jika tanpa connection-mark=no-mark
    ini pembahasan biar jadi referensi bagi yg mungkin belom tau
    jadi bs memahami mikrotik lbh dalam

    kalo masalah mangle poker dan lain2 gk usah di permasalahkan
    saya bukan newbie lagi mas........
    saya gk terlalu suka membuat masalah semakin berbelit2
    disana ada pertanyaannya dan solusi nya
    ini pembahasan mengenai passthough=no
    bukan masalah penangkapan mangle game dan lain2


    Click here to enlarge sory aja bro kalo saya ada salah
    Last edited by adiputrolds; 22-07-2010 at 07:53.

 

 
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [ask] passthrough
    By 4dder in forum Beginner Basics
    Replies: 18
    Last Post: 27-04-2010, 19:15
  2. Passthrough?
    By neeza in forum Beginner Basics
    Replies: 2
    Last Post: 19-06-2009, 00:28
  3. hotspotku aneh
    By ru74r in forum Wireless Networking
    Replies: 0
    Last Post: 15-01-2009, 15:14
  4. Replies: 2
    Last Post: 06-02-2008, 14:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •