Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2
  1. #1
    Status
    Offline
    and1ck's Avatar
    Baru Gabung
    Join Date
    Oct 2009
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Please fix my code: Internet 2 gateway IX to speedy IIX to WLAN

    topologi:
    Internet
    || ||
    Speedy WLAN
    100.10.10.1 100.10.20.1
    || ||
    eth0 eth1
    100.10.10.2 100.10.20.2
    \\ //
    MIKROTIK ROUTER 2.9.X
    ||
    LAN (eth3)
    192.168.0.1/24
    ||
    Client

    Target : Memisahkan bandwith IX ke speedy dan IIX ke WLAN (kalo gini bukan load balancing ya bro? Click here to enlarge)

    Catatan:
    Udah searching di forum akhirnya dapet code dibawah ini, tapi target belum tercapai, di tracert dan di check via speedtest.net yg muncul hanya gateway dari WLAN-nya saja, speedynya gak mau aktif (speedy dicheck langsung dari router, normal gak ada masalah), yg masalah codingku, para master dan senior mohon bimbingannya, semoga thread ini juga bisa sebagai jawaban bagi yg mempunyai masalah yg sama Click here to enlarge

    Code sebelumnya, CMIIW Click here to enlarge
    Code:
    Load balancing iNT TO Speedy, IIX to Wlan With Queue Tree
    
    /interface ethernet
      enable ether1
      enable ether2
      enable ether3
      set ether1 name="Speedy"
      set ether2 name="WLAN"
      set ether3 name="lokal"
    
    /ip address
      add address=100.10.10.2/30 interface=Speedy comment="ip from router speedy"
      add address=100.10.20.2/30 interface=WLAN comment="ip from WLAN"
      add address=192.168.0.1/24 interface=lokal comment="For Lokal Network"
    
    # dengan asumsi bahwa file nice.rsc sudah terupload via ftp
    /import nice.rsc
    
    /ip firewall mangle 
      add chain=prerouting in-interface="lokal" connection-state=new nth=1,2,0 action=mark-connection new-connection-mark=lb_1 passthrough=yes comment="LB Client" disabled=no
      add chain=prerouting in-interface="lokal" connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no comment="" disabled=no
      add chain=prerouting in-interface="lokal" connection-state=new nth=1,2,1 action=mark-connection new-connection-mark=lb_2 passthrough=yes comment="" disabled=no
      add chain=prerouting in-interface="lokal" connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no comment="" disabled=no
      add chain=prerouting src-address=192.168.0.1/24 action=mark-connection new-connection-mark=client-conn passthrough=yes
      add chain=prerouting src-address=192.168.0.1/24 dst-address-list=nice action=mark-connection new-connection-mark=client-iix-conn passthrough=yes
      add chain=prerouting connection-mark=client-conn out-interface=Speedy action=mark-packet new-packet-mark=client-up passthrough=no 
      add chain=prerouting connection-mark=clientiix-conn out-interface=WLAN action=mark-packet new-packet-mark=client-up-iix passthrough=no
      add chain=forward connection-mark=client-conn out-interface=Speedy action=mark-packet new-packet-mark=client-down passthrough=no
      add chain=forward connection-mark=client-iix-conn out-interface=WLAN action=mark-packet new-packet-mark=client-down-iix passthrough=no
    
    
    /ip dns
      # dns primary pake dns wlan, yg second pake speedy
      set primary-dns=xxx.xxx.xxx.xxx secondary-dns=202.134.0.155 allow-remote-requests=yes
    
    / ip firewall nat
      add chain=srcnat out-interface="Speedy" action=masquerade comment="" disabled=no
      add chain=srcnat out-interface="WLAN" action=masquerade comment="" disabled=no
    
    / ip route
      add dst-address=0.0.0.0/0 gateway=100.10.10.1 scope=255 target-scope=10 routing-mark=route_lb_1 comment="" disabled=no
      add dst-address=0.0.0.0/0 gateway=100.10.20.1 scope=255 target-scope=10 routing-mark=route_lb_2 comment="" disabled=no
      add dst-address=0.0.0.0/0 gateway=100.10.20.1 scope=255 target-scope=10 comment="default routing connection" disabled=no
    
    /queue tree
      # untuk download kita menggunakan in-interface kita dalam hal ini Local, sedangkan untuk upload kita menggunakan global-in
        add name=internasional parent=speedy queue=default 
        add name=IIX parent=WLAN queue=default
    
    /queue type
      # personal (Auto) kita menggunakan 0 pada paket personal karena MT akan menghitung berapa besar 
      # bw yang tersedia pada saat client melakukan koneksi.
        add name=auto-down kind=pcq pcq-rate=0 pcq-classifier=dst-address pcq-total-limit=2000
        add name=auto-up kind=pcq pcq-rate=0 pcq-classifier=src-address pcq-total-limit=2000
    
    
    #/queue tree
      #Paket client per ip
        add name=client-down packet-mark=client-down parent=Internasional queue=auto-down max-limit=512000 priority=8
        add name=client-down-iix packet-mark=client-down-iix parent=IIX queue=auto-down max-limit=1024000 priority=8
        add name=client-up parent=Internasional packet-mark=client-up queue=auto-up max-limit=128000 priority=8
        add name=client-up-iix parent=WLAN packet-mark=client-up-iix queue=auto-up max-limit=512000 priority=8

  2. #2
    Status
    Offline
    p4w1r0's Avatar
    Member
    Join Date
    Jul 2007
    Location
    dimana_mana_hatiku_senang
    Posts
    252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    1. masukin address list dr "nice", trus buat routing yg menuju itu
    2. buat routing yg menuju selain list "nice"
    3. masukan route untuk masing2 paket k ISP yg diinginkan

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1 Gateway untuk koneksi ke VPN Telkom dan Internet Speedy
    By masadhix in forum General Networking
    Replies: 6
    Last Post: 27-08-2012, 10:35
  2. 2 paket speedy eklusip 1 gateway
    By sokadon in forum General Networking
    Replies: 8
    Last Post: 29-01-2010, 09:10
  3. gimana cara balancing speedy sama wlan
    By ddjimmyko in forum General Networking
    Replies: 17
    Last Post: 10-11-2009, 23:41
  4. Tanya Error code
    By avian in forum General Networking
    Replies: 7
    Last Post: 09-11-2009, 18:49
  5. Tanya: 2 speedy 2 gateway 1pc
    By inetpribumi in forum Beginner Basics
    Replies: 3
    Last Post: 16-02-2009, 00:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •