Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 5 of 5
  1. #1
    Status
    Offline
    awarmanf's Avatar
    Member
    Join Date
    Apr 2008
    Posts
    222
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Membuat MRTG untuk trafik internasional

    Pada kesempatan ini saya akan menulis bagaimana menampilkan konsumsi bandwidth internasional untuk koneksi internet dari ISP yang bandwidthnya bercampur domestik (nice/iix) + internasional seperti speedy. Mikrotik yang digunakan harus versi v3 ke atas karena memerlukan tool fetch untuk mendownload address list nice. Selain itu diperlukan juga mesin lain yaitu linux untuk mengolah data dan menampilkan hasilnya ke dalam bentuk MRTG. Sebenarnya di mikrotik sendiri kita bisa buat semacam MRTG yakni pakai Tools / Graphing tetapi untuk ini kita harus pakai queue simple, sedangkan tutorial di bawah ini tidak perlu membuat queue lagi.

    Langkah-langkahnya :
    1. Buat script get-nice
      Klik System / Scripts lalu buat script get-nice seperti di bawah ini (tambahkan address lain seperti ip lan modem spidi yang bisa dikategorikan sebagai nice):
      Code:
      /tool fetch address=ixp.mikrotik.co.id src-path=download/nice.rsc;
      /import nice.rsc;
      /ip firewall address-list add address=192.168.0.0/16 list=nice;
    2. Buat mangle untuk "menangkap" upstream dan downstream dari dan ke internasional
      Code:
      /ip firewall mangle
      add chain=prerouting action=accept dst-address-list=!nice in-interface=lan comment="upstream international"
      add  chain=postrouting action=accept src-address-list=!nice comment="downstream international"
      Taruh 2 rule ini di baris teratas.
    3. Buat scheduler untuk menjalankan scrip get-nice setiap hari pukul 04:00.
      Code:
      /system scheduler
      add name=get-nice on-event=get-nice start-time=04:00:00 interval=1d
    4. Buat script get-traf-international di mikrotik
      Code:
      :local a [/ip firewall mangle get [ find comment="downstream international" ] bytes ]; :put $a
      :local b [/ip firewall mangle get [ find comment="upstream international" ] bytes ]; :put $b
      Script ini akan dieksekusi oleh user awarmanf dari mesin linux. Script ini akan menampilkan total bytes downstream dan upstream trafik internasional.
    5. Buat koneksi ssh dari mesin linux ke mikrotik tanpa password.
    6. Buat script /usr/local/sbin/getTrafInt.sh di linux untuk ambil data total bytes downstream dan upstream trafik internasional dari mikrotik.
      Code:
      #!/bin/sh
      #
      # Note:
      # awarmanf adalah user yang bisa ssh tanpa password sebagai user admin di
      # mikrotik dengan ip 192.168.100.2
      
      SSHKEY="/usr/bin/ssh -i /home/awarmanf/.ssh/id_dsa admin@192.168.100.2"
      SED="/usr/bin/sed"
      
      # this will print downstream & upstream traffic international
      # sed used to remove CRLF line terminators
      $SSHKEY "/system script run get-traf-international" | $SED -e 's/\r//'
    7. Tes script /usr/local/sbin/getTrafInt.sh
      Code:
      $ cd /usr/local/sbin
      $ ./getTrafInt.sh 
      1088699432
      149212232
    8. Buat file konfigurasi mrtg.cfg seperti di bawah:
      Code:
      EnableIPv6: no
      WorkDir: /var/www/htdocs/mrtg/
      Options[_]: bits,growright
      
      Target[int]: `/usr/local/sbin/getTrafInt.sh`
      SetEnv[int]: MRTG_INT_IP="192.168.0.254" MRTG_INT_DESCR="int"
      RouterUptime[int]: public@192.168.100.2
      MaxBytes[int]: 625000
      Title[int]: International Traffic (5 WAN Speedy)
      PageTop[int]: <h1>International Traffic</h1>
      		<div id="sysdetails">
      			<table>
      				<tr>
      					<td>System:</td>
      					<td>Mikrotik Load Balancing + Web Proxy</td>
      				</tr>
      				<tr>
      					<td>Maintainer:</td>
      					<td>Arief Yudhawarman <awarmanff@yahoo.com></td>
      				</tr>
      				<tr>
      					<td>Description:</td>
      					<td>International Traffic</td>
      				</tr>
      				<tr>
      					<td>ifType:</td>
      					<td>ethernetCsmacd (6)</td>
      				</tr>
      				<tr>
      					<td>ifName:</td>
      					<td>int</td>
      				</tr>
      				<tr>
      					<td>Max Speed:</td>
      					<td>100.0 Mbits/s</td>
      				</tr>
      				<tr>
      					<td>Ip:</td>
      					<td>192.168.100.2</td>
      				</tr>
      			</table>
      		</div>

    Gambar MRTG Trafik internasional:
    Click here to enlarge
    Trafik downstream internasional yang besar itu disebabkan tes download kernel linux 65MB pakai proz (download accelator) di linux.

    Gambar MRTG Trafik local (domestik+internasional):
    Click here to enlarge

    ---
    Arief Yudhawarman
    Last edited by awarmanf; 08-05-2010 at 19:32.

  2. The Following 5 Users Say Thank You to awarmanf For This Useful Post:


  3. #2
    Status
    Offline
    yogaponsel's Avatar
    Forum Guru
    Join Date
    Oct 2008
    Location
    "BnetAkses"
    Posts
    2,511
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    sip .. gan .. singkat padat dan jelas ........ Click here to enlarge

  4. #3
    Status
    Offline
    langitcyber's Avatar
    Member
    Join Date
    Nov 2008
    Posts
    104
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mantap juraganClick here to enlarge

  5. #4
    Status
    Offline
    m3tr0mini's Avatar
    Member Super Senior
    Join Date
    Sep 2007
    Posts
    660
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    MANTAB'S PAK DHE Click here to enlarge Click here to enlargeClick here to enlargeClick here to enlarge

  6. #5
    Status
    Offline
    c0nf's Avatar
    Contributor
    Join Date
    Jul 2007
    Location
    Bandung, Indonesia
    Posts
    1,816
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    biarpun ada cacti plus addon buat mikrotik, tapi ini mantap

 

 

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Replies: 12
    Last Post: 29-11-2009, 20:19
  2. Cari BW IIX dan Internasional untuk di Pekanbaru
    By jacky10 in forum ISP / Network Link
    Replies: 5
    Last Post: 19-11-2009, 00:37
  3. Replies: 26
    Last Post: 17-09-2008, 18:30
  4. Mengatur trafik up dan down untuk koneksi non nat
    By awarmanf in forum General Networking
    Replies: 9
    Last Post: 16-05-2008, 01:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •